Справочник Windows XP

XP

Главная

Реклама в справочнике и на сайте

Темы

Инсталляция Win XP

Что такое Реестр

Введение в реестр

Манипулирование реестром

Восстановление поврежденного реестра

Редактирование реестра-Меню пуск

Редактирование реестра-Explorer

Редактирование реестра-IExplorer

Редактирование реестра-Интернет-TCP\IP

Редактирование реестра-Разное
Всякие мелочи
Структура Reg-файла
Ручная очистка реестра после удаления программ
Утилиты очистки реестра
Система
Командная строка
Утилиты команд-строки
Восстановление системы
Быстродействие системы
Безопасность системы
Автозагрузка программ
Удаляем Messenger
Отличия Windows XP Professional и Windows XP Home
Windows Media Player 9
Пользовательские права
Ядро системы
Группировка окон
Шрифты
Оптимизация по Биос
Системные службы
Советы по настройке
Вопросы и ответы
Дисковые утилиты
Системные утилиты
Утилита Msconfig
Диспетчер задач
Консоль управления
Деловые статьи
Процессоры AMD
Заправка картриджей
1С: Предприятие 7.7
1С: Предприятие 7.7
Локальная сеть
Сетевые утилиты
ДУ для компьютера
Познавательные статьи
Файловые системы
Что такое NTFS
Оптимальный компьютер
Принцип работы HDD
Тестируем HDD
разное
Твикеры для XP
Каталог ссылок

Сайт Справочника в Интернет находится по адресу: http://reestr.hotmail.ru/

E@mail

E@mail

Информация собрана из разных источников. Моя точка зрения может не совпадать с точкой зрения другого автора.

©2003 Григорий Саитов Ульяновск

Версия 2.08.2003г.


Реестр Windows XP

Cправочник о системном реестре и настройке

с помощью реестра

Справочник по реестру - одному из основных компонентов операционной системы, хранящему всю информацию, необходимую для настройки и функционирования системы Windows XP. Описываются архитектура реестра, структура и типы данных. Обсуждаются методы резервного копирования и восстановления реестра. Рассматриваются методы настройки системы и сети, особенности подключения и конфигурирования аппаратных средств. Приводятся рекомендации по предотвращению сбоев системы и решению различных проблем путем редактирования реестра. Особое внимание уделяется вопросам безопасности и защиты реестра. Обсуждается возможность применения дополнительных утилит для его редактирования. Полезные советы по установке и оптимизации системы и разного софта.

Благодаря своей колоссальной базе всевозможных настроек, скрытых и открытых, документированных и недокументированных, Windows может быть настроен кем угодно и как угодно.

Что такое реестр Windows XP?

Реестр или системный реестр - это база данных для хранения сведений о конфигурации компьютера и настроек операционной системы. Реестр содержит данные, к которым Windows XP постоянно обращается во время загрузки, работы и её завершения, а именно:

  • профили всех пользователей, то есть их настройки;
  • конфигурация оборудования, установленного в операционной системе.
  • данные об установленных программах и типах документов, создаваемых каждой программой;
  • свойства папок и значков программ;
  • данные об используемых портах.

Для работы с реестром используется утилита Regedit.

ПРЕДУПРЕЖДЕНИЕ: НИКОГДА не удаляйте или не меняйте информацию в реестре, если Вы не уверены что это именно то, что нужно. В противном случае некорректное изменение данных может привести к сбоям в работе Windows.

Вся ответственность за нарушение работоспособности компьютера лежит на Вас.

Перепечатка материалов с обязательной ссылкой на сайт http://reestr.hotmail.ru

Размещать Справочник на сайтах без разрешения запрещаеться.


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|20 May 2003 17:47:43 -0000 vti_extenderversion:SR|5.0.2.3409 vti_backlinkinfo:VX|izone353/index.htm Справочник\\ Win\\ XP/index.htm vti_author:SR|GRIGORIY\\Григорий vti_modifiedby:SR|GEORG\\Григорий vti_timecreated:TR|03 Dec 2002 17:05:54 -0000 vti_title:SR|WOTIAS vti_lineageid:SR|{D7754538-FBD5-4711-8F61-68CC47E71D42} vti_nexttolasttimemodified:TW|20 May 2003 08:28:40 -0000 vti_cacheddtm:TX|20 May 2003 17:47:44 -0000 vti_filesize:IR|6813 vti_cachedtitle:SR|WOTIAS vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../030313widows.gif H|main.htm H|../pages/Инсталяция\\ Win\\ XP.htm H|../pages/Что\\ такое\\ Реестр.htm H|../pages/Введение\\ в\\ реестр.htm H|../pages/Восстановление\\ реестра.htm H|../pages/Оптимизация\\ реестра.htm H|../pages/Оптимизация\\ реестра[1].htm H|../pages/Оптимизация\\ реестра[3].htm H|../pages/Оптимизация\\ реестра[2].htm H|../pages/Оптимизация\\ реестра[4].htm H|../pages/Утилиты\\ реестра.htm H|../pages/Реестр\\ XP\\ ком.строка.htm H|../pages/Советы.htm H|../pages/Вопросы\\ и\\ ответы.htm H|../pages/Файловые\\ системы.htm H|../pages/Заправка\\ картриджей.htm H|../pages/1C.htm H|../pages/Сеть.htm H|../pages/Полезные\\ сайты.htm H|http://reestr.hotmail.ru/ H|http://reestr.hotmail.ru/ H|http://reestr.hotmail.ru/ H|http://reestr.hotmail.ru/ H|http://wotias.newmail.ru/ H|mailto:grigoric@rambler.ru H|mailto:wotias@mail.ru vti_cachedsvcrellinks:VX|FSUS|Справочник\\ Win\\ XP/030313widows.gif FHUS|Справочник\\ Win\\ XP/frame/main.htm FHUS|Справочник\\ Win\\ XP/pages/Инсталяция\\ Win\\ XP.htm FHUS|Справочник\\ Win\\ XP/pages/Что\\ такое\\ Реестр.htm FHUS|Справочник\\ Win\\ XP/pages/Введение\\ в\\ реестр.htm FHUS|Справочник\\ Win\\ XP/pages/Восстановление\\ реестра.htm FHUS|Справочник\\ Win\\ XP/pages/Оптимизация\\ реестра.htm FHUS|Справочник\\ Win\\ XP/pages/Оптимизация\\ реестра[1].htm FHUS|Справочник\\ Win\\ XP/pages/Оптимизация\\ реестра[3].htm FHUS|Справочник\\ Win\\ XP/pages/Оптимизация\\ реестра[2].htm FHUS|Справочник\\ Win\\ XP/pages/Оптимизация\\ реестра[4].htm FHUS|Справочник\\ Win\\ XP/pages/Утилиты\\ реестра.htm FHUS|Справочник\\ Win\\ XP/pages/Реестр\\ XP\\ ком.строка.htm FHUS|Справочник\\ Win\\ XP/pages/Советы.htm FHUS|Справочник\\ Win\\ XP/pages/Вопросы\\ и\\ ответы.htm FHUS|Справочник\\ Win\\ XP/pages/Файловые\\ системы.htm FHUS|Справочник\\ Win\\ XP/pages/Заправка\\ картриджей.htm FHUS|Справочник\\ Win\\ XP/pages/1C.htm FHUS|Справочник\\ Win\\ XP/pages/Сеть.htm FHUS|Справочник\\ Win\\ XP/pages/Полезные\\ сайты.htm NHHS|http://reestr.hotmail.ru/ NHHS|http://reestr.hotmail.ru/ NHHS|http://reestr.hotmail.ru/ NHHS|http://reestr.hotmail.ru/ NHHS|http://wotias.newmail.ru/ NHUS|mailto:grigoric@rambler.ru NHUS|mailto:wotias@mail.ru vti_cachedneedsrewrite:BR|false vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru


vti_encoding:SR|utf8-nl vti_timelastmodified:TR|20 May 2003 08:28:41 -0000 vti_extenderversion:SR|5.0.2.3409 vti_backlinkinfo:VX|izone353/index.htm izone353/frame/left.htm Справочник\\ Win\\ XP/index.htm izone353/frame/main.htm vti_author:SR|GRIGORIY\\Григорий vti_modifiedby:SR|GEORG\\Григорий vti_timecreated:TR|03 Dec 2002 17:37:40 -0000 vti_title:SR|Реестр Windows XP vti_lineageid:SR|{685563B2-C5AD-4AE8-8874-5850C0BFCF26} vti_thicketdir:SW|wotias/frame/main.files vti_nexttolasttimemodified:TW|14 May 2003 09:19:30 -0000 vti_cacheddtm:TX|20 May 2003 08:28:42 -0000 vti_filesize:IR|6327 vti_cachedtitle:SR|Реестр Windows XP vti_cachedbodystyle:SR| vti_cachedlinkinfo:VX|S|../des-xp.gif H|http://reestr.hotmail.ru/ vti_cachedsvcrellinks:VX|FSUS|Справочник\\ Win\\ XP/des-xp.gif NHHS|http://reestr.hotmail.ru/ vti_cachedneedsrewrite:BR|true vti_cachedhasbots:BR|false vti_cachedhastheme:BR|false vti_cachedhasborder:BR|false vti_metatags:VR|HTTP-EQUIV=Content-Language ru GENERATOR Microsoft\\ FrontPage\\ 5.0 ProgId FrontPage.Editor.Document HTTP-EQUIV=Content-Type text/html;\\ charset=windows-1251 vti_charset:SR|windows-1251 vti_language:SR|ru vti_progid:SR|FrontPage.Editor.Document vti_generator:SR|Microsoft FrontPage 5.0


1С: Предприятие 7.7.

Установка 1С: Предприятие - задача не столь сложная, как это может показаться на первый взгляд. Если вы никогда не делали этого раньше и принципиально не желаете читать официальное "Руководство по установке и запуску", то, возможно, вам поможет данный материал. Людям, имеющим опыт установки 1C, может пригодиться раздел "советы бывалым" в конце статьи - возможно, найдете что-то новое и полезное для себя. Хочется также обратить ваше внимание на то, что в данной статье вы не найдете ничего про установку SQL версии 1С.

Основные шаги

Процесс установки и запуска 1С: Предприятие на любой компьютер, как и многие другие операции, можно разбить на следующие основные этапы: 1. Установка платформы (системы) 1С: Предприятие. 2. Установка конфигураций. 3. Установка электронного ключа защиты. 4. Настройка сетевых подключений (для сетевых версий). Для того чтобы было более понятно, о чем идет речь, представим с помощью трех обозначений систему программ 1С: Предприятие: Платформа - "движок" и "компоненты" устанавливаются одной программой установки, а конфигурации - отдельными установочными программами.

1. Установка платформы (системы) 1С: Предприятие

Прежде чем приступить к установке, убедитесь в том, что 1С: Предприятие еще не инсталлировано на данном компьютере. Возможно, та платформа, которая уже настроена, годится для запуска необходимой вам конфигурации, поэтому смело переходите к пункту 2 "Установка конфигураций". Вы ничем не рискуете, поскольку совершенно неважно, в какой последовательности устанавливать конфигурации и платформы. Если после установки конфигурации программа все же не заработала, и вы не уверены в собственных силах, то лучший выход - обратиться к специалистам для переустановки платформы 1С: Предприятие. Итак, перед вами дистрибутив 1С - как правило, большой набор дискет, или компакт-диск с установочной программой 1С. Счастливым обладателям компакт-диска достаточно установить его CD-DRIVE и дождаться автоматического запуска установочного меню. В нем необходимо выбрать пункт, под названием "1С: Предприятие 7.7 <такая-то версия>". Если автоматического старта дождаться так и не удалось, придется самостоятельно запустить программу "SETUP.EXE" с диска. Например, это можно сделать так - в меню "Пуск" выбрать пункт "Выполнить", а затем набрать команду "D:\SETUP.EXE" в диалоговом окне и нажать кнопку "OK". Далее нужно смело соглашаться с предложением установки "по умолчанию". Когда программа спросит у вас про "Имя" и "Организацию", не пугайтесь - пишите, что хотите, это никак не скажется на дальнейшей работе программы. Если ваш дистрибутив 1С располагается на дискетах, то придется немного попотеть. Сначала необходимо отсортировать кучу дискет по двум стопкам - "дистрибутив платформы 1С: Предприятие" и "дистрибутив конфигурации". Далее, нужно вставить в дисковод дискету с номером один из дистрибутива платформы и запустить программу "SETUP.EXE". В процессе установки программа станет назойливо требовать вставлять попеременно в дисковод соответствующие дискеты.

2. Установка конфигураций

Для дистрибутива на компакт-диске установка конфигураций запускается из установочного меню выбором соответствующего пункта, например, "1С: Бухгалтерия 7.7 Типовая конфигурация". Если же у вас дискеты, то потребуется вставить дискету №1, на этот раз из стопки "конфигурация", и запустить программу "SETUP.EXE". Вас ждет неприятная процедура попеременной переустановки дискет в дисковод по запросу программы. После запуска программа установки конфигурации задает пользователю следующие вопросы: "Выбор варианта установки" - новая или обновленная конфигурация? Ответ выбирается исходя из ситуации. По умолчанию рассматриваем новую установку. "Выбор каталога установки" - рекомендуем не соглашаться с любезно предлагаемым каталогом "по умолчанию", а выбрать более простой путь, например "c:\1С Базы".

3. Установка электронного ключа защиты

Как правило, программные продукты 1С защищены от незаконного тиражирования электронными ключами HASP. Данный ключ необходимо вставить при выключенном компьютере в разъем параллельного порта. При наличии принтера, кабель от него надо вставить в соответствующий разъем ключа защиты, подключенного к параллельному порту. После чего смело включайте компьютер и выбирайте "Установка драйвера защиты" из меню 1С: Предприятие ("Пуск" - "Программы" - "1С: Предприятие"). Все, установка для пользователей локальных версий закончена. Можно запускать 1С: Предприятие ("Пуск" - "Программы" - "1С: Предприятие" - "1С: Предприятие"). В окне запуска выбираете информационную базу, к которой вы в данный момент хотите подключиться, и нажимаете кнопку "ОК". Внимание! Во время первого запуска информационной базы происходит процесс построения вспомогательных индексных файлов и 1С стартует несколько дольше, чем обычно. Также обратите внимание на то, что если у вас установлена сетевая версия 1С: Предприятие, то при первом запуске должен быть установлен флажок "монопольно". Если для информационной базы существует некий список пользователей, которым разрешена работа с ней, то перед запуском программы появится диалог "Авторизация доступа". Выбирайте пользователя, вводите пароль (если он назначен), и нажимайте кнопку "ОК". Не пугайтесь! При запуске демонстрационных баз у всех пользователей пароль отсутствует - просто выберите пользователя и нажмите "ОК".

4. Настройка сетевых подключений (для сетевых версий)

Настройка сетевой версии 1C потребует от вас ряда по порядку перечисленных ниже действий. Выбор операционной системы Сетевые версии 1С лучше ставить на серверные операционные системы. Если предполагаемое количество пользователей больше трех, то устанавливать 1С рекомендуется на сетевую операционную систему (Novell Netware или Windows 2000 Server). Конфигурации, информационные базы Конфигурации и информационные базы необходимо расположить в папке на сервере с открытым доступом. Желательно подключить данную папку для пользователей как сетевой диск (разумеется, буква, обозначающая сетевой диск, для всех пользователей должна быть одна и та же). Видимость ключа защиты Чтобы электронный ключ защиты был "виден" для остальных пользователей сети, на компьютере, где он установлен, надо запустить "Сервер защиты" (Пуск - Программы - 1С: Предприятие - Сервер защиты) Выбор варианта установки платформы 1С: Предприятие В зависимости от комплекта поставки допускается несколько вариантов установки системы 1С:Предприятие: - локальная установка - административная установка - сетевая установка Локальная установка может быть выполнена для любого комплекта поставки и является единственно возможным вариантом для однопользовательских версий 1С: Предприятие. При выполнении локальной установки необходимо совершить все уже перечисленные выше действия. Административная установка, строго говоря, является не установкой как таковой, а представляет собой подготовку к инсталляции. Суть ее состоит в том, что на сервере локальной сети создается каталог, в который из дистрибутива 1С: Предприятие переносятся все необходимые файлы для того, чтобы, запустив из этого каталога SETUP.EXE, можно было выполнить процедуру локальной или сетевой установки. При этом не производится никаких изменений в меню, системном каталоге и реестре Windows как для сервера, так и для компьютера, на котором запущена программа установки. Сетевая установка может быть выполнена только путем запуска программы SETUP.EXE из каталога, созданного в процессе административной установки. Сетевая установка отличается от локальной главным образом тем, что в процессе сетевой установки на компьютер пользователя не копируются программные файлы 1С: Предприятие, а пункты меню для запуска программ настраиваются таким образом, что при их старте исполняемые файлы (.EXE, .DLL) берутся из того же каталога сервера локальной сети, откуда запускалась программа SETUP.EXE для выполнения сетевой установки. Так какой же из вариантов установки является предпочтительным? (Понятно, что данный вопрос применим только к сетевым вариантам 1С: Предприятие). Локальная установка является наиболее простым вариантом. В этом случае на каждом компьютере, на котором предполагается использовать 1С: Предприятие, необходимо выполнить процедуру локальной установки. В простейшем случае инсталляция выполняется непосредственно с дистрибутивного комплекта. Но локальная установка может быть выполнена также и из каталога на сервере, в который была предварительно произведена административная установка. При локальной установке запуск 1С: Предприятие осуществляется быстрее всего, (программные файлы загружаются с локального диска компьютера, а не с удаленного диска сервера) и несколько меньше загружается сеть, но при этом на каждом из компьютеров пользователей расходуется дисковое пространство под одни и те же программные файлы 1С: Предприятие. Наиболее серьезным недостатком локальной установки являются сложности с администрированием, особенно в тех случаях, когда система 1С: Предприятие используется на многих компьютерах локальной сети. Дело в том, что периодически появляются обновленные выпуски (релизы), которые в случае использования локальной установки приходится переустанавливать на каждый компьютер, на котором используется 1С: Предприятие. Также не рекомендуется использовать при работе с одной и той же информационной базой различные релизы 1С: Предприятие. В случаях, когда в рамках одной локальной сети для работы с системой 1С: Предприятие используется значительное число компьютеров и сеть не слишком перегружена, рекомендуется использовать сетевую установку 1С. Как уже отмечалось, для выполнения сетевой установки 1С: Предприятие надо предварительно выполнить административную установку на диск сервера. И только затем процедура сетевой установки может быть выполнена на компьютерах пользователей. Это несколько усложняет процесс инсталляции в целом, но позволяет воспользоваться некоторыми преимуществами, основным из которых является упрощение процедуры обновления релизов 1С: Предприятие. В данном случае обновление релиза 1С: Предприятие, сводится к административной установке на сервер нового релиза 1С: Предприятие поверх уже имеющегося. Таким образом, на компьютерах пользователей будут запускаться обновленные варианты программных файлов 1С: Предприятие (в случае сетевой установки программные файлы запускаются с диска сервера). Процедура сетевой установки подразумевает копирование в системный каталог Windows на компьютеры пользователей некоторых входящих в комплект поставки 1С: Предприятие системных файлов, которые также могут время от времени подвергаться обновлению (правда, намного реже, чем программные файлы 1С: Предприятие). Поэтому, для обеспечения надежности и во избежание несогласования версий системных файлов, после обновления релиза 1С: Предприятие на сервере, рекомендуется повторить процедуру сетевой установки на компьютерах пользователей.

Советы "бывалым"

Как установить на одном компьютере несколько компонентов 1С: Предприятие? Часто возникает ситуация, что на один компьютер надо установить два разных компонента 1С Предприятия (например, "Бухгалтерский учет, сетевая версия" и "Оперативный учет, 3 раб. места"). Если их поставить в разные каталоги, то пользователь будет путаться, из-под какой платформы и какую конфигурацию ему запускать. В целом, не экономно держать на одной машине две практически одинаковые версии системы 1С. Более рациональным вариантом установки является следующий: установить компонент "Бухгалтерский учет" (из разных вариантов - локальная, 3-х пользовательская, сетевая - выбирается более масштабная версия); в каталоге BIN, найти два файла с расширением PLS и переименовать в соответствии с их оригинальными именами ("оригинальное имя" хранится в свойствах файлов). В результате, вы установите все три компонента 1С: Предприятия. Теперь остается только поставить электронные ключи от тех компонентов, которые приобретены, и можно работать! Успехов вам. В статье использованы следующие материалы: 1. 1С: Предприятие 7.7 Руководство по установке и запуску. 2. Материалы сайта "1С Волшебно" http://www.mista.


1С:Предприятие 7.7

1С: Предприятие 7.7. Как обновить 1С?

Система программ "1С: Предприятие" включает большое количество периодически обновляющихся программных продуктов. Пользователь, владеющий лицензионной версией программы, имеет возможность в любой момент получить соответствующие обновления. В этой статье можно узнать о том, какие бывают обновления, как они называются и чем отличаются друг от друга.

Что и зачем надо обновлять?

Эта информация необходима, чтобы четко понимать, как и какие части "1С: Предприятие" необходимо обновлять. Тогда, при обращении в службу технической поддержки фирмы "1С", пользователь сможет точно сообщить, с каким программным продуктом он работает. Информация об установленных обновлениях существенно повышает эффективность консультации.

Прежде всего, отметим, что "1С: Предприятие" состоит из платформы (системной части) и различных конфигураций. Платформа поставляется всегда в готовом виде и не может быть изменена пользователем. Конфигурация также поставляется в готовом виде, но может изменяться пользователем (кроме базовых версий). В поставку большинства программных продуктов "1С: Предприятие" входит платформа и одна или несколько конфигураций. Некоторые конфигурации поставляются отдельно, и для их работы у пользователя должен быть другой продукт, включающий платформу.

Платформа и конфигурации обновляются независимо, то есть, обновления платформы и конфигурации выпускаются в разное время и имеют разные номера. В некоторых случаях необходимо выполнять обновление и платформы, и конфигурации. Данное обстоятельство обычно указано в инструкции по обновлению конфигурации.

Помимо платформы и конфигураций существуют еще внешние отчеты и внешние печатные формы. Например, 1С выпускает ежеквартально "Квартальные формы отчетности" для бухгалтерских конфигураций - это и есть внешние отчеты.

Итак, что следует обновлять в "1С: Предприятие":

  • Платформу

  • Конфигурации

  • Внешние отчеты и печатные формы

Практика сопровождения пользователей "1С: Предприятие" показывает, что своевременное обновление программ - это решение значительной части проблем.

Получение обновлений

Существует несколько способов получения обновлений.

1. Наиболее эффективный способ - это подписка на диск ИТС, который выпускается раз в месяц.

Диск (CD_ROM) содержит большое количество методического и нормативно-справочного материала, текущие обновления конфигураций и платформы. Подписка на диск ИТС включает доставку диска и установку обновлений. Подписчики диска ИТС имеют возможность получать обновления конфигураций с Web-сайта фирмы "1С".

2. Получить обновления можно у партнеров фирмы "1С". Возможность и условия обновлений следует обсудить с конкретной партнерской организацией.

3. Зарегистрированные пользователи могут также получать обновления непосредственно в фирме "1С".

Не рекомендуется пользоваться неофициальными источниками для получения обновлений.

Установка обновлений

Установка новых версий программы выполняется достаточно редко и подробно описывается в прилагаемой документации.

Установка релизов платформы

Установка релизов платформы выполняется аналогично первоначальной установке программы. Обновление представляет собой обычный дистрибутив (запись программы, предназначенная для установки) - такой же, как в комплекте поставки или специальный дистрибутив с диска ИТС. Установка с обычного дистрибутива ничем не отличается от первичной установки, а установка с диска ИТС автоматически находит программу, установленную на компьютере, и выполняет установку. При установке релиза платформы не важно, какой релиз был установлен до этого.

Следует отметить, что установка новых релизов платформы не является актуальной для пользователей 1С. Фирма "1С", выпуская новый релиз платформы, как правило, не объясняет, чем он отличается от предыдущего.

На сегодняшний день, последним является 20-й релиз. Платформу можно не обновлять, если у вас релиз 14 или выше, и вы довольны работой своей 1С.

Установка конфигураций

Обновление конфигураций (редакций и релизов) должно выполняться согласно инструкции. Для типовых конфигураций инструкция по установке выдается в процессе установки новой редакции или релиза конфигурации. В состав конфигурации включается также и описание изменений, произведенных в данном релизе или редакции. Обновление конфигурации следует выполнять весьма внимательно. Рекомендуется до выполнения обновления сделать резервную копию информационной базы.

При установке обновлений конфигураций следует придерживаться той последовательности, в которой выпускаются релизы и редакции. Так как при установке каждого релиза может выполняться конвертация информации, то для более корректного обновления не следует пропускать релизы.

Внимание! Если у вас "не типовая" конфигурация, то при установке новой конфигурации ваши изменения могут быть уничтожены. Если у вас конфигурация с изменениями, то обновление следует доверить специалистам фирмы "1С".

На диске ИТС существует раздел с подробными рекомендациями по обновлению конфигураций.

Как установить на компьютер регламентированные формы отчетности?

Регламентированные формы отчетности поставляются в виде самораспаковывающихся архивов. Для того чтобы установить формы отчетности, необходимо:

1. Запустить 1С: "Бухгалтерия 7.7".

2. Выбрать пункт меню "Отчеты" -> "Регламентированные".

3. В появившемся диалоге нажать кнопку "Загрузить".

4. Далее выбрать файл с архивом форм отчетности (например, для отчетности за третий квартал 2002 года файл будет называться Rp02q3.exe).

5. Программа автоматически распакует архив, и на экране появится новая группа - отчетность за требуемый квартал.

Я пытаюсь установить формы отчетности, однако новая группа отчетов не появляется. Что делать в этом случае?

Практика показывает, что отчетность в автоматическом режиме не всегда устанавливается правильно. При возникновении ошибок можно установить формы отчетности вручную. Для этого:

- перейдите в каталог ExtForms, расположенный в каталоге с вашей информационной базой;

- в каталоге ExtForms создайте каталог с именем RP02Q3.GRP (если нужно загрузить формы отчетности за 3 квартал 2002 года);

- в каталог RP02Q3.GRP скопируйте файл самораскрывающегося архива Rp02q3.exe;

- запустите файл Rp02q3.exe на выполнение. Он начнет распаковку форм отчетности и запись их на диск.

Если в каталоге RP02Q3.GRP уже есть какие-либо файлы отчетов, программа распаковки выдаст на экран запрос такого вида: FRM1.ERT [YNA]? и будет ждать вашего ответа. Имя файла, который извлекается из архива, может быть различным, одинаковыми будут только символы в квадратных скобках.

В ответ на этот запрос следует нажать одну из трех клавиш:

1. Y (Yes, Да) - если вы ХОТИТЕ ЗАМЕНИТЬ файл отчета, который уже есть у вас на диске, новым файлом, извлеченным из архива;

2. N (No, Нет) - если вы НЕ хотите заменять файл отчета, который находится у вас на диске, новым файлом, извлеченным из архива.

Если вы ответили на запрос "Y" или "N", программа распаковки в дальнейшем также будет требовать ответ на запрос всякий раз, когда имя извлекаемого из архива файла совпадает с тем, который уже существует на диске.

3. A (Always, Всегда) - если вы хотите заменить этот и все оставшиеся файлы отчетов, находящиеся у вас на диске, новыми файлами, извлекаемыми из архива.

После ответа "A" программа распаковки будет работать автоматически, и запрос на экран выдаваться не будет.

После окончания распаковки перейдите в "1С:Бухгалтерия 7.7" и вызовите режим "Регламентированные отчеты". В списке "Группа отчетов" должна появиться новая строка "Отчетность за 3 квартал 2002 года".

Я пытаюсь вручную установить формы отчетности, однако все равно формы правильно не устанавливаются. Почему?

Чаще всего это происходит, из-за того, что путь к Вашей информационной базе слишком длинный. Переместите информационную базу ближе к корневому каталогу и загрузите формы отчетности стандартным образом.

Ранее на компьютер были установлены формы отчетности за 3-й квартал 2002 года. Сейчас вышла новая версия форм за 3-й квартал. Как установить обновление?

- В каталоге ExtForms, расположенном в каталоге с Вашей информационной базой, в папке temp.grp удалите файл Rp02q3.exe (если нужно загрузить формы отчетности за 3 квартал 2002 года);

- Загрузите формы отчетности стандартным образом.

Что такое "версия" программы?

В системе программ "1С: Предприятие" понятие "версия" относится к платформе. Версия является своего рода "поколением" системы программ. Новая версия выпускается раз в несколько лет и является существенным развитием практически всех возможностей системы. Текущей версией "1С: Предприятие" (на апрель 2001 года) является версия 7.7. По названию этой версии именуются и все продукты, выпускаемые с момента выхода данной версии. Например, "1С: Бухгалтерия 7.7" включает платформу "1С:Предприятие" версии 7.7 и типовую конфигурацию, разработанную для этой версии. Конфигурации, разработанные для предыдущих версий, могут использоваться с данной версией, но только после выполнения конвертации (преобразования самой конфигурации и данных).

Номер версии указывается (и) на коробке и в книжке. В самой программе его можно посмотреть в режиме "Помощь - О программе" - в верхней строке диалога. Для версии 7.7 (там) должно быть написано "1С: Предприятие 7.7 ...". Далее может быть уточнение варианта платформы, например, "для SQL".

Заметим, что слово "версия" в "1С: Предприятие" используется и для обозначения варианта поставки, например, "базовая", "сетевая", "стандартная", "для SQL" и т. д. Однако версия в этом смысле не влияет на обновление программы - это именно варианты поставки программного продукта (подробнее варианты поставки были описаны нами в № 1 "БУХ.1С" за 2001 год, а также содержатся в разделе "Различия программных продуктов системы программ "1С:Предприятие" диска ИТС).

Что такое "редакции"?

Понятие "Редакция" в системе программ "1С: Предприятие" применяется к конфигурациям. Новые редакции конфигураций разрабатываются в среднем раз в полгода и являются развитием конкретной конфигурации. В новых редакциях расширяется состав задач, решаемых программой, вводятся новые возможности (документы, справочники, отчеты), улучшаются алгоритмы и внешнее оформление. В некоторых случаях выпуск новых редакций обусловлен существенными изменениями законодательства, требующими перестройки механизмов учета. Новая редакция, как правило, имеет новую документацию. Кроме того, новая редакция обычно содержит описание отличий для пользователей предыдущих редакций. При переходе на новую редакцию требуется выполнить определенную процедуру установки, которая может выполняться с конвертацией данных или без нее, в зависимости от характера развития конфигурации.

Номер редакции обычно не включается в название самого продукта, но указывается в названии книги, описывающей работу с типовой конфигурацией. В самой программе номер редакции можно посмотреть в режиме "Помощь - О программе". После слова "Конфигурация" располагается название конфигурации и номер редакции. В некоторых конфигурациях номер редакции может не отображаться в режиме "О программе". Помимо этого, для некоторых конфигураций (например, "Зарплата + Кадры") понятие редакции не используется.

Что такое "релиз (выпуск)"?

Термин "релиз" (от английского "release" - "выпуск") используется в компьютерной индустрии для обозначения обновления программы, незначительно отличающегося от предыдущего. В 1С: Предприятии понятие "релиз" применяется для обозначения текущего обновления как платформы, так и конфигурации. Соответственно, бывают релизы платформы, а бывают релизы конфигураций. Релиз не является существенным развитием программы. В основном, выпуски релизов связаны с исправлением обнаруженных ошибок или изменениями, внесенными в соответствии с вышедшими нормативными актами.

Обновление релиза платформы выполняется достаточно просто. Конвертация данных при этом не производится. Обновление релиза конфигурации выполняется по прилагаемой инструкции. В зависимости от сделанных в релизе изменений, при обновлении может потребоваться, или не потребоваться конвертация данных.

Номера релизов не печатаются в документации или каких-либо других печатных материалах. Их можно посмотреть в самой программе в режиме "Помощь - О программе". Номер релиза платформы выводится в скобках справа от названия и номера версии платформы, а номер релиза конфигурации выводится в скобках справа от названия и номера конфигурации.

В некоторых конфигурация номер релиза может не отображаться в режиме "О программе".

Где получить информацию о выходе обновлений?

Выход новых версий платформы и редакций конфигураций обычно освещается в прессе, на единых семинарах и других маркетинговых мероприятиях. Информацию о выпуске новой версии или редакции можно посмотреть в новостях на Web-сайте фирмы 1С (www.1c.ru). Эту информацию можно также узнать у партнеров, занимающихся продажей и поддержкой программных продуктов фирмы "1С".

Выпуск релизов, как правило, не освещается в прессе. Информация о выходе релизов конфигураций регулярно публикуется на Интернет-ресурсе для бухгалтеров buh.1c.ru., Также ее можно получить в отделе технической поддержки фирмы 1С.


IP-Tools

 Небольшая по размеру (всего 1,2 Мб), утилита под названием IP [image] -Tools включает в себя семнадцать утилит для работы с IP-сетями. Не запутаться в таком большом количестве поможет хорошо написанный файл помощи. Правда, почему-то часть сведений в справке представлена на русском языке, а часть - на английском, причем английская версия значительно полнее русской. Например, описание команды "trace" на английском языке содержит 150 слов, а для русской аудитории автор ограничился одной лаконичной фразой: "Trace как trace, показывает маршрут по которому бегают ваши IP-пакетики до заданного компьютера". Итак, набор предоставленных в распоряжение пользователя утилит, можно разделить на четыре группы. Группа первая, информационная:
  • "Local Info" - отображает общую информацию о компьютере.
  • "Connection" - отображает подробную информацию о состоянии портов компьютера: заняты ли они в настоящее время, и если заняты, то кем, и что в данный момент с ними происходит.
  • "NetBios" - отображает информацию об используемых на заданном компьютере сетевых интерфейсах.
Следующая группа состоит из пяти утилит, которых можно назвать одним словом - сканеры. Это: сканер "зашаренных" сетевых ресурсов ("NB Scanner"), сканер TCP-портов ("Port Scanner") и "UDP Scanner", который ищет сервисы, использующие протокол UDP. А с помощью "Ping Scanner'а" и "Host Monitor'а" можно проверить один или несколько ip-адресов на предмет их доступности. Третья группа представляет собой набор довольно простых, но весьма полезных функций, которые помогают отследить маршрут прохождения ip-пакетов ("trace"), узнать регистрационные данные о домене ("whois"), вывести информацию о пользователе заданного хоста ("finger"), получить информацию о конкретном сервере, его ip-адресе и алиасах ("lookup"). И, наконец, замыкает этот список группа из четырех утилит.
  • "Get Time" - синхронизация системного времени с серверами точного времени;
  • "HTTP" - отображает все данные, пришедшие от сервера по протоколу HTTP;
  • "IP Monitor" - показывает в реальном масштабе времени графики количества входящих, выходящих, ошибочных пакетов для протоколов TCP, UDP, ICMP.
  • Ну, а последняя утилита - "Telnet", думается, в особом представлении не нуждается.
Заканчивая обзор данной программы, нельзя не сказать о том, что большинство описанных выше утилит обладает приличным набором разнообразных настроек и параметров, которые доступны из меню "Options". Хорошим дополнением к IP-Tools является программа Advanced Host Monitor, разработанная тем же программистом, Александром Козловым. Внешне Host Monitor очень напоминает IP-Tools, и функционально они тоже частично пересекаются. Например, в Host Monitor'е присутствует и клиент "telnet", и утилита "trace", и модуль общей информации о системе. Но главная задача Host Monitor'a отлична от IP-Tools - сбор и анализ статистики о жизнедеятельности компьютера. Допустим, у вас возникли подозрения, что ваш сервер в течение дня склонен к периодическому "проваливанию", но вы не имеете ни возможности, ни желания круглосуточно сидеть перед монитором и отслеживать его состояние. В этом случае Host Monitor вполне справится с ролью спасителя "отца русской демократии". Для этого необходимо лишь нажать кнопочку "add", расположенную в верхней части экрана, и в появившемся довольно внушительном списке выбрать пункт "ping". Теперь осталось только задать несколько параметров (имя тестируемого сервера, расписание тестирования (например, каждые пять минут), событие, которые выполнится при отрицательном результате (звуковой сигнал, сообщение по сети, отправка письма по электронной почте, завершение работы компьютера и т.д.). После всех этих манипуляций в главном окне программы появится новое задание, которое Host Monitor будет выполнять с присущей всем программам постоянностью. Если бы способности Host Monitor'a ограничивались "пингованием" серверов, то, возможно, об этой программе не стоило бы и говорить. Но, к счастью, "ping" это всего лишь одна из тридцати шести функций, предоставляемых программой в ваше распоряжение. Кроме нее, Host Monitor умеет отслеживать свободное место на жестких дисках, выполнять ODBC-запросы, проверять ящики электронной почты, работать с файлами, подключаться к СУБД, выполнять скрипты, написанные на Java Script и Visual Basic'е и так далее, и тому подобное. Кроме того - и это очень важно, - Host Monitor в качестве отслеживаемых параметров использует и внутренние счетчики компьютера (Perfomance Counter), а их - более ста! Чтобы вы не запутались в многочисленных заданиях, Host Monitor позволяет сгруппировать их по какому-нибудь признаку, представив общую структуру всех заданий в виде "дерева". Например, одна ветка "дерева" будет называться "серверы" и содержать задачи, отслеживающие состояние определенных компьютеров, вторая - "почта", третья - "пользователи" и т.д. Неплохо в программе реализован и модуль отчетов, с помощью которого можно следить за всеми происходящими событиями. В меню "Report" расположены готовые шаблоны самых разнообразных отчетов. От вас требуется только выбрать нужный. Для особых случаев существует "Report manager". Таким образом, если вам приходится часто отслеживать какие-то параметры своего компьютера, локальной сети или ресурсов в Интернете, то Host Monitor - эта как раз та программа, которая может снять с вас хотя бы эту проблему. Программы в каталоге Softkey.ru:
  • IP-Tools / Автор: Alex Kozlov
  • Advanced Host Monitor / Автор: Alex Kozlov

Маленький сервер, если в вашей локальной сети насчитывается всего несколько компьютеров и задачи не очень сложны. Для таких случаев существует маленькая, но функциональная программа Eserv, объединяющая в себе функции веб-, почтового, FTP- и новостного сервера. Давайте рассмотрим ее возможности подробнее.

Eserv имеет очень простой и удобный русскоязычный интерфейс администратора и может работать как в режиме сервиса Windows NT, так и обычным приложением в среде Windows 95/98. Все настройки программы находятся на одном экране и довольно просты для понимания. Однако за кажущейся простотой скрывается множество полезных функций.

С помощью Eserv вы можете организовать внутриофисный обмен почтовыми сообщениями. Для этого вам не нужно будет даже иметь выхода в Интернет. Необходимо лишь завести локальный домен и "раздать" пользователям электронные адреса. Кроме того, Eserv служит еще и локальным сервером новостей - используя его, можно построить удобную систему обмена информацией внутри компании. Для работы с сервером пользователи могут использовать свои любимые стандартные клиенты The Bat!, Microsoft Outlook, Netscape Messenger, Eudora и другие.

Кроме работы исключительно в локальной сети, Eserv поддерживает доставку почты в Интернет и обратно. Этот процесс осуществляется двумя способами. Наиболее распространено явление, когда провайдер выделяет компании отдельный домен и направляет всю электронную почту для него в отдельный почтовый ящик. Это удобно, если у вас нет постоянного доступа в Интернет, и вы пользуетесь модемом, тогда сервер будет забирать всю почту из этого ящика и автоматически сортировать по ящикам внутренних пользователей.

Более продвинутым и надежным является метод, когда SMTP-сервер провайдера сам передает почту на ваш сервер. В этом случае вам желательно иметь постоянный доступ к Интернету. Никаких дополнительных настроек сервера тогда не понадобится.

Защитить внутренних и внешних пользователей от вирусов вы можете, применяя антивирусный модуль программы Eserv. С его помощью сервер будет использовать для проверки всех проходящих через него писем один из популярных антивирусов, таких как Kaspersky Antivirus, DrWeb, Stop или UNA. Если в письме будет обнаружена вредоносная программа, то оно будет заблокировано, а отправителю послано соответствующее предупреждение.

Кроме этого, Eserv позволяет организовать листы рассылок. За это отвечает отдельный модуль, входящий в комплект поставки программы. С его помощью вы сможете настроить шаблоны сообщений в рассылке, адресатов и робота, который будет реагировать на запросы пользователей. Система эта довольно проста и уступает по функциональности модулю рассылок MDaemon, но вполне подойдет для несложных задач.

Встроенный в Eserv прокси-сервер позволит всем пользовательским компьютерам получать доступ в Интернет. Для этого нет необходимости каждому компьютеру иметь реальный IP-адрес в Интернете. Прокси-сервер может работать как с постоянным соединением (выделенной линией), так и с коммутируемым доступом (модем). В зависимости от настроек, при появлении запросов внутренних пользователей, прокси-сервер может "дозвониться" до провайдера и установить соединение с Интернетом. Прокси сервер поддерживает "зеркалирование" любых TCP и UDP портов, а также имеет встроенную поддержку Socks4 и Socks5. Для работы с внешней Сетью пользователи также могут использовать практически любые браузеры, интернет-пейджеры или FTP-клиенты.

Eserv хорошо подойдет и для организации небольших Интернет и интранет-серверов по протоколам HTTP или FTP. Если вам не требуются возможности Apache или IIS, то Eserv - это то, что вам нужно. На нем удобно отлаживать работу простых сайтов и организовывать FTP-доступ к ресурсам сервера.

Не секрет, что для каждого круга задач нужно подбирать свое программное обеспечение. Eserv идеально подойдет для небольшой корпоративной сети или домашнего использования. Программа позволяет вам бесплатно поработать с ней в течение месяца, после чего от вас потребуется регистрация. Кстати, совсем не дорогая для такого рода системы - чуть больше трех тысяч рублей. Если посчитать, то приобретение всех серверов по отдельности будет стоить вам гораздо дороже. А когда не требуется выполнять сверхзадачи, то зачем платить больше? Так или иначе, но попробовать использовать программу стоит. Хотя бы для того, чтобы понять, что вам нужно нечто другое.

Программы в каталоге Softkey.ru:

  • Eserv - SMTP/ POP3/ IMAP/ HTTP/ FTP/ NNTP/ Socks серверы и прокси / Автор: ЗАО "Компания Етайп"

  • Антивирусный фильтр KAV для Eserv / Автор: ЗАО "Компания Етайп"

Ссылки по теме:

  • Сайт программы Eserv

  • Сайт компании Etype

  • Сайт компании "Лаборатория Касперского"

  • Сайт программы "Антивирусный фильтр для Eserv"


MMC

Консоль управления Microsoft

Microsoft Management Console (MMC, консоль управления Microsoft). Что это такое? У администраторов системы и ее предшественников был целый набор административных инструментов, часть из которых была вынесена в панель управления, а другая часть находилась в меню Администрирование. Каждый инструмент представлял собой отдельное приложение пусть и с удобным, но своим интерфейсом. К тому же, приложение могло выполнять сразу несколько функций. По этим причинам начинающим администраторам (а данными утилитами пользуются, в основном, администраторы) было трудно управлять системой, часто они просто терялись в многообразии функций отдельного приложения, в то же время так и не находя нужного им параметра.

Для исправления сложившейся ситуации компания Microsoft решила создать новый универсальный продукт, удовлетворяющий следующим требованиям:

• Должна быть единая универсальная среда, в которой можно выполнять все задачи по управлению системой, используя однотипные приемы и стандартный интерфейс пользователя. Среда должна позволять выполнение нескольких задач одновременно.
• Набор задач должен быть настраиваемым и расширяться/сокращаться по желанию администратора.
• Доступ к инструментам должен выполняться как локально, так и удаленно с самых разнообразных клиентов.
• Инструменты должны обладать возможностью передачи их от одного администратора другому с минимальными затратами.
• API среды должен позволять создавать сторонним фирмам аналогичный инструментарий для своих приложений.

What is it?
MMC является общей расширяемой средой для управляющих приложений, удовлетворяющей вышеперечисленным условиям. Реализована она в виде обычного MDI-приложения (многооконного), широко использующего интернет-технологии. Сама по себе MMC не представляет управляющих функций — это лишь среда для оснасток (snap-in). Оснастка — управляющий компонент, интегрирующийся в MMC. Одна оснастка представляет единицу управления, а их набор — управляющий инструмент. Оснастка может как посылать команды приложению, так и принимать их, а также выступать в качестве элементов интеграции различных приложений. Одновременно в системе можно использовать и MMC, и управляющие приложения других фирм, задействовав их отдельно либо создав ярлыки на них в MMC. Вырисовывается такая схема (см. рис. 1)

Архитектура MMC
Обратите свое внимание на рис. 2. Здесь вы увидите модель консоли управления.

Диспетчер оснасток (Snap-in manager) — основа консоли управления — позволяет добавлять, удалять и модифицировать оснастки, а также разрешает указать, как будет работать данная оснастка: автономно или с дополнительными расширениями. Значения параметров хранятся в файлах с расширением .msc. Из нескольких загруженных оснасток администратор может создать инструмент управления. Этот инструмент сохраняется в MSC-файле для повторного использования и называется документом.
"Монитор маршрутизации" и "Журнал событий" на рисунке являются подгруженными оснастками, с которыми взаимодействует пользователь.
Объединяясь, оснастки создают пространство имен — упорядоченный набор узлов в виде древовидной структуры. Если дерево большое, можно воспользоваться страницей Избранное (интерфейс MMC в целом напоминает Проводник). Для каждого узла можно открывать дочерние окна.

Оснастки
Оснастка (snap-in) — это минимальная единица управления, реализованная в виде OLE Inproc-сервера, исполняемого в контексте MMC. Как уже говорилось, набор оснасток представляет собой инструмент управления. Оснастка способна вызывать другие поддерживаемые в системе элементы управления и DLL. Такая гибкость позволяет создавать инструменты по желанию администратора, заточенные под конкретные задачи. Оснастки бывают самостоятельными и оснастками-расширениями. Самостоятельные оснастки полностью самодостаточны, а оснастки-расширения обеспечивают нужной функциональностью оснастку-родителя. Многие оснастки обладают двойной функциональностью, являясь одновременно самостоятельными и расширяющими, как, например, оснастка Ведение журнала, расширяющая оснастку Управление компьютером. Оснасткам доступны следующие механизмы расширения консоли управления:

• Перечисление имен.
• Расширение контекстного меню.
• Расширение меню Новый (New).
• Расширение меню Задачи (Tasks).
• Расширение панели инструментов и кнопок на ней.
• Расширение страницы свойств.
• Расширение меню Вид (View).
• Организация последовательностей в программах-мастерах.
• Расширение справочной системы.
Думаю, с этим все ясно.

Работа с MMC
Консоль работает в двух основных режимах: авторском (author) и пользовательском (user). Пользовательский режим делится на 3 подрежима:

• полного доступа;
• ограниченного доступа с несколькими окнами;
• ограниченного доступа с одним окном.

Полное управление над инструментом и консолью в целом вы получаете только в режиме автора, в любом пользовательском вы можете лишь использовать его, причем с ограничениями. Для перехода в авторский режим следует загрузить консоль командой mmc, а затем добавить нужный инструмент. Также можно выделить нужный mmc-файл и в контекстном меню по правому щелчку мыши выбрать команду Автор (Author) либо запустить данный файл с ключом /a.

Добавить или удалить оснастку можно в авторском режиме из меню Консоль, Добавить или удалить оснастку (Console, Add/remove Snap-in). Кстати, на закладке Расширения (Extensions) можно отключить ненужные в данный момент оснастки-расширения для добавляемой оснастки.
Для изменения свойств созданного вами инструмента, сохраненного в файле .msc, служит пункт Параметры (Options) меню Консоль (Console), где можно указать необходимый режим доступа.

У MMC есть одно замечательное свойство — панели заданий (taskpads). Это окно с одной или несколькими вкладками, на которых может располагаться список параметров и произвольные задания в виде значка. Заданием может быть команда из меню текущей оснастки, ссылка на web-страницу или любая команда, вызывающая приложение или сценарий. Для создания такой панели необходимо щелкнуть правой кнопкой мыши на нужной вам ветке консоли и выбрать команду Новый вид панели задач (New Taskpad View). Запустится программа-мастер, которая сначала настроит вид этой панели, а потом запустит другой мастер, добавляющий задания на созданную панель. Надо признать, это очень удобная вещь.

Внешний вид оснастки позволяет настроить команда Настроить (Customize) меню Вид (View).

Управление доступом к оснасткам
В дополнение к вышесказанному отмечу возможность управления доступом к оснасткам с помощью групповой политики, которая позволяет разрешить/запретить:

• доступ ко всем оснасткам в авторском режиме;
• использование тех или иных оснасток.

Итак, открываем оснастку Групповая политика (Group Policy) для локального компьютера или любого другого. В ветви Конфигурация пользователя (User Configuration) находим ветвь Консоль управления Microsoft (Microsoft Management Console), где указываем нужные параметры. В списке запрещенных или разрешенных оснасток следует запретить оснастки, использование которых нежелательно. Если вы используете XP или Server 2003, то слева от параметров будете видеть исчерпывающие подсказки, посмотреть на которые можно также на закладке Объяснение.

заключение
Как видите, MMC — серьезная среда управления с множеством полезных свойств. К сожалению, не многие ею пользуются, так как не догадываются о ее существовании. С одной стороны, MMC — это инструмент администратора, предназначенный для удаленного и локального администрирования машин в сети, с другой же — данная возможность присутствует на всех версиях NT старше 4.0, так почему бы ею не воспользоваться. К тому же, это стандартное и удобное средство, позволяющее вытворять с вашей машиной множество вещей, недоступных другими способами.


MSCONFIG

В XP присутствует утилита "Настройки системы" (System Configuration Utility, SCU). Вы можете ее вызвать указав MSCONGIF в строке запуска программ Пуск->Выполнить или msconfig.exe Утилита позволяет удобно управлять запускаемыми приложениями.
В утилите присутствует несколько закладок, позволяющих пользователям выборочно и временно изменять параметры запуска. Первые две закладки, SYSTEM.INI и WIN.INI добавлены из соображений совместимости с предыдущими версиями Windows, вряд ли они когда-нибудь вам вообще понадобятся.
Закладка BOOT.INI позволяет управлять загрузкой Windows XP. Сам файл BOOT.INI показывается в текстовом режиме, в нем вы можете указать конкретные строчки для изменения. Но вряд ли у вас получится здесь что-либо ускорить, не испортив систему.
Закладка Службы (Services) позволяет включать и отключать загрузку служб в XP, но для этого существует более подходящий путь, который мы обсудим далее.
В закладке Автозагрузка (Startup) вы найдете список всех программ, которые будут запускаться при загрузке Windows XP. Здесь вы можете отключить некоторые программы, если сочтете их не слишком нужными. К примеру, это Microsoft Office TSR, Quicken Agent, агенты RealPlayer и Winamp, да и прочая ерунда. Вся прелесть SCU состоит в том, что отключение загрузки какой-либо программы не удаляет код, вы можете отключить компонент, а затем перегрузиться и проверить работоспособность программ и железа. Если будут наблюдаться какие-либо неполадки, вы можете включить компонент обратно и перезагрузиться.
Экспериментируя с SCU, вы можете ощутимо увеличить производительность системы и убрать все лишнее. Как только вы найдете запускаемую при старте Windows программу бесполезной, вы можете удалить ее из списка загрузки в списке SCU. Некоторые программы можно также удалить через группу Пуск->Программы->Автозагрузка (Start Menu -> Startup).
Если программа загружается через реестр, ее можно убрать с помощью REGEDIT. Естественно, перед этим вам следует сделать резервную копию реестра. Чаще всего такие программы находятся в ветке [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run] Вы можете убрать программу из автозагрузки просто удалив соответствующую строчку.


Windows Media Player 9

Вэб-сайт от Microsoft, с которого распространяются расширения к Windows Media Player 9

Microsoft открыла Web-узел WM PLUGINS.COM, через который распространяются разнообразные дополнительные плагины и компоненты для мультимедийного плейера Windows Media Player 9 Series под платформу Windows XP. В настоящее время на нем уже предлагается свыше 100 компонентов как от самой Microsoft, так и от сторонних разработчиков. Наиболее популярные и рейтинговые компоненты:
  • TweakMP Powertoy for Windows XP
  • Windows Media 9 Series Viz for Windows XP
  • Xbox Live : Remix
  • Windows Media Bonus Pack for Windows XP
    Разно Soft
    CacheExplorer
    FlashGet
    Outpost
    WinCmd
    TheBat!
    TopStyle
    HomeSite
    AceHTML
    Scribbler2000
    PHPTriad
    Ad-Aware
    System Mechanic
    jv16PowerTools
  • Dancing Stick Figures
  • Animator
  • Anark Client for Windows Media 9 Series
  • Picture Viz II for Windows XP
  • Kenwood KDC-X959
  • Ice
  • Plus! Analog Recorder
  • Plus! Butterflies Party Mode
  • Plus! Nature Party Mode
  • Plus! Sunburst Party Mode
  • Plus! The Bionic Dot LE for WM Player 9 Series
  • Plus! Xbox Live Party Mode
  • Press the Green Button
  • Quantum Redshift
  • The Sentinel
  • Windows Media Player Skin Importer

Русскоязычная версия клиентского ПО DirectX 9.0

Корпорация Microsoft сообщила о выходе локализованных версий клиентского ПО DirectX 9.0 (включая русскую). ПО доступно здесь: http://www.microsoft.com/windows/directx/. Обновленная версия DirectX 9.0a доступна здесь


XP Tweaker

Совсем недавно появилась и уже обрела определенную популярность отечественная программа XP Tweaker, предназначенная для настройки, оптимизации и защиты Windows XP. Она является достойной альтернативой излишне навороченной и слишком дорогой программе Tweak XP Pro, выгодно отличаясь от нее как по своим размерам, так и по потребным для работы ресурсам. Кроме этого, особый интерес к новой программе у отечественных пользователей могут вызвать несколько ее опций, предназначенных специально для русских версий Windows XP. Например, маленькая, но очень полезная функция - возможность использования кодовой страницы "1251" вместо "1252", что решает проблемы с отображением русских шрифтов в некоторых программах. Вроде бы ерунда, но ведь до появления XP Tweaker-а эту "ерунду" приходилось в Реестре каждый раз делать ручками. XP Tweaker, в полном соответствии со своим именем, не совместим ни с одной с другими версией Windows, кроме ХР. Однако большинство опций программы могут нормально работать в Windows 2000 и Windows Longhorn, если запустить программу с ключом /nocheckver. В компактном справочном файле толково и доходчиво изложено не только то, для чего нужна каждая опция настройки, но и приводятся информация обо всех изменениях в ключах Реестра, которые она производит.

  • Размер дистрибутива - 640 Кбайт.
  • Условия распространения - freeware.
  • Сайт разработчика: http://xptweaker.narod.ru.

Powertoys для Windows XP, включающий утилиту для "тонкой" настройки Tweak UI, а также мелкие, но полезные дополнения: Faster User Switcher, Task Switcher, Slide Show Generator, ISO Image Burner и некоторые другие, в том числе графический калькулятор, виртуальный менеджер рабочих экранов и добавочка для управления Windows Media Player из системной панели. Пакет включен в каталог Softodrom.ru.

TweakMP Powertoy for Windows Media Player 9 Series предназначена для операционной системы Windows XP (в принципе плагин сможет работать и под другими версиями Windows, однако в этом случае некоторые возможности плагина будут недоступны).

Утилита TweakMP Powertoy предоставляет следующие возможности:

  • Дополнительные расширенные настройки для медиа-библиотеки

  • Расширение возможностей при записи CD (например автоматическая регулировка громкости во время записи аудио-CD

  • Полноэкранные анимации и другие возможности

Утилита выпушена 22 января. Производитель: Microsoft. Распространяется бесплатно.

Optimizer XP 3.52 538 Кб новое поколение твикеров РС. Специально для XP.Проверка показала что скорость доступа к Интернет заметно увеличилась, прорисовка иконок стала резче, свободной оперативки стало больше, мгновенно стали распахиваться окошки.

Avto Cleaner XP 57 Кб Автоматическая очистка от мусора на вашем компьютере, избавит вас от лишних хлопот по уборке мусора.


Автозагрузка в Windows XP

Автозагрузка

Существует немало способов автозагрузки программ. Ниже приведены несколько вариантов для ознакомления, возможно это поможет вам, если возникнет необходимость найти и удалить какую-либо программу из автозагрузки.

Способы автозагрузки и отключение списков автозагрузки:

Реестр - автозагрузка представлена в нескольких местах:

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ Run] - программы, которые запускаются при входе в систему. Данный раздел отвечает за запуск программ для всех пользователей системы.

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ RunOnce] - программы, которые запускаются только один раз при входе пользователя в систему. После этого ключи программ автоматически удаляются из данного раздела реестра. Данный раздел отвечает за запуск программ для всех пользователей системы.

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ RunOnceEx] - программы, которые запускаются только один раз, когда загружается система. Этот раздел используется при инсталляции программ, например для запуска настроечных модулей. После этого ключи программ автоматически удаляются из данного раздела реестра. Данный раздел отвечает за запуск программ для всех пользователей системы.

[HKEY_CURRENT_USER\ Software\Microsoft\ Windows\CurrentVersion\ Run] - программы, которые запускаются при входе текущего пользователя в систему

[HKEY_CURRENT_USER\ Software\Microsoft\Windows\ CurrentVersion\ RunOnce] - программы, которые запускаются только один раз при входе текущего пользователя в систему. После этого ключи программ автоматически удаляются из данного раздела реестра.

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ RunServices] - программы, которые загружаются при старте системы до входа пользователя в Windows.

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\ CurrentVersion\ RunServicesOnce] - программы отсюда загружаются только один раз, когда загружается система.

Например, чтобы автоматически запускать Блокнот при входе текущего пользователя, открываем Редактор реестра (regedit.exe), переходим в раздел
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Run] и добавляем следующий ключ: "NOTEPAD.EXE"= "C:\\WINDOWS\\System32\\ notepad.exe"

Использование групповой политики для автозапуска: - Пуск-Выполнить (gpedit.msc), откройте оснастку "Групповая политика", перейдите на вкладку "Конфигурация компьютера - Административные шаблоны - Система". В правой части оснастки перейдите на пункт "Запускать указанные программы при входе в систему". По умолчанию эта политика не задана, но вы можете добавить туда программу: включаем политику, нажимаем кнопку "Показать - Добавить", указываем путь к программе, при этом если запускаемая программа находится в папке ..WINDOWS\System32\ то можно указать только название программы, иначе придется указать полный путь к программе. При этом в системном реестре в разделе [HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies] создается подраздел \Explorer\Run с ключами добавленных программ. Пример:

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies\Explorer\Run]
"1"="notepad.exe"
"2"="iexplore.exe"

В итоге получаем запуск Блокнота и Internet Explorer для всех пользователей. Аналогично задается автозапуск для текущих пользователей, в оснастке "Групповая политика" это путь "Конфигурация пользователя - Административные шаблоны - Система", а в реестре раздел

[HKEY_CURRENT_USER\ Software\Microsoft\ Windows\CurrentVersion\ Policies\Explorer\Run]

При этом программы из этого списка не отображаются в списке программ доступных для отключения в msconfig.exe, а также определяются не всеми менеджерами автозагрузки.

Автозапуск из особого списка - Программы могут запускаться и из следующего раздела реестра:

[HKEY_CURRENT_USER\ Software\ Microsoft\Windows NT\ CurrentVersion\Windows]

Параметры:

"load"="programma" - программы запускаемые до входа пользователя в систему:
"run"="programma" - программы запускаемые после входа пользователя в систему.

Эти параметры - аналог автозагрузки из Win.ini в Windows 9х. Пример: запускаем Internet Explorer до входа пользователя в систему и Блокнот после входа пользователя в систему:

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows NT\CurrentVersion\ Windows]
"load"="iexplore.exe"
"run"="notepad.exe"

Не обрабатывать список автозапуска для старых версий - Настраивается с помощью групповой политики: "Конфигурация компьютера - Административные шаблоны - Система - Не обрабатывать список автозапуска для старых версий", если эту политику включить, то не будут запускаться программы из следующих разделов реестра:

[HKEY_LOCAL_MACHINE\ Software\Microsoft\ Windows\CurrentVersion\ Run]

При использовании этой политики в реестре создается следующий ключ:

[HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies\Explorer]
"DisableLocalMachineRun"=dword:00000001

Аналогично устанавливается политика для текущих пользователей: "Конфигурация пользователя - Административные шаблоны - Система - Не обрабатывать список автозапуска для старых версий" с тем отличием что в реестре эта опция включается в ином месте:

[HKEY_CURRENT_USER\ Software\Microsoft\ Windows\CurrentVersion\ Policies\Explorer]
"DisableLocalUserRun"=dword:00000001

Игнорировать списки автозагрузки программ выполняемых однажды - Настраивается с помощью групповой политики: "Конфигурация компьютера - Административные шаблоны - Система - Не обрабатывать список автозапуска программ, выполняемых однажды", если эту политику включить, то не будут запускаться программы запускаемые из списка

[HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\CurrentVersion\ RunOnce]

Если эта политика включена, в реестре создается следующий ключ:

[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\Explorer]
"DisableLocalMachineRunOnce"= dword:00000001

Так же настраивается политика для текущих пользователей: "Конфигурация пользователя - Административные шаблоны - Система - Не обрабатывать список автозапуска программ, выполняемых однажды" Параметры реестра:

[HKEY_CURRENT_USER\ SOFTWARE\Microsoft\ Windows\CurrentVersion\ policies\Explorer]
"DisableLocalUserRunOnce"=dword:00000001

Назначенные задания - программы могут запускаться с помощью "Мастера планирования заданий". Посмотреть список установленных заданий, а также добавить новое можно так: "Пуск - Все программы - Стандартные - Служебные - Назначенные задания" - при этом откроется папка ..\WINDOWS\Tasks, в которой отображены назначенные задания. Чтобы добавить новое задание, нужно дважды щелкнуть левой кнопкой мыши по значку "Добавить задание". Запуск программ с помощью этого мастера возможен однократно, при входе в Windows, при включении компьютера, а также по расписанию.

Папка "Автозагрузка" - это папка, в которой хранятся ярлыки для программ запускаемых после входа пользователя в систему. Ярлыки в эту папку могут добавляться программами при их установке или пользователем самостоятельно. Существует две папки - общая для всех пользователей и индивидуальная для текущего пользователя. По умолчанию эти папки находятся здесь:

..\Documents and Settings\ All Users\Главное меню\ Программы\Автозагрузка - это папка, программы из которой будут запускаться для всех пользователей компьютера.

..\Documents and Settings\ Username\Главное меню\ Программы\Автозагрузка - это папка, программы из которой будут запускаться для текущего пользователя (здесь он назван Username).

Посмотреть какие программы у вас запускаются таким способом можно открыв меню "Пуск - Все программы - Автозагрузка". Если вы создадите в этой папке ярлык для какой-нибудь программы, она будет запускаться автоматически после входа пользователя в систему. Если при входе пользователя в систему удерживать нажатой клавишу "Shift", то программы из папок "Автозагрузка" запускаться не будут.

Смена папки автозагрузки- Windows считывает данные о пути к папке "Автозагрузка" из реестра. Этот путь прописан в следующих разделах:

[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\Windows\ CurrentVersion\Explorer\ User Shell Folders]
"Common Startup"= "%ALLUSERSPROFILE%\ Главное меню\Программы\ Автозагрузка" - для всех пользователей системы.

[HKEY_CURRENT_USER\ Software\Microsoft\ Windows\CurrentVersion\ Explorer\User Shell Folders]
"Startup"= "%USERPROFILE%\ Главное меню\ Программы\Автозагрузка" - для текущего пользователя.

Сменив путь к папке мы получим автозагрузку всех программ из указанной папки. Например:
[HKEY_CURRENT_USER\ Software\Microsoft\ Windows\CurrentVersion\ Explorer\User Shell Folders]
"Startup"="c:\mystartup" - система загрузит все программы, ярлыки которых находятся в папке c:\mystartup\, при этом папка "Автозагрузка" все так же будет отображаться в меню "Пуск", а если у пользователя в ней ничего не было, то он и не заметит подмены.

Подмена ярлыка для программы из списка автозагрузки - допустим у вас установлен русскоязычный пакет Microsoft Office. Тогда в папке "Автозагрузка" у вас будет находиться ярлык "Быстрый запуск Microsoft Office" - этот ярлык устанавливается туда по умолчанию. Но вовсе необязательно этот ярлык ссылается именно на "Быстрый запуск Microsoft Office" - вместо него может быть запущена любая другая программа, тем более что на функциональности Office это не скажется.

Добавление программы к программе запускаемой из списка автозагрузки - модификация предыдущего варианта - одновременно с загрузкой какой-либо программы из списка автозагрузки у вас будет стартовать другая программа - дело в том, что можно "склеить" два исполняемых файла в один и они будут запускаться одновременно. Существуют программы для такой "склейки". Или ярлык может ссылаться на командный файл, из которого и будут запускаться как оригинальная программа из списка, так и добавленные посторонние программы.

Посмотреть список автоматически загружаемых программ можно открыв программу "Сведения о системе" (откройте "Пуск - Все программы - Стандартные - Служебные - Сведения о системе" или наберите msinfo32.exe в командной строке) и перейдя в пункт "Программная среда - Автоматически загружаемые программы". Программа "Свойства системы" отображает группы автозагрузки из реестра и папок "Автозагрузка".

Другая программа, позволяющая посмотреть список программ автозагрузки - "Настройка системы" (или наберите msconfig.exe в командной строке). Эта программа кроме просмотра списка автозагрузки предоставляет возможность отключения всех пунктов автозагрузки (вкладка "Общие") или выборочных программ (вкладка "Автозагрузка").

Примечание: Вся информация, относится в первую очередь к опытным пользователям, способным восстановить систему после ошибочных изменений в реестре. Если вы не уверены, что в случае ошибочных действий сможете восстановить систему, не используйте приведенную информацию в практических целях, ошибочные действия при внесении изменений в реестр могут серьезно повредить систему и даже привести к переустановке системы. Начинающие пользователи для добавления программ в список автозагрузки должны использовать только папку "Автозагрузка" или "Мастер назначенных заданий".


Безопасность

Безопасность\Параметры защиты

Запрет запуска апплета "Установка и удаление программ".

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddRemovePrograms" dword= значение 1 - запрещает запуск апплета Установка и удаление программ

Данный параметр скрывает вкладку "Изменение или удаление программ" в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoRemovePage"dword= значение 1 - скрыть вкладку

Скрывает вкладку Установка программ в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddPage" dword= значение 1 - скрыть вкладку

Скрывает вкладку Установка компонентов Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoWindowsSetupPage" dword= значение 1 - скрыть вкладку

Скрывает раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddFromCDorFloppy" dword= значение 1 - скрыть вкладку

Скрывает раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddFromInternet" dword= значение 1 - скрыть вкладку

Скрывает раздел Установка программ из сети.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoAddFromNetwork" dword= значение 1 - скрыть вкладку

Скрывает ссылку Сведенья о поддержке

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

"NoSupportInfo" dword= значение 1 - скрыть сведенья о поддержке

Полностью отключить общие ресурсы (ADMIN$, C$ и т.д.)

Эти ресурсы доступны Администратору, для отключения/включения требуется перезагрузка. Windows XP позволяет отключить эти ресурсы, но только до перезагрузки.

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

"AutoShareWks" dword= значение 0 - общие ресурсы отключены, 1 - включены

Считается очень важным при выходе из системы уничтожать файл подкачки (PageFile.sys). Этот файл является своеобразным контейнером, куда скидывается вся информация, в том числе и пароли. Чтобы файл подкачки создавался заново (при включенной опции весь файл забивается нулями) необходимо в ветке реестра [HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager \ Memory Management ] параметр "ClearPageFileAtShutdown"= dword:00000001.
Такого же эффекта можно добиться в апплете Local Security Policy в Administrative Tools, раздел Local Policies, Security Options, ключ Shutdown: Clear virtual memory pagefile when system shuts down. (Администрирование-Локальная Политика безопасности-ключ Завершение работы: Очистка страничного файла виртуальной памяти. Хранитель экрана (Screen Saver). По умолчанию в ветке реестра [HKEY_USERS\.DEFAULT\Control Panel\Desktop] параметр "ScreenSaveActive"=dword:1 изменить "0". Если хранитель экрана выбран не был стартует заставка login.scr. Или какой-нибудь вирус. И еще одна брешь: автозапуск компакт-дисков, обычно удобная вещь, но не всегда безопасная и полезная. Как обычно при старте диска стартует какой-либо файл, им может оказаться и вирус. Да и вообще, некоторым не нравится автозапуск и спасаются от этого нажатием левого SHIFT. Но проще будет поправить ветку в реестре HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ CDRom паpаметp: Autorun тип: REG_DWORD значение: 0 (1=включено) Скачать заплатку. Если вы не используете экран входа(logon User Interface), то по умолчанию в поле "Пользователь" виден последний удачно залогинившийся пользователь. Это не есть хорошо. Ведь теперь для злоумышленника будет существенна упрощена задача - логин известен. Чтобы это поле было пустым необходимо в ветке реестра HKEY_LOCAL_MACHINE\ Software\ Microsoft\ Windows\ CurrentVersion\ Winlogon создать парметр DontDisplayLastUserName = 1 - имя пользователя показано не будет, 0 - будет. Скачать заплатку. Как правило, при выполнении команд с помощью пункта меню "Выполнить" список совершившихся команд будет доступен любому пользователю, то же самое в списке "Недавние документы" хранятся использованные в недавнем прошлом документы. Всё это можно убрать, обратившись к ветке реестра HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer. Там необходимо создать параметр ClearRecentDocsOnExit со значением 01 00 00 00. При выключении компьютера все списки будут очищаться. Скачать заплатку Вместе с ОС обычно стартует определенное количество программ, иногда необходимых (таких как антивирус), а иногда и лишних, тем более, что вирус так же может стартовать с Windows. Как правило, папка Автозагрузка в меню "Пуск" может решить некоторые задачи, но для полного контроля за программами с автозапуском необходио прогуляться в реестр: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\ CurrentVersion\Run. Здесь можно удалить программы, которые стартуют вместе с ОС. Немного легче будет запустить утилиту Msconfig и сделать необходимые установки на вкладке Автозагрузка (StartUp). Компьютер под управлением Windows XP необходимо сконфигурировать таким образом, чтобы предотвратить доступ анонимно регистрирующихся пользователей ко всем ресурсам. Это можно сделать в ветке [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] поменяв параметр "restrictanonymous"=dword:00000000 на 00000001. Скачать заплатку "Голубой экран смерти" - печально известная для пользователей Windows вещь. Но иногда даже она может определенным образом помочь. Можно вызвать этот пресловутый экран путем нажатия сочетания определенных клавиш, тем самым мгновенно уничтожив всю информацию в оперативной памяти, файле подкачки, во временных файлах. Эта функция может помочь, когда необходимо мгновенное стирание информации (Неожиданный визит специалистов из ФСБ :-), например). Чтобы осуществить это необходимо в ветке реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters создать параметр DWord CrashOnCtrlScroll и присвоить ему значение 1. и теперь при двухкратном нажатии Scroll Lock с удерживаемой правой клавишей Ctrl система впадет в глубокий даун. Скачать заплатку Иногда необходимо запретить Windows XP защищать системные файлы (System File Protection). Это необходимо при установке новых Logons или Boot-screens, например. Но надо оценивать и определенную долю риска, связанной с с запретом защищать системные файлы. Устанавливаемые программы теперь могут заменить некоторые библиотеки системы или пользователь может сам удалить важный файл. Для того, чтобы отключить систему защиты файлов необходимо в реестре по адресу [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] заменить имеющееся значение параметра
"SFCDisable" на новое значение: dword:ffffff9d. Скачать заплатку.


Быстродействие

Операционная система Windows никогда не работает с максимальной скоростью при настройках по умолчанию. Частично это связано с большим количеством оборудования, на которое устанавливается данная система. Microsoft должна сбалансировать производительность с легкостью в использовании и совместимостью с любым оборудованием. Windows XP выдвигает несколько предположений о том, как она будет использоваться. Графический интерфейс системы обладает своеобразной теплотой и дружественностью, но эффекты типа теней и исчезающего меню замедляют Windows. Инструменты по обеспечению отказоустойчивости типа "Восстановления системы" (System Restore) облегчают восстановление после аварий, но они также съедают дисковое пространство, а их работа в фоновом режиме потребляет часть мощности процессора. Windows XP запускает большое количество служб, которые вам как могут понадобиться, так и могут оказаться совершенно бесполезными, в зависимости от рода вашей деятельности на компьютере. Снятие лишних служб помогает ускорить запуск системы и немного разгрузить процессор для других приложений. К тому же многие приложения типа "Microsoft Office" загружают свои фоновые приложения, которые также съедают системную память и процессор. Если вы потратите несколько минут на снятие лишних фоновых приложений и служб, а также отключите некоторые графические украшательства, то вы сможете заметно улучшить игровую и офисную производительность вашей Windows XP. Даже сама XP помогает оптимизировать файловую систему в зависимости от ваших нужд, к тому же Microsoft поставляет несколько утилит для оптимизации системы. Большинство оптимизаций потребуют редактирование реестра или внесение изменений в жизненно важные части системы, так что вам потребуются административные привилегии. Перед работой вы должны отключить антивирусные средства и программы по обеспечению безопасности, а также выполнить резервирование всех жизненно важных данных. Windows XP прекрасно настраивается! Честно :-) И помните, что только эксперимент поможет вам выбрать оптимальное соотношение между графическими украшениями и производительностью. Встроенная оптимизация Windows XP. Самое интересное, что оптимизация в Windows XP производится постоянно. По мере того, как вы запускаете приложения, Windows наблюдает за вашим поведением и записывает динамический файл layout.ini. Каждые три дня, после того, как система сочтет компьютер бездействующим, она изменяет физическое местоположение некоторых программ на жестком диске для оптимизации их времени запуска и выполнения. XP также ускоряет процесс загрузки системы и оптимизирует запуск программ с помощью предсказаний. Windows наблюдает за кодом и программами, которые запускаются сразу после загрузки, и создает список, позволяющий предсказать запрашиваемые данные во время загрузки. Точно также при запуске отдельных программ, Windows следит за используемыми программой компонентами и файлами. В следующий запуск приложения Windows предсказывает список файлов, которые потребуются программе. Предсказания используются и в ядре Windows XP, и в планировщике задач. Ядро следит за страницами, к которым обращается данный процесс сразу же после его создания. Далее служба создает ряд инструкций предсказания. Когда процесс будет создан в следующий раз, ядро выполнит инструкции предсказания, ускорив выполнение процесса. Оптимизация диска и ускорение запуска приложений/загрузки тесно работают вместе. Списки, записанные при запуске приложения и при загрузке системы, используются при выполнении оптимизации файловой системы для более быстрого доступа к программам. Ускорение графики Иконки и обои Чистый рабочий стол - это самый лучший рабочий стол. Никогда не ставьте обои! Более странного поступка трудно себе представить. Системной памяти и процессору наверняка найдется лучшее применение, чем играться с красивым фоном и сортировать сотни иконок. Как и в предыдущих версиях Windows, чрезмерное количество иконок и обои поедают напрочь системную память. Особенно тяжелым бременем на систему ложится анимированный рабочий стол. С другой стороны, удар по производительности не слишком велик, если ваша система оснащена более 256 Мб памяти и нормальным процессором (где-то 1000 МГц или быстрее). Если же у вас 64 Мб памяти и Pentium 2, то здесь придется серьезно экономить отключая все, что только возможно. Снизьте количество эффектов Благодаря новому виду и GNOME-подобной поддержке скинов, Windows XP выглядит красивее любой предыдущей версии Windows. Переход между меню анимирован, диалоги и курсор имеют тень, экранные шрифты настраиваются под максимальную читаемость и т.д. Все эти визуальные утехи могут снижать реакцию интерфейса на пользователя. XP запускает несколько тестов для автоконфигурации своего пользовательского интерфейса чтобы сохранить как удобство, так и красоту, но вы легко можете все исправить. Если исчезающие меню вам больше досаждают, нежели нравятся, а тени под окнами диалогов вам безразличны, то вы можете убрать все лишнее. Некоторые настройки выполняются через закладку Оформление (Appearance) в свойствах дисплея, которые вы можете вызвать нажав правую клавишу мыши на любой свободной части экрана и выбрав Свойства (Properties). Нажмите клавишу Эффекты (Effects) и вы сможете настроить переходы в меню, тени и шрифт, включая новую технологию улучшения читаемости шрифта Microsoft ClearType. По нашему мнению, ClearType хорош для ноутбуков и ЖК мониторов, но на ЭЛТ текст выглядит слишком жирно и смазано. Учтите, что даже на ЖК мониторе не всем нравится ClearType, так что выбирайте по своему вкусу. Вы можете и дальше настраивать производительность графического интерфейса через Свойства системы (System Properties). Откройте свойства через Панель управления (Control Panel) или нажмите правой клавишей мыши на значок System и выберите там Properties (Свойства). Далее перейдите к закладке Дополнительно (Advanced) и нажмите Параметры (Settings) в панели Производительность (Performance). Здесь вы можете указать как максимальную производительность, так и максимальную красивость, равно как выбрать необходимые параметры самому.
Перейдите к закладке Дополнительно (Advanced) в Параметрах быстродействия (Performance Options) и убедитесь, что распределение ресурсов процессора и памяти выставлено на оптимизацию работы программ – вам нужно указывать приоритет фоновых служб и кэша если только ваш компьютер выполняет роль сервера.
Здесь вы также можете указать размер и местоположение файла подкачки. Но Windows XP обычно сама прекрасно выбирает этот размер. Мы попытались вручную изменять его, но прироста производительности в синтетических или игровых тестах это не дало.
Быстрое переключение между пользователями
Такая функция доступна в "XP Home Edition" и "Professional", если компьютер не входит в домен. Быстрое переключение позволяет пользователям одного компьютера быстро переключаться между учетными записями без завершения сеанса. Прекрасная функция, если вашим компьютером пользуется мама, папа и всякие сестры-братья, однако такое переключение колоссально (!) отъедает доступную память.
Если в систему вошло более одного пользователя, то настройки каждого пользователя, равно как и запущенные программы сохраняются в памяти при переключении к другому пользователю. Скажем, если у вас запущен Word, Excel и Цивилизация, и в это время придет ваш брат, переключит систему на себя и попытается поиграть в Red Faction, он заметит явное падение производительности, до полной неиграбельности.
Windows XP автоматически отключает быстрое переключение между пользователями, если компьютер оснащен 64 Мб памяти или меньше. Для максимальной производительности убедитесь, что в одно время в систему заходит только один пользователь. Вы также можете отключить эту функцию, зайдите в Панель управления\Учетные записи пользователей (Control Panel\User Accounts) нажмите кнопку "Change the way users log on or off": и уберите галочку с пункта "Use Fast User Switching".
Автоматическое обновление
Вы всегда должны ставить на Windows последние исправления, версии DirectX, патчи совместимости и другие обновления (!). Но по умолчанию XP будет сама делать это за вас, разве что для этого потребуется запуск небольшой программы в фоне, которая будет проверять обновления.
Если вы сами следите за обновлениями, то можете сказать XP более вас по этому вопросу не беспокоить. Перейдите в закладку Автоматическое обновление (Automatic Updates) в Свойствах системы (System Properties). Здесь вы можете указать Windows определять и скачивать обновления автоматически, или сообщать вам об этом, или вообще отключить определение.
Восстановление системных файлов
Полезная функция, если ваш компьютер не используется исключительно для ресурсоемких задач типа игр. Так что лучше оставить ее включенной. При этом компьютер периодически создает слепки критичных системных файлов (файлы реестра, COM+ база данных, профили пользователей и т.д.) и сохраняет их как "точку отката". Если какое-либо приложение "снесет" вашу систему, или что-то важное будет испорчено, вы можете обратить компьютер в предыдущее состояние - в точку отката.
Точки отката автоматически создаются службой "Восстановления системы" (System Restore) при возникновении некоторых ситуаций типа установки нового приложения, обновления Windows, установки неподписанного драйвера и т.д. Вы можете и вручную создавать точки отката через интерфейс Восстановления системы (System Restore), который можно вызвать пройдя путь: Пуск\Программы\Стандартные\Служебные\Восстановление системы (Start\Programs\Accessories\System Tools\System Restore).
Восстановление системных файлов опирается на фоновую службу, которая минимально сказывается на быстродействии и записывает снимки, отнимающие часть дискового пространства. Вы можете вручную отвести максимальный объем дискового пространства для данной службы. Вы также можете полностью отключить службу для всех дисков.
Отключить можно пометив бокс "Turn off System Restore"
Поскольку служба восстановления системных файлов может влиять на результаты тестовых программ, ее обычно отключают перед тестированием, что нам и приходится часто делать.
Регулярно производите дефрагментацию DOS и не-NT версии Windows мало заботились об оптимизации своих файловых систем. Когда вы устанавливаете и удаляете программы, то в различных областях дискового пространства создаются "дыры". В результате свободное место представляет собой не сплошной блок, оно разбросанно по всему диску. При заполнении свободного пространства файлы также оказываются разбросанными по нескольким секторам, что сильно снижает производительность – при обращении к файлу диску приходится читать не один последовательный участок, а несколько произвольно разбросанных.
В NT-версиях Windows, использующих файловую систему NTFS, применяются особые меры для сохранения целостности дискового пространства – но фрагментация все равно происходит. Поэтому вы должны регулярно дефрагментировать ваш жесткий диск, причем регулярность зависит от характера вашей деятельности на компьютере.
Если вы часто устанавливаете и удаляете программы, или вы постоянно создаете, перемещаете или удаляете файлы, то вы должны выполнять дефрагментацию раз в неделю. Если же вы долгое время используете одни и те же приложения, при этом вы не слишком часто перемещаете файлы, то вы можете увеличить промежуток между дефрагментациями до одного месяца.
Если вы достаточно часто выполняете дефрагментацию, то вы не заметите ощутимого прироста в производительности после дефрагментации. Это совершенно нормально. Если же прирост явно ощутим, то вы слишком долго не выполняли дефрагментацию.
Снятие ненужных служб
В Windows XP фоновые программы снижают производительность пользовательских программ и игр. Поскольку для фоновых служб требуется память, то соответственно увеличиваются обращения к файлу подкачки, при этом процессор также не остается в стороне.
Вы можете посмотреть на список фоновых служб с помощью Диспетчера задач (Task Manager), который вызывается нажатием клавиш Ctrl+Alt+Delete. В отличие от Windows 9x, XP различает пользовательские приложения и системные службы. Нажмите на закладку Процессы (Processes) для просмотра системных служб и фоновых приложений. Отсюда вы также можете завершить работу каких-либо процессов, если они зависнут.
Вы сразу же можете узнать некоторые процессы по имени. Если у вас работает фоновая антивирусная программа, вы увидите ее в списке процессов. Здесь вы найдете различные процессы, от конфигурирующих вашу мышь (EM_EXEC.EXE) до оболочки Windows Explorer (EXPLORER.EXE). Если вы привыкли к 9x, то часть процессов будут вам незнакомы: SERVICES.EXE, WINLOGON.EXE, SYSTEM и т.д.


В ведение в реестр Windows XP.

Я надеюсь, что данный материал будет интересен широкому кругу читателей. Мы вместе пройдем по запутанным лабиринтам реестра Windows XP. И это будет полезно, поучительно и интересно.

Мы пробежимся по таким темам, как что такое реестр Windows XP. Вашему вниманию предлагаются следующие темы:
Введение в реестр Windows XP
— Что такое реестр Windows XP.
— Из каких файлов состоит реестр Windows XP.
Манипулирование реестром Windows XP
— Общие вопросы.
— Резервное копирование реестра в Windows XP.
— Восстановление реестра в Windows XP.
— Структура .reg-файла. R — опции командной строки.
— Удаление разделов и ключей реестра при помощи .reg-файла.
— Восстановление поврежденного реестра, когда Windows XP не загружается.

Customizer XP своими руками
— Настройка системы. Закладка System.
— Настройка меню "Пуск".
— Настройка Explorer.
— Настройка Интернет.
— Настройка Internet Explorer.
— Разное.

Что такое реестр Windows XP ?

Для начала немного теории, а заодно определимся с терминологией. Эта важная часть нужна нам для того, чтобы лучше понимать друг друга.

Итак, реестр, или системный реестр — это база данных для хранения сведений о конфигурации компьютера и настроек операционной системы. Реестр содержит данные, к которым Windows XP постоянно обращается во время загрузки, работы и ее завершения, а именно:
— профили всех пользователей, то есть их настройки;
— конфигурация оборудования, установленного в операционной системе. Я не пишу "установленного в компьютере", поскольку железо может быть, как говорится, "на борту", но не быть установленным в ОС, например, из-за устаревших драйверов.

— данные об установленных программах и типах документов, создаваемых каждой программой;
— свойства папок и значков программ;
— данные об используемых портах.

Реестр имеет иерархическую древовидную структуру, состоящую из разделов, подразделов и ключей (параметров).

Для работы с реестром используется простая и понятная утилита Regedit, знакомая еще со времен Windows 3.1.

Разделы и подразделы — это, грубо говоря, папки в левом окне Regedit'а. Ключ реестра, или параметр — это некая переменная, которой присвоено определенное значение, проще говоря — это то, что мы видим в правом окне Regedit'а.

Куст (основной раздел, стандартный раздел, в английской документации — улей, от англ. hive) — это раздел реестра, отображаемый как файл на жестком диске. Куст является набором разделов, подчиненных разделов и параметров и имеет корни на верхнем уровне иерархии реестра. По умолчанию большинство файлов кустов (Default, SAM, Security и System) сохраняются в папке %SystemRoot%\System32\Config. Папка %SystemRoot%\Profiles содержит профили (настройки) для каждого пользователя компьютера. Поскольку куст представляет собой файл, его можно перемещать из одной системы в другую. Для редактирования этого файла необходимо использовать редактор реестра.

Важное замечание: Windows XP в отличие от своих предшественниц не имеет ограничения по размеру реестра.

Реестр Windows XP состоит из следующих основных разделов:
HKEY_CLASSES_ROOT — это ссылка на раздел HKEY_LOCAL_MACHINE\ Software\Classes. Хранящиеся здесь сведения обеспечивают запуск необходимой программы при открытии файла с помощью проводника. Этот раздел содержит связи между приложениями и типами файлов, а также информацию об OLE.

HKEY_CURRENT_USER — это ссылка на определенный подраздел HKEY_USERS. Настройки соответствуют текущему, активному пользователю, выполнившему вход в систему.

HKEY_LOCAL_MACHINE — раздел содержит настройки, относящиеся к вашему компьютеру и действительные для всех пользователей, а также информацию об аппаратной конфигурации и установленном программном обеспечении.

HKEY_USERS — этот раздел содержит настройки для всех пользователей компьютера.

HKEY_CURRENT_CONFIG — это ссылка на HKEY_LOCAL_MACHINE\ SYSTEM \CurrentControlSet\ Hardware Profiles\Current. Раздел содержит сведения о настройках оборудования, используемых локальным компьютером при запуске системы, т.е. информацию о текущей конфигурации.

Вышеуказанные основные стандартные разделы вы не сможете удалить или переименовать. Некоторые разделы реестра являются энергозависимыми (volatile) и не хранятся в каком-либо файле. Операционная система создает и управляет этими разделами полностью в памяти, поэтому они являются временными по своей природе. Система создает энергозависимые разделы каждый раз при начальной загрузке. Например, HKEY_LOCAL_MACHINE \HARDWARE — раздел реестра, который хранит информацию по физическим устройствам и назначенным им ресурсам. Назначение ресурса и аппаратное обнаружение происходят каждый раз при загрузке системы, поэтому логично, что эти данные не записываются на диск.

Сердце системного реестра — это раздел HKEY_LOCAL_MACHINE \SYSTEM.

Наибольший интерес для нас представляют ветви HKEY_CURRENT_USER и HKEY_LOCAL_MACHINE: именно там хранятся настройки, изменение которых способно облагородить нашу операционную систему.

Часто для обозначения основных разделов реестра пользуются сокращениями:
HKEY_CLASSES_ROOT — HKCR
HKEY_CURRENT_USER — HKCU
HKEY_LOCAL_MACHINE — HKLM
HKEY_USERS — HKU
HKEY_CURRENT_CONFIG — HKCC

Раздел HKEY_USERS содержит все активные загруженные параметры пользователя. Он имеет не менее трех ключей:
— Подраздел DEFAULT, где хранится используемая конфигурация, когда ни один из пользователей еще не вошел в компьютер. То есть мы еще видим приглашение на вход в систему.

— Дополнительный подраздел, который имеет имя в соответствии с security ID текущего пользователя (описание SID см. ниже). Этот подключ реестра содержит конфигурацию текущего пользователя. Если пользователь вошел удаленно, данные для конфигурации пользователя сохраняются в системном реестре местного компьютера. Данные из HKEY_USERS\%SID% также появляются в HKEY_CURRENT_USER.

— Дополнительный подраздел, который имеет имя в соответствии с SID текущего пользователя с суффиксом Classes. Этот раздел содержит классы текущего пользователя. Данные в HKEY_USERS\%SID%_Classes также содержатся в HKEY_CLASSES_ROOT.

В Windows XP конфигурация пользователя по умолчанию (default user profile) не хранится в системном реестре. Она находится на системном диске в файле \Documents and Settings\Default User\Ntuser.dat.

Отметим, и это важно, что куст HKEY_CURRENT_USER является ссылкой, линком на определенный подраздел куста HKEY_USERS. Это значит, что все изменения в разделах, подразделах и ключах куста HKEY_CURRENT_USER автоматически тут же отображаются в определенном подразделе HKEY_USERS, соответствующем активному пользователю. То есть пользователю, выполнившему процедуру входа.

В каком же именно разделе HKEY_USERS проводятся изменения? Для этого вы должны узнать свой SID. Тогда искомый раздел будет именоваться, например, так: HKEY_USERS\S-1-5-21-117609710 -1606980848-839522115-500. Где цифровая часть, вместе с буквой S, и есть SID.

Идентификатор безопасности (SID, security ID) — структура данных переменной длины, которая идентифицирует пользователя, группу или компьютер. Каждая учетная запись в сети имеет уникальный SID. Внутренние процессы в Windows обращаются к SID для получения учетной записи пользователя или имени группы.

Откройте редактор реестра HKLM\SOFTWARE\ Microsoft\Windows NT\CurrentVersion\ProfileList. Выберите SID и посмотрите ProfileImagePath. В конце строки найдете имя пользователя.

Увидеть все SID, относящиеся к пользователям компьютера, вы можете раскрыв раздел HKEY_USERS. Но в большинстве случаев знать SID не обязательно.

Отметим также, что HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet — это тоже ссылка, линк на один из пронумерованных подразделов с именами HKEY_LOCAL_MACHINE\ SYSTEM\ControlSet00n, где n — номер. Подразделы ControlSet00n представляют собой наборы настроек для операционнной системы Windows XP. Большинство систем имеют два пронумерованных управляющих набора: оригинал и резервную копию, которая использовалась при последнем успешном старте системы. Операционная система Windows XP может обслуживать несколько таких наборов. Windows XP обслуживает резервные копии так, чтобы вы могли отменить изменения конфигурации, которые в противном случае могли бы препятствовать загрузке операционной системы. Windows XP хранит последний набор настроек, который был использован успешно, и настройки по умолчанию. Эти значения сохранены в подключе Select. Имена параметров ключа Select соответственно: Current — текущие настройки и Default — настройки по умолчанию. Также обратите внимание на параметр LastKnownGood, расположенный там же. При загрузке Windows XP вы можете выбрать пункт меню "Загрузка последней удачной конфигурации", а действительный номер набора загружаемых настроек будет определен именно этим параметром реестра.

Все значения ключей реестра относятся к определенному типу. далее дадим описание типов данных, используемых в реестре Windows XP:
REG_BINARY — двоичные данные. Большинство сведений об аппаратных компонентах хранится в виде двоичных данных и выводится в редакторе реестра в шестнадцатеричном формате.

REG_DWORD — целые числа размером в 4 байта. Многие параметры служб и драйверов устройств имеют этот тип и отображаются в двоичном, шестнадцатеричном или десятичном форматах.

REG_EXPAND_SZ — строка данных переменной длины.

REG_MULTI_SZ — многострочный текст. Этот тип, как правило, имеют списки и другие записи в формате, удобном для чтения. Записи разделяются пробелами, запятыми или другими символами.

REG_SZ — текстовая строка фиксированной длины.

REG_FULL_RESOURCE_DESCRIPTOR — последовательность вложенных массивов, разработанная для хранения списка ресурсов железа или драйверов.

Из каких файлов состоит реестр Windows XP ?

Итак, повторим, куст — это раздел реестра, отображаемый как файл на жестком диске. Имя используется для указания на ветвящуюся структуру.

Однако не вся информация из некоторых подразделов кустов хранится на диске, но об этом немного ниже.

А сейчас — вот они, файлы реестра Windows XP:
(имени файла соответствует куст реестра Windows XP)

Имя файла | Соответствующий раздел реестра Windows XP
SAM | HKEY_LOCAL_MACHINE\SAM
SECURITY | HKEY_LOCAL_MACHINE\Security
Software | HKEY_LOCAL_MACHINE\Software
System | HKEY_LOCAL_MACHINE\System HKEY_CURRENT_CONFIG
Default | HKEY_USERS\.DEFAULT
Файлы Ntuser.dat | HKEY_CURRENT_USER (эти файлы хранятся в С:\Documents and Settings\%UserName%) Содержат конфигурацию для конкретного пользователя.

По умолчанию почти все файлы кустов: Default, SAM, Security, Software и System, — сохраняются в папке %SystemRoot%\System32\Config.

Папка %SystemRoot%\Profiles содержит настройки для каждого пользователя компьютера.

Если есть сомнения, то точный список файлов реестра Windows XP можно посмотреть здесь: HKEY_LOCAL_MACHINE\System \CotnrolSet\Control\HiveList\.

При начальной загрузке к этому разделу обращается Configuration Manager, чтобы проинициализировать все основные разделы реестра.


Вопросы и ответы

Подскажите, пожалуйста, есть ли способ переустановки протокола TCP/IP в XP?

В Windows XP и Windows Server 2003 стек протоколов TCP/IP официально считается компонентом ядра операционной системы, поэтому удаление TCP/IP обычным способом невозможно. В случаях некоторых сбоев переустановка TCP/IP может оказаться единственно верным решением для пользователя.

При помощи многофункциональной утилиты командной строки \WINDOWS\SYSTEM32\netsh.exe (NetShell предназначена для настройки и тестирования сетевых компонентов) возможно восстановление стека протоколов TCP/IP в первичное состояние, на момент установки операционной системы. То есть записи в реестре, касающиеся TCP/IP, будут возвращены в исходное состояние, что равносильно переустановке протокола.

Для того чтобы это осуществить, введите в командной строке: netsh int ip reset [ имя_файла_журнала ], либо: netsh interface ip reset [ имя_файла_журнала ].

Например: netsh int ip reset c:\resetlog.txt.
Указывать файл журнала, то есть протокола, в котором будет записано все, что проделала утилита netsh.exe в реестре, крайне желательно не только в образовательных целях.

Дело в том, что содержимое журнала может не оказаться пустым, причиной чего будет являться идентичность текущих параметров реестра параметрам, устанавливаемым в оригинальной конфигурации. В этом случае причину сбоя придется искать в чем-то другом. Подробнее же обо всех командах netsh.exe вы узнаете из файла \WINDOWS\Help\netsh.chm.

Пропал автозапуск у CD-ROM и CD-RW, а также в контекстном меню. Подскажите пожалуйста что мне делать.

Реестр (Пуск - Выполнить - regedit), найти ключ:

[HKEY_LOCAL_MACHINE \ SYSTEM \CurrentControlSet \ Services \ CDRom] Autorun : REG_DWORD
значение: (0=отключено, 1=включено)

или система перестает видеть привод CD и CD-RW.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}Все ваши приводы должны быть здесь.

Как изменить SID Windows NT4.0/2000/XP с загруженной операционной системой?
Можно, воспользовавшись бесплатной программой NewSID.

Можно ли установить программу с помощью inf-файла ?

Да, возможно. Устанавливать и удалять программы с помощью inf-файла можно, используя командную строку. Для инсталляции ввести в строке "Выполнить" меню Пуск команду: rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %1, где %1 - путь к inf-файлу и его имя.
Удалить же установленную таким образом программу можно, выполнив команду: rundll32.exe setupapi,InstallHinfSection DefaultUninstall 132 %1, где %1 - путь к inf-файлу и его имя.

Если же это не сработало и программа не удалена, то откройте в Блокноте соответствующий inf-файл и просмотрите его, в частности секцию [DefaultInstall] - в ней указывается, какие файлы в какую директорию на диске копируются при установке программы и какие параметры при этом добавляются в реестр.

Где находится серийный номер?

О невозможности установить SP1 на системы с нехорошими серийными номерами. Серийный номер прописан в реестре в трех местах:
HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Internet Explorer\Registration
"ProductId"="ХХХХХ-ХХХ-ХХХХХХХ-ХХХХХ"
HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Windows\CurrentVersion
"ProductId"="ХХХХХ-ХХХ-ХХХХХХХ-ХХХХХ"
HKEY_LOCAL_MACHINE\SOFTWARE\
Microsoft\Windows NT\CurrentVersion
"ProductId"="ХХХХХ-ХХХ-ХХХХХХХ-ХХХХХ"
Найти можно через поиск, введя в качестве критерия свой серийный номер.

Где хранится код активации Windows XP?

Как известно, лицензионная Windows XP при переустановке системы требует повторной активации. Чтобы этого избежать, достаточно перед переустановкой системы скопировать файл wpa.dbl, расположенный в папке windows\ System32, например, на дискету - именно в этом файле хранится код активации. После переустановки системы, естественно, нужно будет заменить файл wpa.dbl на тот, что записали на дискету.

Где хранятся регистрационные данные на право обладания данной копией?

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion

Для чего нужна вкладка Совместимость в свойствах exe-файла?

Эта вкладка предназначена для "обмана" программ.
Учитывая, что Windows XP является вроде как бы "гибридной" операционной системой, на которую будут переходить пользователи и Windows 98, и Windows NT, и Windows 2000, Microsoft приняла решение не ждать, пока разработчики программного обеспечения выпустят патчи и обновленные версии программ, совместимые с Windows XP, а сама добавила в операционную систему специальную функцию "режим совместимости", который как раз и настраивается на вкладке Compatibility (совместимость).

Поставив на этой вкладке галку напротив надписи "Запустить программу в режиме совместимости" и выбрав одну из предложенных операционных систем (Windows 95, 98, Me, NT или 2000), мы тем самым заставим программу поверить, что она работает не в Windows XP, а в выбранной операционной системе. Стоит отметить, что Windows XP не просто сообщает программе, что она - не Windows XP, но и эмулирует структуру системного реестра соответствующей операционной системы, что позволяет заставить нормально работать в Windows XP большинство из программ, формально не предназначенных для работы в этой ОС, и только некоторые из них (те, что проверяют ядро ОС) не поддадутся на эту уловку и откажутся работать.

На этой же вкладке, кстати, можно изменить и некоторые другие параметры запуска конкретного приложения - установить разрешение экрана 640х480, уменьшить цветность до 256 цветов и отключить общий для всей операционной системы скин.

Хочу заменить файл в папке System32, а Windows ругается и не дает. Что делать?

Не дает - и правильно делает: незачем систему ломать. Это срабатывает система защиты файлов, которая не отключается для загрузочного раздела жесткого диска даже в том случае, если отключить Систему Восстановления (System Restore), убрав соответствующую галку на странице ее настройки.

С другой стороны, если нельзя, но очень хочется, и при этом вы ясно представляете, что делаете и чем все это дело может закончиться (а итог может быть весьма плачевным), то можно воспользоваться крохотной утилитой по имени SetSfс, позволяющей изменить параметры системы восстановления Windows 2K/XP, а также отключить ее полностью - в том числе и для загрузочного раздела.

Windows все время хочет обновиться и пытается лезть в Интернет. Это безобразие можно прекратить?

Можно: Пуск/Панель управления/Система, на вкладке Автоматическое обновление следует отметить последний пункт - "Отключить авто-обновление". После этого следить за появлением обновлений операционной системы придется самостоятельно.

Как включить интернет-защиту?

Одна из новых опций, появившихся в WinXP - файрволл для интернет-защиты. Заходим в свойства того соединения, которое нужно защитить: через Пуск /Панель управления/Сетевые подключения, в контекстом меню нужной иконки выбираем пункт Свойства, выбираем вкладку Дополнительно и отмечаем пункт "Защитить мое подключение к интернет" (ошибиться вряд ли получится - больше галку там поставить негде)

Где находятся те утилиты, о которых говорится в обзоре Windows XP?

В процессе установки Windows XP они не автоматически не устанавливаются, поэтому их придется инсталлировать уже после установки операционной системы. А находятся они на установочном компакт-диске Windows XP Pro, в папке Support\ Tools

Можно ли в XP снимать с аудио-CD цифровой звук?

Можно - Windows XP допускает передачу аудиоданных с компакт-диска в цифровом виде через IDE-шлейф (без использования проводка, которым обычно соединяют CD-ROM со звуковой картой). Чтобы воспользоваться такой очень полезной возможностью, следует зайти через Панель управления /Система на вкладку Оборудование, там нажать на кнопку Device Manager и выбрать CD-ROM, в свойствах которого (Properties CD) на одноименной закладке поставить галку напротив "Enable Digital CD-Audio for this CD-ROM device". После этого тот проводок, о котором говорилось выше, можно выбросить.

Как запустить дефрагментатор из контекстого меню Проводника?

Загрузите файл context_defrag.vbs. После установки (для этого достаточно щелкнуть по файлу) в контекстном меню Проводника появится пункт defrag, позволяющий быстро запустить дефрагментацию жесткого диска<

Как включить MP3-кодирование с высоким битрейтом?

Создайте reg-файл (назвав его, например, mp3.reg) следующего содержания:

Regedit 4
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ MediaPlayer\ Settings]
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ MediaPlayer\ Settings\ MP3Encoding]
"LowRate"=dword:0000dac0
"MediumRate"=dword:0000fa00
"MediumHighRate"=dword:0001f400
"HighRate"=dword:0002ee00

и импортируйте его в реестр (щелчок по файлу - установить). После внесения такого изменения в реестр включится встроенный MP3 кодек, но его максимальный битрейт будет ограничен 192 килобитами.
Второй способ кодирования с высоким битрейтом - использование для кодирования не встроенного, а внешнего MP3-кодека.

Как изменить интервал синхронизации системных часов компьютера с time-сервером?

Находим в реестре ключ
HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet001 \ Services \ W32Time \ TimeProviders \ NtpClient
Выбираем параметр SpecialPollInterval и изменяем его значение: оно должно быть равно требуемому интервалу между синхронизациями системного времени, выраженному в секундах (например, 172800 - 2 дня, 43200 - 12 часов)

А что, в XP нет своего факса?

Есть, но автоматически при инсталляции операционной системы Cлужба факсов не устанавливается. Чтобы воспользоваться ее возможностями, включающими в себя отправку, прием и контроль факсов, следует через Start / Control Panel открыть апплет 'Установка или удаление программ', щелкнуть там по иконке 'Установка/удаление компонентов Windows', отметить пункт 'Fax Services' и нажать кнопку Next (Далее). После этого последует просьба вставить инсталляционный компакт-диск с Windows XP и начнется процесс установки факс-службы.

Как удалять файлы, минуя "мусорную корзину"?

Пуск -> Выполнить и даем команду gpedit.msc
В открывшейся консоли выбирает User Configuration, Administrative Templates, Windows Components, Windows Explorer и отмечаем "Do not move deleted files to the Recycle Bin" (не уверен, что подобный пункт есть в Windows XP Home Edition)

Как сделать, чтобы при перезагрузке стирался/создавался заново файл подкачки pagefile.sys?

Открываем реестр и находим ключ
HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager \ Memory Management
где выставляем значение "ClearPageFileAtShutdown"=dword:00000001
Следует отметить, что этот ключ не стирает файл подкачки, а очищает, т.е. заполняет его нулями, но сам файл на диске остается. Такого же рузультата, ксати, можно добиться и через апплет Local Security Policy, находящийся в Administrative Tools (раздел Local Policies, Security Options, ключ Shutdown: Clear virtual memory pagefile when system shuts down).

Как мне залочить компьютер? Через Crtl+Alt+Del не получается...

Теперь для этого установлена другая комбинация - Win+L. Кроме этого, можно создать *.cmd файл и лочить машину, запуская его. Содержание этого файла должно быть таким:
rundll32.exe user32.dll,LockWorkStation

Как сделать, чтобы зависшие и переставшие отвечать задачи убивались автоматически?

В реестре по адресу HKCU\ Control Panel\ Desktop находится ключ HungAppTimeout, значение которого определяет интервал (в миллисекундах), через которое не отвечающее приложение считается зависшим. Кроме этого ключа, в той же ветви находятся ключи WaitToKillServiceTimeout (задаёт время ожидания перед "убийством" зависшей службы), и AutoEndTasks (при установке его значения в 1 системе дается разрешение убивать зависшие процессы самостоятельно).

Откуда загружаются программы при старте системы? У меня папка Автозагрузка пустая...

При загрузке операционной системы команды на запуск некоторых программ даются из системного реестра, где имеется специальная ветвь HLKM \ SOFTWARE \ MICROSOFT \ WINDOWS \ CURRENTVERSION \ RUN (и аналогичная ...\ RUNONCE). В этих ветвях записаны значения, каждое из которых соответствует одной запускаемой при старте программе...
Только не стоит спешить - если не уверены, что за программа записана, перед удалением обязательно сохраните выбранные строчки (через пункт редактора реестра "экспорт").
На закуску - маленький секрет. В Windows XP есть утилитка под названием msconfig, которая позволяет очень комфортно управлять параметрами загрузки. Запустить эта утилиту можно через кнопку Start (Пуск) - Run (Выполнить).

Можно ли ввести компьютер в состояние hibernate из командной строки?

Можно. Делается это такой вот командой:
%windir%\ System32\ rundll32.exe powrprof.dll,SetSuspendState

Как добавить прав в Recovery Console ?

Хорошая мысль - включить максимальные возможности восстановительного инструмента - Recovery Console, только сделать это нужно, не дожидаясь сбоев...
Для разрешения полного доступа к папкам в Recovery Console открываем (под эккаунтом Администратора) Control Panel -> Administrative Tools и запускаем апплет Local Security Policy -> Local Policies -> Security Options, находим там пункт "Recovery Console: Allow floppy copy and access to all drives and folders" и переключаем его в "Enable". Проделав это, перегружаемся в режим Recovery Console и даем команду ->
SET AllowAllPaths = TRUE

Как восстановить повреждённый загрузчик XP?

Загружаемся в Recovery Console и даем команду ->fixboot

Можно ли в WinXP сделать загрузочные дискеты?

Можно, но для этого придется прогуляться на сайт Microsoft - уж не знаю почему, но необходимый для этого пакет теперь (в отиличие от W2K) не входит в дистрибутив. Адрес страницы загрузки:
http://support.microsoft.com/ support/kb/articles/q310/ 9/94.asp?ID=310994
Обратите внимание: созданные загрузочные дискеты не будут "аварийными" - они предназначены лишь для установки операционной системы на компьютеры, не поддерживающие загрузку с компакт-диска. При загрузке компьютера с установочных дисков Windows XP будут автоматически загружены драйверы привода компакт-дисков, и начнется установка операционной системы.

Как увидеть все установленные программы?

По умолчанию, в окне "Add/Remove programs"(Установка и удаление программ) почти ничего нет. Чтобы в этом окне появились все компоненты, которые можно удалить, надо найти файлик sysoc.inf в каталоге WINNT\INF и подредактировать его: убрать слова HIDE или hide везде, где они встретятся. После этого на вкладке "Add/Remove Windows components" появится множество новых пунктов. К сожалению, далеко не все из установленных компонентов поддаются удалению, несмотря на то, что они присутствуют в меню. Например, в Microsoft считают Fax Service настолько важной, что удалить её стандартными методами не представляется возможным.

Иногда невозможно установить драйвер, в процессе инсталляции установка прекращается, что делать?

И что же? - Причина оказывается до банальности простой: перед началом установки драйвера происходит опрос операционной системы - "Ты кто?", и после ответа "Windows XP" инсталлятор, который знать не знает про XP, вполне резонно (с его точки зрения) прекращает установку. Решение: перед установкой драйвера лезем в реестр HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
и меняем там "Microsoft Windows XP" на "Microsoft Windows 2000".

Часто забываю пароль входа, что делать? Для особо забывчивых, создание дискеты для сброса пароля (Password Reset Disk)

С помощью этой дискеты можно будет зарегистрироваться на компьютере даже в том случае, если пароль забыт. Для создания Password Reset Disk следует нажать кнопку Start, выбрать Control Panel, а в ней - User Accounts, и щелкнуть по своему эккаунту. В появившемся окошке в левой колонке (под Related Tasks) есть пункт Prevent a forgotten password - после щелчка по нему запустится мастер создания "спасительной" дискеты. Эта дискета создается один раз - ее не нужно переделывать при каждой смене пароля, поэтому особое внимание следует обратить на порядок ее хранения: дискета должна храниться в укромном месте, потому что тот, кто найдет и воспользуется ей, сможет войти в систему под вашим именем.

Существуют ли аналоги autoexec.bat и config.sys под XP?
Да. Расположены они в папке C:\WINDOWS\system32\, и называются autoexec.nt и config.nt. Эти файлы влияют только на процессы, работающие через NTVDM (эмуляция DOS) и на Win32 никакого эффекта не оказывают.
Можно отметить настройку эмуляции Sound Blaster 2.0, которую теперь поддерживает NTVDM. Через autoexec.nt можно настроить ресурсы (IRQ, I/O порт, DMA). Значения которые установлены по умолчанию строкой SET BLASTER=A220 I5 D1 P330 соответствуют "традиционным значениям", которые считались стандартными для SB, и менять их, как правило, не приходится. Причём абсолютно не имеет значения, какие ресурсы реально использует ваша звуковая плата, при работе через NTVDM все порты виртуальные.
Кроме того следует отметить, что при указании путей в autoexec.nt могут некорректно вести себя Win16-приложения. Поэтому крайне рекомендуется прописывать пути в свойствах "Мой компьютер" ("My Computer") на закладке "Дополнительно" ("Advanced") -> "Переменные среды" ("Environment Variables").

Примечание: Если в момент загрузки W2k в корне системного раздела присутствовал файл autoexec.bat, то значения переменной path, определенные в нём, добавятся к путям определенным в "Переменных среды". Если вы не хотите этого, в разделе реестра HKCU\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon значение параметра ParseAutoexec: REG_SZ: установите 0.


Восстановление поврежденного реестра

Восстановление поврежденного реестра, когда Windows XP не загружается

А теперь посмотрим, что нужно делать, когда из-за ошибок в реестре Windows XP не загружается.

Описываемая процедура не гарантирует полного восстановления системы к предыдущему состоянию, однако мы сможем восстановить наши данные.

Разрушенные файлы системного реестра могут вызывать ряд различных сообщений об ошибках.

Если у вас имеется копия системы, сделанная Automatic System Recovery (ASR), то используйте эту копию, прежде чем попробовать процедуру, описанную в данной главе. Попробуйте при загрузке Windows XP нажать F8 и выбрать вариант "Загрузка последней удачной конфигурации" (Boot Using Last Known Good Configuration). При этом восстанавливаются только данные в разделе реестра HKLM\ System\ CurrentControlSet. Любые изменения в других разделах реестра сохраняются. Загрузка последней удачной конфигурации позволяет восстановить реестр в случае неполадок, вызванных, например, новым, несовместимым с имеющимся оборудованием драйвером. Неполадки, возникшие вследствие повреждения или ошибочного удаления драйверов или файлов, не могут быть устранены таким образом.

Примечание: Вы должны будете заменить все 5 ульев системного реестра. Если вы заменяете только один улей или два, то это может вызывать проблемы, так как программное обеспечение и оборудование может иметь параметры настройки во многих местах в системном реестре.

Итак, при попытке запуска Windows XP вы получаете сообщение об ошибке, например, одно из указанных ниже:
Windows XP could not start because the following file is missing or corrupt: \ WINDOWS\ SYSTEM32\ CONFIG\ SYSTEM;
Windows XP could not start because the following file is missing or corrupt: \ WINDOWS\ SYSTEM32\ CONFIG\ SOFTWARE;
Stop: c0000218 {Registry File Failure} The registry cannot load the hive (file): \ SystemRoot\ System32\ Config\ SOFTWARE or its log or alternate.

Очень хорошо, теперь настала пора применить ваши знания на практике. Если вы когда-либо выполняли NTBACKUP и завершили системное копирование успешно, то вы можете сразу приступить к 4-му шагу.

Шаг 1

Загружаемся в Recovery Console, создаем временную папку, копируем туда существующие файлы системного реестра, удаляем файлы системного реестра и затем копируем файлы системного реестра из папки Repair в папку System32\ Config. Затем мы сможем загрузить Windows XP.

Системный реестр, находящийся в папке Repair, был создан и сохранен при начальной установке Windows XP, поэтому любые изменения, которые были проведены позже, будут утеряны.

Итак, выполняем следующие шаги:
1. Загружаем Recovery Console.
 2. В командной строке выполняем следующие действия:
md tmp
copy c:\ windows\ system32\ config\ system c:\ windows\ tmp\ system.bak
copy c:\ windows\ system32\ config\ software c:\ windows\ tmp\ software.bak
copy c:\ windows\ system32\ config\ sam c:\ windows\ tmp\ sam.bak
copy c:\ windows\ system32\ config\ security c:\ windows\ tmp\ security.bak
copy c:\ windows\ system32\ config\ defa-ult c:\ windows\ tmp\ default.bak
delete c:\ windows\ system32\ config\ system
delete c:\ windows\ system32\ config\ software
delete c:\ windows\ system32\ config\ sam
delete c:\ windows\ system32\ config\ security
delete c:\ windows\ system32\ config\ default
copy c:\ windows\ repair\ system c:\ windows\ system32\ config\ system
copy c:\ windows\ repair\ software c:\ windows\ system32\ config\ software
copy c:\ windows\ repair\ sam c:\ windows\ system32\ config\ sam
copy c:\ windows\ repair\ security c:\ windows\ system32\ config\ security
copy c:\ windows\ repair\ default c:\ windows\ system32\ config\ default

Примечание: Здесь имеется в виду, что Windows XP установлена в папку C:\ Windows. Если это не так, то вам придется внести небольшие изменения.

Чтобы сэкономить время, вы можете оформить все вышеприведенные команды в отдельный файл, например, regcopy1.txt, набрав его на другом компьютере, и выполнить на вашем одной командой:
batch regcopy1.txt

Шаг 2

Чтобы выполнить процедуру, описанную в этом разделе, вы должны войти как администратор или как пользователь, приравненный к администратору. Т.е. пользователь, имеющий учетную запись в группе "Администраторы".

Если у вас Windows XP Home Edition, то вы сможете войти как административный пользователь. Но если вы хотите войти как администратор, то вы должны сначала запустить Windows XP Home Edition в безопасном режиме (Safe mode).

Также полагаем, что у вас файловая система — FAT32.

Выполняем следующие действия:
1. Перегрузите компьютер.
2. При загрузке Windows XP нажмите F8.
3. Выберите безопасный режим.
Если вы используете проводник в качестве файл-менеджера, то придется выполнить несколько действий, чтобы сделать папку System Restore видимой:
1. Запускаем "Проводник".
2. В меню "Сервис" выбираем "Свойства папки" и далее закладку "Вид".
3. Раскрываем опцию "Скрытые файлы и папки" и щелкаем на "Показывать скрытые файлы и папки".
4. Далее щелкаем на "Применить" и "ОК".

Теперь:
1. Открываем раздел жесткого диска где установлена Windows XP, и находим папку System Volume Information. Примечание: Это скрытая системная папка. Она содержит одну или более папок с именами вида _restore {GUID}, например, _restore{87BD3667-3246- 476B-923F-F86E30B3E7F8}.

2. Откройте папку, которая была создана НЕ в текущее время. Это может быть одна или больше папок, имена которых начинаются с RP. Это — точки восстановления.

3. Откройте выбранную папку и затем папку с именем Snapshot. Например,
c:\ System Volume Information\ _restore {DBB3294C-F5C9-43A9 -9010-A75010CD2631} \ RP2\ snapshot\ Repository.

4. Из папки Snapshot в папку C:\ Windows\ Tmp, уже созданную на первом этапе, скопируйте следующие файлы:
— _REGISTRY_USER_.DEFAULT
— _REGISTRY_MACHINE_SECURITY
— _REGISTRY_MACHINE_SOFTWARE
— _REGISTRY_MACHINE_SYSTEM
— _REGISTRY_MACHINE_SAM

Эти файлы созданы службой восстановления системы — System Restore. Так как на предыдущем шаге мы использовали файлы системного реестра, созданные при начальной установке Windows XP, то этот "новый" системный реестр не знает, что "старые" точки восстановления существуют и доступны. При загрузке Windows XP создана новая папка с новым GUID и с новым System Volume Information, и создана новая точка восстановления, которая включает копию файлов нового системного реестра. Вот почему важно не использовать самую новую папку, особенно если время ее создания — текущее время.

Таким образом, конфигурация существующей системы не знает о предыдущих точках восстановления. Нам нужна предыдущая, "старая" копия системного реестра от предыдущей, "старой" точки восстановления, чтобы сделать все предыдущие, "старые" точки восстановления доступными. Я надеюсь, что вы меня поняли.

Файлы системного реестра были скопированы из папки Snapshot в папку C:\ Windows\ Tmp, чтобы сделать их доступными, когда мы будем находиться в Recovery Console. Мы будем использовать эти файлы, чтобы заменить ими файлы текущего системного реестра в папке C:\ Windows\ System32\ Config. Дело в том, что в Recovery Console папка с System Volume Information в общем случае недоступна. Если вам нужно иметь доступ ко всем папкам, то вам следует позаботиться об этом заранее: об этом я уже писал в разделе "Общие вопросы".

Шаг 3

В третьей части мы удалим существующие файлы системного реестра, а затем скопируем файлы системного реестра, созданные службой System Restore, в папку C:\ Windows\ System32\ Config:
1. Загружаемся в Recovery Console.

2. В командной строке Recovery Console выполняем следующие команды:
3.
4. del c:\ windows\ system32\ config\ sam
5. del c:\ windows\ system32\ config\ security
6. del c:\ windows\ system32\ config\ software
7. del c:\ windows\ system32\ config\ default
8. del c:\ windows\ system32\ config\ system
9.
10. copy c:\ windows\ tmp\ _registry_machi-ne_software c:\ windows\ system32\ config\ software
11. copy c:\ windows\ tmp\ _registry_machi-ne_system c:\ windows\ system32\ config\ system
12. copy c:\ windows\ tmp\ _registry_machi-ne_sam c:\ windows\ system32\ config\ sam
13. copy c:\ windows\ tmp\ _registry_machi-ne_security c:\ windows\ system32\ config\ security
14. copy c:\ windows\ tmp\ _registry_user_. default c:\ windows\ system32\ config\ default
Перегружаем компьютер.

Шаг 4

Теперь запускаем программу "Восстановление системы" (System Restore) или %SystemRoot%\ System32\ restore\ rstrui.exe и выбираем "Восстановление более раннего состояния компьютера"

Можно попробовать восстановить систему с загрузочного диска. Установить в биосе загрузку с CD. Ставишь диск с ХР и загружаешься. Выбираешь "Консоль восстановления". Набираешь команду "sfc.exe scannow". Испорченные файлы будут восстановлены.

Внимание! Будь уверен что все делаешь правильно, последствия необратимы.


Всякие мелочи

1. Например, удалите ключ HKEY_LO-CAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Desktop\ NameSpace\ {645FF040-5081-101B-9F08-00AA002F954E}, и корзина пропадет со стола. Или переименовать "Корзину", в "Мусор" Раздел реестра HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder. Параметр Attributes Значение 40 01 00 20 Меняем в значении 40 на 70.
Клик правой кнопкой мыши на ярлыке "Корзины" и видим пункт "Переименовать".

2. Когда программа требует ввода данных, она может либо "выскочить" наверх, либо начать мигать иконкой в панели задач. Вы можете выбрать то поведение, которое вам больше нравится. Для этого нужно:
Найти в реестре ключ HKCU\ Control Panel\ Desktop.

Создать или изменить параметр ForegroundLockTimeout, тип DWORD и установить его значение на время задержки до "перехвата" фокуса: 0 — немедленно, а 200 000 (0x00030d40 hex) — значение по умолчанию.

А также создать или изменить DWORD-параметр ForegroundFlashCount и установить его значение на нужное число миганий для привлечения вашего внимания. Значения устанавливаются в десятичной системе: 0 заставит иконку мигать бесконечно, по умолчанию значение равно 3.

3. Если у вас на компьютере проинсталлировано много программ, и контекстное меню Создать стало очень большим и начало притормаживать, то нужно найти в реестре ключ HKCR и стереть подраздел ShellNew в тех ключах, которые вам больше не понадобятся в контекстном меню Создать. После этого Windows XP перезагружать не надо. Первый раз она ругнется, а потом все будет нормально.

4. Даже в Windows XP иногда случается так, что уже деинсталлированные программы все-таки показываются в списке Установка-Удаление программ. Чтобы решить проблему, удалите их из списка HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Uninstall.

Изменить заставку на входе в систему:
Выбираем Пуск/Выполнить, набираем "regedt32" и нажимаем "OK". Находим в системном реестре следующий ключ: HKEY_USERS\DEFAULT\ Control Panel\Desktop. И меняем строковый параметр "SCRNSAVE.EXE" с "logon.scr" на путь и имя к той заставке, которая вам больше по вкусу. Главное, чтобы путь был указан правильно, а если файл заставки находится в каталоге %SystemRoot%\System32, то путь можно вообще не указывать, достаточно одного имени файла. (сам еще не пробовал)

Отменить экран заставки при загрузке:
Данное действие поможет, правда совсем немного уменьшить время загрузки вашей ОС. Не забывайте только, что в результате вы также не будете видеть и всякие сообщения системы о процессе загрузки (chkdsk, convert ... ), хотя, если проблем у вас нет, можно проделывать это смело. Все, что нам нужно, это отредактировать файл BOOT.INI, добавив в него параметр "/noguiboot" сразу после "/fastdetect".

После рестарта системы заставка возникать больше не будет, и на медленных компьютерах это может сэкономить вам несколько секунд. Соответственно, чтобы вернуть все на свои места, надо в том же BOOT.INI удалить вышеуказанный параметр. Или в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop присвойте параметру "ScreenSaveActive" =dword:0

Еще один способ ускорения загрузки Windows XP:

Отключить неиспользуемые устройства в Device Manager.

Например, если Вы не имеете периферийных устройств, подключенных к внешним портам компьютера (USB или COM), Вы можете заблокировать их, что заметно повлияет на скорость загрузки.

Control Panel -> System -> Hardware tab -> device manager

Защита паролем экранной заставки

Настроить политику паролей для экранных заставок. В разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop параметр "ScreenSaverIsSecure"=dword:?

Состояние параметров:

  • Параметр ScreenSaverIsSecure отсутствует в реестре. Обычное поведение экранной заставки - пароли можно изменять, применять или отменять их использование через окно "защита паролем".
  • Параметр хранит значение "0". Использование паролей к заставкам недоступно.
  • Параметр хранит значение "1", пароли к экранным заставкам принудительно включены.

Описанная выше политика "Отменить экран заставки" имеет приоритет над этой политикой. Если политика "Отменить экран заставки" находится в активном состоянии, система игнорирует состояние политики "Защита паролем экранной заставки".

Отключаем индексирование:
Делается это следующим образом. Открываете "Мой компьютер", кликаете правой клавишей мыши на иконке жесткого диска и выбираете "Свойства". В самом низу открывшегося окна вы увидите галочку напротив пункта "Разрешить индексирование диска для быстрого поиска". Вот эту самую галочку и следует убрать. После нажатия кнопок "Применить" или "ОК" появится новое окно, в котором вам будет задан вопрос, применить ли выбранные атрибуты только к текущему диску или и ко вложенным файлам и папкам тоже. Окончательное исполнение данной процедуры может занять пару минут (смотря сколько у вас файлов на диске), но в результате вы сможете наслаждаться немного более быстрой работой ОС. Естественно, что работает это только для дисков с файловой системой NTFS.

Увеличиваем производительность NTFS:
Перво-наперво, отключим создание коротких имен. По-умолчанию NTFS генерирует имена согласно старому правилу 8.3 для совместимости с MS-DOS и Windows 3.x клиентами. Если в вашей сети таких клиентов не наблюдается, то можно смело эту функцию отключать, для чего следует поменять значение ключа NtfsDisable8dot3NameCreation на 1. Найдете вы этот ключ в системном реестре в разделе HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\ Control\Filesystem.

Вторым шагом мы отключим запись даты последнего обновления файла. По-умолчанию NTFS каждый раз при изменении любого файла записывает дату и время его последнего обновления. На больших разделах NTFS это может очень существенно влиять на производительность файловой системы. А отключить это так же просто: надо ключу NtfsDisableLastAccessUpdate присвоить значение 1. Находится этот ключ в том же разделе HKEY_LOCAL_MACHINE\ SYSTEM\CurrentContolSet\Control\Filesystem. Может так оказаться, что такого ключа не существует, тогда его надо создать с типом REG_DWORD.

Теперь отведем достаточно места для главной файловой таблицы. Добавьте в системный реестр ключ NtfsMftZoneReservation типа REG_DWORD в раздел HKEY_LOCAL_MACHINE\ SYSTEM\CurrentControlSet\ Control\FileSystem. Когда вы это сделаете, система зарезервирует место на диске для главной таблицы размещения файлов. Для чего это нужно? Да для того, чтобы взять под контроль процесс роста этой таблицы. Если на ваших разделах NTFS мало файлов, но они большого размера, то наилучшим значением созданного параметра будет 1 (по-умолчанию). Обычно оптимальным значением является 2 или 3. А 4 (максимальное значение) следует использовать только в случае, если у вас на диске количество файлов огромно (десятки тысяч). Тем не менее, со значениями больше 2 следует экспериментировать осторожно, так как в этом случае система может отхватить для таблицы размещения файлов немаленький кусок дискового пространства.

Ускорить действие файловой системы: (если позволяет оперативная память) увеличив параметр типа DWORD IoPageLockLimit в разделе
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management от заданных по умолчанию 512 КБ до 4 МБ и более.

Этот параметр представляет максимальное число байт, которые могут быть блокированы для операций I/O. Когда значение параметра равно 0, то система использует встроенный алгоритм определения необходимой памяти и использует объем 512 КБ. Установка максимального значения должна основываться на объеме памяти в Вашей системе. Так, если Вы имеете 128Mb памяти, установите шестнадцатеричное значение 4000, если 256Mb – 10000, и если 512Mb – 40000.
Таблица рекомендуемых значений

Установки вступят в силу после перезагрузки системы

Самый простой способ отключить UpnP:
Эта брешь в безопасности известна, по-моему, с тех пор, когда XP была еще в пеленках. Тем не менее, что-то с нею делать надо, поэтому проще всего для того, чтобы отключить Universal Plug and Play, скачать программу с сайта www.grc.com. Программа эта маленькая, всего 22Кб и подходит ко всем версиям Windows XP (Pro и Home).

Office XP - отключаем посылку ошибок:
Office XP имеет невероятно нужную функцию - при возникновении ошибки, он пытается отправить отчет о ней в Microsoft. Если вам это надоело, то функцию эту можно отключить. Ниже я привожу текст .REG-файла, который вам в этом поможет:

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\ Policies\Microsoft\Office\10.0\Common]
"DWNeverUpload"=dword:00000001
"DWNoExternalURL"=dword:00000001
"DWNoFileCollection"=dword:00000001
"DWNoSecondLevelCollection"=dword:00000001
[HKEY_USERS\.Default\Software\ Policies\Microsoft\Office\10.0\Common]
"DWNeverUpload"=dword:00000001
"DWNoExternalURL"=dword:00000001
"DWNoFileCollection"=dword:00000001
"DWNoSecondLevelCollection"=dword:00000001

СОВЕТУЮ СДЕЛАТЬ В ПЕРВУЮ ОЧЕРЕДЬ результат просто обалденный.

В Windows XP есть функция BootDefrag (или BootOptimize), суть которой заключается в следующем. Поскольку дефрагментация и оптимизация расположения на диске файлов, нужных системе во время загрузки, решающим образом влияет на весь процесс загрузки ОС, а пользователю часто лениво самому запускать дефрагментатор (не то чтобы даже часто, а почти всегда), то система теперь умеет сама - так сказать, без участия оператора - оптимизировать эти файлы, причем не как ей вздумается, а основываясь на данных все тех же файлов notosboot-B00DFAAD.pf и layout.ini. Правда, происходит автоматическая дефрагментация при простое системы - если пользователь 10-30 минут после загрузки ОС не производил никаких операций. А потому может случиться так, что на вашей интенсивно используемой системе файлы окажутся не оптимизированы. Проверить, произошла ли оптимизация, можно, заглянув в реестр - если в разделе HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ Dfrg\BootOptimizeFunction стоит параметр "OptimizeComplete"="Yes", то дефрагментация была произведена. Если же этого пока не случилось, то просто перегрузите ПК и оставьте его минут на тридцать в одиночестве - Windows сама все сделает, и ускорение следующей загрузки будет заметно даже на глаз.

Только запомните, что перед оптимизацией ПК со свежеустановленной ОС должен иметь в своем багаже хотя бы три перезагрузки для накопления нужных данных. Штатный дефрагментатор Windows XP не отменяет эту оптимизацию, так что пользоваться им можно без опаски.

Если же вы сомневаетесь, работает ли вообще у вас эта функция, или хотите ее отключить, то проверьте в реестре наличие параметра, включающего BootDefrag: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Dfrg\BootOptimizeFunction - параметр "Enable"="Y".

Уменьшение задержки вывода меню:
Не секрет, что все меню Windows XP открываются с определенной задержкой, что иногда несколько раздражает. Для более быстрого открытия меню необходимо изменить значения ключа MenuShowDelay, расположенного в разделе HKEY_CURRENT_USER/Control Panel/Desktop. По умолчанию значение этого ключа равно 400. Если изменить это значение в 0, то Вы увидите значительное ускорение открытие меню.(советую 100, 0 слишком быстро)

Изменяем приоритет запросов на прерывание (IRQ) - сделать просто необходимо.

Итак, последний совет по увеличению производительности– изменение приоритета запросов на прерывание. Для тех, кто не знаком с этим понятием, напомним, что каждому компоненту Вашего компьютера назначается номер прерывания IRQ для доступа к системной шине. Если увеличить приоритет CMOS памяти и часов реального времени, то можно увеличить производительность всех элементов системной платы. Для начала необходимо определить, для какого устройства Вы хотите увеличить производительность. Затем, Вы должны определить, какой запрос на прерывание использует это устройство. Для этого необходимо открыть Control Panel a System (Вы так же можете воспользоваться комбинацией клавиш Windows+Break). Нажмите на закладку ’Hardware’ и нажмите кнопку ’Device Manager’. Теперь правой кнопкой мышки войдите в свойства выбранного устройства, и выберите закладку ’Resources’.

Здесь Вы можете увидеть, какой номер IRQ используется выбранным устройством. Запомните номер прерывания и закройте все окна. Теперь запустите RegEdit. Найдите раздел HKEY_LOCAL_MACHINE/ System/CurrentControlSet/ Control/PriorityControl. Создайте новый DWORD ключ IRQ#Priority (где ’#’ номер IRQ), и установите его в 1. Например, в нашем случае IRQ нашего System CMOS равен 08. Поэтому мы создали ключ

IRQ8Priority.

Теперь, после перезагрузки, Вы должны обратить внимание на увеличение производительности выбранного компонента. Мы рекомендовали бы Вам именно CMOS, поскольку он увеличивает производительность все системной платы. Так же Вы можете создать множественные приоритеты IRQ, однако это не очень эффективно и может привести к неустойчивой работе. Для удаления настройки, просто удалите созданный ключ.

Cистемное время

Windows XP умеет подстраивать системное время, сверяясь со специальными серверами в Интернете. Можно изменить адреса используемых серверов.

Без использования реестра: Щелкните правой кнопкой мыши на значке часов в системной области панели задач, выберите команду "Adjust Date/Time" и на странице "Internet Time" установите нужный сервер

При помощи реестра: Откройте раздел
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ Windows\CurrentVersion\DateTime\Servers
внесите свой собственный список серверов, использующихся для синхронизации времени.

Раскладка клавиатуры

Рядом с часиками находится значок раскладки, позволяющий переключать языки при набивке текста (В России обычно используют два языка - Русский и английский). Чтобы изменить всплывающий текст при подведении мыши, идем в раздел
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Сontrol\Nls\Locale. Там нужно изменить значение соответствующего параметра. Параметр русского языка — 00000419, английского — 00000409 и т.п. Например, вместо слова "Русский" пишем "Все пропало"

Данные изменения вступят после перезагрузки


Группировка окон

Как изменить число открытых окон программы, при достижении которого на панели задач включается режим их группировки в одну кнопку?

Режим группирования нескольких открытых окон в одну кнопку - одно из многочисленных не сразу заметных, но очень удобных нововведений. Смысл его заключается в том, что при достижении числа открытых окон определенного значения они группируются и отображаются на панели задач в виде одной кнопки, щелчок по которой вызывает ниспадающее меню со всеми открытыми окнами этой программы. Очень удобная функция, например, при прогулках по Сети с помощью Internet Explorer - уже первый десяток открытых страниц без использования режима группировки донельзя захламляет панель задач.

Для изменения числа открытых окон программы, которое приводит к включению режима их группировки, нужно запустить Regedit, найти в реестре ключ
HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ Advanced
и изменить параметр TaskbarGroupSize. Если такого параметра нет, то нужно его создать (в виде DWORD) и настроить: щелкаем по параметру правой кнопкой мыши и выбираем в контекстном меню пункт Modify (к примеру, установка для TaskbarGroupSize значения 5 заставит Windows включать режим группировки при пяти открытых однотипных окнах)

Кстати: а как вообще включить этот режим группировки? Очень просто: щелкаем правой кнопкой по панели задач, выбираем пункт Properties и на вкладке Панель задач ставим галку напротив "Сгруппировать похожие кнопки..."


Дисковые утилиты

Мой компьютер -Выбранный диск- Свойства- Сервис, запуск дисковых утилит. Можно прописать туда свои программы вместо установленных по умолчанию. Раздел:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer. В разделе находятся некоторые подразделы, отвечающие за дисковые утилиты. Если их нет, создайте сами и в значениях по умолчанию задайте путь к вашему приложению.
Очистка диска подраздел CleanupPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\cleanmgr.exe /D %c"

Проверка диска - подраздел ChkDskPath
По умолчанию используется
NT/2000/XP: "%SystemRoot%\system32\chkdsk.exe %c:"

Дефрагментация диска - подраздел DefragPath
По умолчанию используется
NT/2000/XP: "%systemroot%\system32\dfrg.msc %c:"


Диспетчер задач

Диспетчер задач (Task Manager) (CTRL+ALT+DEL) позволяет не только наблюдать за потреблением памяти и снимать зависшие приложения. Перейдите в закладку Процессы (Processes) и нажмите правой клавишей на любом процессе.
В появившемся меню будет опция Приоритет (Set Priority). Благодаря ей вы можете выставить приоритет на получение процессорного времени практически у всех приложений и служб. К примеру, если вы работаете в Photoshop и вдруг решите проверить почту или покопаться в Интернете, вы можете вручную распределить вычислительную мощность вашего процессора. Или если вы запустили достаточно "тяжелое" приложение типа записи CD, компиляцию кода в Visual C++ или рендеринг объектов в 3D Studio Max, вы можете установить этим процессам высокий приоритет, чтобы другие приложения не мешали их работе.
Уберите "скрытые" компоненты Windows К сожалению, Microsoft не разрешает вам убрать всякую чушь типа Windows Messenger обычным способом. Messenger устанавливается по умолчанию и он не появляется в диалоге Установка и удаление программ (Add/Remove Program) в Панели управления (Control Panel).
Вы можете обмануть Microsoft, отредактировав файл SYSOC.INF в каталоге C:\WINDOWS\INF (или где у вас там располагается Windows XP) с помощью Блокнота (Notepad).
Найдите там заголовок [Components], за ним вы увидите кучу параметров для различных приложений Windows. Некоторые из них содержат слово "hide". Среди них Windows Messenger, Terminal Server и другие, которые установлены на вашей Windows XP, но они убраны из диалога Установка и удаление (Add/Remove).
К примеру, для удаления Windows Messenger уберите hide из строчки msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7 после чего она будет выглядеть следующим образом msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,7
Запишите файл после редактирования и перейдите в диалог "Установки и удаления программ" (Add/Remove Program). Нажмите там Установка компонентов (Windows Components), и вы увидите в списке Windows Messenger, уберите справа от него галочку и нажмите Далее (Next) чтобы завершить жертвоприношение этой пакости.
Вы можете свободно убрать hide во всех местах SYSOC.INF, а затем убрать все ненужное с вашей системы.
Включайте DMA на всех ATAPI дисках. По умолчанию вторые диски (slave) на ATAPI интерфейсах часто устанавливаются в режим обмена PIO, даже если они способны на работу в более эффективном режиме UltraATA (или DMA). Режим PIO заметно снижает производительность записывающих CD-ROM приводов, проигрывание DVD и другие дисковые функции. Кроме того, режим DMA намного меньше загружает процессор, нежели PIO.
Вы можете устранить данный недостаток через Диспетчер устройств (Device Manager). Откройте диалог Управление компьютером (System Properties) (правой клавишей выбираем Свойства (Properties) на значке Мой компьютер (My Computer)) и выберите закладку Оборудование (Hardware). Далее нажмите клавишу Диспетчер устройств (Device Manager). Откройте плюсик слева от IDE ATA/ATAPI контроллеры (IDE/ATAPI controllers), выберите Первичный канал IDE (Primary IDE channel) и нажмите Свойства (Properties). Далее выберите закладку Дополнительные параметры (Advanced Settings). У каждого устройства установите режим передачи в DMA, если доступно (DMA if possible). Не опасайтесь, если устройство не поддерживает DMA, оно будет работать в PIO. Выполните то же самое и для Вторичного канала IDE (Secondary IDE channel).


Сеть

Передающая среда

Передающая среда — это то понятие, на котором основывается весь процесс передачи данных, и обойти этот пункт вниманием просто невозможно :-). Ведь процесс передачи данных заключается в пространственном перемещении энергии, несущей полезный сигнал. К примеру, когда вы говорите с кем-то, то передаете энергию от голосовых связок частицам воздуха, и эта энергия распространяется от одного слоя воздуха к другому в виде волны, пока не достигает барабанной перепонки уха собеседника. Там она превращается в колебания, которые распознаются человеческим мозгом как звуки и слова. В рассмотренном примере передающей средой выступал газ, а энергией — кинетическая энергия движения его частиц. Подобным же образом действуют и интересующие нас системы передачи данных, только используют они электромагнитные волны, а распознаются полученные сигналы электронными устройствами.

Итак, медный кабель. Медь была избрана для передачи данных как металл с оптимальным соотношением сопротивления и стоимости применения. Тут стоит пояснить, почему так важен показатель сопротивления. Из школы нам известно, что при прохождении тока через проводник часть электрической энергии превращается в тепловую. Чем большее сопротивление имеет металл, тем больше тепла выделяется и тем быстрее затухает сигнал, который мы передаем. То есть наш полезный сигнал может весь превратиться в тепло, согревающее окружающее пространство, но никак не способствовать получению информации. На пассивном уровне противостоять переходу электрических сигналов в тепло можно лишь избирая в качестве передающей среды металл с как можно меньшим сопротивлением. По этому показателю нам лучше всего подойдет серебро или золото. Но лишь представьте себе сотни тысяч километров золотых кабелей, и вы поймете, почему так важен фактор цены :-). Именно исходя из этих соображений, в качестве среды передачи и была выбрана медь.

Сейчас распространено две разновидности медных кабелей: коаксиальный и витая пара. Их целевое использование предопределило необходимость минимизации возникающих в них помех. Чтобы понять механизм возникновения помех, давайте представим два параллельных провода, близко расположенных друг к другу. Если в одном из них начнет проходить высокочастотный электрический сигнал, то он будет излучать электромагнитные волны, которые индуцируют во втором проводнике электрический ток. Если второй проводник используется для передачи информации, то она может быть при этом существенно искажена. Поэтому так много усилий было приложено конструкторами для преодоления этого негативного эффекта.

Толстый и тонкий

Коаксиальный кабель (от латинского co — «совместно» и axis — «ось») представляет собой центральный провод, находящийся в толстой и равномерной изоляционной оболочке. Вокруг изоляции кабеля располагается сплошной цилиндрический экран, который представляет собой плетеную оболочку или фольгу, либо их комбинацию. Этот экран используется как второй контакт. Сверху кабель покрывается еще одним слоем изоляции. Такая конструкция позволяет минимизировать распространение электромагнитного излучения от кабеля извне, а также уменьшить наводки на сам провод.

Существует несколько разновидностей коаксиала. Во-первых, это, так называемый, «толстый» кабель RG-8 или RG-11 (RG — сокращение Radio Grade, т.е волновод), на базе которого на заре развития локальных сетей создавались сети Ethernet. Но на сегодняшний день его почти вытеснила другая разновидность — «тонкий» коаксиальный кабель RG-58, который дешевле, а сети на его основе ничуть не уступают по производительности вышеупомянутым «толстым» собратьям.

Завитушки

Витая пара (twisted pair) представляет собой два медных провода в изоляции, скрученных между собой. Этим достигается уменьшение электромагнитного излучения, так как электромагнитные поля, возникающие вокруг каждого из проводников, индуцируют одинаковые по амплитуде сигналы, находящиеся в противофазе. Таким образом, в идеальном варианте излучение пары равно нулю.

Обычно в кабеле, используемом для передачи данных в сети, объединяется несколько витых пар. Так, в кабеле UTP (Unshielded Twisted Pair — незащищенная витая пара) пятой категории, который является одним из наиболее широко используемых при прокладке сетей, их четыре. Для исключения взаимных наводок соседних пар их скручивают с различным шагом.

Кабель «витая пара» может быть как экранированным (ScTP — Screened Twisted Pair), так и неэкранированным (UTP — Unscreened Twisted Pair). Именно последние чаще всего и используются в сетях. Но если кабелю предстоит проходить неподалеку от сильных источников электромагнитного излучения (электродвигатель, кондиционер, мощное передающее оборудование) или параллельно с кабелем питания, то имеет смысл воспользоваться экранированным кабелем, например фольгированным FTP (Foiled Twisted Pair). Еще более радикальным и дорогим решением является использование кабелей с индивидуальным экранированием каждой витой пары — STP (Shielded Twisted Pair).

Волокнистые решения

Оптоволоконный кабель представляет собой тонкое стеклянное волокно, покрытое слоем с меньшим коэффициентом преломления и заключенное в пластмассовую оболочку. Свет, попадая в один из концов оптоволоконного кабеля, практически беспрепятственно проходит через весь кабель, отражаясь от границы раздела сред с разными коэффициентами преломления. При этом происходит так называемое полное внутреннее отражение луча. Лучше всего меня поймет тот, кто хоть раз, плавая в водоеме, наблюдал, каким получается отражение от поверхности, если смотреть на нее из-под воды под маленьким углом.

Обычно оптоволоконный кабель состоит из нескольких волокон, расположенных по кругу или в одной плоскости. В одной из возможных схем отдельные оптические волокна расположены симметрично по кругу, в центре кабеля проходит стальной или кевларовый трос. Снаружи кабель защищен стальной оплеткой и эластическим покрытием, а внутренняя полость заполняется гидрофобным гелем.

Различают два вида оптоволокна: одномодовое и многомодовое. Одномодовое волокно от многомодового конструктивно отличается лишь намного меньшим диаметром. Это позволяет уменьшить так называемую модовую дисперсию и соответственно увеличить пропускную способность и расстояние передачи. Однако одномодовое оптоволокно гораздо дороже и менее удобно при прокладке (только представьте себе, насколько трудно совместить ось одномодового волокна толщиной 8–9 микрометров с осью приемника или передатчика).

Кроме модовой дисперсии, ограничения на оптоволокно накладываются материальной дисперсией, вызванной разным углом отражения света различных длин волн. Так, длинноволновые красные лучи отклоняются меньше, чем коротковолновые синие. Применяемые же для передачи данных по оптоволокну источники света не способны излучать свет конкретной длины, а лишь выдают определенный диапазон волн. Даже полупроводниковый лазер излучает свет в интервале длин волн в несколько нанометров, более же дешевые светодиоды и вовсе имеют полосу шириной в 30–40 нм.

Еще одним негативным фактором оптоволокна является неидеальная поверхность волокна и загрязнение его различными примесями, что соответственно приводит к искажению световых импульсов и поглощению света.

Оптоволокно имеет ряд преимуществ перед обычным медным кабелем: оно не восприимчиво к электромагнитным помехам и само не является их источником. Теоретически подсчитано, что пропускная способность оптоволокна может достигать 100 Тбит/сек, а это делает данную технологию весьма перспективной.

Но, к сожалению, такой тип кабеля не лишен и ряда недостатков. Первым из них является его дороговизна, которая отобьет желание у любого пользователя «тянуть оптоволокно» для домашней сети. Далее следует отметить, что немало хлопот вас ждет в процессе прокладки и эксплуатации. Концы оптоволокна во время установки необходимо отполировать при помощи специального оборудования. Если же достаточно хрупкие оптоволоконные кабели будут сломаны в результате изгиба, то место поломки будет определить чрезвычайно трудно, а устранять ее придется опять-таки с помощью специального оборудования. Небольшой комплект последнего стоит порядка одного-двух новых компьютеров.

Учитывая все преимущества и недостатки оптоволокна, можно сказать, что такой тип кабеля является идеальным вариантом для соединения двух локальных сетей, находящихся в разных зданиях. Рекомендуется он для решений, требующих повышенной информационной безопасности и конфиденциальности, так как сделать «отвод» от оптоволокна практически невозможно. Применяется оно и в некоторых сетевых технологиях, требующих высокой скорости передачи данных. К примеру, в 10 Gigabit Ethernet без оптоволокна уже просто не обойтись.

По радио

В наше время все большее значение приобретают системы беспроводной радиосвязи. Согласно концепции «беспроводного будущего», в скором времени они захватят значительную долю рынка коммуникаций, отобрав ее у решений на базе проводников. По оценкам аналитиков, на 2003 год оборот рынка беспроводных сетей составит около $2 млрд.

Так давайте разберемся, чем же так привлекает человечество радиоволна в качестве носителя цифровой информации. Первая и, наверно, главная причина — это мобильность. Та самая настоящая мобильность, которая наконец дала человеку возможность оторваться от кабеля и жить самостоятельной информационной жизнью. И уже на втором месте находятся другие преимущества. Такие как гибкость и быстрое развертывание систем, построенных на основе радиосвязи. А также организация связи в ранее недоступных для этого местах, таких как малозаселенная местность, океан, космос. В некоторых случаях добавляется еще и такой фактор, как дешевизна, тоже связанный с мобильностью. Ведь зачастую куда дешевле наладить радиосвязь между двумя домами, чем прокладывать весьма дорогостоящий кабель. А в условиях города радиосвязь часто просто незаменима.

Но у радиометода существует и ряд существенных недостатков. Первым из них является очень маленькая скорость, особенно в сравнении с высокоскоростными кабельными соединениями. Конечно же, эта проблема легко решается увеличением используемой полосы частот, но тут проявляется еще один недостаток — чрезвычайно высокая конкуренция за радиочастоты со всеми вытекающими отсюда последствиями.

Существует множество вариантов, которые позволяют в полной мере насладиться всеми преимуществами беспроводного обмена данными. Пожалуй, самым экзотическим из них является использование маломощных радиопередатчиков для обмена данными между устройствами, находящимися в одном системном блоке. На таких небольших расстояниях и при широкополосной передаче достигается большая скорость, достаточная для большинства компонентов современного компьютера. А вот зачем это необходимо нам, видимо, объяснят попозже :-). Также радиосвязь можно использовать на немного большие расстояния, такие, например, как от вашего системного блока до принтера, клавиатуры, мыши или мобильного телефона, что куда более актуально.

Но, пожалуй, наибольший интерес, сообразно теме статьи, представляют локальные сети, построенные на основе радиотехнологий (того же RadioEthernet, к примеру). В таких сетях уже используются более мощные передатчики, работающие в основном на частотах, свободных от лицензирования. При этом они также обеспечивают вполне приличную скорость, исчисляемую десятками мегабит в секунду.

Также радиосвязь служит для обеспечения дальней связи, начиная от нескольких тысяч метров и кончая десятками километров. Но и этот вариант сейчас скорее экзотика и применяется чаще всего для систем типа точка-точка или точка-многоточка. Это технологии, которые работают на максимальном расстоянии без использования ретрансляторов.

Так как наша планета, грубо говоря, круглая, а радиоволны коротковолнового диапазона не обладают способностью огибать поверхность, то существует предел, которым определяется максимальное расстояние для радиосвязи. Для того чтобы обойти это ограничение, можно использовать ретрансляторные вышки или более высокотехнологичное достижение науки — ретрансляционные спутники. Наиболее удобными для этих целей являются спутники с геостационарной орбитой, то есть неподвижно висящие над одной точкой земной поверхности. Для этого они должны по законам физики находиться на расстоянии 35785 км от Земли, откуда открывается чудесный вид :-) и большие возможности по увеличению площади приема сигнала. Сигнал, посланный с Земли, принимается ретранслятором спутника, усиливается и отправляется назад под другим углом.

Но существует одна проблема — количество геостационарных спутников ограничено, ведь чтобы не создавать взаимных помех они должны находиться на определенном расстоянии друг от друга (это обычно угловое расстояние в 4–8 градусов). Поэтому в системах радиосвязи также широко используются низкоорбитальные спутники. Такой спутник облетает Землю приблизительно за 1.5 часа, и естественно, ни о какой постоянной передаче данных с помощью одного такого спутника и речи быть не может.

Для обеспечения постоянной связи используются целые комплексы низкоорбитальных спутников, которые имеют довольно сложную систему пространственной навигации и взаимодействия. В таких системах данные передаются через тот спутник, который в данный момент находится в наиболее подходящем положении, затем очередь переходит к следующему и т.д. Если же необходимо передать информацию, к примеру, на другую сторону Земли, то происходит обмен данными между спутниками. Тогда сеть спутников начинает напоминать Интернет :-), где существует своя система адресации и маршрутизации.

Для охвата всей земной поверхности сетью низкоорбитальных спутников их понадобиться от тридцати до семидесяти штук (в зависимости от высоты), и тогда над каждой точкой земного шара будет постоянно «виден» хотя бы один из них. Удовольствие, конечно, не из дешевых, и именно поэтому спутниковая связь все еще остается такой дорогой. И это несмотря на большое количество ретрансляторов, находящихся на каждом из спутников, и разделяемость ресурсов каждого из ретрансляторов (сейчас любой спутников может одновременно вести несколько тысяч сеансов связи).

Существуют другие, более дешевые способы расширения зоны покрытия. К примеру, использование микроволнового излучения, знакомого нам по сотовой связи и по ретрансляционным вышкам, возвышающимся вдоль дорог и в городах. Именно его иногда применяют для передачи данных, хотя системы, созданные на его основе, довольно редкое явление. Более известной любому из нас является передача цифровых данных с использованием систем сотовой телефонной связи. В последнее время данная услуга все чаще стоит в отдельной графе телефонных счетов.

Недостатком решений на микроволнах является обязательное условие прямой видимости и необходимость установки множества вышек с весьма дорогим оборудованием.

В процессе борьбы за частотный диапазон появилось еще несколько эффективных решений. Одно из них — использование для передачи информации инфракрасного излучения (наподобие того, как устроены пульты дистанционного управления телевизора). Чаще всего такой подход применяется для создания сети между компьютерами в одной комнате, или обмена данными компьютера с беспроводными устройствами (например, клавиатурой или мышью). При этом должно соблюдаться условие строгой взаимной ориентации приемника и передатчика.

Второе решение — использование лазера. И если раньше лазер у нас упоминался в связи с необходимостью передачи данных через оптоволокно, то сегодня он применяется для передачи данных через открытое пространство. Стоит ли говорить, что взаимное положение приемника и передатчика должно быть весьма строгим. Но результат кропотливой установки и настройки вполне оправдывается скоростью передачи в сотни мегабит в секунду при максимуме расстояния порядка трех километров. Правда, если данная технология применяется на улице, то достаточно пойти небольшому дождику, и вы сможете оценить все недостатки такого решения, а именно — полную неработоспособность системы в плохих погодных условиях.


ДУ для компьютера.

На сегодняшний день Майкрософт признала всю прелесть такого простого, но очень уж приятного устройства, как пульт ДУ, — в Windows Media Center без него уже не обойтись. На нем буквально все завязано.

Что же мы имеем для начала? Компьютер, рабочий инструмент под названием «не очень корявые руки» :-) и большое желание управлять компьютером издалека. Далее — что есть у компьютера? Правильно, порты ввода/вывода. Вот их мы и будем использовать. Вас никто не заставляет отказываться от LPT- или USB-портов. Но все же конструкция получится гораздо проще, если подключать инфракрасный (ИК) приемник пульта нашего ДУ именно к COM-порту.

Выбор ДУ

В принципе, можно использовать любое ДУ. Ибо наш компьютер жестко не привязан ни к какому из них. И это очень важно! С помощью программного обеспечения (ПО) мы сможем настроиться на любой имеющийся пульт.

HardWare

Необходимое нам чудо техники зовется фотоприемником. Фотоприемник - можно любой импортный. Я использую фотоприемник SFH 506-36 (рис. 1) или ТК-19 (рис.2).Не забудьте посмотреть спецификацию устройства. В принципе, какой брать фотоприемник — неважно, лишь бы потреблял и выдавал 5 вольт. Обратите на это особое внимание! Для обеспечения фотоприемника стабильным напряжением 5В приобретаем стабилизатор КРЕН5А. Он будет преобразовывать 12В на выходе COM-порта в 5В. Также покупаем и электролитический конденсатор (от 5 до 30 мкФ — чем больше, тем лучше). Еще понадобится резистор (от 1 до 2 кОм, подбирается экспериментально). Наконец, потребуются всякие косметические примочки — разъем и корпус для COM-порта , а также соединительные провода. Можно взять еще один небольшой корпус (например, для COM- или LPT-порта), чтобы поместить всю Рис. 1 собираемую схему в него. Или же вывести фотоприемник отдельно на переднюю панель системного блока — это кому как удобней. Итак, собираем простую схему (рис. 2 или 4) — и наш ИК-приемник сигналов с ДУ (для любопытных — работающий в инфракрасном диапазоне электромагнитных волн) готов. Кому надо, может соорудить еще и ИК-передатчик (брать сигнал нужно с выхода 3 COM-порта, сам порт показан на рисунке 3). Получится самый настоящий ИК-порт для компьютера, используемый, например, для сообщения с мобильными устройствами, управлением бытовой техникой, беспроводной связи с другим компьютером и проч. рис.1

рис.2

Для тестирования можете посмотреть на выходной сигнал осциллографом. У кого его нет или если кто не знает, что это такое :-), — подключите светодиод к выходу ИК-приемника. При нажатии кнопки на ДУ светодиод должен мигать. С помощью вольтметра проверяем, чтобы на выходе был достаточный «разброс» сигнала логических единицы и нуля.

IR приемник подключается к свободному СОМ порту компьютера проводом длиной 1-30 метров.

рис.3

рис.4

SoftWare

В поисках подходящей программки я пересмотрел несколько вариантов. Остановился же на WinLIRC http://winlirc.sourceforge.net/ как самой функциональной. Главным аргументом в ее пользу была встроенная (!) поддержка со стороны некоторых Медиа Плееров. К тому же, WinLIRC справится и с управлением бытовой техники — он может посылать команды, как будто вы нажали кнопку на пульте. Недостатком является работа только с последовательными портами (COM). Не в пример своему «предку» — программе LIRC, которая не брезгует практически ничем, к чему можно подключить ДУ :-), включая некоторые модели ТВ-тюнеров. Ну и ладно, ведь что может быть для юзера лучше обеспеченной разработчиками возможности управления развлекательным процессом? Сам по себе WinLIRC никаких действий не производит. Он выступает сервером, распознающим команды, поступающие с пульта, посылает имена этих команд клиентам, которыми являются прикладные программы, и таким образом предоставляет программам доступ практически к любому пульту ДУ. То есть WinLIRC позволяет избежать программно-аппаратной привязанности к конкретному принимающему устройству и пульту. И в то же время утилита предоставляет стандартизированный и удобоваримый способ получать эти самые управляющие команды.

После первого запуска нам предлагают настроить WinLIRC, на что надо незамедлительно соглашаться. В открывшемся окне настроек выбираем тип нашего приемника — RX Device или DCD Device. Поясняю: RX Device — это устройство, выходной сигнал которого подается на 2-ую «ногу» COM-порта, а DCD Device — на 1-ую. В нашей схеме сигнал подается на обе ноги, а значит, это дает возможность поэкспериментировать с обоими типами настроек и разными программами. Я заметил, что в Windows 9x лучше выбирать RX, а в Windows NT (2000, XP) — DCD Device. В этом же окне определяются настройки ИК-передатчика, скорость COM-порта и другие параметры. Итак, все нужное выбрали. Жмем Learn. Далее следует процесс настройки на конкретный пульт ДУ. Ничего сложного в этой процедуре нет. Только одно замечание — может оказаться, что имеющийся у вас пульт при зажатой клавише посылает не один и тот же пакет (набор, состоящий из 1 и 0), а вначале идет пакет нажатой кнопки, а затем — код повтора. В этом случае необходимо во время обучения не зажать и держать, а очень быстро нажимать и отпускать нужную клавишу (64 раза ). После непродолжительного процесса обучения нам предлагают нажать кнопку Analyze. Она должна проверить правильность полученных настроек, т.е. сгенерированного конфигурационного файла. Если все прошло успешно — остается только наслаждаться установленным и настроенным WinLIRC’ом. Можно ярлычок на него поместить в Автозагрузку (StartUp) — тогда он будет запускаться вместе со стартом Windows.

После запуска настроенного WinLIRC в System Tray в виде маленькой лампочки появится индикатор состояния. Его серый цвет сигнализирует о готовности принимать команды с пульта ДУ, красный, как нетрудно догадаться, — об ошибке в настройках, зеленый — об успешном распознании нажатой клавиши ДУ, желтый — об инициализации (открытии) порта, синий — о передаче команды, например, бытовой технике.

Программы поддерживающие WinLIRC.

Радуйтесь, меломаны, речь пойдет о Winamp’е. Ибо именно этот аудиоплейер завоевал наибольшую популярность. Хотя, по-моему, МР3 он играет не лучшим образом, здесь по качеству воспроизведения его обходит даже более «легкий» Apollo. Но не об этом сейчас речь. Для Winamp’а существует плагин управления через WinLIRC. Зовется он незамысловато — WinLIRC Plugin. есть: http://prdownloads.sourceforge.net/ winlirc/gen_ir-0.3.zip, 80 Кб. Сам файл называется gen_ir.dll. Плагин предоставляет широкий спектр функций, необходимых для управления Winamp’ом. От воспроизведения, паузы, остановки до таких экзотических для пульта ДУ команд, как открытие опций визуализации и загрузка настроек эквалайзера.

Для добавления новой команды жмем кнопку Add. Появляется маленькое диалоговое окно с полем ввода названия клавиши пульта (одного из тех названий, которые вы давали во время настройки WinLIRC), и выпадающим списком, в котором необходимо выбрать действие, соответствующее указанной кнопке.

Учтите, что Winamp нужно будет запускать после WinLIRC. Делать это нужно для того, чтобы в проигрывателе была доступна сама возможность удаленного управления. Это касается и всего остального софта, использующего WinLIRC.

Кстати, существует очень интересная возможность управления с пульта ДУ программами, выполняющимися на разных ПК. Ведь ничто не мешает утилите подключиться к WinLIRC’у через сеть. Но для этого нужно, чтобы в настройках соответствующей программы была возможность вводить адрес WinLIRC-сервера. К примеру, gen_ir такой возможностью не обладает .

Если все было настроено правильно, то после запуска ПО соответствующий плагин начнет реагировать на команды с пульта ДУ.

Универсальный плеер, мы писали о нем в статье- Проигрыватели.

В качестве примера видеоплейера я опишу Light Alloy (http://la.video-soft.com/). Это достаточно молодой, но прогрессивный плейер. В нем реализованы все необходимые функции для проигрывания аудио- и видеофайлов, плюс немного больше. Главное же его преимущество перед остальными плейерами — нормальная работа с WinLIRC.

Итак, в настройках плеера Light Alloy ставим «галочку» возле надписи «Использовать WinLIRC». Указываем адрес сервера и порт. Можно также включить дублирование команды с пульта звуком. То есть при нажатии на кнопку пульта раздается звуковой сигнал. Здесь же отображается состояние соединения с WinLIRC’ом и последняя нажатая клавиша. Для установки соединения с WinLIRC’ом необходимо перезапустить плейер.

Далее в настройках клавиатуры ставим курсор на нужную команду и нажимаем соответствующую кнопку на ДУ. И так для каждой кнопки/команды.

Универсальный помощник

Да, такова уж жизнь, что набор прикладного ПО не ограничивается Winamp’ом и Light Alloy. Может возникнуть реальная необходимость управлять с помощью ДУ и другими программами, которые не поддерживают WinLIRC. Что же желать? Выход есть всегда, когда есть вход :-). И в данном случае тоже. Зовется он InfraRed EXecuter (http://www.ramscan.com/irex, 24 Кб). С помощью ДУ эта программа позволяет эмулировать нажатия любых клавиш клавиатуры, действия мыши, управлять громкостью звука, запускать многие программы. Например, InfraRed EXecuter (IREX) при нажатии кнопки на пульте ДУ может заставить программу, чье окно в данный момент активно, считать, что нажата соответствующая клавиша на клавиатуре, или мышь выполнила какое-то действие (например, левый или правый клик, перемещение указателя). Очень удобным будет, к примеру, настроить несколько кнопок на пульте ДУ на самые используемые в мультимедиа (и не только) клавиши клавы. Такие как курсор вверх/вниз/влево/вправо, пробел, Enter, Alt-Tab и т.д. А затем во всех используемых плейерах установить управление при помощи клавиатуры, задействуя эти клавиши.

К тому же, IREX очень «умен». Так, при старте он дожидается запуска WinLIRC; при его закрытии завершает свою работу; автоматически перезагружает свой файл настройки (который может храниться или в папке вместе с IREX’ом, или в «Мои Документы»), когда он изменяется. IREX представлен иконкой в System Tray и подмигивает, когда «понял» какую-то команду. Именно его я использую для запуска Light Alloy.

А теперь наслаждайтесь тем что у вас получилось, а у вас получится, я в этом уверен. Всем пока, Григорий.


Заправляем картриджи в домашних условиях

Струйный принтер — это хорошо. Струйный принтер от Hewlett-Packard — хорошо вдвойне, потому как это и технологические новшества, и высокое качество печати, и приемлемая цена. Вашему вниманию предлагается обзор наиболее распространенных моделей принтеров от этой известной компании. Перед тем, как перейти к описанию тех или иных конкретных устройств, позвольте рассказать о некоторых особенностях, присущих практическим всем струйным принтерам Hewlett-Packard.

Качество печати

Все модели HP используют термоструйный принцип печати — каждое сопло печатающей головки снабжено миниатюрным нагревателем, который при необходимости выдать порцию чернил накаляется до высокой температуры. В чернилах, окружающих нагревательный элемент, образуется и вырастает пузырек пара, который «выталкивает» каплю в сторону листа бумаги. Данная технология, безусловно, не лишена некоторых недостатков: наличие неконтролируемых капель-сателлитов, нестабильная форма капли, низкое качество фотографических изображений и пр., о чем много и с пристрастием пишут почитатели другого метода печати, пьезоэлектрического (подробнее о способах струйной печати смотрите в МК, № 5 (176), 9 (180) за 2002 год). Следует, однако, заметить, что последние анонсированные модели принтеров, в которых используется термоструйный метод нанесения капель, имеют разрешающую способность в 2400 и даже 4800 точек на дюйм. Они обеспечивают замечательную четкость картинки и превосходное качество фотоотпечатков, что только подтверждает давно известную истину — первостепенное значение имеет не то, какая именно технология используется, а то, как хорошо она реализована. Для улучшения цветопередачи в принтерах НР применяется несколько дополнительных методов повышения качества отпечатков. Основной из которых — технология многослойного нанесения микрокапель PhotoRet. Благодаря применению этой технологии каждая точка изображения на бумаге состоит из 16 (PhotoRet II) или 29 (PhotoRet III) микроскопических порций разноцветных чернил. При смешении красок различных цветов расширяется диапазон воспроизведения цветовой палитры — фотографии и цветные изображения получаются насыщенными и натуральными. При выводе черного текста также используется метод Ret (resolution enhancement technology). При формировании точки микропорции чернил позволяют достичь равномерного заполнения площади (внутреннее пространство символов) или плавного изменения яркости (окантовка символов), в результате чего текстовые отпечатки значительно выигрывают в качестве. Вспомогательная технология ColorSmart III, работающая исключительно на программном уровне, отвечает за улучшение качества изображения до начала растрирования и, соответственно, печати. Производится анализ гистограммы картинки, увеличивается ее цветовой диапазон, улучшается резкость. Для изображений с низким разрешением (что весьма типично для иллюстраций, взятых из Интернета) производится предварительное сглаживание. Разумеется, для профессионального использования, например, цветопробы или получения предварительных оттисков, ColorSmart III — вещь абсолютно ненужная. Но для домашнего или офисного пользователя данная технология способна значительно облегчить подготовку ярких и красивых цветных публикаций. В целях предотвратить погрешности цветопередачи при подготовке иллюстраций к печати, все струйные принтеры HP поставляются с профилями цветового пространства sRGB, а преобразование цветов в CMYK-модель происходит согласно стандарту CIECAM97s. Проще говоря, имея sRGB-профили и для других устройств обработки изображения, а также установленную ОС Win 98 или выше, можно без особых усилий обеспечить правильную цветопередачу в любой точки цепочки цифровая камера (сканер) — монитор — принтер. При помощи драйверов можно выбрать один из трех вариантов печати: Draft (черновое качество), Normal (нормальное качество) или Best (наилучшее качество). Последний режим, к сожалению, устанавливается далеко не для всех видов бумаги, а только для материалов со специальным покрытием. Правда, драйвер можно и обмануть, выбрав нужный сорт бумаги из предлагаемого списка, при этом качество распечатки несколько повышается. При печати на оригинальных расходным материалах, в особенности на фотобумаге, качество изображения сравнимо с тем, которое достигается при выводе на лазерных принтерах. На обычной же офисной бумаге (т. н. отбеленная, плотностью 80 г/м2), даже при использовании самых высоких разрешений, заметны легкая чернильная «бахрома» по краям темных областей и слабые цветные разводы. Впрочем, если вы используете в основном обычную бумагу, то продукция HP — первый из претендентов на приобретение. Эти принтеры издавна славятся качеством печати независимо от типа применяемых носителей. (Чего, к сожалению, нельзя сказать об изделиях других компаний, в особенности Canon и Epson. Они разрабатывают состав своих чернил с учетом специфики фирменных носителей, и при переходе на бумагу сторонних поставщиков качество отпечатков заметно снижается).

Скорость печати

Компания HP заявляет о довольно-таки высокой скорости печати своих принтеров — от 5 листов черного текста за минуту для моделей низшего уровня, до 15-17 стр/с у дорогих профессиональных и офисных принтеров. Все эти цифры справедливы, только с одной оговоркой — указанная скорость печати относится исключительно к черновому качеству. Кроме того, при тестировании быстродействия своих изделий компании используют документы с гипотетическим 5%-ным заполнением листа для текстов и 15%-ным — для цветных изображений. На практике все немного по-другому. Заполнение текстовых документов зависит от типов применяемых шрифтов, их размеров, межсимвольного и межстрочного интервалов, а также текстовых полей, и может достигать 7%, 10% и даже 13% площади листа. При выводе изображений на степень заполнения влияют размеры картинки, ее насыщенность, контрастность и яркость; диапазон типичных значений — от 30% до 45%. Так что при печати реальных документов в режиме нормального, и уж тем более наилучшего качества, скорость вывода уменьшается в 2–3.5 раза от заявленной. Что касается создания фотоотпечатков, то на каждый полный лист формата A4 при максимальном разрешении затрачивается около 20 мин. Время печати фотоснимка размером 10х15 см — примерно 5 мин. Некоторые модели принтеров имеют специальный блок для двусторонней печати, который по необходимости автоматически переворачивает каждый отпечатанный лист и вновь направляет его в приемное устройство. Для некоторых других моделей эта приставка доступна опционально и поставляется по цене $70. Такое решение позволяет несколько ускорить работу в том случае, если существует необходимость частого вывода двусторонних распечаток. Но не обошлось тут и без недостатков — использование блока двусторонней (или, как его еще называют, дуплексной) печати увеличивает нижнее поле страницы до 4 см, что может доставить определенные неудобства при выводе полноформатных документов. Косвенно на скорость печати влияет и такой параметр, как ресурс принтера. Это максимальная месячная нагрузка, выражаемая в тысячах страниц. Ее значение колеблется в пределах от 1 до 5 тыс., и зависит в основном от потребительского класса устройства. Нагрузка на принтер должна распределяться равномерно, в течение всего месяца. Количество опечатываемых за день страниц не должно превышать трех суточных норм. Например, для принтера с ресурсом в 1000 стр. максимальной будет отметка в 100 стр/день ((1000/30)х3), для модели с ресурсом в 3000 стр. — 300 стр/день ((3000/30)х3). Если не придерживаться этого правила и печатать по принципу «за пару дней месячная норма, затем длительный отдых», то это приведет к излишнему износу картриджа и механических узлов, что может повлечь за собой преждевременный выход принтера из строя.

Стоимость печати

За право наслаждаться четкими и красочными оттисками придется заплатить. А именно: черный текст: 5-% заполнение — 0.03–0.05 цента за страницу цветная иллюстрация: 15-% заполнение — 0.2–0.25 цента за страницу фотоотпечаток: от доллара и выше за каждую страницу. Приведенные цифры справедливы в том случае, если используются оригинальные расходные материалы: специальная бумага для струйной печати, фотобумага для фотоотпечатков и фирменные картриджи. Причем картриджи после израсходования чернил не заправляются заново, а выбрасываются — именно это, кстати, и советуют делать все фирмы-производители принтеров. Как нетрудно заметить, при таком подходе струйный принтер может заметно опустошить семейный бюджет. Интенсивная печать потребует частой смены картриджей, чернильный ресурс которых, как известно, редко когда превышает 600 страниц. А это в свою очередь приведет к тому, что за месяц-другой на различные «расходники» придется потратить сумму, равную или превышающую ту, что была уплачена за сам принтер . Обслуживание принтера можно существенно удешевить, прибегая к перезаправке использованных картриджей. Тут уж реально сэкономить как на самих картриджах, «перезаряжая» их по несколько раз, так и на чернилах. Покупая менее качественные, но в то же время и более дешевые чернила, которые сегодня продаются «литрами» и «на разлив», удается снизить стоимость текстового и цветного отпечатка в 3–5 раз (до 5 коп. и 25 коп. соответственно). Конечно, при этом придется пожертвовать качеством, да и картриджи надо все же время от времени покупать — при длительном использовании и частой перезаправке загрязняются и изнашиваются сопла печатающей головки. По опыту можно сказать, что «время жизни» картриджа редко когда превышает 10–12 перезарядок, а в пересчете на листы 5000–7000. Единственный тип печати, который удешевлению не поддается, это фотовывод. Здесь дорог сам носитель — фотобумага. Его цена составляет от доллара за одну страницу и выше.

Модельный ряд

В настоящее время на компьютерном рынке широко доступны шесть моделей принтеров Hewlett-Packard формата A4, одна модель формата A3 и одна из семейства фотопринтеров DeskJet 656C — компактный красавец по сверхнизкой цене, всего лишь $50. Самой компанией устройство позиционируется как «идеальный выбор для тех, кто впервые покупает принтер для дома». Данная модель поддерживает черно-белую и цветную печать с разрешением до 600 тчк/дюйм, причем печатает не только на бумаге, но и на прозрачных пленках и наклейках. Весьма примечательно также и то, что DeskJet 656C имеет возможность фотопечати — с этой целью в принтере реализована поддержка ранней версии технологии PhotoRet. Единственное ограничение — для вывода оттисков с фотографическим качеством придется приобретать специальный фотокартридж. Принтер рассчитан на подключение к современным компьютерам и оснащен только одним интерфейсным разъемом — USB. Полностью поддерживаются спецификации стандарта USB версии 2.0. Данная модель является Win-принтером, т. е. работает только под управлением операционных систем Microsoft Windows 98 и выше. Максимальная месячная нагрузка — 1000 страниц. DeskJet 845C — «семейный принтер» начального уровня. Недорогое, но достаточно серьезное решение для вывода текстов и несложных фотографических документов. Благодаря реализации технологии PhotoRet II фотопечать доступна при обычном цветном картридже. Указанная модель подключается к компьютеру посредством интерфейса USB (поддерживается USB 2.0). В комплекте поставки идут драйверы для ОС Windows версий 98 и выше, в также Mac OS версии 8.6. Заявленный ресурс принтера — 1000 страниц в месяц. DeskJet 920C — мечта начинающего фотолюбителя. Благодаря поддержке PhotoRet III, фотографические отпечатки, выводимые на этом принтере, по своему качеству вполне сравнимы с настоящими фотографиями. Максимально доступное разрешение печати — 2400х1200 тчк/дюйм. Принтер имеет несколько интересных конструктивных и технических особенностей. Во-первых, это упрощенный компактный лоток для приема бумаги, который в перерывах между сеансами печати можно сложить, тем самым сэкономив место на рабочем столе. Во-вторых, кнопка прерывания печати, мгновенно останавливающая процесс вывода и очищающая буфер принтера. В-третьих, автоматический индикатор уровня чернил, благодаря которому можно избежать досадных перерывов на дозаправку в самый неподходящий момент. Для подключения к компьютеру могут быть использованы два типа интерфейса: параллельный LPT и USB. Принтер рассчитан на работу совместно с ОС Windows версий 3.1 и выше, а также с Mac OS версий 8.1 и выше (для соединения с ПК Macintosh используется интерфейс USB). DeskJet 940C — универсальная модель для дома и малого офиса. От предыдущего устройства отличается увеличенной емкостью приемного лотка и более высокой скоростью вывода документов на печать. Кроме этого, в комплект поставки входит набор программ HP Photosolution, предназначенных для упрощенной печати фотографий. DeskJet 960C. По своим возможностям модель является переходным звеном между универсальным домашним принтером и профессиональным офисным и рассчитана на ежедневную интенсивную печать. В отличие от более дешевых устройств, DJ 960C имеет увеличенную скорость вывода документов, большую допустимую месячную нагрузку, а также расширенный объем памяти. Реализованы функции автоматического определения типа бумаги (и других носителей), а также автокалибровки цветных картриджей. (В других, более слабых моделях, для калибровки принтера требуется делать тестовые распечатки нескольких вариантов специального изображения, а затем программным путем выбирать наилучший.) DeskJet 995C — идеальное решение для любых задач, хотя и не дешевое. Этот принтер поддерживает такие интерфейсы связи с ПК, как USB, инфракрасный IrDA и новомодный Bluetooth. При помощи этого принтера можно распечатывать документы и картинки не только с настольных систем, но и с ноутбуков, переносных компьютеров и наладонников. Среди других его отличительных особенностей — встроенный блок для двухсторонней печати. DeskJet 1220C — высокопроизводительный офисный принтер формата A3. Обеспечивает скорость черновой печати текста в 11 стр/мин для листов формата A4, и 7 стр/мин — для формата A3. Максимальная месячная нагрузка составляет 5000 страниц. Имеется встроенный датчик ширины бумаги, для толстых носителей предусмотрена подача с тыльной стороны принтера, минуя изгиб на поворотном валике. Вместе с принтером поставляется оригинальное программное обеспечение HP Smart Software, позволяющее быстро и качественно подготавливать бюллетени, брошюры, листовки, преобразовывать документы из одного формата в другой (увеличивать, уменьшать, поворачивать, создавать плакаты из иллюстраций небольшого размера) и проделывать другие востребованные в условиях офиса операции. В настройках драйвера предусмотрена возможность отключения алгоритмов автоматической обработки изображения, что обеспечивает возможность получения полноценной цветопробы. Модель DJ 1220C поддерживает интерфейсы LPT и USB, работает совместно с ОС MS-DOS 3.3 и выше, ОС Windows 3.1 и выше, а также Mac OS 7.6.1 и выше. PhotoSmart 1215 — фотопринтер, предназначенный для печати фотографий как с ПК, так и с цифровых камер. Модель поддерживает интерфейсы LPT, USB и IrDA, имеет несколько слотов для подключения флэш-карт и жидкокристаллический дисплей с меню. На дисплее выбирается номер изображения, которое необходимо напечатать, есть возможность вывода индексной страницы с уменьшенными копиями («ноготками») всех картинок, чтобы затем отобрать нужные. Внутренний процессор принтера поддерживает следующие форматы графических файлов: JPEG и TIFF (цветовая модель RGB). При печати документов с помощью ПК качество значительно лучше, чем при автономном выводе изображений посредством одного только принтера — здесь сказывается недостаток ресурсов встроенного процессора. При подключении к принтеру компьютера содержимое флэш-карт представляется в виде отдельных папок, причем доступна операция копирования выбранных файлов на жесткий диск.

Заправка картриджей

Что делать, когда принтер в самый неподходящий момент вдруг перестает печатать? Правильно - надо заменить картридж. Но сейчас в продаже имеется большой, я бы сказал, даже слишком большой выбор самых различных картриджей практически для всех известных моделей принтеров. Можно приобрести оригинальный картридж, довольно дорогой, но качество его работы будет гарантировано производителем принтера. Кроме них, бывают еще и восстановленные, то есть бывшие в употреблении, но перезаправленные, чаще всего в полукустарных условиях, которые ощутимо дешевле оригинальных. Между ними, как по качеству, так и по цене, располагаются так называемые совместимые картриджи, производимые третьими фирмами. А может быть, стоит попытаться самому заправить старый картридж, вдохнув в него новую жизнь, и между делом, сэкономив "энную" сумму для своего домашнего бюджета? Не секрет, что все без исключения производители принтеров, желая захватить максимально большую долю рынка, продают свои изделия по цене, не слишком отличающейся от себестоимости, а упущенную при этом прибыль "добирают" на стабильно дорогих расходных материалах. При этом все они с поразительным единодушием обещают всяческие неприятности (и в первую очередь - значительное снижение качества печати) всем тем, кто не пожелает следовать их настоятельным рекомендациям использовать только оригинальные расходные материалы. Спору нет - качество важно, но если денег нет, то мы выбираем то, что нам по карману: разница в цене между оригинальным картриджем и флакончиком с чернилами достигает десятикратной величины (такое соотношение цен справедливо и для лазерных принтеров).

Струйные принтеры

В домашних условиях принтеры получили широкое распространение только лишь после появления технологии струйной печати, что позволило, по сравнению с матричными принтерами, кардинально улучшить качество печати и, вместе с тем, значительно снизить шумность и увеличить скорость печати. Но самое главное - появилась возможность цветной печати, причем с высоким качеством. Большинство моделей струйных принтеров являются всего лишь незамысловатыми механизмами для протяжки бумаги и позиционирования чернильного картриджа, который и является сосредоточением всех технологических "изюминок", определяющих возможности данного принтера. Такое "разделение труда" привело к тому, что стоимость картриджа, в наиболее дешевых моделях, доходит до половины полной стоимости принтера. Так что при интенсивном использовании, когда картриджи меняются чуть ли не один за другим, суммарная стоимость владения струйного принтера стремительно приближается к соответствующему показателю дорогого лазерного. Что же делать? Неужели все-таки раскошеливаться на лазерный принтер? Не обязательно, но для кардинального сокращения затрат на содержание струйного принтера вам придется освоить процесс заправки картриджей. Поверьте, это не так страшно, как кажется, но вот только насчет снижения качества печати после повторной заправки - тут, к сожалению, очень часто производители бывают правы. Так что перезаправлять рекомендуется только черные картриджи - ведь к качеству черно-белой печати, по большей части текстов, требования далеко не такие высокие, как к цветной, и тем более - к фотопечати. Однако перед тем, как перейти к практической части нашего повествования, неплохо было бы обновить в памяти кое-какие теоретические сведения о струйной печати. Итак:

Устройство чернильного картриджа

Печатающий блок любого струйного принтера состоит из двух основных частей. Во-первых, это резервуар (или чернильница), наполненный чернилами, и капиллярная система, подводящая чернила из резервуара к соплам, откуда чернила и "выстреливаются" на бумагу. В некоторых черных картриджах и практически во всех цветных чернильница заполнена специальной абсорбирующей губкой (типа поролона). Для перезаправки такие картриджи подходят наилучшим образом. В других моделях чернила удерживаются в резервуаре за счет разницы внутреннего и внешнего давления. Ну а в некоторых картриджах это происходит за счет специального мешка, заполненного воздухом. Головка является важнейшей частью печатающего блока. При этом у некоторых принтеров головка составляет с чернильницей единый неразборный блок (например, у картриджей для принтеров HP, Lexmark). У других же моделей она остается в принтере, а меняются только чернильницы. Тут тоже может быть два варианта, так, в принтерах Epson головка является неотъемной частью конструкции принтера, тогда как в большинстве моделей Canon головка сделана съемной. В последнее время, с "легкой" руки Epson, многие картриджи стали оснащаться встроенными чипами, контролирующими расход чернил. Одной из важнейших (с точки зрения производителей) функций таких чипов является борьба с повторным использованием одних и тех же картриджей, так как они запоминают нулевой уровень чернил в резервуаре и блокируют повторное использование таких картриджей. Но голь на выдумки хитра, долго такая защита не продержалась, и сейчас во многих файловых архивах в Интернете можно найти программы-"ломалки" для различных моделей слишком "интеллектуальных" картриджей. Чернила, используемые в различных картриджах, также различаются. Причем, как утверждают производители, для каждой модели принтеров нужен свой, строго определенный тип чернил. Но такая тщательность (ведь универсальных, пригодных для всех случаев жизни, чернил не бывает) верна только по отношению к оригинальным картриджам и чернилам. Сейчас очень часто продаются чернила (в основном, большими емкостями), которые, по заявлениям продавцов, подходят к разным моделям принтеров и даже разных производителей. Такие чернила относятся к группе простых (стандартных) чернил, и они подходят для печати с низкими разрешениями, то есть, в основном, простого текста. Изредка можно встретить и специальные чернила для печати с высоким разрешением, однако они достаточно дороги, да и для высококачественной печати перезаправленные (да еще и в кустарных условиях) картриджи не подходят по определению. При заправке картриджа чернилами от неизвестного, или известного, но другого производителя картридж рекомендуется предварительно тщательно промыть. Для промывки можно использовать дистиллированную воду или специальные промывочные жидкости, не содержащие щелочь. В тех же случаях, когда при заправке тип чернил не изменяется, наоборот, рекомендуется дозаправлять картридж, не дожидаясь его опустошения. Сам процесс заправки довольно сильно отличается для картриджей различных производителей. Однако если вы не хотите, чтобы заправка картриджей вместо ожидаемой экономии средств принесла вам дополнительную головную боль, не стоит забывать о нескольких общих правилах: - Перед заправкой картриджа следует обратить внимание на его целостность, отсутствие трещин на корпусе и, для моделей, совмещенных с печатающей головкой, на токопроводящей гибкой плате с электрическими контактами. Иногда встречаются низкокачественные чернила, которые могут разъесть медь на этой плате. - Лучше всего заправку производить сразу же после окончания чернил в картридже, иначе чернила, оставшиеся в соплах, могут засохнуть и картридж придется подвергнуть длительному процессу очистки, который далеко не всегда приводит к положительному результату. - При заправке любых картриджей, во избежание образования воздушных пузырьков, чернила должны вводиться МЕДЛЕННО. Ну а теперь, разобравшись с общими моментами, можно смело переходить к рассмотрению специфики процесса заправки картриджей от разных производителей.

Заправка картриджей Epson

Сменные картриджи Epson представляют собой обычные емкости для чернил, без какого-либо механизма, обеспечивающего печать. Печатная головка принтера не вынимается и имеет ресурс такой же, как и у принтера, и поэтому она не должна заменяться в течение всего периода его эксплуатации. Если вам вдруг по какой-либо причине захочется ее заменить в сервисной мастерской, то стоимость работы будет сопоставимой со стоимостью нового принтера. А согласно всезнающей статистике, печатающий блок Epson'а чаще всего выходит из строя именно из-за засыхания остатков чернил в каналах, использования поддельных картриджей или их заправке чернилами низкого качества. Во всех вышеперечисленных случаях фирма снимает с себя гарантийные обязательства, поэтому, решившись на перезаправку, надо четко уяснить себе все возможные последствия такого шага. Сам по себе процесс заправки картриджа предельно прост. Сразу после извлечения картриджа из принтера необходимо заклеить выходящее отверстие заранее подготовленным кусочком скотча. После этого, если у резервуара есть отверстия (они должны быть заклеены пленкой) на крышке, вводим иглу шприца до дна картриджа и медленно закачиваем чернила. Если же отверстий нет - придется их проделать самому. Завершая операцию заправки, нужно будет не забыть заклеить заправочное отверстие и освободить - выходящее. Но самое главное, о чем стоить помнить всегда - нельзя вынимать картридж из принтера больше чем на минуту, иначе печатающая головка безвозвратно засохнет, со всеми вытекающими из этого последствиями. Одним из выходов в такой ситуации может стать запасной картридж - один вынул, другой сразу вставил, и полный порядок.

Заправка картриджей Hewlett Packard

В картриджах этой фирмы печатающая головка совмещена с резервуаром. Такая конструкция делает картриджи более дорогими по сравнению с Epson, однако имеются и определенные преимущества. И главное из них то, что в случае неудачной заправки испорченный картридж просто заменяется на новый, а самому принтеру не будет причинен никакой ущерб. Цветные и черные картриджи HP отличаются друг от друга конструкцией. У первых, так же как и моделей от Epson, резервуар имеет поролоновый наполнитель, да и заправляются они похоже. Для заправки картриджа 51625 (для принтера DeskJet 4хх/5хх) нужно снять верхнюю крышку (сделать это не так просто, как кажется на первый взгляд). Под ней обнаружатся 3 отверстия для заливки чернил различных цветов. Заклеиваем два из них, а в третье закачиваем с помощью шприца новую краску. Затем заклеиваем следующие два, и так далее, пока все чернильницы не будут заполнены. После этого убираем все, что мы понаклеили, и возвращаем верхнюю крышку на место. Закрепить ее можно "Моментом" или даже простым скотчем. Теперь давайте разбираться с черными картриджами. В наиболее популярных моделях для устаревших принтеров НР начального уровня DeskJet 4хх/5хх (картридж модели 51626) и более современных DeskJet 6хх (модель 51629) разрежение создают специальные внутренние воздушные мешки, при повреждении которых чернила вытекут наружу и картридж придется выбросить. Заправка таких картриджей наиболее трудоемка. Сначала необходимо заклеить скотчем все вентиляционные отверстия как сверху, так и снизу картриджа. Затем в углу картриджа сверлим заправочное отверстие (кстати, на некоторых картриджах оно может уже присутствовать, в этом случае нужно только протолкнуть внутрь шарик, закрывающий его). Далее, с помощью шприца закачиваем чернила. После этого плотно заклеиваем заправочное отверстие скотчем (или, если вы пользуетесь заправочным комплектом, специальной пробкой). Именно здесь допускается наибольшее количество ошибок. Отверстие должно быть закрыто герметично, иначе возможна утечка чернил из картриджа, причем это может случиться не сразу, а тогда, когда он уже будет вставлен в принтер. После этого удаляем скотч с вентиляционных отверстий. Теперь осталось только закачать немного воздуха в технологическое отверстие, расположенное посередине верхней части картриджа. Здесь надо быть особо осторожным, так как при этом чернила будут выделяться из сопел головки. Закачку воздуха следует продолжать до тех пор, пока чернила не перестанут вытекать из отверстия для сброса избыточного давления, которое находится на дне картриджа (обычно хватает 2-3 кубиков воздуха). Гораздо проще производится заправка с помощью специального держателя картриджа, входящего во многие заправочные комплекты. В этом случае уже не нужно заклеивать вентиляционные отверстия - они будут закрыты держателем (все, кроме верхнего). Достаточно просто просверлить отверстие для заправки, затем заполнить картридж, а далее закачать немного воздуха в верхнее вентиляционное отверстие и заклеить заправочное. Все - можно вынимать готовый картридж. С черными картриджами старших моделей (51645 для HP DeskJet 7хх/8хх/9хх/11хх) все обстоит гораздо проще. Достаточно отделить пленку, закрывающую специальное отверстие около сопел, и протолкнуть внутрь шарик-пробку. Затем залить внутрь чернила и плотно заклеить отверстие скотчем. Теперь осталось только перевернуть картридж и подождать, пока не вытекут лишние чернила.

Заправка картриджей Canon

Картриджи для принтеров Canon в наибольшей степени подходят для любителей домашней заправки и заправляются довольно легко, причем количество перезаправок ограничивается лишь степенью износа поролонового наполнителя чернильницы. В последних моделях принтеров Canon используется печатная головка со съемными чернильницами (как у Epson), но, однако, сама головка легко снимается и ее замена не представляет никаких проблем. Это позволяет не бояться заправлять чернильницы (при неудачной заправке картридж просто выкидывается и покупается новый) и, в то же время, в случае повреждения печатной головки заменить ее будет стоить примерно столько же, сколько приобрести новый картридж для принтеров НР. Широко распространенные черные картриджи типа BC-20 заправляются через боковое вентиляционное отверстие. Для этого его нужно немножко расширить, ввести в него иглу и закачать чернила. Вот и все. Кстати, не забудьте, что заклеивать это отверстие нельзя - полная герметичность картриджам Canon не нужна. Немного сложнее заправляются картриджи типа BC-21. Для начала нужно заклеить скотчем выходные отверстия. Затем аккуратно удалить верхнюю крышку. Под ней находятся заправочные отверстия. По очереди закачивайте в каждое чернила, погружая иглу до середины картриджа (не до конца!). Только не перепутайте краски - заправочное отверстие каждого цвета находится ровно над выходным отверстием того же цвета. Теперь осталось только вернуть крышку на место, обмотав ее скотчем. Самое главное - случайно не заклеить вентиляционные отверстия. Кстати, есть еще один способ заправки картриджей этих типов. Внизу каждого картриджа есть специальная волокнистая мембрана. Достаточно медленно капать на нее чернила, которые будут впитываться. Правда, при таком способе заправки можно ввести в картридж слишком много чернил, и они будут выступать через вентиляционные отверстия. Картриджу это не повредит, но перепачкаться можно изрядно.

Заправка картриджей Lexmark

Картриджи для принтеров Lexmark конструктивно похожи на картриджи НР и имеют чернильницы, совмещенные с печатающими головками. Чернила в резервуаре удерживаются за счет губчатого заполнения его внутреннего объема. Процесс заправки картриджей Lexmark похож на процесс заправки картриджей Canon и точно так же безопасен для принтера - при неудаче картридж выкидывается и покупается новый. В процессе заправки, для начала, нужно немного расширить вентиляционное отверстие, затем ввести в него иглу шприца до середины и медленно закачать чернила. В цветных картриджах нужно аккуратно отделить верхнюю крышку и с помощью шприца ввести краску последовательно во все три отделения. Потом прикрепить крышку на место: и все.

Лазерные принтеры

Вероятно, главным достоинством лазерного принтера является высокое качество печати наряду с вполне приемлемой, для большинства нужд, производительностью. Что касается стоимости, то цены на младшие модели принтеров вплотную приблизились к отметке 200 долларов, что делает их вполне доступными для домашнего использования. Однако многие недорогие модели поступают в продажу с картриджами, имеющими уменьшенный, относительно стандартных, ресурс. Поэтому через определенное время, когда тонер закончится, владелец принтера встанет перед дилеммой: покупать новый картридж либо заправлять старый. Естественно, первый вариант самый простой и очевидный, однако цена нового картриджа колеблется для разных моделей от 50 до 100 долларов, и далеко не каждый может позволить себе купить его именно в тот момент, когда он закончился. А желающим сэкономить придется осваивать непростую науку самостоятельной заправки картриджей. В этом случае придется раскошелиться лишь только на тубу с тонером. Однако трудозатраты при этом будут значительно выше, чем в случае заправки картриджей для струйных принтеров, да и риск повредить сложное и хрупкое устройство, каким является лазерный картридж, достаточно велик. Основные различия в конструкции картриджей для лазерных принтеров различных производителей заключаются в том, входит ли селеновый фотобарабан в комплект самого картриджа (к таким моделям относятся все принтеры Hewlett Packard - производителя, чья продукция наиболее распространена в России) или же находится в отдельном специальном "драм-картридже". Во втором случае заправка картриджа тонером обычно не вызывает особых проблем, а вот в первом: Если вы все-таки решитесь самостоятельно заправить такой картридж, то сделать это можно двумя способами. Первый из них, классический, подразумевает полную разборку картриджа, извлечение селенового фотобарабана и засыпку тонера в бункер. Однако полная разборка картриджа требует изрядных слесарных навыков, кроме того, существует определенная вероятность повреждения поверхности или засветки фотобарабана, что неминуемо приведет или к существенному ухудшению качества печати, или, иногда, к потере работоспособности картриджа, а в самых "клинических" случаях - и к выходу из строя самого принтера. Однако существует и другой, более простой способ засыпать тонер в картридж, исключающий возможность повреждения внутренних элементов. Для его реализации необходимо аккуратно проделать отверстие в бункере тонера, и через него засыпать свежий тонер, используя воронку. После чего отверстие нужно заклеить скотчем. Отверстие можно проделать самыми различными способами, например: 1. Прожечь паяльником; 2. Аккуратно вырезать острым скальпелем; 3. Просверлить сверлом диаметром 8 - 10 мм. Если будут использоваться способы 2 или 3, то нужно будет не забыть вытрясти из бункера стружки вместе с остатками старого тонера. В любом случае не стоит внедряться в корпус слишком глубоко, дабы не повредить находящиеся внутри элементы конструкции (отверстие необходимо делать на максимальном удалении от магнитного вала). Как недостаток такого метода заправки картриджа можно отметить невозможность очистки фотобарабана и опорожнение бункера-отстойника, поэтому количество заправок таким способом не должно быть больше 2-3 подряд.

И что у нас в осадке?

Как видите, заправить картридж для принтера, особенно для струйного, совсем не так сложно, как может показаться на первый взгляд. Главное - не спешить и соблюдать элементарные правила безопасности. Никому не надо особо объяснять, что тонер для лазерных принтеров очень мелкий и, поэтому летучий, а чернила для струйного принтера отмываются с бо-о-ольшим трудом. Поэтому весь процесс заправки лучше всего проводить не жилом помещении, а, например, в ванной. Среди всех рассмотренных производителей струйных принтеров традиционно лояльным отношением к заправке отличаются принтеры Canon и таким же традиционно негативным - модели Epson, особенно самые последние, оснащенные "интеллектуальными" картриджами. Принтеры Hewlett Packard и Lexmark занимают в таком "ранжире" среднее положение, причем, если картриджи Lexmark проще заправлять, то изделия Hewlett Packard, независимо от типа принтера - лазерного или струйного, отличаются исчерпывающим ассортиментом любых аксессуаров для них, в том числе и самым широким выбором чернил (или тонера) для заправки. И напоследок хочу предупредить, что не каждая заправка может быть удачной: в среднем, картриджа хватает на 3-5 перезаправок, но иногда он может "погибнуть" и после первой. Однако не стоит огорчаться - кто не рискует, у того не остается денег на шампанское! На картридж то уже не хватает.


Что такое реестр

Инсталляция.

1.Как поставить XP?
Есть несколько способов. Во-первых, если ваш CD с дистрибутивом похож на тот, что выпускается Microsoft, то он должен быть бутовым (загрузочным). Чтобы загрузиться с него надо в BIOS-e параметр "Boot sequence" установить равным CD-ROM, вставить CD и перезагрузиться. После старта компьютера запустится программа установки. Дальше - просто следовать инструкциям.
Это единственный метод загрузиться прямо в программу-установщик, имея только CD. Microsoft считает, что CD-ROM - это неотемлемая и абсолютно необходимая деталь для компьютера, на который устанавливается XP, поэтому средств для реализации старого доброго способа загрузки с дискеток в состав дистрибутива больше не входит.

Во-вторых, можно загрузиться с DOS-овской системной дискеты с драйвером CD-ROM и запустить программу "winnt.exe" в директории i386 на диске с дистрибутивом.

Примечание: если ваш винчестер подключен к внешнему контроллеру (SCSI или IDE), то не забудьте скачать новый XP (или W2k) драйвер для него и скинуть его на дискету. Он понадобится, если программа инсталляции не сможет правильно определить и установить устройство. В этом случае необходимо нажать на F6, когда будет производиться поиск таких устройств.

И, наконец, можно из под W9x, NT4 или W2k запустить программу "setup.exe" из корневого каталога СD диска, или winnt32.exe из директории i386, и апгрейдить систему на XP. Делается это корректно, и перед перезагрузкой система выдаёт список программ и драйверов, несовместимых с XP.
Однако, последний способ не является самым оптимальным. Несмотря на то, что XP пытается самостоятельно определить список программ и драйверов, которые не будут работать с ней корректно, она не в состоянии сделать это правильно во всех случаях. Поэтому, во избежание проблем с совместимостью, мы бы рекомендовали вам ставить систему заново.
Есть ещё более радикальный метод решения проблем с совместимостью. При инсталляции поверх существующей ОС, у вас будет возможность выбора ОС (Dual boot).
Примечание: после установки XP как отдельной ОС будет невозможна нормальная работа Outlook Express и Internet Explorer в Windows 9x, т.к. XP заменит последние. Это верно только в случае установки обеих ОС на один и тот же раздел диска. Но эту проблему можно решить путём копирования некоторых DLL из WinXP\System32 в Windows\System. Для определения нужных библиотек можно воспользоваться программой ShowDep (www.showdep.com) или аналогичные сведения показывает Outlook Express в окне "О программе".
Кроме этого, многие программы придётся устанавливать по два раза, отдельно для XP и для W9x. Иногда можно в один и тот же каталог, например Office 2000 уже при установке способен понять, что он уже установлен, и в итоге устанавливает всего около 18 мегабайт.

2. Как выбрать нужную версию ядра и HAL ещё при инсталляции?
В самом начале текстового этапа установки XP при появлении сообщения "Setup is inspecting your computer's hardware configuration" нажмите и удерживайте клавишу "F5". В появившемся на экране списке версий библиотек HAL выберите версию, соответствующую вашему компьютеру, или выберите позицию "Other" для того, чтобы указать файл библиотеки от производителя оборудования. Затем продолжите установку Windows. В поставку XP включены следующие версии библиотеки HAL:

  • ACPI Multiprocessor PC - для ACPI-систем с несколькими процессорами.
  • ACPI Uniprocessor PC - используется для ACPI-систем с многопроцессорной системной платой и одним установленным процессором.
  • Advanced Configuration and Power Interface (ACPI) PC - используется для однопроцессорных ACPI-систем.
  • MPS Uniprocessor PC - для систем без поддержки ACPI, с многопроцессорной системной платой и одним установленным процессором.
  • MPS Multiprocessor PC - для многопроцессорных систем без поддержки.
  • ACPI Compaq SystemPro Multiprocessor or 100% compatible - для компьютеров Compaq SystemPro или полностью совместимых с ними.
  • Standard PC - используется для любого стандартного компьютера, не многопроцессорного и без поддержки ACPI.
  • Standart PC with C-Step i486 - используется для компьютеров с поддержкой этой технологии.

3. При инсталляции система не даёт выбрать компоненты, да и после инсталляции в Add/Remove programs – Windows Components почти ничего нет.
Во время установки ничего выбрать вам, к сожалению, не удастся. Но, после инсталляции, в Windows/inf найдите файлик sysoc.inf и удалите в нём слово hide или HIDE везде, где найдёте. В Add/Remove Windows components появятся новые пункты. К сожалению, всё из появившихся пунктов удалять нельзя, но кое-что всё-таки можно.

4. Стоит ли переходить с FAT32 на NTFS? Что такое NTFS
Всё зависит от того, с какой целью вы используете компьютер, и сколько у вас оперативной памяти. Следует учесть, что NTFS работает несколько медленнее чем FAT, из-за дополнительно загружаемых сервисов и её системы безопасности. Если у вас мало оперативной памяти, и вы решили поставить себе XP, то вам однозначно нельзя ставить себе NTFS. Если у вас 128MB или больше, то можно уже подумать об NTFS. Следует взвесить преимущества и недостатки NTFS для простого пользователя и решить, что вам нужно. К преимуществам FAT32 можно отнести то, что она быстрее и требует меньше памяти для работы. Если система работает только с FAT32, то в память не грузятся драйвера и сервисы, необходимые NTFS. Кроме этого, при использовании FAT32 имеется возможность доступа к диску при загрузке с загрузочного флоппи W9x. Преимущества NTFS для простого пользователя можно описать одним ёмким словом: indestructible. На полном серьёзе, вышибить NTFS чрезвычайно сложно, хоть и возможно. Для опыта запускалась куча различных приложений, оптимизаторы диска, и в самые неподходящие моменты жалась кнопка reset. Повторение этого садизма добрый десяток раз никакого впечатления на систему не произвело, она продолжала работать без ошибок. Кроме этого, NTFS обладает встроенными средствами шифрования файлов, что обеспечивает определённую уверенность в сохранности данных. Конечно, при условии что система не будет переустанавливаться.

5. Что такое NTFS, и как она работает?
NTFS выросла из файловой системы HPFS, разрабатываемой совместно IBM и Microsoft для проекта OS/2. Она начала использоваться вместе с Windows NT 3.1 в 1993 году. Windows NT 3.1 должна была составить конкуренцию серверам на базе NetWare и Unix, поэтому NTFS вобрала в себя все тогдашние технологические достижения. Вот основные из них:

1. Работа с большими дисками. NTFS имеет размер кластера 512 байт, что в принципе оптимально, но его можно менять до 64К. Более важно то, что NTFS способна теоретически работать с томами размером в 16,777,216 терабайт. Теоретически, потому что таких жестких дисков пока просто не существует, и появятся они весьма не скоро.

2. Устойчивость. NTFS содержит две копии аналога FAT, которые называются MFT (Master File Table). В отличие от FAT MSDOS, MFT больше напоминает таблицу базы данных. Если оригинал MFT повреждён в случае аппаратной ошибки (например, появления bad-сектора), то система при следующей загрузке использует копию MFT, и автоматически создаёт новый оригинал, уже с учётом повреждений. Но это не самое главное. Главное, что NTFS использует систему транзакций при записи файлов на диск. Эта система пришла из СУБД, где защита целостности данных - жизненно важное дело. Уже это говорит о её эффективности. В упрощённом виде она работает так:

  • Драйвер ввода/вывода NTFS инициирует процесс записи, одновременно сообщая сервису Log File Service вести лог всего происходящего.

  • Данные пишутся в кэш, под управлением сервиса Cache Manager.

  • Cache Manager посылает данные Virtual Memory Manager-у (менеджеру виртуальной памяти), для записи на диск в фоновом режиме.

  • Virtual Memory Manager посылает данные драйверу диска, пропустив их через Fault Tolerant Driver (если у вас массив дисков RAID).

  • Драйвер диска шлёт их контроллеру, который уже пишет их либо в кэш, либо прямо на диск.

  • Если эта операция проходит без ошибок, запись лога удаляется.

  • Если происходит сбой, запись лога остается в таблице транзакций, и при следующем доступе к диску Log File Service обнаруживает эту запись, и просто восстанавливает всё как было до этой операции.

Такая система гарантирует абсолютную сохранность данных в случае копирования, перемещения и удаления файлов или директорий. При внесении изменений в файл, вы теряете те изменения, которые находились в момент сбоя в памяти или в кэше контроллера, и не успели записаться на диск.

3. Защищенность. NTFS рассматривает файлы, как объекты. Каждый файловый объект обладает свойствами, такими как его имя, дата создания, дата последнего обновления, архивный статус, и дескриптор безопасности. Файловый объект также содержит набор методов, которые позволяют с ним работать, такие как open, close, read и write. Пользователи, включая сетевых, для обращения к файлу вызывают эти методы, а Security Reference Monitor определяет, имеет ли пользователь необходимые права для вызова какого-либо из этих методов. Кроме этого, файлы можно шифровать. Правда, с шифрованием стоит быть осторожнее. Если у вас рухнет система, или вы её переустановите то вы не сможете прочитать зашифрованные файлы, если не имеете ERD.

4. Компрессия данных. NTFS позволяет компрессировать отдельные каталоги и файлы, в отличие от DriveSpace, который позволял сжимать только диски целиком. Это очень удобно, для экономии пространства на диске, например можно сжимать "на лету" большие графические файлы формата BMP, или текстовые файлы, причём для пользователя всё это будет прозрачно.

5. Поддержка формата ISO Unicode. Формат Unicode использует 16bit для кодировки каждого символа, в отличие от ASCII, который использовал 8bit, или ещё хуже - 7bit. Для простого пользователя это означает то, что теперь он может называть файлы на любом языке, хоть на китайском - система это будет поддерживать, не требуя изменить кодовую страницу, как это делал DOS и W9x.

6. Что нового в файловой системе NTFS5, и в чем её отличия от NTFS4?
Самое главное, за что ругали NT4, и в чём она уступала NetWare, это за отсутствие квотирования. Квотирование - это ограничение максимального объёма дискового пространства для пользователя, которое он сможет использовать. Зачем это нужно? Ну, на компьютерах, работающих в больших сетях, в фирмах и организациях и без вопросов понятно зачем, ведь жесткие диски не резиновые. А на домашнем компьютере, можно например, выделить пользователю "жена" или "младший брат" не более 50МБ на винчестере, чтобы они не захламляли диск чем попало. Причём, вовсе не обязательно, чтобы все файлы пользователя хранились в одном месте, они могут быть разбросаны по всем дискам. Устанавливаются квоты через Properties NTFS раздела, закладка Quota. Через Quota Entries... можно выставлять квоты для каждого отдельного пользователя. Второе, достаточно важное отличие NTFS5 от старой версии - возможность поиска файла, по имени его владельца. Зачем это нужно? А вот зачем: например, вам нужно найти все файлы созданные в Word-е, каким-то одним пользователем, на диске, где этих файлов тысячи. В NT4 это было проблемой. С помощью Access Control List (Список управления доступом), можно легко проверить, какие файлы доступны пользователю, и установить права доступа к отдельным файлам или каталогам. Кроме непосредственного изменения самой структуры NTFS, в XP добавлен Microsoft Index Server, который значительно ускоряет поиск файлов, особенно по их содержимому, за счёт индексации содержимого дисков. Управляется эта служба через раздел Indexing Service окна Computer Management. В этом разделе можно просмотреть, какие директории индексируются, и, при желании, добавить новые или удалить старые. Работает это c любыми разделами, а не только NTFS. В NTFS5 добавлена такая функция как точки монтирования или, по-другому, точки соединения (junction point). Функция эта давно знакома пользователям различных вариантов Unix/Linux, но в продуктах Microsoft она появилась впервые недавно (только с W2k). С помощью этой технологии можно присоединить любой дисковый ресурс в любое место файловой системы. Например, можно присоединить жёсткий диск D:\ в любой из каталогов на диске C:\, например, в C:\games Теперь, зайдя в директорию C:\games, можно будет видеть содержимое корневого каталога диска D:\. Все изменения, которые будут произведены в этой директории, будут произведены на диске D:\. После этого, можно в окне Computer management -> Disk Management убрать букву, присвоенную этому диску (Change disk letter and path), и пользователь даже не будет знать, что на компьютере установлено два диска! Он будет работать с одним диском C:\ и директория C:\games для него ничем не будет отличаться от других. Смонтировать диск или раздел в директорию на NTFS разделе или диске, можно из уже знакомого нам меню Change disk letter and path, выбором пункта Add.. -> Mount in this Ntfs folder -> Browse... Управлять этой функцией можно и через командную строку, командой mountvol. Сразу после примонтирования диска, директория в которую он смонтировался, будет показываться другим значком: Но стоит переименовать её, как она примет такой же вид, как и все остальные.

Что бы размонтировать диск, используйте Disk Management, меню Change disk letter and path, выбором пункта Remove. Если просто удалите папку с примонтированым диском в Explorer'е, то вместе с папкой вы удалите ВСЁ содержимое примонтированого диска. Так что будьте внимательны. Кроме монтирования целых дисков, можно монтировать отдельные директории, но для этого придётся воспользоваться сторонней утилиткой. Взять её можно здесь. Зайдите в консоль, запустите её, и ознакомитесь с её операндами.

7. Что такое кластер, и какого размера он должен быть?
Кластер - минимальный размер места на диске, которое может быть выделено файловой системой для хранения одного файла. Определяется он, как правило, автоматически, при форматировании винчестера, по зависимости указанной в таблице:

Размер раздела | Секторов в кластере | Размер кластера
< 512mб | 1 | 512 байт
< 1024mб | 2 | 1K
< 2048mб | 4 | 2K
< 4096mб | 8 | 4K
< 8192mб | 16 | 8K
< 16384mб | 32 | 16K
< 32768mб | 64 | 32K
> 32768 MБ | 128 | 64K

Небольшое исключение для системного раздела: если он меньше 2048МБ, то размер кластера, при использовании NTFS, всегда 512 байт.
Кроме этого, при конвертации Fat32 раздела в NTFS встроенной в XP утилиткой convert, размер кластера всегда будет 512 байт. Что бы избежать, придётся воспользоваться внешними программами, например Partition Magic.

Узнать размер кластера в XP можно несколькими способами. Во первых, можно зайти в Administrative Tools -> Computer Management -> Storage -> Disk Defragmenter. Выбрать нужный диск и нажать на Analyze. Через несколько секунд появится табличка, где есть три кнопки. Нажатие на View Report запускает окошко, в котором море информации про выбранный диск, в том числе и Cluster size.
Есть ещё один метод, который подходит не только для XP. Создаётся, или берётся готовый, маленький файлик размером от 1 байта до 500 байт. Нажимается на нём правая кнопка мыши, выбирается Properties. Смотрим на два пункта, Size и Size on disk. Size должен быть чем-то вроде 10 байт (или какой там размер он реально имеет), а Size on disk будет, к примеру, 4096 байт, что соответствует размеру кластера, т.е. 4K.
Размер кластера можно выбрать и самому, вручную, правда, только при форматировании. Делается это так: "format d: /A:size", где size это размер кластера в байтах. Однако существуют некоторые правила, которых следует придерживаться: во-первых, размер кластера должен быть кратен размеру физического сектора, то есть 512 байтам в подавляющем большинстве случаев; во-вторых, есть ограничения по количеству кластеров на разделе.
Кроме всего вышеперечисленного следует учитывать, что при размере кластера выше 4 килобайт на NTFS разделе не будут работать функции сжатия, встроенные в файловую систему.

8. Как уменьшить занимаемый объем пpоинсталлиpованной XP?
Можно удалить директории:

* %SystemRoot%\Driver Cache\i386\ Это можно сделать в том случае, если всё оборудование уже стоит и работает. При добавлении нового оборудования система будет запрашивать дистрибутив.

* %SystemRoot%\system32\dllcache\ Это кэш защищенных системных файлов, используемый для их автоматического восстановления в случае повреждения. Размер по умолчанию этой папки 400 Мб, и определяется он параметром SFCQuota (0xFFFFFFFF) в ключе реестра HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ Winlogon Изменить размер кэша системных файлов можно помощью команды sfc: sfc /cachesize=0 (можно ввести другое значение, например, 3 Мб), а потом вручную удалить все файлы в указанной директории. Если не задать /cachesize=0, то при следующей проверке защищенных системных файлов система снова наполнит свой кэш до заданного объема.

* Выключить System Restore. Сделать это можно здесь: System Properties -> System Restore -> Turn off System Restore for all drives. Этим вы сотрёте всю информацию, которая записана System Restore, и хранится в папке System Volume Informatiоn.

* Отключить Hibernate. Так называется технология, которая позволяет быстро выключать и включать компьютер. Основана она на сохранении содержимого оперативной памяти в виде файла на жёстком диске. Поэтому при её использовании в корне системного диска всегда присутствует файл под названием hiberfil.sys объёмом равным оперативной памяти. Стирать его вручную бесполезно, во первых сделать это можно только под другой ОС, во вторых при загрузке он будет создан заново, даже если компьютер не уходил в хибернейт. Сделано это для того, чтобы не было ситуации, когда машина не может уйти в хибернейт только из за того, что на диске не хватает места для этого. Для того чтобы убрать этот файл навсегда, требуется отключить хибернейт, что можно сделать в Control Panel – Power Options, закладка Hibernate, снять галочку с чекбокса Enable Hibernate.
* Уменьшить размер Swap файла. По умолчанию XP создаёт файл подкачки размером в полтора раза больше чем объём оперативной памяти. С современными объёмами RAM, которые даже в домашних машинах могут доходить до гигабайта, и файл подкачки того размера, что XP выставит для такой машину по умолчанию, большинству пользователей не нужен. Поменять размер файла подкачки можно через System Properties – закладка Advanced, кнопка Settings раздела Performance. В открывшемся окне переходим на закладку Advanced и нажимаем на кнопку Change раздела Virtual Memory.

В открывшемся окне выбираем диск или раздел, на котором требуется изменить размер файла подкачки, вводим нужные значения, и нажимаем на кнопку Set. Остаётся только перезагрузиться.

9. Можно ли отконвеpтировать диск FAT32 в NTFS без потеpи данных?
1. Можно воспользоваться командой CONVERT том: /FS:NTFS [/V] Преобразование произойдет при следующей перезагрузке. Потери информации не при этом не будет, но нужно иметь в виду, что размер кластера после конвертации составит 512 байт, что не очень хорошо на больших разделах, кроме того, диск после конвертации будет сильно фрагментирован. Обратное преобразование (NTFS -> FAT) без потери данных средствами XP невозможно, потребуется отформатировать раздел заново.
2. Выполнить конвертацию также сможет программа Partition Magic. C NTFS 5 нормально работает, начиная с версии 6.0, но если использовать только загрузочную дискету, то подойдет и версия 5.01. Данная программа также позволяет выполнять обратное преобразование без потери данных и даже может менять размер кластера (к сожалению, только на FAT16 и FAT32). Partition Magic не работает с динамическими дисками, только с основными.

Если кого-то не устраивает, что Windows XP занимает слишком много места и восстанавливает удалённые из его директории файлы, то может удалить папку dllcache, но после следующей проверки системных файлов Windows снова заполнит эту папку. Для устранения этого "греха", после удаления или до удаления файлов (но не папки), нужно запустить команду sfc /cachesize=число. Числом будет количество мегабайт которое должно резервироваться для папки windows\system32\dllcache. Можно поставить = 0.

10.Генератор номеров для продуктов Microsoft

Предупреждение: Вся нижеизложенная информация может быть использована только для ознакомления, автор не несет никакой ответственности за возможные негативные последствия.

Генератор ключей CD-Key от BlueList XP KeY ReCoVeRER AND DiSCOVErER 5.12 OeM EdiTion генерирует ключи для установки.

Рекомендую установить число попыток поиска> 40 (лучше 100) в режиме Find Key

max ключей > 2

и записать ключи в log-файл

1) Выбирать надо "WIN XP REAL OEM" а не WIN "XP PRO OEM"!!! Программа генерирует ключи CD-Key, с которыми WINDOWS XP OEM устанавливается и активируется.

2) Поставить с одним из этих ключей Windows XP PRO OEM.

3) Активировать ее до (!) установки SP1.

4)Активируем и храним файл \windows\system32\wpa.dbl – именно в нем и находится код активации. При последующей переустановке Windows Xp этот файл копируется на своё место – и…активация выполнена.

Скачать Key-generator


Скрипты

HTTP://WEBSCRIPT.RU - Разнообразие различных скриптов [Каталог скриптов, статей и т.д.]

Графика

HTTP://PHOTOSHOP.RU - Все о Photoshop [Макросы, эффекты и примочки для Photoshop'a]

NONAGS

www.nonags.com/nonags - это огромная коллекция бесплатных программ, проверенных на вирусы, тестированных на баги и классифицированных по рейтингу.

WebAttack.com
 http://www.webattack.com/ -Великолепно организованный сайт, на котором представлена богатейшая коллекция бесплатных и платных программ.

Wotias

http://wotias.newmail.ru/ -Коллекция бесплатных программ

Софтодром"
http://www.softodrom.ru/ -Один из лучших российских сайтов: линки на разнообразный софт, сопровождаемые краткими описаниями.

Softbox.ru
http://softbox.ru/ - Линки на разнообразный софт, сопровождаемые краткими описаниями

Soft Variant
http://www.softvariant.ru -Новый российский сайт: линки на разнообразный софт, коллекция бесплатных и платных программ, сопровождается краткими описаниями.


Востановление реестра

Манипулирование реестром Windows XP. Общие вопросы

Как мы уже знаем, в операционной системе Windows XP сведения о конфигурации системы централизованно размещены в реестре. Это упрощает администрирование компьютера или сети, но, вместе с тем, одно неправильное изменение в реестре может вывести операционную систему из строя. Приведенный ниже список содержит советы и рекомендации по аккуратному использованию реестра и редактора реестра.
— Перед внесением изменений в реестр делайте резервную копию. Этот вопрос мы и рассмотрим прежде всего.
— Не заменяйте реестр Windows XP реестром другой версии операционных систем Windows или Windows NT.
— Не оставляйте редактор реестра работающим без присмотра.
— Для редактирования реестра используйте редактор реестра или другие программы, которые обеспечивают безопасные методы работы с реестром.

Кроме того, вы можете ограничить доступ к реестру различным пользователям. Для этого в левом окне Regedit'а кликните правой кнопкой мыши на выбранном разделе реестра и выберите пункт "Разрешения".

Для некоторых операций с реестром нам пригодится Recovery Console. Загрузиться в нее можно с CD-ROM, на котором находится Windows XP, нажимая клавишу R, но для удобства использования можно установить ее и на жесткий диск.

Для этого вставьте установочный CD-ROM с Windows XP и выполните команду:
[буква CD-ROM]:\i386\winnt32.exe /cmdcons
и далее следуйте инструкциям.

После установки консоль восстановления появится в виде варианта загрузки. Причем все ее содержимое находится в отдельной скрытой папке Cmdcons в корне загрузочного диска с Windows XP. Объем папки около 8 Мб, и изменение настроек Windows XP не повлияет на консоль восстановления.

Еще один важный для нас вопрос: как в Recovery Console получить доступ в папки, отличные от \WINDOWS? Возможно, нам это понадобится, поэтому позаботьтесь об этом заранее. Под аккаунтом администратора заходим в "Панель управления — Администрирование". Далее запускаем аплет "Локальная политика безопасности — Локальные политики — Параметры безопасности", опцию "Консоль восстановления: Разрешить копирование дискет и доступ ко всем папкам" устанавливаем во "Включен". После этого, когда вы будете находиться в режиме Recovery Console, нужно дать команду SET AllowAllPaths = TRUE.

Если вам что-то не понравится или нужно будет освободить место на жестком диске около 8 Мб, то удалить консоль восстановления не составит особого труда:
— Удалите из корня диска скрытую папку \Cmdcons.
— Удалите из корня диска скрытый файл Cmldr.
— Откройте файл Boot.ini и удалите строку, похожую на эту:
C:\cmdcons\bootsect.dat="Microsoft Windows Recovery Console" /cmdcons

Все! Теоретическая часть закончена. Осталось разучить несколько интересных операций, и мы подойдем к самому главному.

Резервное копирование реестра в Windows XP и его последующее восстановление

Резервное копирование реестра

"Ничто так не радует, как горе ближнего". Если бы я следовал этой злословице, то ни за что не написал бы этот раздел. Информация, приводимая здесь, — наискучнейшая, но необходимая.

Способ 1

Примечание. Не используйте этот способ для экспорта всего реестра или его основных разделов (ульев, hive), таких как HKEY_CURRENT_USER и т.п.

Прежде, чем начать редактирование реестра вручную с помощью REGEDIT, или REG-файла, не помешает сохранить ту часть реестра — раздел или подраздел, — которую вы будете изменять. Для этого:
— Запустите REGEDIT. можно "Пуск-Выполнить-REGEDIT".
— Найдите ветвь реестра, содержащую ключ, значение которого вы будете редактировать, и кликните на ней в левой части окна REGEDIT.
— В главном меню выберите "Файл-Экспорт" и укажите имя файла. Либо кликните правой кнопкой и укажите "Экспортировать".

Альтернативный вышеприведенному способ состоит в том, что можно выполнить команду или командный файл определенного содержания. Например, сохраним настройки популярной программы

The Bat!:
regedit /e thebat1.reg HKEY_CURRENT_USER\Soft-ware\RIT
regedit /e thebat2.reg HKEY_LOCAL_MACHINE\Software\RIT

Вся необходимая информация будет помещена в файлы THEBAT1.REG и THEBAT2.REG

Способ 2

Для резервного копирования всего реестра используйте программу архивации данных "Программы-Стандартные-Служебные-Архивация данных" или просто %SystemRoot%\system32\ntbackup.exe

Программа архивации позволяет архивировать и восстанавливать так называемые данные состояния системы, что включает в себя следующие системные компоненты:
— реестр;
— базу данных регистрации классов COM+;
— загрузочные файлы: Ntldr и Ntdetect.com;
— системные файлы.

Пошаговые инструкции для архивации реестра Windows XP такие:
— Войдите в систему с необходимыми правами, например, как администратор.
— Запустите NTbackup ("Архивация данных").
— Если NTbackup запустилась в режиме мастера, перейдите в "Расширенный режим".
— Выберите закладку "Архивация".
— В левом окне найдите и пометьте "птичкой" строку "System State".
— Нажмите кнопку "Архивировать" и выберите "Дополнительно".
— Снимите "галочку" с пункта "Автоматически архивировать защищенные системные файлы вместе с состоянием системы". Таким образом мы заархивируем только файлы реестра, что произойдет быстро и займет немного места на диске, примерно 17-20 Мб.
— На этой же вкладке "Тип архива" установите "Обычный".
— "ОК" и нажмите "Архивировать". После архивации вы сможете просмотреть отчет.
— Отчеты об архивации накапливаются в папке x:\Documents and Settings\%User%\Local Settings\Ap-plication Data\Microsoft\Windows NT\NTBackup\data\ в пронумерованных файлах backup01.log, back up02.log и т.д.

NTbackup можно использовать и из командной строки, но мы не будем рассматривать этот способ, так как восстановить данные с командной строки нам не удастся и, кроме того, при архивации вместе с реестром будут заархивированы и все системные файлы, необходимые для загрузки Windows XP. А это потребует более долгого времени и займет заметно больше места на жестком диске.

Способ 3

Полностью системный реестр можно заархивировать и вручную с помощью консоли восстановления (Recovery Console). Для этого:
— Загружаемся в Recovery Console.
— В командной строке Recovery Console выполняем следующие команды:
md tmp
copy c:\windows\system32\config\system c:\windows\tmp\system.bak
copy c:\windows\system32\config\software c:\windows\tmp\software.bak
copy c:\windows\system32\config\sam c:\windows\tmp\sam.bak
copy c:\windows\system32\config\security c:\windows\tmp\security.bak
copy c:\windows\system32\config\default c:\windows\tmp\default.bak

Обратите внимание: вам придется скопировать сразу все пять файлов системного реестра.

Чтобы сэкономить время, вы можете оформить все вышеприведенные команды в отдельный файл, например, arcregistry.txt, предварительно подготовив его, и выполнить одной командой:
batch arcregistry.txt

Примечания

Примечание 1. В общем случае не рекомендуется перемещать сохраненные файлы реестра за пределы папки C:\Windows, так как в Recovery Console они могут быть недоступны даже если вы — администратор. Это верно, если не предпринять особых мер, описанных выше в разделе "Общие вопросы".

Примечание 2. Я бы рекомендовал вышеописанные способы №2 и №3 только если вы ожидаете полного краха системы. Обычно всегда удается загрузить последнюю удачную конфигурацию.

Примечание 3. Какой из способов: №2 или №3 — выбрать? Способ №2 проще в том смысле, что не требует перезагрузки в режиме Recovery Console для сохранения файлов реестра, но гораздо сложнее для восстановления, если самое большое горе все-таки случится — ваша любимая Windows XP перестанет загружаться. Способ №3 самый простой в плане восстановления, но для его выполнения требуется перезагрузка (еще до того момента, как вы начнете курочить реестр) в режим Recovery Console. А можно выбрать и оба способа.

Восстановление реестра

В данном разделе мы практически повторим предыдущий, но с точки зрения восстановления реестра, а не архивации. Итак,

Способ 1

При архивации части реестра мы с помощью REGEDIT экспортировали данные в REG-файл. Теперь, чтобы извлечь их и восстановить исходный вид части реестра, выполним следующие шаги:
— Запустите REGEDIT. "Пуск-Выполнить-REGEDIT".
— В главном меню выберите "Файл-Импорт" и укажите имя файла.

Или можно выполнить команду или командный файл определенного содержания. Например, восстановим настройки программы The Bat!:
regedit -s thebat1.reg
regedit -s thebat2.reg

Вся необходимая информация будет взята из файлов THEBAT1.REG и THEBAT2.REG.

Способ 2

Пошаговые инструкции для полного восстановления реестра Windows XP:
— Войдите в систему с необходимыми правами, например, как администратор.
— Запустите NTbackup.
— Если NTbackup запустилась в режиме мастера, нажмите кнопку "Расширенный" в окне мастера архивации.
— Перейдите на вкладку "Восстановление и управление носителем".
— Установите в списке "Установите флажки для всех объектов, которые вы хотите восстановить" флажок для объекта "Состояние системы". Это позволит восстановить данные состояния системы

Обратите внимание: вам придется скопировать сразу все пять файлов системного реестра.

Чтобы сэкономить время, вы можете оформить все вышеприведенные команды в отдельный файл, например, arcregistry.txt, предварительно подготовив его, и выполнить одной командой:
batch arcregistry.txt


Удаление Мессенгер

Удаляем Windows Messenger:

Данная опция относится только к встроенному Windows Messenger, если вы ставили более новую версию, то для ее удаления используйте "Установку и удаление программ" в Панели управления. Каждый раз при загрузке системы Messenger тоже стартует, замедляет процесс запуска, пожирает системные ресурсы. При открытии Outlook запускает встроенную версию Windows Messenger, даже если установлена более новая версия, используйте данную опцию чтобы удалить встроенный Windows Messenger из системы.

Если опция включена, измените следующие параметры в реестре:

HKLM\SOFTWARE\Policies\Microsoft\Messenger\Client

DWORD PreventAutoRun, значение 1 - запрет автоматического запуска
DWORD PreventAutoUpdate, значение 1 - запрет обновлений
DWORD PreventBackgroundDownload, значение 1 - запрет загрузки файлов
DWORD PreventRun, значение 1 - запрет запуска

Данные значения никак не влияют на удаление, а само удаление происходит так:

Меню/Пуск/Выполнить напечатать следующее: "RunDll32 advpack.dll,LaunchINFSection %windir%\INF\msmsgs.inf,BLC.Remove" и нажать "OK".

После этой операции вам будет предложено перезагрузиться. После перезагрузки вы Messenger у себя на компьютере не найдете.

Данные изменения вступят после перезагрузки


Оптимальный компьютер

Автор: Creator

Вступление
 У меня наконец-то появилось свободное время, и я решил высказать свои соображения по поводу выбора оптимального компьютера. Именно оптимального, а не идеального. Проблема выбора сбалансированной ЭВМ стояла и стоит перед пользователями при покупке новой машины или апгрейде старой. Данная статья в первую очередь ориентирована на людей любознательных и умеющих учиться на чужих ошибках, чтобы не делать своих. Если вы хотите купить свой первый компьютер или модернизировать старый, данный материал для вас. Единственное но: я даю советы, как собрать сбалансированный компьютер под конкретную задачу, а не привожу список лучших моделей "железок" — тут вам придется почитать обзоры знающих людей.

ПК. Полезные советы
Обобщая свой опыт, я решил дать читателю несколько советов по выбору комплектующих персонального компьютера . Вот они:

• Собирая машину, подумайте, какие задачи она будет выполнять. Исходя из этих данных, выбирайте комплектующие. Советую, однако, немного приподнять планку их характеристик: возможно, в будущем задачи машины расширятся, да и небольшой запас по мощности никогда не помешает.

• Учитывайте ваши финансовые возможности. Отдать все деньги за самый "навороченный" компьютер, особенно если он у вас первый, — не дело. Лучше потренироваться на более дешевой конфигурации, а потом сделать апгрейд. Следующий совет объясняет это правило.

• Есть одна очень важная тенденция в компьютерной индустрии — определенный набор комплектующих очень быстро дешевеет, порой в 2 раза за полгода. К таким "железкам" относятся микропроцессоры, видеоадаптеры. В то же время такие вещи, как дисплей, корпус, акустическая система, могут упасть в цене совсем незначительно. Поэтому, если в данный момент вы не собираетесь использовать какую-то возможность вашей машины на всю катушку, обойдитесь более дешевым аналогом или по возможности вообще не покупайте данную деталь: когда она вам действительно понадобится, ее цена окажется гораздо меньше изначальной.

• При покупке комплектующих свой выбор нужно отдать изделиям известных брэндов и фирм среднего звена. Как правило, они обладают хорошими техническими характеристиками и отменным качеством, причем у не очень "раскрученных" фирм и цена при этом более чем приемлема. Продукцию неизвестного производителя лучше не брать, так как у нее есть одна бо-о-ольшущая проблема — качество, а точнее, его отсутствие. Хотя, конечно, есть редкие исключения, которые, впрочем, лишь подчеркивают правило.

• Все оборудование я советую покупать в хорошо зарекомендовавших себя фирмах поблизости от вашего места жительства. Так вы избавитесь от головной боли по поводу замены детали по гарантии — не придется никуда ехать и что-то доказывать. В первую очередь данное правило распространяется на потенциально сбойные комплектующие, такие, как жесткий диск, и дорогие вещи — например, монитор. То, что где-то в Польше все можно купить гораздо дешевле, не должно вас волновать: возможные издержки по замене сгоревшей детали превзойдут разницу в цене.

• Если вы покупаете деталь б/у и/или с рук, убедитесь, что владелец вернет деньги обратно, если она откажется работать в вашей машине. Обычно честные продавцы тестируют работу детали на вашем ПК и дают небольшую гарантию — 1-2 недели.

• Идеальный вариант получения сбалансированного компьютера — покупка отдельных комплектующих в одной/нескольких фирмах с последующей самостоятельной сборкой (очень занимательный процесс, кстати). Однако данный способ не подходит для новичков, покупающих первый ПК. Для них лучше пойти в фирму, торгующую готовыми моделями ПК, и выбрать машину, наиболее подходящую для их задач. Возможно, придется немного изменить эталонную конфигурацию — такой сервис предоставляют многие фирмы.

• Никогда не стоит экономить на таких вещах, как монитор, память, материнская плата, винчестер, корпус с блоком питания. Почему, будет рассказано в следующих советах.

• Ответственно отнеситесь к выбору монитора: ваши глаза дороже (у меня всегда вызывали слезы умиления люди, сидящие за 14-дюймовым выпуклым монитором десятилетней давности, имея при этом "навороченную" машину на базе Athlon'а), к тому же, монитор — одна из наиболее редко заменяемых частей компьютера. Как вы, наверное, знаете, желательно брать монитор, имеющий сертификат соответствия какому-либо стандарту безопасности (TCO'95, TCO'99 и др.), подтверждающий его экологическую нейтральность. Это, конечно, не панацея от вредных воздействий, однако наличие такого сертификата дает надежду на то, что фирма-разработчик относится к этой проблеме достаточно серьезно. Собственно, в наше время большинство мониторов удовлетворяют самым последним (и, соответственно, требовательным) стандартам безопасности. Еще нужно обратить свое внимание на такой параметр, как рабочее разрешение и частота. Согласно TCO'99, частота вертикальной развертки кадров для рабочего разрешения ЭЛТ (CRT) монитора должна быть не менее 85 Герц, а лучше — 100 Герц. Если вы собираетесь работать в разрешении, отличном от паспортного (заводского) рабочего, убедитесь, что это правило выполняется для выбранного вами значения. Про другие параметры говорить нет особого смысла: они либо и так достаточно неплохи для всех современных мониторов (зерно, например), либо очень специфичны для каждой модели и даже экземпляра (цветопередача, геометрия, дизайн, наконец). Могу разве что посоветовать брать для дома либо неплохой 17" ЭЛТ-монитор от LG, Sony, Samsung и др., либо, для любителей, 15" ЖК (LCD) дисплей — сейчас они более чем доступны по цене, да и технические характеристики на уровне.

• Корпус и блок питания относятся к числу компонентов, от которых зависит надежность работы вашего ПК. Хороший корпус изготавливается из толстой жести или алюминия и стоит больше $40. Хорошо себя зарекомендовала фирма Inwin, производящая качественные и сравнительно недорогие модели, и ряд других компаний. Тип корпуса (Desktop или Tower) зависит от предпочтений пользователя, а размер желательно выбирать побольше — меньше проблем с охлаждением и монтажом оборудования. Блок питания должен: во-первых, обладать достаточным запасом мощности (для современных машин на базе PIV и Athlon XP с мощными видеоадаптерами 300 Вт совсем не будут лишними), а во-вторых, быть изделием известной фирмы, выпускающей качественные комплектующие.

• Материнская (системная) плата — основа вашей машины. От нее зависят: надежность работы системы в целом, расширяемость, производительность, поддерживаемые технологии и стандарты (тип шины, модель процессора, тактовые частоты памяти/процессора, контроллеры периферийных устройств и т.д.). Исходя из всего вышесказанного можно сделать следующие выводы: покупать нужно современную "мать", удовлетворяющую всем вашим требованиям по производительности и расширяемости, изготовленную такими фирмами, как Gigabyte, MSI, Intel, Elite Group, Epox, Asus и некоторые другие. К тому же, не забывайте, что от модели северного моста (MCH — Memory Controller Hub, контроллер памяти) зависит модель используемого процессора, тип памяти и режим работы шины AGP (Accelerated Graphic Port, ускоренный графический порт), а от южного моста — возможности по подключению дополнительного оборудования (иногда функции обоих "мостов" интегрированы в одном чипе).

• Процессор — "сердце" компьютера. Все современные процессоры показывают приличную производительность, достаточную для большинства приложений. Однако если вы геймер или профессионально занимаетесь обработкой звука или видео, стоит взять что-нибудь помощнее — не забудьте только обеспечить хорошее охлаждение вашему "кипятильнику". Выбор между AMD и Intel можно сделать исходя из следующих данных: Intel — это надежность, неприхотливость, приличная производительность; AMD — это низкая цена, бескомпромиссная скорость работы и серьезные требования к остальному оборудованию. Лично я всегда предпочитал надежность и совместимость и считаю, что для домашнего ПК сегодня идеально подойдет недорогой Intel Celeron на базе PIII или PIV вместо пышущего жаром Athlon'а.

• Памяти никогда не бывает много. Это правило хорошо знают поклонники NT- и UNIX-систем. В большинстве случаев хватает 128 Мб. Если вы используете Windows 2000 или XP, оптимальным количеством будет 256 Мб. 512 Мб — разумный предел: все просто летает, к тому же, больший объем может понадобиться только для обработки видео/аудиоинформации на профессиональном уровне, а там совсем другие требования к производительности машины. Выбор между DDR- и обыкновенной SDRAM-памятью, думаю, сейчас очевиден: все современные чипсеты поддерживают именно быструю и дешевую с некоторого времени DDR-память, покупать SDRAM имеет смысл только для апгрейда уже имеющейся машины. Здесь я не затронул такие технологии, как ECC (Error Checking and Correction — поиск и коррекция ошибок), имеющие смысл только для серверов, — целевая аудитория не та.

• Винчестер домашней машины должен быть большим, надежным и недорогим, а сервера/рабочей станции — надежным, быстрым, большим. Чувствуете разницу? Также следует обратить внимание на такие параметры, как рабочая температура, шумность, устойчивость к вибрациям. Примеры фирм-изготовителей хороших винчестеров я не приведу: ситуация здесь меняется очень быстро — с выходом каждой новой модели.

• Видеоадаптер отвечает за формирование сигнала для дисплея, однако во всех современных видеоадаптерах имеется специализированный процессор (GPU — Graphic Processor Unit, графический процессор) и собственная быстрая память для работы с двух- и трехмерной графикой, что ускоряет обработку видеоинформации, разгружая при этом CPU (Central Processor Unit — центральный процессор). Именно поэтому видеокарты часто называют видеоакселераторами, т.е. видеоускорителями. Таким образом, для домашней машины подходит почти любой выпускаемый сейчас продукт. Если же вы играете в требовательные к аппаратуре игры, то должны понимать, как сказываются на показателях быстродействия тип чипа, количество, разрядность и тип памяти, тактовые частоты видеопроцессора, памяти и RAMDAC, поддерживаемые технологии ускорения обработки графики (DirectX, OpenGL) и т.д. Выбор между чипами от NVIDIA и ATI (а они наиболее популярны) сродни выбору между Intel и AMD. Можете также обратить внимание на дополнительные возможности — аналоговый выход для подключения телевизора и др. Для домашнего ПК неплохо подходят модели на базе GeForce2 MX и GeForce4 MX.

• Если вы меломан, то наверняка отдадите немалые деньги за серьезную звуковую карту и акустическую систему (профессиональные модели я, конечно, опускаю — это удел специалистов). Выбор здесь очень субъективен, к тому же, и цены не маленькие. Хорошо себя зарекомендовали саундбластеры от Creative Technologies: Sound Blaster Live!, Audigy и Audigy2, обеспечивающие качественный многоканальный звук и аппаратную его акселерацию (технологии EAX и EAX2), что важно для игр. Акустику нужно предварительно послушать: звук разных моделей серьезно отличается. Конечно же, корпуса колонок должны быть изготовлены из дерева (ДСП, в крайнем случае), особенно если это дорогая 5.1-канальная система. Ну, а для всех остальных подойдет любая современная звуковая карта и пластиковые колонки-"пукалки".

• Важный момент — CD- или DVD-приводы (флоппи-диски опускаются — они давно морально устарели). Правило №1: быстрый — не значит хороший, скорее наоборот. Традиционно качественные, хотя и дорогие изделия выпускает фирма Teac. Сейчас имеет смысл купить CD-RW-привод (к тому же, почти все они оснащены технологией защиты от опустошения буфера), а по мере необходимости приобрести и DVD. А можно сразу взять DVD-CD-RW-комбайн. Покупать пишущие DVD-приводы нецелесообразно из-за их редкости и дороговизны.

• Если вам нужен выход в Internet, необходимо приобрести модем, поскольку, как правило, используется доступ по коммутируемым (телефонным) линиям. Выбор между внешним и внутренним модемами — дело вкуса пользователя. Однако внутренние модемы (и ряд внешних, подключаемых по шине USB) в большинстве своем являются программными, т.е. часть функций по обработке сигнала возлагается на процессор, что плохо сказывается на устойчивости связи и скорости работы. Так что если вам нужна хорошая и быстрая передача данных, ищите аппаратный внешний за соответствующую цену (аппаратные внутренние сейчас редкость), ну, а для тех, кто пользуется Сетью время от времени, подойдет недорогой программный внутренний. Главное — чтобы модем имел сертификат годности на использование в наших тяжелых условиях. Хорошей репутацией пользуются изделия фирм Zyxel и US Robotics.

• С локальной сетью отдельная история. Вкратце — рекомендую брать полнодуплексные 100 Мб карточки для витой пары (если, конечно, у вас есть выбор).

• Такие вещи, как мышь и клавиатура, должны быть в первую очередь удобными и надежными (жаль, что больше не выпускают клавиатур на основе микропереключателей — такие удобные штуковины были, с приятным и четким "кликом"). Я с удовольствием поменял бы мощный процессор на клавиатуру от Microsoft: на ней гораздо приятнее набирать текст. Рекомендую эргономичные (ломаные) клавиатуры для тех, кто много печатает (поверьте, они гораздо удобнее традиционных прямых). Мышь лучше брать оптическую — меньше возни с чисткой, однако не всегда подходит для игроманов. Извращения вроде радиосвязи — удел любителей и киберпанков. Лучшую (и самую дорогую) продукцию выпускают Microsoft и Logitech.

• Всяческие прибамбасы, такие, как рули, педали, джойстики, видеокамеры и др., следует выбирать исходя из обзоров в газетах и журналах — все-таки вещи довольно специфические и не всегда дашь адекватный совет.
Я нарочно не говорил о принтерах, сканерах и прочей периферии, так как это отдельная серьезная тема, к тому же, данные устройства нужны не всем пользователям, в отличие от большинства "внутренностей" системного блока.

Источник: http://www.nestor.minsk.by/kg/


Оптимизация по Биос

Биос

В базовой системе ввода/вывода скрыты многие настройки компьютера, которые позволят оптимизировать его работу. С помощью BIOS возможен разгон и оптимизация, то есть повышение производительности компьютера. Сейчас мы займёмся тонкой оптимизацией с помощью BIOS.

Процессор.
CPU Mstr post WR Burst mode
Опция включает пакетный режим передачи данных но, ЦП должен быть в режиме Bus-master. Значительно повышает производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

CPU Priority
Устанавливает приоритет ЦП над другими устройствами, работающими в режиме master.
Значение опции:
*Always Last- приоритет ПЦ над другими устройствами;
*CPU 2nd- ПЦ по приоритету на втором месте;
*CPU 3nd- ПЦ по приоритету на третьем месте;
*CPU 4nd- ПЦ по приоритету на четвёртом месте.

Cache Timing Control
Данная функция контролирует скорость чтения/записи данных кэш-памяти второго уровня.
Значение опции:
*Fast (Turbo) - быстрый режим, высокая производительность;
*Medium - средняя скорость;
*Normal - Нормальная скорость, низкая производительность, устанавливается по умолчанию.

Видео карта.
Display Cache Window Size
Функция устанавливает размер кэшируемой системой памяти, которая используется для видеосистемы.
Значение опции:
*32MB - размер кэшируемой памяти составляет 32 Мбайт;
*64MB - размер кэшируемой памяти составляет 64 Мбайт.

AGP Capability
Позволит выбрать режим работы видеокарты. Оказывает прямое значение на производительность.
Значение опции:
*1X Mode - стандартный режим работы, данный режим устарел.
*2X Mode - удвоенный режим передачи данных.
*4X Mode - утроенный режим передачи данных. Самый быстрый.
Возможно, на самых новых видеокартах есть режим *8X Mode - самый быстрый из всех предыдущих.

AGP Master 1WS Read;
AGP Master 1WS Write
Количество тактов чтения/записи данных с шины AGP.
Значение опции:
*Enabled- включено, количество тактов равно 1. Производительность максимальная, но есть шанс не стабильной работы.
*Disabled- отключено. Количество тактов равно 2. Работа - стабильна.

VGA 128K Range Attribute
Между видеопамятью и ЦП включает буфер, увеличивается производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

Оперативная память.
FSB/SDRAM/PCI Freq. (MHz)
Функция позволит выбрать значение частот FSB, SDRAM и PCI.

Memory Hole At 15-16M
Копирует медленную память устройств ISA в оперативную память.
Значение опции:
*Disabled- отключено, используется, если в системе нет ISA - устройств;
*Enabled- включено, используется, если в системе есть ISA - устройства.

Memory Read Wait State
Функция контролирует задержку при чтение данных из оперативной памяти. Маленькая задержка - большая производительность, но есть шанс не стабильной работы.
Значение опции:
*0, 1, 2, 3 - задержка в тактах системной шины.

Optimization Method
Функция увеличивает скорость обмена данными с оперативной памятью. Повышает производительность.
Значение опции:
*Normal - стандартные параметры обмена;
*Turbo 1 - ускоренные параметры обмена;
*Turbo 2 - максимально быстрые параметры обмена.

SDRAM CAS Latency Time;
SDRAM RAS-to-CAS Delay;
SDRAM RAS Precharge
Данные опции оказывают прямое значение на производительность. Чем меньше значение - тем больше производительность, но есть шанс не стабильной работы.

Жёсткий диск.
HDD SMART Capability
Опция включает SMART. При этом понижается общая производительность системы.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

IDE Burst Mode
Опция включает буфер данных, имеющийся на любом современном HDD интерфейса IDE. Значительно повышает производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

IDE Burst for DOS & Windows
Опция включает буфер для интерфейса IDE упреждающего чтения и отложенной записи.
Повышается пропускная способность канала IDE. Повышает общая производительность.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

IDE HDD Block Mode Sectors
Режим поблочной многосекторной передачи данных с HDD. Значительно повышает производительность.
Значение опции:
* HDD MAX - авто определение;
*Своё значение - обратитесь к инструкции HDD.

Несколько интересных опций.
Automatic Power Up
Включить компьютер в определённое время.
Значение опции:
*Everyday - каждый день в определённое время;
*By date - в определённую дату, время, месяц, и другое.
*Disabled- отключено.

Wake On PS/2 KB/Mouse
Включает компьютер при нажатие на <пробел> или ЛКМ.
Значение опции:
*Enabled- включено;
*Disabled- отключено.

Производительность может увеличится на 5-50%. Я не несу ответственность за ваши действия!


Оптимизация реестра

Customizer XP своими руками.

Представленная ниже информация систематизирована в соответствии с меню программы Customizer XP и не только с ним.

Настройка меню Пуск

Предварительно несколько слов о настройке меню Пуск. По умолчанию большинство нижеописанных ключей не содержатся в реестре, поэтому, если не сказано обратное, их нужно будет добавить. Для отмены действия ключа, если нет специальных оговорок, будет необходимо изменить его значение на обратное — чаще с 1 на 0 — либо просто удалить ключ из реестра.

Большинство изменений, описанных в этом разделе, могут использоваться как для отдельного пользователя, так и в более широком масштабе — для всего компьютера. В этом случае проведите идентичные изменения в разделе HKEY_LOCAL_MACHINE.

Start Menu: Remove the Common Groups
Удалить, вернее сказать, скрыть из выпадающего меню кнопки Пуск приложения из папки "c:\ Documents and Settings\ All Users\ Главное меню\ Программы". Добавьте в реестр следующий ключ:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoCommonGroups"=dword:1

Start Menu: Remove the Shut Down Menu
Для удаления меню Завершение работы добавьте ключ:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoClose"=dword:1

Start Menu: Remove the Find Command Menu
Удалить команду Найти из меню кнопки Пуск и контекстно-зависимых меню:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoFind"=dword:1

Start Menu: Remove the Taskbar Properties
Сделать недоступными свойства панели задач и меню Пуск:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoSetTaskbar"=dword:1

Start Menu: Remove the Run Command Menu
Удалить меню Выполнить:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoRun"=dword:1

Start Menu: Remove Control Panel and Printers Menu
Удаляет меню Панель управления и Принтеры и факсы.

[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoSetFolders"=dword:1

Start Menu: Configure Menu Show Delay
Эта опция определяет задержку перед тем, как будет отображено меню. Измените значение ключа. По умолчанию это "400". Рекомендуется попробовать значение 10 или меньше.

[HKEY_CURRENT_USER\ Control Panel\ Desktop]
"MenuShowDelay"="10"

Start Menu: Use Scrolling Mode in Programs Menu
Смысл этой опции в том, что, когда ваше меню Программы разрастется до таких размеров, что не будет помещаться на экране в высоту, то Windows XP по умолчанию создаст второй столбец с теми пунктами меню, которым не нашлось места в первом столбце. Однако данная опция позволяет вам использовать один-единственный столбец с кнопкой прокрутки вместо того, чтобы отображать второй столбец. Добавьте в реестр ключ следующего содержания:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced]
"StartMenuScrollPrograms"="Yes"

Start Menu: Clear Recent Documents on Exit
Очистка списка недавно использовавшихся документов при завершении сеанса работы на компьютере:
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\ explorer]
"ClearRecentDocsOnExit"=dword:1

Start Menu: Disable Recent Documents History
Предотвращает создание списка недавно использовавшихся документов:
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ policies\ explorer]
"NoRecentDocsHistory"=dword:1

Start Menu: Disable the Ability to Modify the Start Menu
Исключает возможность модификации меню Пуск. Обычно пользователь по правому клику мышки на меню Пуск вызывает контекстное меню для изменения его свойств. Данная опция может включить или выключить такую возможность.

[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoChangeStartMenu"=dword:1

Start Menu: Disable Balloon Tips in Start Menu
Обычно Windows XP показывает всплывающие подсказки и дает советы начинающим пользователям. Измените значение ключа с 1 на 0 для того, чтобы исключить эту возможность:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced]
"EnableBalloonTips"=dword:0

А теперь небольшая добавка к полученным умениям:
1. Определим, сколько ярлыков может быть создано в меню Пуск — Документы. По умолчанию их 15, но вы можете изменить это значение на свое. Добавьте или измените ключ, тип DWORD, [HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer] параметр MaxRecentDocs.

________________

Настройка уведомлений
Если окно Настройка уведомлений (Панель управления-Панель задач и меню "Пуск"-вкладка Панель задач-кнопка Настроить) стало чересчер забито значками ненужных программ, значит пришло время почистить список. Для этого открываем раздел HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ TrayNotify и удалить параметры IconStreams и PastIconsStream. Затем откройте Диспетчер задач Windows (Task Manager), выберите вкладку Процессы, выделите Explorer.exe и нажмите кнопку Завершить процесс. Затем в меню Файл выберите Новая задача (Выполнить...) и напечатайте explorer. OK. Terminator II (http://winchanger.narod.ru/)


Customizer XP своими руками

Представленная ниже информация систематизирована в соответствии с меню программы Customizer XP и не только с ним.

Настройка Explorer

Explorer: Show Windows Version Number
Измените значение этого ключа с 0 на 1, и в правом нижнем углу экрана будет показываться версия
[HKEY_CURRENT_USER\ Control Panel\ Desktop]
"PaintDesktopVersion"=dword:1

Explorer: Remove Arrow Symbol on Shortcut
Для того, чтобы удалить стрелочки на ваших ярлыках в левом нижнем углу, просто удалите два строковых параметра в нужном месте реестра:
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ lnkfile]
"IsShortcut"=-

[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ piffile]
"IsShortcut"=-

Explorer: Shortcut Without "Shortcut to"
Использование этой опции предотвращает добавление слова Ярлык для создаваемых вами ярлыков. Измените значение двоичного параметра link с hex:11,00,00,00 на hex:00,00,00,00:
[HKEY_LOCAL_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer]
"link"=hex:00,00,00,00

Explorer: Use Notepad to Open Unknown Files
Используйте эту опцию, чтобы добавить блокнот в контекстное меню для того, чтобы открывать в нем файлы неизвестных системе типов.

Для этого добавьте в ветку HKEY_LOCAL_MA-CHINE\ SOFTWARE\ Classes\ Unknown\ shell\ подраздел Notepad, создайте в нем подраздел Command и присвойте ему следующее значение по умолчанию:
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Unknown\ shell\ Notepad\ Command]
@="notepad.exe %1"
А также измените указанное значение по умолчанию с "openas" на "Notepad":
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Unknown\ shell]
@="Notepad"

Explorer: Add Command Prompt for All Folders
Эта опция используется, чтобы добавить командную строку в контекстные меню всех папок. Для этого в ветку HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Directory\ shell добавьте подраздел Command Prompt, в нем же создайте еще один подраздел Command и присвойте ему следующее значение по умолчанию:
[HKEY_LOCAL_MACHINE\ SOFTWARE\ Classes\ Directory\ shell\ Command Prompt\ Command]
@="Cmd.exe /k cd "%1""

Explorer: Smooth Edges of Screen Font
Эта установка делает экранные шрифты более читабельными. Есть два режима сглаживания шрифтов. Первый из них называется Standard. Для того, чтобы его использовать, сделайте два изменения в реестре. Строковое значение следующего ключа измените с 0 на 2:
[HKEY_CURRENT_USER\ Control Panel\ Desktop]
"FontSmoothing"="2"
а числовое значение этого ключа с 0 на 1:
[HKEY_CURRENT_USER\ Control Panel\ Desktop]
"FontSmoothingType"=dword:1
Стандартный режим сглаживания рекомендован для обычных ЭЛТ-экранов настольных мониторов. Режим Clear Type предназначен для ноутбуков.

Для режима сглаживания, который называется Clear Type, значение последнего ключа установите равным 2:
[HKEY_CURRENT_USER\ Control Panel\ Desktop]
"FontSmoothingType"=dword:2

Explorer: Disable Active Desktop Feature
Возможность Active Desktop позволяет вставлять в оформление рабочего стола HTML-файлы, ссылки из Интернета, файлы с картинками и анимацией и т.п. в качестве обоев. Чтобы исключить эту ненужную для работы особенность, которая к тому же отъедает ресурсы компьютера, измените реестр, как указано ниже:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoActiveDesktop"=dword:1

Explorer: Prevent Windows XP from Hiding Inactive Tray Icons
По умолчанию Windows XP прячет неиспользуемые иконки в системном трее. Поначалу это несколько непривычно, но вы можете изменить это поведение так, чтобы показывались все иконки. Для этого измените значение ключа с 1 на 0:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer]
"EnableAutoTray"=dword:0
Explorer: Disable Grouping Similar Taskbar Buttons
По умолчанию Windows XP группирует подобные кнопки на панели задач. То есть, если запущены две копии, например, Far, то Windows сгруппирует две кнопки в одну и поставит перед названием запущенной программы цифру 2. Таким образом экономится и без того небольшое место на таскбаре. Чтобы отключить эту полезную особенность, измените значение ключа с 1 на 0:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced]
"TaskbarGlomming"=dword:0
Дополнительная информация. Мы можем также изменить алгоритм группировки окон. Для этого найдите в реестре ключ HKCU\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced или HKLM\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Advanced и измените или создайте параметр TaskbarGroupSize, тип DWORD со следующими значениями. Значение 0 по умолчанию означает группировать окна начиная со "старых" окон, когда места на таскбаре мало. 1 — то же самое, но начиная с "новых" окон. 2 — группировать в любом случае, если есть не менее двух подобных окон. 3 — то же самое, если есть не менее трех похожих окон. 4 — не менее четырех. Естественно, TaskbarGlomming должен быть включен.

Explorer: Disable Restoring Open Apps at Reboot
Опция определяет, восстановит Explorer или нет окна, которые были открыты, когда работа с Windows была завершена. Если вы хотите, чтобы он этого не делал, добавьте следующий ключ:
[HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\ Explorer]
"NoSaveSettings"=hex:01,00,00,00

Explorer: Change Windows Pre-Logon Wallpaper
Это возможность для любителей различных украшательств изменить обои, показываемые до того, как какой-нибудь пользователь войдет в систему. Измените строковое значение с "(None)" на путь и имя графического файла:[HKEY_USERS\ .DEFAULT\ Control Panel\ Desktop]
"Wallpaper"="c:\ my_wallpaper.bmp"

Всплывающие подсказки

Всплывающие подсказки для начинающих пользователей. Исключить эту возможность [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"EnableBalloonTips" =dword:0

Запрет на доступ к содержимому выбранных дисков

Запретить пользователю доступ к файлам заданных дисков через Проводник, Мой компьютер, Выполнить Создать параметр
[HKEY CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

"NoViewOnDrive"= dword: ? содержащий битовую маску для дисков. Пример, диск A имеет бит 1, диск С - 4, диск D - 8. Таким образом, чтобы скрыть диски A и D, нужно сложить их значения 1 (A) + 8 (D) и установить значение 9.
Список всех дисков:
A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, Все диски: 67108863


Customizer XP своими руками

Представленная ниже информация систематизирована в соответствии с меню программы Customizer XP и не только с ним.

Настройка Интернет

В задании большинства параметров, освещаемых в данном разделе, возможны варианты : ваше значение; значение, рекомендованное для DialUp, то есть модемных соединений; для соединений с помощью DSL\Cable модемов; и для линий типа T1 и выше.

На мой взгляд наиболее демократичным будет приводить рекомендованные значения, которые вы будете применять на свой страх и риск, для модемных соединений с Интернетом. А когда у вас появится выделенная линия типа T1, то будете ли вы копаться в реестре? По той же причине пропущено рассмотрение некоторых параметров.

Для настройки запускаем RegEdit (Пуск > Выполнить > regedit).

Internet : Change Maximum Transmission Unit Size

Здесь нам предоставляется возможность задать наибольший размер передаваемого блока данных - Maximum Transmission Unit. MTU - это самое большое количество данных, которые могут быть переданы по сети в одном физическом фрейме. Если пакет IP большего чем MTU, то произойдет фрагментация. Эта фрагментация может удвоить время, которое требуется, чтобы послать единственный пакет.

Для изменения размера MTU следует добавить новый параметр и установить желаемое значение. По-умолчанию оно равно 1500 в десятичной системе или 0x5DC в шестнадцатеричной. Для модемных соединений рекомендовано значение 0x240. Однако это ещё не всё, смотрите параметр "Enable MTU Auto Discovery", описанный немного ниже.

[HKEY_LOCAL_MACHINE]
"MTU"=dword:5DC
Для DSL, кабельных модемов, T1 и выше: 1500

Internet : Change the Windows TCP/IP Window Size

Этот параметр определяет максимальный размер окна для приёма TCP пакетов, предлагаемый операционной системой. Окно приёма определяет количество байтов, которые отправитель может передать, не получая подтверждения. Вообще, чем больше окно, тем лучше работа в сетях с высокой пропускной способностью. Однако, не всё так просто. Но выходить за рамки статьи и углубляться в дебри TCP/IP, мы сегодня не будем. Достаточно сказать, что для того, чтобы точно определить значение окна, необходимо будет добавить раздел и параметр в реестре. Значание по-умолчанию 0x2238, а для модемных соединений устанавливать и изменять его не рекомендуется. Коротко и ясно.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"TCPWindowSize"=dword:2238
DSL, кабельный модем - 186880 (0x2DA00)

T1 и выше - 256960 (0x3EBC0)

Internet : Enable MTU Auto Discovery

Включение этой опции заставляет TCP автоматически определять MTU. В реестр нужно добавить ключ:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"EnablePMTUDiscovery"=dword:1

Internet : Change the Default Time to Live Setting

TTL определяет максимальное время, которое пакет IP может прожить в сети, не достигая адресата. Другими словами : использование этой опции определяет, как долго компьютер будет ждать, прежде чем решит, что запрашиваемый вебсайт не найден.

Рекомендованное значение равно 128. Добавьте следующий ключ :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"DefaultTTL"=dword:80

Internet : Enable Selective Acknowledgement Support

Не углубляясь далеко в теорию, отметим, что когда поддержка Selective Acknowledgement (SACK) включена, и пакет или ряд пакетов TCP потеряны, то получатель может сообщить отправителю точно, какие данные были получены, и где находится "дыра" в данных. Тогда отправитель может выборочно повторить передачу только недостающих данных, и не будет повторно передавать блоки данных, которые уже были успешно получены. Особенно это важно для больших TCP окон, см. описание следующей опции.

Для включения возможности SACK нужно добавить в реестр такой ключ :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"SackOpts"=dword:1

Internet : Enable Large TCP Window Support

Совместно с опцией TCP/IP Window Size , описанной выше, данная возможность включает поддержку больших TCP окон, это особенно актуально в сетях с большой пропускной способностью (я думаю, что модемное соединение к ним не относится). Если вам так нужно, то измените значение ключа с 0 на 3 :

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
"Tcp1323Opts"=dword:3

Выше написанное действительно для нормальных линий, то есть стандарты.

Параметры выставленные на моем компьютере, у меня плохая линия. Модем Motorola SM56 PCI

Оптимизация TCP/IP

По умолчанию большинство нижеописанных ключей не содержатся в реестре, поэтому их нужно будет добавить. Для отмены действия ключа, если нет специальных оговорок, будет необходимо изменить его значение на обратное — чаще с 1 на 0 — либо просто удалить ключ из реестра.

Для настройки запускаем RegEdit

HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\Tcpip\Parameters

Параметр DefaultTTL (TTL - Time To Live) - REG_DWORD время жизни пакета. TTL может принимать значения 32, 64, 128. Он предусмотрен для того чтобы при поиске места назначения пакета маршрутизаторы не зацикливались. Как только значение этого параметра превышает допустимое, пакет считается попавшим в цикл и уничтожается. Выставлено значение (80)

Параметр TcpWindowSize (RWIN - Receive Window) - REG_DWORD окно посылки. Значение RWIN рассчитывается по формуле DefaultMSS * n, где n - 4, 6, 8 (1460 * 8=11680).
Когда ты посылаешь запрос на сервер, то он имеет право отправить тебе RWIN количество байт, не дожидаясь подтверждения об удачном приеме. Если RWIN будет равным DefaultMSS, то сервер после каждой отправки пакета будет ждать подтверждения. Если указать DefaultMSS * 20, то сервер будет отправлять сразу 20 пакетов, что увеличит их потерю. Выставлено значение (8760)

Параметр GlobalMaxTcpWin - REG_DWORD это обнаружение пути с максимальным размером пакета. Выставлено значение (5840)

Параметр DeadGWDetectDefault - REG_DWORD нахождение черных дыр. Если этот параметр поставить в (1), то перед началом соединения будет происходить проверка на мертвые маршрутизаторы по пути до сервера. Этот параметр сильно тормозит протокол за счет лишних затрат на поиск. Выставлено значение (0)

HKEY_LOCAL_MACHINE\System\CurrentControlSet\ Services\VxD\MSTCP

Параметр DefaultRcvWindow - REG_SZ Выставлено значение (6432 )

Параметр PMTUDiscovery (Maximum Transmission Unit) REG_SZ - максимальный передаваемый пакет. Возможные значения для MaxMTU: 552, 576, 1002, 1500. По умолчанию в Win XP стоит значение (0).Чем больше значение, тем больше пакет и больше данных получаешь. С максимальным значением модем будет отправлять больше данных, но при плохой связи пакеты теряются и на повторную отправку больших пакетов понадобиться больше времени. Еще одна проблема - стандартом для маршрутизаторов долгое время являлось значение MaxMTU = 576. Сейчас везде по разному. Выставлено значение MaxMTU (1) автоматичекий режим.

Заключение

Данные настройки могут увеличить скорость от 10 до 40 %. Эти настройки являются индивидуальными для каждого в зависимости от качества вашей связи. Для автоматической настройки можно воспользоваться специальной программой TweakMASTERPro (http://www.tweakmaster.com/download.php) Другие программы не рекомендую, или использовать специализированную программу типа Internet Tweak 2001 Gold (http://www.magellass.com/)


IExplorer

Представленная ниже информация систематизирована в соответствии с меню программы Customizer XP и не только с ним.

Настройка IExplorer

В этом разделе названия опций говорят сами за себя, поэтому даны только краткие комментарии.

Запретить доступ к свойствам Internet Explorer

Полностью запрещает доступ к настройкам Internet Explorer. Если данная опция включена, опции ниже игнорируются.

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

" NoBrowserOptions "dword: 1 - доступ к настройкам запрещен

IExplorer : Hide General Page from Internet Properties

Чтобы спрятать вкладку "Общие" в параметрах Internet Explorer'a добавьте в реестр:

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"GeneralTab"=dword:1

IExplorer : Hide Securiry Page from Internet Properties

Чтобы спрятать вкладку "Безопасность" в параметрах Internet Explorer'a добавьте в реестр:

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"SecurityTab"=dword:1

IExplorer : Hide Privacy Page from Internet Properties

Чтобы спрятать вкладку "Конфиденциальность" в параметрах Internet Explorer'a :

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"PrivacyTab"=dword:1

IExplorer : Hide Content Page from Internet Properties

Чтобы спрятать вкладку "Содержание" в параметрах Internet Explorer'a проведите соответствующие изменения в реестре :

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"ContentTab"=dword:1

IExplorer : Hide Connections Page from Internet Properties

Чтобы спрятать вкладку "Подключения" в параметрах Internet Explorer'a добавьте в реестр:

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"ConnectionsTab"=dword:1

IExplorer : Hide Programs Page from Internet Properties

Чтобы спрятать вкладку "Программы" в параметрах Internet Explorer'a :

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"ProgramsTab"=dword:1

IExplorer : Hide Advanced Page from Internet Properties

Чтобы спрятать вкладку "Дополнительно" в параметрах Internet Explorer'a добавьте в реестр:

HKEY_CURRENT_USER\Software\Policies\Microsoft\
Internet Explorer\Control Panel
"AdvancedTab"=dword:1

IExplorer : Change Default Download Path

Для измения папки для закачек по умолчанию, добавьте ключ с именем вашей папки:

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer
"Download Directory"="C:\My Downloads"

IExplorer : Wallpaper for Internet Explorer Toolbar

Для изменения обоев для панели инструментов добавляем ключ:

[HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Toolbar]
"BackBitmap"="c:\папка\имя_файла"

IExplorer : Change Internet Explorer Large Animation

Для замены эмблемы IE необходимо два изображения. Первое размером 38х38 пикселей, а второе 22х22. Если захотите вернуться к значениям по умолчанию, то либо удалите ключи, либо присвойте им пустые значения.

Итак, добавляем ключ :

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Toolbar
"BrandBitmap"="c:\папка\имя_файла_1"

IExplorer : Change Internet Explorer Small Animation

И добавляем ещё:

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Toolbar
"SmBrandBitmap"="c:\папка\имя_файла_2"

IExplorer : Remove the Outlook Express Splash Screen

Не показывать заставку при загрузке OE. Измените значение ключа с 0 на 1:

HKEY_CURRENT_USER\Identities\{8D48CF80-251E-46D0-9EAF-6633E2DBD392}
\Software\Microsoft\Outlook Express\5.0
"NoSplash"=dword:1

IExplorer : Change the Outlook Express Title Bar

Для изменения заголовка окна OE добавьте ключ :

HKEY_CURRENT_USER\Identities\{8D48CF80-251E-46D0-9EAF-6633E2DBD392}
\Software\Microsoft\Outlook Express\5.0
"WindowTitle"="ваш заголовок"

IExplorer : Disable Automatic Image Resizing

По умолчанию IE автоматически подгоняет размеры картинок для отображения в окне браузера. Для отключения этой возможности измените значение ключа с "yes" на "no" :

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Main
"Enable AutoImageResize"="no"

IExplorer : Add Text to the Internet Explorer Title Bar

Чтобы добавить ваш текст к стандартному заголовку IE, добавьте в реестр ключ :

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Main
"Window Title"="ваш заголовок"

IExplorer : Auto Complete Feature

IE имеет режим "Автозаполнение", то есть он может запоминать, какие данные и пароли вы вводите в веб-формах и пользуясь этой "памятью" помогает вводить данные в дальнейшем. Хотя это хорошая особенность, но она может привести к проблемам защиты.

Для включения возможностей автозаполнения измените или добавьте три ключа:

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Main
"Use FormSuggest"="yes"
"FormSuggest Passwords"="yes"
HKEY_CURRENT_USER\Software\Microsoft\
Windows\CurrentVersion\Explorer\AutoComplete
"AutoSuggest"="yes"

IExplorer : Disable the Ability to Customize IE Toolbar

Для запрета возможности изменения панели инструментов IE, измените значение ключа с 0 на 1 :

HKEY_CURRENT_USER\Software\Microsoft\
Windows\CurrentVersion\Policies\Explorer
"NoToolbarCustomize"=dword:1

IExplorer : Disable Internet Explorer Auto-Updates

Для запрета автообновления IE измените значение с 0 на 1 :

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Main
"NoUpdateCheck"=dword:1

IExplorer : Disable Smart Favorites Menu Feature

По умолчанию, редко используемые элементы меню "Избранное" не отображаются. Для отключения этой особенности нужно изменить значение ключа с "YES" на "NO" :

HKEY_CURRENT_USER\Software\Microsoft\
Internet Explorer\Main
"FavIntelliMenus"="NO"

IExplorer : Delete Smart Favorites Menu

Удалить пункт меню Избранное.В разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\

Internet Explorer\Restrictions создайте параметр "NoFavorites"=dword:1 Кнопка Избранное будет недоступна на панели инструментов

IExplorer : Delete Content Advisor Password

Для удаления пароля на изменение настроек свойств обозревателя на закладке "Содержание" удалите ключ :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
Windows\CurrentVersion\policies\Ratings
"Key"=-
Редактор, вызываемый через пункт меню Вид -> Просмотр HTM- кода

HKLM\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name

STRING по умолчанию путь к редактору.

Параметр влияет на поведение IExplorer, если он не находит страницу

HKCU\Software\Microsoft\Internet Explorer\Main

DWORD AutoSearch, Internet Explorer 6.0 использует следующие значения:

0 - Не выполнять поиск из адресной строки
6 - Показать результаты и перейти на самый похожий узел
5 - Только перейти на самый похожий узел
4 - Только показать результаты в главном окне
Запрос на сохранение пароля
HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest PW Ask, значение "yes"
Internet Explorer выводит окно с сообщением сохранять пароль или нет


Разное

Теперь рассмотрим дополнительные опции не вошедшие в предыдущие разделы.

Miscellaneous : Hide Appearance Page from Display Properties

Для того, чтобы скрыть закладку "Темы", "Оформление" измените значение ключа с 0 на 1:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Policies\System]
"NoDispAppearancePage"=dword:1

Miscellaneous : Hide Background Page from Display Properties

1 - скрыть, 0- показать закладку "Рабочий стол" в свойствах экрана:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Policies\System]
"NoDispBackgroundPage"=dword:1

Miscellaneous : Hide Screen Saver Page from Display Properties

1 - скрыть, 0 - показать закладку "Заставка" в свойствах экрана:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Policies\System]
"NoDispScrSavPage"=dword:1

Miscellaneous : Hide Settings Page from Display Properties

1 - скрыть, 0 - показать закладку "Параметры" в свойствах экрана:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Policies\System]
"NoDispSettingsPage"=dword:1

Miscellaneous : Change the Windows Media Player Title

Добавьте ключ в реестр, чтобы изменить заголовок окна медиаплэера:

[HKEY_CURRENT_USER\Software\Policies\Microsoft\
WindowsMediaPlayer]
"TitleBar"="Ваш заголовок"

Miscellaneous : Enable DVD Features in Windows Media Player

Измените значение ключа с "No" на "Yes", чтобы включить DVD возможности медиаплэера Windows:

[HKEY_CURRENT_USER\Software\Microsoft\
MediaPlayer\Player\Settings]
"EnableDVDUI"="Yes"

Miscellaneous : Clear Windows Media Player Recent Files

Для очистки списка последних проигранных медиаплэером файлов удалите или очистите следующие параметры:

[HKEY_CURRENT_USER\Software\Microsoft\
MediaPlayer\Player\RecentFileList]
"File0"=""
"File1"=""
<и т.д.>

Miscellaneous : Clear Microsoft Paint Recent Files

Для очистки списка последних редактированных в MS Paint файлов удалите или очистите следующие параметры:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Applets\Paint\Recent File List]
"File1"=""
"File2"=""
<и т.д.>

Miscellaneous : Clear Microsoft WordPad Recent Files

Для очистки списка последних редактированных в MS Word Pad файлов удалите или очистите следующие параметры:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\
CurrentVersion\Applets\Wordpad\Recent File List]
"File1"=""
"File2"=""
<и т.д.>

Miscellaneous : Change Icon Color Format

Чтобы указать количество цветов для иконок измените значение ключа на 16,24 или 32:

[HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
"Shell Icon BPP"="16"


Права пользователя

Как управлять пользователями, которым можно заходить на компьютер.
Как любая NT, XP имеет механизм идентификации пользователей, и каждого пользователя можно ограничить в правах. На этих пользователях и их правах строится вся модель безопасности XP, как на локальной машине, так и в сети. Нельзя защитить что-либо паролем, можно определить какие пользователи имеют право использовать тот или иной ресурс. Пользователей на одной машине может быть множество, и чтобы было проще ими управлять, пользователи разбиты на группы. Управление пользователями и группами осуществляется с помощью апплета Users Accounts в Control Panel или «Пуск — Выполнить» запустить команду control userpasswords.После установки системы образуется только два пользователя, один с правами администратора, который вы создали в процессе установки XP, и Guest, которые показаны в окне (на самом деле есть ещё несколько пользователей, например пользователь Administrator, но его не показывает в списке, и чтобы залогиниться им придётся идти на некоторые ухищрения). Если вы обладаете правами администратора, то можете добавить или удалить пользователя в этом окне, можете поменять пароль пользователя или пиктограмму соответствующую пользователю, поменять метод, который используется для входа в систему. Для этого надо выбрать пункт Change the way users log on and off. По умолчанию стоит Use the Welcome screen что означает, что для логона следует всего-навсего кликнуть по иконке из списка и ввести пароль. Если убрать галочку с этого пункта, то будет использоваться старый добрый метод входа знакомый по всем NT, с окном в котором предлагается ввести имя пользователя и пароль. Вы не можете использовать Welcome Screen если компьютер входит в домейн. Классический вход может быть двух видов, с требованием нажать Crtl+Alt+Del, и без оного. Для того чтобы это изменить, наберите в любой командной строке control userapasswords2. Откроется знакомое пользователям W2k окно

На второй закладке этого окна, Advanced, ставим или снимаем галочку в чекбоксе Require Users To Press Ctrl+Alt+Delete check box, расположенном в разделе Secure Logon.

На той же закладке можно нажать кнопку Advanced в разделе Advanced User Management, и запустить хорошо знакомый пользователям предыдущих ОС линейки NT апплет Local Users and Groups (ещё его можно запустить через Control Panel - Administrative Tools - Computer Management - Local Users and Groups ). Вы окажетесь в хорошо знакомом пользователям предыдущих ОС линейки NT апплете, в котором сможете добавить или удалить пользователей отредактировать уже существующих, поменять им группу, и т.д...

Кроме этого, некоторые настройки для пользователей, такие как время жизни пароля, конкретные права для различных групп, и некоторые другие настраиваются из апплета Local Security Setings из Administrative Tools.
Последнее, что хотелось бы отметить, это возможность и вовсе отключить необходимость в вводе пароля. Для этого вновь запускаем control userpasswords2, и снимаем галочку c users must enter a user name and password to use this computer. После этого пользователь выбранный в разделе Users for this computer: будет логиниться на компьютер сразу, минуя всякие формальности, вроде ввода паролей или кликанья на собственном имени.

Как выставить права пользователям, работающим на компьютере?

В Windows XP каждому пользователю можно выставить определенные права - что делать разрешается, а что - нет, причем, если пользователей много, их можно распределить по группам, присвоив каждой группе определенные права. Управление пользователями и группами производится через апплет Users Accounts, находящийся в Контрольной панели. Сразу после инсталляции WinXP в этом апплете можно будет увидеть двух пользователей - того, кто был создан в процессе установки (с правами администратора) и второго - гостя (Guest), по умолчанию отключенного. Вообще-то сразу же после установки появляются еще несколько пользователей (например, знакомый еще со времен NT пользователь по имени Administrator), но они не показаны в списке - таков общий принцип построения Windows XP: операционная система предназначена для всех, другими словами - и для чайников тоже, поэтому до "лишнего" можно добраться только после некоторых дополнительных манипуляций. В общем-то, это правильно - меньше дров будет наломано...

В случае, если вы обладаете правами администратора, апплет Users Accounts даст возможность добавлять или удалять пользователей, менять пользователю пароль или соответствующую ему картинку-пиктограмму, а также изменять метод входа в систему. По умолчанию при входе в систему показывается экран Welcome screen с пиктограммами и именами пользователей, но, если выбрать пункт "Change the way users log on and off" и убрать в появившемся окне галку с пункта "Use the Welcome screen", вход в систему будет происходить по NT-шному - через окно, в котором предлагается ввести имя пользователя и пароль.

А где же группы, где возможность редактирования уже существующих пользователей, короче говоря, где все то, что было в NT/2K? - Чтобы получить доступ к контролю над пользователями, который можно назвать "полным", придется заглянуть в апплет Computer Management (Start /Administrative Tools /Computer Management) и кликнуть по плюсику, раскрывающему Local Users and Groups...

Но и это не все хитрости: есть еще апплет Local Security Setings (он там же, в Administrative Tools), с помощью которого можно, например, изменить время жизни паролей и выставить конкретные права каждой имеющейся группе пользователей.

Как зайти в систему администатором (пользователь Administrator)?

Самый простой способ - отключить режим Welcome screen . Кроме этого, залогиниться как Administrator можно, если начать загрузку системы в режиме Safe mode. Наконец, есть и третий, самый хитрый способ: после появления экрана "Welcome screen" дважды нажмите Ctrl+Alt+Del

Как переименовать папку аккаунта Administrator?

Сначала входим в систему под аккаунтом Administrator и создаем в директории Documents and Settings папку с нужным именем. Затем через контекстное меню My computer / Properties / Advanced добираемся до User Profiles, где копируем профиль администратора в созданную папку. После этого открываем в реестре ключ HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ ProfileList и находим там ветвь, соответствующую профилю администратора (по значению ключа ProfileImagePath) и исправляем в ней этот параметр на нужный. Теперь можно перелогиниться...


Процессоры AMD

На этот раз речь пойдет об усмирении знойного характера процессоров компании AMD. Среди ряда пользователей ПК и тех, кто только собирается таковым стать, бытует мнение, что эти процессоры выделяют очень много тепла и для их устойчивой работы необходимы едва ли не пятикилограммовые медные радиаторы и подобающие высокооборотистые вентиляторы. Если к данному вопросу подойти с холодным умом и здравым рассудком (чем мы сейчас и займемся), то описанная ситуация видится совершенно в ином свете.

Энергопотребление, равно как и тепловыделение процессоров Intel Pentium 4 ничуть не меньше этих же показателей для процессоров AMD Athlon XP. Более того, у старших моделей P4 рассеиваемая мощность даже выше, чем у «камней» от AMD. Но почему же тогда клеймо «горячих» получили именно последние? Дело в том, что системы на P4 и процессорах от AMD имеют различную архитектуру. Поэтому если в «разгрузочное время» для перехода P4 в режим энергосбережения необходимо подавать на процессор команду Halt, то для Athlon XP это недостаточное условие. Чтобы дать отдохнуть процессору Athlon XP (равно как и Duron’у), необходимо произвести «отключение» процессора от системной шины (режим Bus Disconnect), иначе он будет молотить пустые циклы с довольно низким КПД.

Реализация функции отключения процессора от системной шины, в общем-то, не представляет особых трудностей, по счастливой случайности все чипсеты, когда-либо выпускавшиеся под платформу Socket A, поддерживают режим Bus Disconnect. Вот только по умолчанию он деактивирован. Что ж, будем активировать. Для этого нам понадобятся две небольшие программы — WPCREdit (http://download.viahardware.com/ wpcredit/wpcre12a.exe, 64.9 Кб) и WPCRSet (http://download.viahardware.com/ wpcredit/wpcrs120.exe, 59.6 Кб).

Программа WPCREdit потребуется всего единожды. После того, как вы ее скачаете, лучше сохранить файл в отдельную папку, так как это самораспаковывающийся архив, и его активация приводит к разархивации содержимого без предварительного указания пути. Утилита не требует инсталляции и предназначена для просмотра и редактирования управляющих регистров шины PCI. Программа WPCRSet отвечает за автоматическую установку запрограммированных значений в процессе запуска операционной системы. Ее нужно проинсталлировать, запустив файл instdd.exe.

После всех этих перипетий не помешало бы вспомнить, на каком чипсете основана ваша материнская плата (для этого проще всего заглянуть в руководство к плате).

Итак, вы знаете, какой чипсет установлен на вашей плате и полны решимости сделать свой вклад в борьбу с глобальным потеплением на планете. Запустите программу WPCREdit (wpcredit.exe). Перед вами таблица регистров нулевого PCI-устройства — системного контроллера. Все, что нужно сделать, — установить в 1 (единицу) один из битов в одном из байтов :-). Какой именно — зависит от чипсета и отчасти от BIOS материнской платы. Непосредственно процессор переводится в режим энергосбережения подпрограммами интерфейса ACPI, код которого содержится в BIOS. Последний может переводить процессор в режим энергосбережения либо командой Halt, либо командой чтения из специального ACPI-порта. Замечено, что AMI BIOS обычно использует Halt, а AWARD — команду чтения ACPI-порта. В зависимости от этого нужно редактировать регистры. Для чипсетов VIA KT133, KT133A, KT133E и, возможно, серий КМ133 и KLE133 (для последних — не проверялось) нужно редактировать 7-ой (старший) бит регистра 52 в случае ACPI-охлаждения. И 1-ый бит (напоминаем — биты считаются с нулевого, справа налево) 55-го регистра, если охлаждение происходит через Halt. Кстати, особо ленивые могут поставить сразу оба варианта — это ничему не помешает.

Регистры для других чипсетов:

КТ266, КТ266А, КТ333CE (и, возможно, КМ266) — регистр 92 бит 7 и регистр 95 бит 1 соответственно; КТ333CF, KT400 — регистр D2 бит 7 и регистр D5 бит 1 соответственно;

AMD760 — регистр 62 бит 1 и регистр 62 бит 1 соответственно;

SiS735 — регистр 6А, биты 0–1. Какой именно отвечает за охлаждение посредством Halt, а какой ACPI, точно сказать не можем, так как у нас отсутствуют платы на этом чипсете. Проверьте оба — это не опасно.

Для чипсета NVIDIA nForce 2 — регистр 6F, бит 4 — охлаждение ACPI. Какой бит отвечает за охлаждение посредством Halt — нам не известно, так как экземпляры плат на nForce2 с BIOS, использующим Halt, еще не попадались.

Еще — как отличить КТ333CE от KT333CF? Посмотрите (все в том же WPCREdit), в каком из регистров — 92 или D2 — находится значение 69 или 6B. Это и будет нужный регистр. Установите его старший бит в 1 — полученное значение окажется, соответственно, E9 или EB.

Рис. 1. Давайте рассмотрим процесс редактирования значения регистра на примере платы с чипсетом nForce2.Регистр 6F имеет значение 0F (или в бинарном коде 00001111) (рис. 1). Биты с нулевого по третий установлены в 1. Теперь нужно поменять четвертый бит с 0 на 1. Для этого просто выбираем его курсором и меняем значение на 1. Теперь жмем Enter для подтверждения изменения. Все, значение регистра изменилось на 1F.

Отредактируйте, согласно вышеописанной технологии, соответствующие биты для вашей платы и понаблюдайте за температурой процессора — она должна довольно быстро начать снижаться (особенно если плата производит мониторинг температуры по внутреннему термодатчику процессора). Запомните или запишите значения, которые появились в исправленных регистрах после редактирования нужных битов.

Итак, нужный бит найден и установлен. Теперь неплох было бы закрепить успех, для чего потребуется программа WPCRSet. Запустите файл wpcrset.exe и выставите переключатель Startup в положение Start. Нажмите кнопку Add. Введите номер нужного регистра и значение, которое у вас получилось при редактировании этого регистра. Нажмите OK, чтобы добавить значение, и еще раз OK, чтобы сохранить его и выйти. Программа попросит перезагрузиться — этого можно не делать, ведь мы и так выставили нужные показатели в регистре при помощи WPCREdit.

Или с помощью утилиты Vcool http://vcool.occludo.net температура процессора в простое поддерживается на уровне 35 градусов. Утилита совершенно замечательная. Весит она всего около 40 Кб и однозначно должна присутствовать у любого владельца компьютера на базе процессора AMD. Принцип ее работы довольно прост. Процессоры AMD имеют несколько другой алгоритм входа в режим простоя, чем процессоры Intel. Современные операционные системы, к которым относятся не только все версии Windows, но и "Линукс", замечательно умеют охлаждать процессоры Intel, но не додают одну команду процессорам AMD. В результате этот вид процессоров отдыхает как бы "наполовину". VCool ставится как драйвер и додает процессорам AMD ту самую недостающую команду. После этого система на AMD у вас перестанет исполнять роль вспомогательного обогревателя квартиры. Работает программа под всеми версиями Windows, у автора также имеется версия и для "Линукс".

Вот тебе первая выгода…

Каких же результатов на практике можно достичь при включении режима Bus Disconnect? Чтобы продемонстрировать реальную пользу от этого, мы представляем вам диаграмму рабочих температур в различных режимах работы процессора. Для эксперимента использовалась материнская плата Soltek SL-75DRV5 и процессор Athlon XP с частотой 2250 МГц (ну, разогнан слегка, не без этого :-)). Нужно заметить, что значения температуры получены по внутреннему датчику процессора. Поэтому если ваша плата измеряет ее по внешнему датчику, не пытайтесь воспроизвести такую же (то есть максимальную). Ну как? Нам кажется, что цифры говорят сами за себя.

Вот тебе вторая выгода…

Существенно снизив температуру процессора, можно браться за утихомиривание вентилятора — будем двух зайцев одним выстрелом бить. Ну, в самом деле, зачем ему вертеться на полных оборотах, если температуры процессора и помещения практически совпадают.

Рис. 2. Схема Схему, представленную на рисунке 2 отличают максимальная простота и надежность. Аналогичная система уже долгое время работает в домашнем компьютере у одного из авторов данной статьи.

Полевой транзистор, указанный в схеме, при желании может быть заменен практически любым другим силовым MOSFET’ом. Автор использовал имевшийся в наличии SST60N06, но покупать специально именно такой же мы не рекомендуем. Ведь его цена гораздо выше, чем у менее мощных транзисторов, которые, тем не менее, сгодятся для этой цели. Терморезистор RT1 также может быть подобран в зависимости от объемов закромов Родины :-). Вполне подойдет деталь с номинальным сопротивлением от пары кОм до нескольких десятков кОм. Сопротивление подстроечного резистора R1 подбирается в зависимости от резистора RT1 — номинал R1 должен быть примерно в 2 раза меньше номинала RT1.

Настройка схемы сводится к регулировке порога запуска вентилятора. Для этого подключите схему к блоку питания (если вы используете для настройки БП вашего компьютера — не забудьте установить кулер на процессор). Далее, подстраивая резистор R1, найдите положение, в котором вентилятор не будет крутиться при комнатной температуре терморезистора RT1, но начнет запускаться при нагревании RT1 теплом руки. После настройки схемы терморезистор крепится к радиатору процессора. На этом самострой заканчивается.

Если вы работаете в текстовом редакторе, при этом слушая любимые MP3-шки, а вентилятор на процессоре вовсе не вращается, — не пугайтесь, теперь это для него лишнее. С увеличением температуры сопротивление терморезистора начнет плавно уменьшаться, и вентилятор будет постепенно набирать обороты, достигая предельных значений в игровых баталиях. Но перед тем как закрыть корпус, проконтролируйте работу системы. Вентилятор в обязательном порядке должен запускаться и увеличивать обороты при повышении температуры, иначе последствия могут оказаться довольно неприятными.

Подводные камни

Замечено несколько возможных проблем, связанных с арбитражем шины PCI при включенном режиме Bus Disconnect. Иногда могут возникать трудности с неправильным воспроизведением звуков (хрипца) sound-картами (в основном фирмы Creative). Такие проблемы практически всегда решаются увеличением значения PCI Latency Timer для звуковой карты. Для того чтобы это сделать, необходимо вновь запустить wpcredit.exe, нажать кнопку Select Device..., выбрать устройство Audio Controller и изменить значение его регистра 0D на максимально возможное (все биты установить в 1). Если после ввода некоторые биты снова сбросились в 0 — не пугайтесь, это означает, что максимальное значение регистра меньше FF. Если такое вмешательство помогло — снова запускайте WPCRSet и добавляйте соответствующую строку, не забыв ввести номер нужного устройства (Device).

На чипсетах производства VIA с видеокартами фирмы NVIDIA иногда наблюдается проблема, выражающаяся в замедлении программ, работающих с 2D-графикой. Разрешить ее можно установкой драйверов Detonator 28.32 или более ранних.

При использовании низкокачественного блока питания или звуковой карты возможно появление в колонках негромких шумов, изменяющихся в зависимости от загруженности процессора. Проблема решается только заменой комплектующих на более качественные или установкой дополнительных конденсаторов в цепи питания, но это уже тема для отдельной статьи.


Принцип работы жестких дисков

  • Как работает жесткий диск?

  • Типы интерфейсов (IDE/SCSI)

  • Производительность

  • Файловые системы

  • S.M.A.R.T.

  • Функция Bus Master

  • Драйвера поддержки Bus Master

  • Проблемы, возникающие при работе с драйверами Bus Master

    Как работает жесткий диск?
    Как правило, всех пользователей интересует один вопрос: "быстрый" ли диск? Ответ на него неоднозначен и требует рассказа о следующих характеристиках:

    • Скорость вращения диска

    • Количество секторов на дорожке

    • Время поиска/время переключения головок/время переключения между цилиндрами

    • Задержка позиционирования

    • Время доступа к данным

    • Кэш-память на жестком диске

    • Размещение данных на диске

    • Скорость обмена между процессором и диском

    • Интерфейс (IDE или SCSI)

    Опишем, для начала, как физически устроен жесткий диск.
    На жестком диске данные хранятся на магнитной поверхности диска. Информация записывается и снимается с помощью магнитных головок (все почти как в магнитофоне). Внутри жесткого диска может быть установлено несколько пластин (дисков), в просторечье именуемые "блинами". Двигатель, вращающий диск, включается при подаче питания на диск и остается включенным до снятия питания.
    ПРИМЕЧАНИЕ: Если в разделе Power Management программы Setup из BIOS установлен параметр выключения жесткого диска при отсутствии обращения к нему, то двигатель может быть выключен программой BIOS. Двигатель вращается с постоянной скоростью, измеряемой в оборотах в минуту (rpm). Данные организованы на диске в цилиндрах, дорожках и секторах. Цилиндры - концентрические дорожки на дисках, расположенные одна над другой. Дорожка затем разделяется на сектора. Диск имеет магнитный слой на каждой своей стороне. Каждая пара головок одета как бы на "вилку", обхватывающую каждый диск. Эта "вилка" перемещается над поверхностью диска с помощью отдельного серводвигателя (а не шагового, как часто ошибочно думают - шаговый двигатель не позволяет быстро перемещаться над поверхностью). Все жесткие диски имеют резервные сектора, которые используются его схемой управления, если на диске обнаружены дефектные сектора.

    Скорость вращения диска
    Обычно современные жесткие диски имеют скорость вращения от 5400 до 7200 об/м. Чем выше скорость вращения, тем выше скорость обмена данными. Следует только учесть, что при возрастании скорости вращения увеличивается температура корпуса жесткого диска и диски со скоростью 7200 об/мин требуют либо применения корпуса с продуманной для целей отвода тепла конструкцией, либо дополнительного охлаждения внешним вентилятором собственно диска. Вентилятора блока питания для этого недостаточно. Еще более высокооборотные диски со скоростью вращения 10000 об/мин, которые сейчас выпускают все без исключения фирмы-производители, требуют как хорошей вентиляции внутри корпуса, так и "правильного" корпуса, хорошо отводящего тепло. Жесткие диски на 15000 об/мин без принудительного обдува просто не рекомендуется использовать.

    Количество секторов на дорожке
    Современные жесткие диски имеют различное количество секторов на дорожке в зависимости от того, внешняя ли это дорожка или внутренняя. Внешняя дорожка длиннее и на ней можно разместить больше секторов, чем на более короткой внутренней дорожке. Данные на чистый диск начинают записываться также с внешней дорожки.

    Время поиска/время переключения головок/время переключения между цилиндрами
    Время поиска (seek time) минимально только в случае необходимости операции с дорожкой, которая является соседней с той, над которой в данный момент находится головка. Наибольшее время поиска соответственно при переходе с первой дорожки на последнюю. Как правило, в паспортных данных на жесткий диск указывается среднее время поиска (average seek time).

    Все магнитные головки диска находятся в каждый момент времени над одним и тем же цилиндром, и время переключения определяется тем, насколько быстро выполняется переключение между головками при чтении или записи. Время переключения между цилиндрами - это время, требуемое для перемещения головок на один цилиндр вперед или назад. Все времена указываются в документации на жесткие диски в миллисекундах (ms).

    Задержка позиционирования
    После того, как головка оказывается над желаемой дорожкой, она ждет появления требуемого сектора на этой дорожке. Это время называется задержкой позиционирования и также измеряется в миллисекундах (ms). Среднее время задержки позиционирования считается как время поворота диска на 180 градусов и, поэтому зависит только от скорости вращения шпинделя диска. Конкретные данные по величине задержки сведены в таблицу.

    Скорость вращения,
    об/мин         		Задержка,
    миллисекунды

    3600

    8.3

    4500

    6.7

    5400

    5.7

    7200

    4.2

    10000

    3.3

    Время доступа к данным
         Время доступа к данным по сути - это комбинация из времени поиска, времени переключения головок и задержки позиционирования, измеряется также в миллисекундах (ms). Время поиска, как вам уже известно, это только показатель того, как быстро головка оказывается над нужным цилиндром. До тех пор, пока данные не записаны или считаны, следует добавить время на переключение головок и на ожидание необходимого сектора.
    Кэш-память на жестком диске
    Как правило, на всех современных жестких дисках есть собственная оперативная память, называемая кэш-памятью (cache memory) или просто кэшем. Производители жестких дисков часто называют эту память буферной. Размер и структура кэша у фирм-производителей и для различных моделей жестких дисков существенно отличаются. Обычно кэш память используется как для записи данных так и для чтения, но на SCSI дисках иногда требуется принудительное разрешение кэширования записи, так обычно по умолчанию кэширование записи на диск для SCSI запрещено. Есть программы, позволяющие, определить, как установлены параметры кэш-памяти, например ASPIID от фирмы Seagate. Как это многим не покажется странным, размер кэша не является определяющим для оценки эффективности его работы. Организация обмена данными с кэшем более важна для повышения быстродействия диска в целом.
    Некоторые производители жестких дисков, такие как Quantum, используют часть кэша под свое программное обеспечение (для модели Quantum Fireball 1.3 Gb, например, под firmware занято 48 Kb из 128). Как нам кажется, более предпочтителен способ, используемый фирмой Western Digital. Для хранения firmware используются специально отведенные сектора на диске, невидимые для любых операционных систем. По включению питания эта программа загружается в обычную дешевую DRAM на диске и при этом отпадают затраты на микросхему флэш-памяти для хранения firmware. Такой способ позволяет легко исправлять встроенное программное обеспечение жесткого диска, что часто фирма Western Digital и делает.
    Размещение данных на диске
    О том, что конфигурация диска задается через количество цилиндров, головок и секторов на дорожке, все знают с начала эпохи PC. Хотя еще несколько лет тому назад точное указание в программе SETUP всех этих параметров диска было обязательным, сейчас это не так. Строго говоря, те параметры диска, которые вы видите в разделе SETUP Standard CMOS Setup, как правило, ничего общего не имеют с реальными параметрами диска, причем вы можете заметить, что эти параметры меняются в зависимости от вида трансляции геометрии диска - Normal, LBA и Large. Normal - геометрия в соответствии с данной производителем в документации на диск и не позволяет DOS увидеть более чем 504 Mb (1 Mb - 1048576 байт). LBA - Logical Block Address - эта установка позволяет видеть DOS диски объемом до 4 Gb. Large используется такой операционной системой, как Unix. Параметры, установленные в SETUP, преобразуются в реальные логикой управления жестким диском. Многие современные операционные системы работают с диском через LBA, минуя BIOS.
    Скорость обмена между процессором и диском
    Существует несколько способов физического сохранения данных на жестком диске. Определить способ отображения данных на диске можно, только используя различные программы определения быстродействия диска (benchmark). В программу Winbench 98/99 включен High-end тест жесткого диска, где оцениваются не достаточно отвлеченные в настоящее время 2 параметра - скорость передачи данных и время доступа, а проверяется, для каких задач и для каких наиболее популярных программ, активно работающих с диском, диск наиболее пригоден. Этот тест можно получить на сервере фирмы Ziff-Davis.

    " Вертикальное" отображение

    Обычные жесткие диски используют "вертикальное" отображение. Данные записываются сначала на одном цилиндре сверху вниз, затем головки переходят на другой цилиндр и т.д.

    "Горизонтальное" отображение.

При "горизонтальном" отображении сначала данные записываются последовательно от цилиндра к цилиндру на поверхности одного диска, затем также на поверхности следующего диска и т.д. Такой способ лучше подходит для записи непрерывного высокоскоростного потока данных, например, при записи "живого" видео.

"Комбинированный"

Комбинированный способ отображения, использующий как "вертикальный" так и "горизонтальный" способ.
При тестировании таких дисков видно, что чем дальше от начальных цилиндров, тем хуже параметры диска. Это связано с тем, что на внешних дорожках размещается больше секторов и считывание/запись выполняется быстрее.
В справедливости этого легко убедиться, запустив Winbench 97/98/99, выбрав сначала диск C для теста диска, а затем последний логический диск (желателен диск объемом не менее 2.5 Gb). Разница в оценке быстродействия диска для модели WD AC32500 составила 15%!
Реально диск разделен на зоны, в каждую из которых входит обычно от 20 до 30 цилиндров с одинаковым количеством секторов. Эти зоны также называются "notches".
Чем выше плотность записи на диск, тем выше будет скорость считывания с него. Именно поэтому при оценке параметров диска следует внимательно смотреть на внутреннюю скорость передачи данных. Внутренняя скорость передачи данных прямо пропорциональна плотности записи на диск и скорости вращения шпинделя. Так как увеличивать скорость вращения диска достаточно сложно - увеличивается энергопотребление, шум, возникают проблемы с теплоотводом, то наиболее оптимальный путь повышения производительности - это увеличение плотности записи на диск. Именно поэтому современный жесткий диск со скоростью вращения 5400 об/мин легко опережает по производительности диск с 7200 об/мин, выпущенный двумя годами ранее. Все производители жестких дисков в первую очередь и заняты проблемой повышения плотности записи. При прочих равных условиях, из двух накопителей равной емкости быстрее будет работать накопитель с меньшим количеством дисков, т.е. с большей плотностью записи.
Интерфейс (IDE или SCSI)
Сейчас фактически осталось только два действующих интерфейса: IDE (распространенный сейчас в варианте Enhanced IDE - EIDE) и SCSI. На любой материнской плате, выпущенной после 1996 года, можно обнаружить контроллер EIDE. Это, а также существенно более низкая стоимость IDE дисков по сравнению со SCSI объясняет значительное превосходство IDE дисков в количественном выражении над SCSI.
Каждый контроллер EIDE имеет два канала (primary - первичный и secondary - вторичный), к каждому из которых можно подключить до двух устройств (всего четыре). С интерфейсом IDE в настоящее время, кроме жестких дисков, выпускаются также приводы CD-ROM, накопители Iomega Zip, накопители на магнитной ленте. Интерфейс SCSI, как правило, требует отдельного контроллера, так как пока очень незначительное количество материнских плат выпускаются с контроллером SCSI. Сканеры, магнитооптические накопители, устройства записи для CD и т.п. выпускаются как с интерфейсом SCSI, так и с IDE. При принятии решения о покупке жесткого диска с тем или иным интерфейсом, следует учесть главное - если вам не требуется подключение нескольких жестких дисков, ваш компьютер не является сервером или мощной рабочей станцией, ресурсы которой доступны другим пользователям, SCSI диск НЕ ДАСТ НИКАКИХ ОЩУТИМЫХ ПРЕИМУЩЕСТВ по сравнению с EIDE диском. Это правило, естественно, справедливо для одинаковых по физическим характеристикам дисков. Выигрыш будет только в снижении нагрузки на центральный процессор за счет использования процессора SCSI контроллера. Интерфейс SCSI позволяет подключать до 7 устройств, а Wide SCSI до 14 устройств. Существуют также многоканальные SCSI контроллеры, позволяющие подключить и большее количество устройств.
Основной недостаток интерфейса EIDE - отсутствие "интеллекта". Если на одном канале подключены жесткий диск и накопитель CD-ROM, то в случае обращения к CD-ROM процессор будет ожидать завершения операций с CD-ROM, прежде чем сможет обратиться к жесткому диску. Поэтому очевидно, что нельзя к одному каналу EIDE подключать быстрое и медленное устройство одновременно. CD-ROM всегда следует подключать только ко второму каналу. Каналы EIDE в современных контроллерах EIDE, как правило, достаточно независимы друг от друга. Для повышения производительности EIDE были разработаны и стандартизованы режимы PIO (Programming Input Output - программируемый ввод/вывод), single word DMA (обмен одиночными словами в режиме DMA - Direct Memory Access - прямого доступа к памяти) и multi word DMA (обмен несколькими словами в режиме DMA).
SCSI интерфейс имеет несколько разновидностей, которые совместимы друг с другом (достаточно иметь пассивные переходники). 8 бит (50-ти контактный разъем) или 16 бит (68-и контактный разъем для Wide SCSI). Частота шины может быть 5 MHz (SCSI 1), 10 MHz (Fast SCSI), 20 MHz (Fast-20 or Ultra SCSI) or 40 MHz (Ultra-2 SCSI).
Сейчас стал активно внедряться стандарт Ultra2 SCSI LVD, являющийся разновидностью Ultra2 SCSI. Полное название стандарта - Ultra2 SCSI (LVD) Low Voltage Differential Parallel SCSI Interface, т.е. низковольтный дифференциальный параллельный SCSI интерфейс. Этот вариант SCSI существенно отличается от всех своих предшественников по двум параметрам:
  1. Скорость передачи увеличена до 80 MB/s
  2. Максимальная длина соединительного кабеля может достигать 12 метров
Кроме этого, к одному шлейфу можно подключить до 15 устройств. Обратная совместимость, как это принято для SCSI устройств, также выдерживается и устройство с Ultra2 SCSI LVD можно подключить к обычному контроллеру SCSI. С этим интерфейсом выпускаются только жесткие диски в вариантах с 68-контактным разъемом (Wide) и SCA.
Но и скорость в 80 MB/s, как оказалось, не является предельной на сегодняшний день. Уже начинает внедряться производителями как контроллеров, так и жестких дисков следующий вариант SCSI, называемый официально как SPI-3 (SCSI Parallel Interface - 3), неофициально Ultra160/m SCSI. Он разработан на базе Ultra2 SCSI LVD и отличается удвоенной скоростью передачи данных. Каким образом это достигнуто, видно из схематичной временной диаграммы. ultra160diag.gif (1001 bytes)

По диаграмме ясно, что передача данных синхронизируется как по заднему, так и по переднему фронту сигнала ACK и, тем самым, скорость передачи удваивается по сравнению с Ultra2 SCSI LVD. На обычном SCSI (Ultra2) тактовая частота составляла 40 MHz, частота для данных 20 MHz и можно таким образом передать до 40 MBytes/s (так как за один цикл передается 2 байта), на Ultra2 SCSI LVD частота передачи данных была увеличена до 40 MHz и тем самым скорость обмена возросла до 80 MBytes/s.
Существенным отличием нового стандарта является только 32-х разрядный алгоритм CRC контроля передаваемых/принимаемых данных. Ранее в SCSI использовался только контроль по четности, да и его можно было легко отключить (что часто и делали) в BIOS SCSI контроллера. Новый алгоритм контроля позволяет обнаруживать ошибки в пакетах данных до 32-х бит длиной.

С более подробным разъяснением терминологии SCSI можно ознакомиться в "SCSI Глоссарии".

Максимально возможная скорость передачи данных для интерфейса SCSI и максимально допустимые длины кабелей
Частота шины SCSI | 8 бит (50-ти контактный разъем) |  | 16 бит (68-и контактный разъем, Wide SCSI)
 | Макс. скорость обмена | Макс. длина кабеля | Макс. скорость обмена | Макс. длина кабеля
5 MHz (SCSI 1) | 5 MB/s | 6 m | N/A* | -
10 MHz (Fast SCSI, SCSI II) | 10 MB/s | 3 m | 20 MBytes/s | 3 m
20 MHz (Fast-20, Ultra SCSI) | 20 MB/s | 1.5 m | 40 MBytes/s | 1.5 m
40 MHz (Ultra-2 SCSI) LVD | N/A | N/A | 80 MBytes/s | 12 m
40 MHz (Ultra3 SCSI) LVD | N/A | N/A | 160 MBytes/s | 12 m

*Примечание: N/A - режим отсутствует

С массово выпускаемыми в настоящее время жесткими дисками EIDE максимально возможная скорость обмена данными составляет 66.6 MByte/s для режима multi DMA mode 2. Поскольку собственно скорость обмена повышена за счет добавления возможности передачи данных как по переднему, так и по заднему фронту сигнала записи или чтения, совместимость как жестких дисков с UltraDMA/66 с обычным контроллером, так и контроллера UltraDMA/66 с обычным EIDE диском есть без каких-либо проблем.
Стандарты UltraDMA/33 и UltraDMA/66 отличается от предыдущих улучшений IDE не только скоростью обмена. Впервые в них используется механизм обнаружения ошибок с помощью CRC (циклический контрольный код). Это позволяет избежать ошибок при приеме/передаче данных, так как при получении данных с ошибкой пересылка данных повторяется снова.
Первой диски в стандарте UltraDMA/33 выпустила фирма Quantum - Fireball ST (это не удивительно, поскольку она вместе с Intel и явилась автором стандарта). При установке нового диска на компьютер, в случае появления сбоев в работе, следует понизить скорость работы жесткого диска, принудительно установив в SETUP меньший режим PIO. Мы сталкивались с таким явлением на дисках, выпущенных до 1997 года - хотя жесткий диск согласно его документации в mode 4 работать должен, но не работает устойчиво!
Все вновь выпускаемые жесткие диски с 1999 года поддерживают стандарт UltraDMA/66, который уже стал фактически новым стандартом на интерфейс IDE жестких дисков.

Максимально возможная скорость передачи данных для интерфейса IDE (он же ATA)
single word DMA 0 | 2.1 MByte/s
PIO mode 0 | 3.3 Mbyte/s
single word DMA 1, multi word DMA 0 | 4.2 MByte/s
PIO mode 1 | 5.2 MByte/s
PIO mode 2, single word DMA 2 | 8.3 MByte/s
Максимально возможная скорость передачи данных для интерфейса EIDE (он же ATA-2)
PIO mode 3 | 11.1 MB/s
multi word DMA 1 | 13.3 MB/s
PIO mode 4, multi word DMA 2 | 16.6 MB/s
Максимально возможная скорость передачи данных для интерфейса Ultra-ATA (он же ATA-3) (он же Ultra DMA/33)
multi word DMA 2 | 33.3 MB/s
Максимально возможная скорость передачи данных для интерфейса Ultra-ATA/66 (он же ATA-4) (он же UltraDMA/66)
multi word DMA 2 | 66.6 MB/s

Реально максимальная скорость передачи данных для любого диска не превышает 10 MB/s, так как механические характеристики диска обойти невозможно. Большие значения скоростей относятся к работе с внутренним кэшем жесткого диска. Так как объем кэш-памяти для IDE дисков не превышает 2 MBytes, а объем кэш-памяти для SCSI дисков в большинстве случаев не более 4 MBytes, то скорость обмена данными не является определяющей при оценке производительности жестких дисков.

Интерфейс SCSI дает ощутимый выигрыш в основном только в многозадачной среде, когда несколько программ одновременно добиваются доступа к дискам и в случае необходимости достижения максимальной производительности дисковой подсистемы, так как пока только диски SCSI имеют скорость вращения 10000 и 15000 об/мин и время доступа 5-6 ms.
Применение SCSI также еще оправдано при решениях задач, связанных как с высокой нагрузкой на диск так и с существенной загрузкой процессора, например, при обработки больших (по объему) изображений в Adobe Photoshop, хотя необходимость в SCSI дисках в связи с ростом производительности процессоров в подобных случаях становится все меньшей.
Стоимость высокоскоростных SCSI дисков в 2-3 раза выше лучших дисков IDE такой же емкости. По планам производителей жестких дисков различия в физических параметрах жестких дисков IDE и SCSI будут уменьшаться и SCSI диски будут все более уходить в сферу специальных задач - на сервера и мощные рабочие станции. Уже начиная с середины 1999 года отпала необходимость в применении SCSI дисков для работы с видеопотоками, хотя несколькими годами ранее использование IDE дисков для записи видео даже не обсуждалась.

Производительность
Оценка производительности диска - это достаточно сложная задача. Существуют десятки различных тестов, оценивающих тем или иным способом производительность дисковой подсистемы. В связи с тем, что наибольшую популярность сейчас получили многозадачные операционные системы, такие как Windows 95/98, Windows NT/2000, OS/2, Lunix, SCO UNIX и т.п., старые тесты под MS-DOS (Norton Sysinfo, VSeek, Checkit, PC Bench...) уже не дают реального представления о качестве работы диска в многозадачных средах. Для оценки работы жесткого диска под Windows 95 или Windows NT/2000, с нашей точки зрения, лучшим является Winbench 97/98/99 и аналогичные тесты тех же авторов, посколько с диском выполняются действия, максимально приближенные к реальным.

Файловые системы
Как уже сообщалось ранее, жесткие диски поступают с завода-изготовителя уже отформатированными. Все программы так называемого низкоуровнего форматирования на самом деле не выполняют физического форматирования жесткого диска, а только полностью уничтожают содержимое диска (что часто тоже требуется). Различные операционные системы же своими программами форматирования создают лишь ЛОГИЧЕСКУЮ структуру диска. В настоящее время наиболее распространены 4 файловые системы - FAT (MS-DOS, Windows 3.X, Windows 95/98), NTFS (Windows NT/2000), FAT32 (Windows 95/98) и HPFS (OS/2).

FAT16

DOS, DOS 7.0 из Windows95 использует FAT для сохранения данных как на жестких дисках, так и гибких. В качестве одного элемента адресации на диске используется кластер, объединяющий несколько секторов. FAT исторически сама старая файловая система с 16-ти разрядной адресацией и максимально возможное количество кластеров на одном логическом диске не превышает 65536. Соответственно максимальный размер одного кластера 32 Kb, так как максимальный размер логического диска 2 Gb. Поэтому один из главных недостатков FAT - большой размер кластера. Дело в том, что при кластере 32 Kb файл с информацией в 1 байт займет на диске 32 Kb. Теоретически можно заполнить логический диск в 2 Gb 65536 файлами по 1 байту, хотя физически диск будет практически пустой. Поэтому при работе с DOS, Windows 95 или Windows NT под FAT рекомендуется разбивать диск на разделы, не превышающие 1 GBytes. Для разбиения/переразбиения диска можно воспользоваться известной программой Partition Magic.

Соотношение между размером раздела диска и размером кластера на диске
Размер раздела | Размер кластера
2 GByte | 32 KByte
<1 GByte | 16 KByte
<512 MByte | 8 KByte
<256 MByte | 4 KByte
<128 MByte | 2 KByte

FAT32
Попытка отказаться от ограничений классической FAT и видоизменить ее была тихо предпринята фирмой Microsoft в версии Windows 95 OEM service Release 2 (v.4.00.1111&DOS 7.1 - также 950b). В этом варианте Windows 95 FAT стала 32-х разрядной. Из 32 бит 4 были зарезервированы. Таким образом, максимальный размер раздела в этом варианте становится 2 Tb (2048 Gb), а раздел в 8 Gb получает кластер размером всего 4 Kb. Кроме этого, корневая директория диска не имеет фиксированного размера, что снимает ограничения на количество файлов и директорий в корневом каталоге. При этом приложения DOS не могут работать с файлами более 2 Gb, а 32-x разрядные приложения Windows могут работать с файлами до 4 Gb.

  • Все это было бы замечательно, если бы не некоторые но, существенные на момент появления FAT32:
  • кроме как DOS 7.1 и Windows 95 v.950b или Windows 98 (даже NT 4.0!) эту прекрасную систему никто не видит;
  • любые дисковые утилиты, не написанные специально под FAT32, будут "творить чудеса" с ней;
  • попытка работы с FAT32 программами, которые ее не понимают, может привести к гибели данных на диске;
  • утилиты для работы со SCSI дисками также должны быть разработаны под FAT32;
  • производительность дисковой подсистемы по Winbench 97 чуть меньше с FAT32 по сравнению с FAT16.

Но те преимущества, которые дает FAT32, как правило, перевешивают недостатки. В команде format OSR2 есть недокументированный ключ z, с помощью которого можно создать логический диск с кластером от 1024 байт. Синтаксис команды: размер кластера 512 format диск: /z:n, где n - множитель для 512 (собственно 512 байт и параметр n=1 запрещены), поэтому n может быть равен 2, 4, 6 и т.д. Желательно только понимать, что при кластере в 1 Kb на диске объемом 3000 Mb будет 3 миллиона кластеров и процесс, скажем, дефрагментации диска может занять часы... Разумно уменьшить размер кластера на том логическом диске, который используется для хранения программ и оставить его 4 Kb (размер кластера по умолчанию для Windows 95 OSR2) на остальных.
В Windows 98 появилась возможность конвертировать разделы FAT16 в FAT32. С появлением Windows NT 5.0 (или Windows NT 2000, как ее теперь называют) FAT32 стала новым фактическим стандартом файловой системы для приложений, не требующих высокой степени защиты информации, а FAT16 уйдет с рынка за ненадобностью.

NTFS (NT File System)
 После выхода Windows 2000 NTFS постепенно становится все более и более популярной. Основные отличия от FAT32 - неограниченный размер файлов (до 12 TBytes) и возможность управлять правами доступа к файлам и каталогам.

S.M.A.R.T.
Эта аббревиатура все чаще встречается при указании технических характеристик жестких дисков. Что она означает?
Идея S.M.A.R.T. (Self-Monitoring Analysis and Reporting Technolodgy - технология самоанализа и информирования) технологии заключается в создании механизма предсказания возможного выхода из строя жесткого диска и предотвращения тем самым потери данных. S.M.A.R.T. была предложена фирмами COMPAQ и IBM несколько лет тому назад и сейчас включена в версию стандарта ANSI X3T10. Сейчас S.M.A.R.T. технология используется в программе BIOS от фирмы AWARD Software и в ряде программ под Windows 95 (например, S.M.A.R.T. Vision от ACE Laboratory).
Для анализа надежности жесткого диска используются две группы параметров (здесь и далее подразумевается жесткий диск, поддерживающий S.M.A.R.T. технологию). Первая характеризует параметры естественного старения жесткого диска:

  • количество циклов включения/выключения (старт/стоп)
  • количество оборотов двигателя за время работы
  • количество перемещений головок

Вторая группа параметров уже информирует о текущем состоянии качества накопителя. К этим параметрам относятся:

  • высота головки над поверхностью диска
  • скорость обмена данными между дисками и кэш-памятью на диске
  • количество переназначений плохих секторов (когда вместо испорченного сектора подставляется свободный исправный)
  • количество ошибок поиска
  • количество операций перекалибровки
  • скорость поиска данных на диске

Данные о типичных дефектах жесткого диска и способах их предсказания сведены в таблицу:

Вид дефекта | Симптом/Чем вызвано | Что предсказывает
Большое количество плохих секторов | Физические дефекты поверхности, повреждения при транспортировке | Количество дефектов поверхности, скорость их роста
Чрезмерный шум | Дефект мотора, повреждения при транспортировке | Диагностика
Значительное количество нерегулярных ошибок | Повреждение головки или ее загрязнение | Частые повторы при обращении к диску, срабатывание схемы ECC контроля
Отказ мотора | Не вырабатывается сигнал готовности, нет шума вращения дисков/ Дефект мотора, повреждения при транспортировке | Повторы включения, увеличение времени набора номинальной скорости вращения
Диск не отвечает (эффект такой же, как при отсутствии диска) | Дефект электроники диска | Ничто не может предсказать катастрофу в данном случае (к сожалению)
Ошибки позиционирования серводвигателя | Большое количество ошибок перемещения головок/ повреждения при транспортировке | Ошибки позиционирования, частые повторы калибровки
Сбой работы головки, резонанс при ее перемещении | Значительное количество нерегулярных ошибок | Рост ошибок при чтении, а также ошибок позиционирования

Значения всех параметров (как и собственное программное обеспечение накопителя), как правило, хранятся на специальных дорожках диска, не видимых со стороны компьютера или, что бывает значительно реже, в энергонезависимой памяти.

У производителей жестких дисков достаточно много степеней свободы, так как именно они присваивают граничные значения (thresholds) всем параметрам. Если хотя бы один параметр ушел за граничные значения, то накопитель желательно заменить. Конечно, пока механизм наблюдения за накопителем не будет встроен в операционную систему, трудно ожидать массового использования технологии S.M.A.R.T. Подробнее об этом (и обо всем, что связано с IDE) можно узнать из соответствующих документов на посвященном IDE стандартам сайте.

В силу некоторой ограниченности технологии S.M.A.R.T (пользователь ставится перед свершившимся фактом - диск как-то почти сломался, его осталось только заменить), появились расширения способов предотвращения потери данных, разработанных отдельными фирмами-производителями жестких дисков.
Для примера можно рассмотреть технологию Data LifeguardTM фирмы Western Digital. Основная ее идея - проверка через каждые восемь часов работы поверхности всего диска, выявление секторов, которые могут стать плохими и перенос информации на резервные нормальные области диска. Понятно, что все эти операции выполняются в паузах (которые составляют до 90% времени работы диска) и никак не снижают производительность компьютера. Совместимость с S.M.A.R.T тем не менее полностью сохраняется. Впервые Data LifeguardTM была применена в накопителе AC310100.

Фирма Quantum, начиная с серии жестких дисков Fireball Plus KA применила свою фирменную технологию Data Protection System (DPS), которая отличается от Data LifeguardTM доступной на WEB программой диагностики, позволяющей выявить возможные дефекты и во многих случаях устранить их. Quantum утверждает, что ее диагностическая программа способна "лечить" все диски, выпущенные этой компанией с июня 1996 года.

Функция Bus Master
Функция Bus Master (дословно Хозяин Шины, ранее по ГОСТ в нашей стране - задатчик на шине) введена в контроллеры EIDE с приходом процессоров Pentium. Что это такое? Классический способ приема данных от какого-либо устройства следующий - процессор выполняет команду чтения порта, считывает байт или слово данных в свой регистр, после чего переписывает этот байт или слово в память, затем повторяет эту процедуру до тех пор, пока вся необходимая информация не будет считана из устройства в память. Если бы процессору больше нечего было делать, то этот способ всех бы устраивал. Но с появлением многозадачных операционных систем стало слишком накладно использовать процессор для операций ввода/вывода. Поэтому контроллеры внешних устройств (EIDE в частности) стали оборудоваться как бы собственными процессорами ввода/вывода. С появлением шины PCI, первой реально многопользовательской шины в архитектуре IBM PC реализация этой идеи стала совсем простой.

Что происходит в этом случае? Процессор программирует контроллер EIDE на шине PCI, указывая ему, откуда он должен взять данные и куда в память их положить. После получения этих указаний контроллер захватывает управление шиной PCI, а драйвер Bus Master управляет шиной доступа к памяти и совместно с контроллером выполняет операции по считыванию данных с жесткого диска или CD-ROM непосредственно в память с помощью контроллера прямого доступа в память (DMA - Direct Memory Access). При таком способе обмена данных процессор свободен после выдачи команд контроллеру EIDE и может заниматься любыми другими делами. Надо только понимать, что процессор может в это время не получить доступ к шине PCI и основной памяти.

Функция Bus Master делает интерфейс EIDE SCSI-подобным (хотя это только подобие - современные контроллеры SCSI на шине PCI также могут работать в режиме Bus Master и, кроме этого, "интеллектуально" управлять своей периферией). Если доступ к диску выполняет только одна, запущенная в данный момент программа, то значительного выигрыша в производительности не будет. Но достаточно запустить несколько приложений, работающих с диском, как заметное повышение производительности будет очевидным. Это легко проверить, запустив одновременно, например, два Winbench 99 с тестом диска с Bus Master драйверами или без оных. В контроллерах IDE из наборов микросхем фирмы Intel, ранее называемых Triton, встроена функция Bus Master. Intel называет эти контроллеры PIIX (Pci Isa Ide aXcelerator). Пока Intel выпустил 4 таких контроллера 80371FB (PIIX), 82371SB (PIIX3), 82371AB и 82371EB (PIIX4). Предпоследний из них входит в набор Intel 430TX - это первый Intel контроллер IDE с поддержкой режима Ultra DMA/33. Сейчас, в основном, используется 82371AB&EB, включая и материнские платы на Pentium II/III. На платах с набором 80440BX применяется микросхема 82371EB, функционально ничем не отличающаяся от 82371AB, но допускающая обращение к ней со стороны процессора с частотой 100 MHz. В наборах i810, i810e, i820, i840 поддерживается стандарт UltraDMA/66, а в наборах i815E, i815EP и далее поддерживается UltraATA100.

Следует заметить, что Windows 95 OSR2 не совсем корректно работала с парой "UltraDMA жесткий диск - UltraDMA контроллер". Фирма Western Digital отмечает высокую вероятность ошибок при работе в этом случае и настоятельно рекомендует использовать драйвера Bus Master от Intel, поскольку в их работе ошибок нет. Сама Microsoft также подтверждает существование проблемы.

В Windows 98 драйвера IDE работают корректно. Intel прекратила разработку отдельных драйверов Bus Master для Windows 98 до выхода наборов i8xx. В Windows NT функция Bus Master может быть включена с как с помощью специальной программы , так и драйверов от Intel.

Драйвера поддержки Bus Master
Функция Bus Master включается только специальными драйверами под соответствующую операционную систему. Для примера мы предлагаем ссылки на драйверы для Windows 95, OS/2 и Windows NT. Windows 98 не требует установки драйверов Bus Master от третьих фирм, так встроенные в систему драйвера работают вполне удовлетворительно. С нашей точки зрения, наилучшими драйверами Bus Master являлись в свое время драйверы, разработанные фирмой Triones (последняя версия 3.70). Эти драйверы разработаны не только для Windows 95/NT и OS/2, но и для Novell, SCO Unix, MS-DOS. К сожалению, продукт Triones не является freeware или shareware. Комплект драйверов Triones поставлялся вместе с некоторыми материнскими платами, например, фирм Gigabyte, DataExpert, Acer.

  • Intel Bus Master Driver (оригинал от Intel)
  • VIA Bus Master Driver
  • Драйвера Bus Master под все наборы микросхем

В OEM service release 2 Windows 95 подобный драйвер встроен в систему (у него осталось старое имя ESDI_506.pdr). Режим перекачки данных, использующий DMA, может быть отключен в System Manager из Control Panel/System. К своим последним драйверам Intel стал прилагать диагностическую программу Intel Companion, которая сообщает подробную информацию обо всех устройствах, подключенных к IDE интерфейсу и о режимах их работы.

Проблемы, возникающие при работе с драйверами Bus Master
Проблемы, описанные ниже, возникали в таком виде не так давно, сейчас большинство этих проблем устранено, но тем не менее, они представляют некий исторический интерес.

Большинство проблем возникает с накопителями CD-ROM и старыми жесткими дисками. Поэтому после установки драйверов проверьте функционирование системы (сохраните в какой-либо программе файлы, перепишите файлы с диска на диск и т.д.). Рекомендуется также проверить CD-ROM на чтение CD-ROM дисков и воспроизведение аудио дисков. CD-ROM рекомендуется всегда устанавливать как master на втором IDE канале.

Мы столкнулись с тем, что в случае использования материнской платы на наборе 430TX и установкой под Windows NT 4.0 соответствующих драйверов происходил crash системы при использовании CD-ROM приводов Samsung (12-24x), неустойчивая работа с CD-ROM Panasonic модели CR-583 (8-ми скоростной) и т.д. Мы не можем утверждать, что виноваты накопители - может быть, виноваты драйверы (мы тестировали на драйверах от Intel и Triones - результаты были одинаковы), мы просто констатируем факт. 24-х скоростные и выше CD-ROM уже не имеют проблем с драйверами Bus Master.

Если вы обнаружили неприятные эффекты, например "зависание" компьютера при попытке сохранить файл, невозможность проигрывания аудио дисков и т.п., то следует удалить драйвера Bus Master или, что то же самое, очистить поле DMA в свойствах IDE контроллера. В Windows 95 это также делается повторным запуском программы Setup установки драйверов Bus Master и последующего выбора Uninstall.

Из известных нам общих проблем - невозможно проиграть аудио диск в Windows NT 4.0, невозможность просмотра некоторых видов видеодисков в Windows 95 (с драйверами от Triones все в порядке), несколько неустойчивая работа с диском у драйверов Intel.

Множество проблем обсуждаются на сайте BMdrivers.com. Особенно актуальны эти проблемы для пользователей Windows 95 OSR2, в которую Microsoft встроила поддержку Bus Master, но как это часто бывает, с многочисленными ошибками. Ссылки на "заплатки" к Windows 95 OSR2 также есть на этом сайте.

Надо также понимать, что нормальное функционирование режима Bus Master и DMA возможно ТОЛЬКО на правильно спроектированных материнских платах и IDE кабелях. В противном случае операционная система снимет режим DMA, не уведомляя при этом пользователя. Производительность жесткого диска, CD-ROM и других IDE устройств существенно понизится, не говоря уже о возрастании в несколько раз нагрузки на центральный процессор.


Чем отличаются Windows XP Professional и Windows XP Home?

Обе эти системы имеют очень много общего, XP Pro и XP Home построены на одном и том же ядре, NT 5.1. Разница между ними заключается только в том, что XP Home не поддерживает несколько функций, работающих в XP Pro. В XP Home не поддерживаются следующие функции:

  • Remote Desktop – позволяет удалённую работу на компьютере.

  • Offline Files and Folders – позволяет иметь доступ к сетевым ресурсам когда отключены от сервера.

  • Scalable processor support – поддержка многопроцессорных систем.

  • Encrypting File System – шифрование файлов на средствами файловой системы.

  • Access Control – ограничение доступа к файлам, программам и другим ресурсам

  • Centralized administration – централизованое администрирование системы в рамках домена.

  • Group Policy – облегчает администрирование групп пользователей на компьютере.

  • Software Installation and Maintenance – автоматически инсталлирует, конфигурирует, ремонтирует и удаляет программное обеспечение.

  • Roaming User Profiles – доступ к вашим документам и настройкам из любого места, где Вы подсоединились в домен.

  • Remote Installation Service (RIS) – поддержка удалённой инсталляции операционной системы по сети.

  • Multi-lingual User Interface (MUI) add-on – поддержка изменения языков интерфейса различных пользователей.

Кроме этого, есть незначительная разница в интерфейсах, например в XP Home нельзя выключить Simple File Sharing и включить нормальный.


Командная строка

Командная строка. Опции командной строки

Рано или поздно каждый пользователь сталкивается с необходимостью использования командной строки. Более того, в некоторых случаях решить задачу оказывается гораздо проще и удобнее с помощью текстовых инструкций, а для определенных команд вообще не существует эквивалента в графическом интерфейсе.

Так что чем раньше вы овладеете освоитесь с командной строкой, тем для вас же и лучше. А теперь нажимайте Пуск > Выполнить, вводите текст cmd и жмите Enter.

Настройка

Внешний вид командной строки можно изменять. Щелкните правой кнопкой мыши по строке заголовка окна и выберите пункт Properties (это окно можно также запустить нажатием Alt + «Пробел» + P). Откроется окно с четырьмя вкладками, на которых будут доступны опции изменения настроек программы. Если вам не нравится стандартный черный экран командной строки, то на вкладке Color вам предлагается выбрать цвет экрана и текста либо из 16 стандартных цветов, для которых имеется соответствующие образцы, либо задав числовое значение цвета в формате RGB.

На вкладке Layout настраивается размер окна и экранного буфера. Если в ранних ОС MS-DOS и Windows размер экрана оставался неизменным — 25 строк в высоту и 80 символов в длину, и для вывода большего количества строк приходилось добавлять команду |more, то в системах NT и более поздних можно просто задать достаточно большой размер буфера экрана и пользоваться полосой прокрутки, что гораздо удобнее.

Текст в окне командной строки

Для копирования и вставки текста в окно командной строки обычные для Windows комбинации клавиш, такие как Ctrl+C, Ctrl+V, работать не будут. Для извлечения текста из буфера обмена вам придется вызвать меню, щелкнув правой кнопкой мыши по заголовку окна, и выбрать подменю Edit. Или же просто щелкните правой кнопкой по окну. Для копирования текста из окна выберите пункт Mark и мышью выделите нужный текст. Затем либо нажмите Enter, либо в том же меню выберите Copy. Если надо вставить какой-то текст в окно командной строки, обратитесь к команде Paste.

Для повторного выполнения команды воспользуйтесь стрелками «вверх» и «вниз», позволяющими перемещаться по списку выполненных команд. Для очистки экрана от текста служит директива cls.

Для того чтобы просмотреть все открытые в системе файлы, предлагаю воспользоваться командой openfiles /query. Она позволит определить все файлы, открытые как локально, так и удаленно, а также покажет имя процесса, использующего их. Команда openfiles /disconnect отключает удаленных пользователей от общих файлов на вашем компьютере.

Напоследок рассмотрим еще одну очень интересную команду — Fsutil hardlink. Она принимает всего один параметр — create. Эта команда позволяет создавать жесткие ссылки на файлы. Жесткие ссылки позволяют одному файлу иметь несколько разных имен. Один и тот же файл может появляться в разных директориях или даже в одной директории с различными именами. И данные этого файла не могут быть удалены, пока счетчик имен файлов не будет равен нулю. Так как все ссылки указывают на один и тот же файл, программы могут открывать любую из них и изменять исходный файл.

Приведем пример использования этой команды. Допустим, имеется файл d:\1.avi, занимающий 600 Мб. Воспользовавшись командой fsutil hardlink create d:\2.avi d:\1.avi, вы создаете жесткую ссылку на этот файл. В результате вы получите два файла, но объем занимаемого дискового пространства не изменится. Хотя если Вы выделите эти два файла, Вам будет показано, что они занимают 1200 мегабайт. Таким образом Вы можете создать неограниченное число копий какого-либо файла, при том что на занятом пространстве диска это никак не отразится. Причем если удалить один из таких клонов, все остальные останутся без изменений. Для того чтобы уничтожить исходный файл придется удалить все жесткие ссылки на него. Но у этой команды есть ограничения: все файлы должны быть в пределах одного тома, и файловая система — только NTFS (NT File System).

Изменение вида приглашения (Windows NT/2000/XP)

Вы можете изменить вид приглашения для командной строки. Как правило используется формат типа C:\> (текущий диск и угловая скобка). Откройте раздел
HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\Control\Session Manager\Environment и создайте параметр PROMPT типа REG_EXPAND_SZ, которому нужно присвоить одно из следующих значений:

  • $B - | (вертикальная черта)

  • $D - текущая дата

  • $G - > (знак больше)

  • $L - < (знак меньше)

  • $N - текущий диск

  • $P - текущий диск и путь

  • $Q - = (знак равно)

  • $T - текущее время

  • $V - версия Windows

  • $$ - $ (знак доллара)

Изменения вступят после перезагрузки

Запрет на режим командной строки и обработки bat-файлов (Windows 2000/XP)

Существует возможность запрета на режим командной строки (cmd.exe) и обработки bat-файлов. Для этого найдите или создайте параметр типа DWORD DisableCMD в разделе HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System.

Данный параметр может принимать следующие значения

0 (или отсутствие записи в реестре | Система может использовать режим командной строки и обрабатывать bat-файлы
1 | Система не может использовать режим командной строки, но может обрабатывать bat-файлы
2 | Система не может использовать режим командной строки и обрабатывать bat-файлы

Сделанные изменения вступают в силу немедленно

Запрет на расширенный режим командного процессора (cmd.exe))

Существует возможность запрета на расширенный режим командного процессора (cmd.exe). Например, в расширенном режиме существуют такие команды как del, erase, chdir, goto. Для запрета найдите или создайте в разделе HKEY_CURRENT_USER\Software\Microsoft\Command Processor параметр EnableExtensions :dword=0. Для включения режима используйте значение 1 Также имеется аналогичная запись в разделе HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor


Реклама

Информация по рекламе

Реклама двигатель торговли, услуг и множитель доходов

Показ рекламы осуществляется на сайте или через Справочник Реестр Windows XP. Мы можем поставить как баннеры, так и текстовые блоки либо комбинированные блоки (текст + графика). В любом выбранном вами рекламном месте (вверху, внизу, слева, справа и т.д.) мы поставим неограниченное количество вашей информации.

Большинство пользователей, скачивающих справочник - хранят у себя на компьютере справочник для постоянного использования. Ваша реклама всегда на виду.
Соответственно, рекламная информация размещенная в справочнике- имеет гораздо более длительный "срок жизни", чем реклама в обычных рассылках. Количество читателей загружающих и просматривающих Справочник: в день не менее 200 человек. Справочник обновляется 1-2 раза в месяц.

Расценки: относительно Справочник :1выпуск = Сайт :15 дней + 100 показов вашего баннера через баннерную сеть Ket.Ru Silver (234x60).

Размещение | Тип рекламы | 1 выпуск | 3 выпуска
Главная страница справочника, вверху (в правом фрейме) | баннер 468х60 | $2 | $4
 | текстовый блок до 300 знаков | $2 | $4
Главная страница справочника, вверху (в левом фрейме) | кнопка 120х60 | $2 | $4
 | баннер 100х100 | $2 | $4
Главная страница справочника, середина (в правом фрейме) | Статья или текстовый блок до 5000 знаков | $4 | $8
Внутри справочника, вверху (на страницах со статьями, кроме главной и служебной) | баннер 468х60 | $2 | $4
 | текстовый блок до 300 знаков | $2 | $4
Статья рекламная внутри справочника (размещается с анонсом названия статьи в общем списке тем выпуска) | Статья до 7000 знаков | $2 | $6

Примечание:

Нестандартные варианты размещения рекламы - если у вас возникнут вопросы по другим вариантам размещения, не указанным здесь - пишите: Reestr@Григорий

Статьи и материалы, текстовые блоки и баннеры, заказанные более чем на 1 раз - могут быть как одними и теми же (повторение в каждом обновлении), так и различными (вы можете предоставить несколько вариантов - в каждом выходящем номере будет ваша новая информация).

Бесплатно: в вашей статье или материале могут также присутствовать одно или несколько графических изображений общим "весом" не более 20 кб.

При подсчете знаков html-тэги не учитываются.
Правильно подсчитывайте знаки в вашем рекламном объявлении - используйте, например текстовый редактор Word. Скопируйте в него ваш текст, а затем в меню Word найдите пункт Статистика.

Форматы присылаемых текстовых блоков, материалов и статей:

HTML, HTM, Word (doc). Присылать упакованным в zip-архив. Баннер Ket.Ru Silver (234x60)

Обратите внимание: обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам.
Статьи, содержащие много ошибок -не будут опубликованы.

Как платить? Все расчеты производятся при помощи платежной системы WebMoney.
Наши кошельки: ID- 614910355032
Z 216785746300
R 369346322339
Оплату и пересылку материала можно произвести Здесь

Порядок оформления рекламного заказа:

- Переведите нужную сумму денег на наш кошелек в системе Webmoney
- В примечании к переводу укажите -реклама и ваш емейл. Это чтоб мы могли понять, от кого пришли деньги и за что.
- Затем присылаете письмо с сообщением о переводе денег и вашим рекламным текстом (статьей) или баннером.
- Ваша реклама выходит в ближайшем выпуске справочника.

По вопросам размещения рекламы обращаться: Reestr@Григорий


Утилита полностью не очистит вам реестр

Очистка реестра

Утилита полностью не очистит вам реестр. Вам придется лезть в реестр и вручную удалять остатки софта.

  • Наведываться в Реестр лучше всего сразу после деинсталляции практически любых программ для того, что бы удалить следы их пребывания в системе. И каждый раз Вы будете удивлены, как много "мусора" даже лучшие их них оставляют после себя.

  • Очень полезно регулярно инспектировать Реестр с целью выявления и удаления ключей отдельных излишне рьяных приложений, без угрызения совести прописывающих себя в тех ветвях Реестра, которые отвечают за различные виды автоматического запуска программ при старте системы.

Поэтому вы хорошо должны знать что удалили, а что у вас еще установлено. В основном софт оставляет папки программ в разделе[ HKEY_LOCAL_MACHINE/Software] и

[HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/

SurrentVersion/Explorer/MenuOrder/StartMenu2/Programs]

За автозапуск программ в Windows отвечают ключи, находящиеся в ветке:
[HKEY_LOCAL_MACHINE\Software\ Microsoft\Windows\CurrentVersion]. Там есть подразделы: Run, RunOnce, RunOnceEx, Run Services, RunServicesOnce. В них и содержатся ключи, отвечающие за запуск программ. Название ключа может быть произвольным, а в качестве его значения указывается запускаемая программа. В разделе Run по умолчанию система устанавливает следующие ключи: internat.exe, LoaderPowerProfile, ScanRegistry, SystemTray, TaskMonitor, а в разделе RunServices повторно дублируется ключ LoadPowerProfile. В разделах, в которых присутствует слово "Once", прописывают свои значения программы, запуск которых надо произвести один раз, например при установке, или наоборот, при удалении программы. Поэтому в нормальных условиях они должны быть пусты. Все остальные ключи, присутствующие в любом из этих разделов Реестра, добавлены установленными программами и подлежат придирчивой инспекции на предмет их лояльности. Здесь же, в папке CurrentVersion проверьте папку Uninstall, и удалите все что у Вас не установлено.

Вся информация для удаления программ храниться в разделе реестра:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Информация о каждой программе храниться в отдельном разделе. В каждом разделе обязательно должны присутствовать два параметра:

STRING DisplayName, значение - имя, которое отображается в списке удаляемых программ

STRING UninstallString, значение - путь к программе удаления

также могут присутствовать другие пункты, их обычно добавляют современные инсталляторы:

STRING DisplayIcon - иконка, соответствующая приложению в диалоге "Установка и удаление программ"
STRING ModifyPath - Путь инсталлятора для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка "Заменить/Удалить" распадается на две - "Заменить" (выполняется ModifyPath) и "Удалить" (выполняется UninstallString)

Следующие параметры относятся к диалоговому окну Поддержка

STRING Publisher - Издатель продукта
STRING Readme - Путь к файлу Readme для данного продукта
STRING Comments - Комментарии к продукту
STRING Contact - Контактное лицо (e-mail и т.п.)
STRING DisplayVersion - Номер версии
STRING ProductID - Код продукта
STRING RegCompany - Зарегистрированная компания
STRING RegOwner - Зарегистрированный владелец
STRING URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
STRING URLUpdateInfo - URL обновления продукта
STRING HelpLink - URL сведений о поддержке

Здесь же, в папке CurrentVersion в разделе Uninstall можно изменить параметры Установки и удаления программ, это уже относится к разделу Безопасность

Открываем RegEdit, нажимаем комбинацию клавиш Ctrl-F - и в появившемся окошке вводим название того, что мы хотим найти. Естественно, это будет название удаленной программы, или его варианты. Так, например, иногда стоит поискать и по имени фирмы - разработчика. И ищем, ищем, ищем... Да, это долго и нудно (ведь после каждого найденного значения необходимо еще раз нажать F3, и так до конца, особенно если ключей очень много, но никуда не денешься. Конечно, существует большое количество специализированных утилит для поиска и удаления "дохлых" ссылок реестра, способные существенно облегчить ваш труд "ассенизатора", мы дальше будем рассматривать некоторые из них, однако правда жизни такова, что на все 100 % гарантировать успешный результат ни одна из них не в состоянии. Ведь структура Реестра настолько гибка, что позволяет вносить в него все, что заблагорассудится. И поверьте, иногда может такое "заблагорассудиться", что систему сразу парализует . Так что ручками, ручками...и головой тоже. А дальше - оптимизация Реестра, которая является логическим продолжением операции чистки. Ведь при удалении ссылок из Реестра они оттуда физически не удаляются, а только помечаются, как удаленные, что, конечно, обеспечивает определенное увеличение скорости работы с Реестром.


Сеть.

Итак, сети бывают локальные и глобальные. Локальные сети объединяют некоторое количество компьютеров в пределах одного или нескольких зданий. Такие сети иногда называют интранет. Глобальные сети подразумевают соединение различных локальных сетей в одну общую сеть, называемую Интернет.

Физическая установка сети

Предположим, что мы используем в сети три компьютера – два “клиентских компьютера” и один «сервера». Для организации, даже такой маленькой сети нам понадобятся сетевые карты, которые устанавливаются в каждый компьютер, свич или хаб, а так же специальный сетевой кабель, называемый витая пара. Дополнительная информация

Выбор сетевой карты

Сегодня сетевая карта стала настолько доступной, что частенько ее интегрируют на системную плату. В случае, если Ваша плата не имеет интегрированного сетевого контроллера, то Вам придется воспользоваться внешней PCI платой. Карта должна соответствовать стандарту Realtek 10/100. Она стоит около 10$. Более дорогие карточки имеют множество дополнительных функций, обеспечивающих большую стабильность при передаче данных. Ниже на фотографии показан внешний вид типичной сетевой карты.

При выборе сетевой карты, необходимо обратить внимание на максимальную поддерживаемую скорость передачи 10/100. Это означает, что карта может передавать данные на скорости 10mbps и 100mbps в зависимости от сетевой архитектуры. Дополнительно необходимо, что бы карточка имела разъем RJ-45 (современный стандарт CAT5), поддерживающий скорость передачи 100mbps и обратно совместимый с 10mbps стандартом (именно такой разъем показан на фотографии). Самый последний стандарт “CAT6”, (пока находится в разработке) будет поддерживать скорости от 300mbps до 1gbps. Это означает, что Вы сможете копировать файлы в сети со скоростью 125 мегабайт в секунду. Это быстрее скорости современных жестких дисков. CAT5-E или категория 5 UTP Enhanced так же обратно совместима с 10, 100 и 1000Mbit Ethernet. Использование RJ-45 предпочтительнее, чем RJ-58, или больше известные как BNC. Этот разъем предназначен для подключения на более низких скоростях (ограничена 10mbps) коаксиальным кабелем.

Хаб или Свич

Для управления всеми транзакциями (передача блоков информации) в сети используется устройство называемой хаб или свич. В чем отличие между этими двумя устройствами?. Во время передачи пакета данных хаб отправляет их сразу на все компьютеры, что значительно уменьшает пропускную способность канала. Свич, имеет встроенную память, в которой храниться информация о том, к какому порту подключен какой компьютер. Поэтому во время передачи пакета, он отправляется на определенный порт. Кроме того, свич позволяет использовать в сети контроллеры с разной скоростью передачи, при этом общая пропускная способность не будет опускаться до уровня контроллера с минимальной скоростью. Учитывая незначительное ценовое отличие мы настоятельно рекомендуем приобрести именно свич. На сегодняшний день впускаются свичи с 5, 8, 16, 24 или 32 портами. Цена устройства зависит от количества портов.

Говоря об организации сети, необходимо затронуть вопрос беспроводных сетей, т.е. передающих информацию по радиоканалу. Такие сети становятся все популярнее, т.к. позволяют сделать размещение компьютеров более гибким, а пользователям использующим мобильные компьютеры или ноутбуки, получить доступ к сети в любой точке офиса и даже за пределами. На сегодняшний день существует два стандарта 802.11a и 802.11b. Для реализации такого подключения необходимо использовать специальные хабы и сетевые карточки.

Конфигурация сети в Windows XP

Установить сетевые параметры в Windows XP Вы можете несколькими способами. Во-первых, вручную. Этот метода предпочтительнее, т.к. позволяет контролировать все настройки. Во-вторых, для тех, кто ничего не понимает в сетевых терминах, Microsoft включила мастер установки сети (Network Setup Wizard). Для запуска мастера, необходимо войти в "My Network Places"Сетевое окружение" и нажать на “set up a home or small office network”мастер настройки сети". Нажмите Next, на втором экране будут описаны некоторые рекомендации по правильной установке. Фактически здесь Вы найдете полное руководство к действию. Нажимаем Next-Далее. Теперь для всех клиентских компьютеров Вы должны выбрать третью опцию (Другое) и нажмите Next-Далее. На следующем экране Вы можете ввести или изменить имя компьютера. Теперь переходим к следующему окну, где мы сможем изменить название рабочей группе. Следующий экран резюмирует сделанные изменения и применяет их. На следующем экране Вам будет предложено создать диск установки сети. Так как мы делаем меленькую домашнюю сеть этот диск можно не создавать. Просто нажмите {{Wizard and then Finish}}-{{Выход}}.

Мастер сетевой идентификации

Теперь необходимо установить имя Вашего компьютера в рабочей группе, к которой он принадлежит. Для этого нажмите Start -> Settings -> Control Panel -> System -> и выберите закладку Computer Name. Сначала нажмите “Network ID”, что позволит активизировать мастер сетевой идентификации (Network Identification Wizard). На первом экране просто нажмите Next. На следующем экране нужно выбрать первую опцию (This computer is part of a business network, and I use it to connect to other computers at work), на следующем экране выберете вторую опцию (My company uses a network without a domain). Здесь Вы должны установить название рабочей группы. Эти действия Вы должны повторить на всех компьютерах Вашей сети.

IP адресация

Прежде всего вы должны идентифицировать каждый компьютер в сети. Для этого служит так называемая IP (Internet Protocol) адресация. IP адрес – это уникальный номер Вашего компьютера в Вашей сети. IP адрес может быть “статическим” или “динамическим”. В своей внутренней сети Вы можете использовать IP адреса класса C, т.е. в диапазоне 192.168.0.1 до 192.168.0.254. В одной рабочей группе может работать до 254 компьютеров. Обычно серверу назначают адрес 192.168.0.1. Когда Вы активизируете совместный доступ к сети (Internet Connection Sharing) по умолчанию Вашему серверу будет автоматически назначен этот адрес.
При установке постоянного IP-адреса, вместо динамически выделяемого, время загрузки сократиться более чем в 5 раз. Делается так: открывается Панель управления, в ней заходим в свойства Сети, там открываем свойства TCP/IP (внимание, имеется в виду настройки ЛОКАЛЬНОЙ сети, пожалуйста, не гробьте свой Internet прописанием не тех IP-адресов). А в свойствах протокола прямо на первой вкладке меняем "получение IP адреса автоматически" на постоянный адрес из 4 чисел. Пример 192.168.0.1 для первой машины, 192.168.0.2 для второй машины и т.д.

Конфигурация сервера

Для установки сетевых параметров Вы должны войти с правами администратора. Вам необходимо назначить каждому компьютеру IP адрес. Для этого нажмите Start -> Settings -> Network Connections. Теперь кликните правой кнопкой мышки на “Local Area Connection” и выберите меню Properties. Затем укажите на протокол TCP/IP и нажмите Properties. Перед Вами откроется окно, позволяющее установить все необходимые сетевые параметры.

В случае если доступа к сети нет, попробуйте сначала проверить правильность подключения всех кабелей, и включение концентратора или свича. Если все сделано правильно то при подключении сетевого кабеля к Вашей сетевой карте, на экране в tray области (рядом с часами, появиться сообщение о сетевом подключении на скорости 100 или 10Mb). В случае если этого не происходит, необходимо проверить включение опции отображения индикатора в сетевых настройках и проверить правильность и целостность кабеля. Далее надо пингануть северное подключение. Для этого мы используем утилиту

NetView Killer{R} v 2.71. 899 Кб TCP/IP ЛОКАЛЬНОГО сетевого менеджера. Plug-ins поддержка. Английский. Free. 98/ME/XP Скачать можно Здесь

Если пинг не прошел, необходимо проверить работоспособность и настройку сетевых карт и свича. Кроме того, одной из причин имеющихся проблем может быть установка Windows XP поверх другой операционной системы имеющей настроенную сеть, либо компьютер использовал собственное подключение к Интернет. После неоднократной установки мы пришли к выводу, что для полной работоспособности необходимо устанавливать новую ОС на чистый диск, или раздел.

Статус Интернет соединения

Теперь необходимо коснуться вопроса контроля состояние подключения к Интернет. Особенно это касается случая использования операционных систем отличных от Windows XP. Для доступа к этой опции нажмите Start -> Network Connections. Как Вы можете видеть Windows XP достаточно подробно показывает параметры соединения, такие как скорость соединения и трафик на Вашей клиентской машине. Кроме того, здесь Вы можете отключить Интернет соединение.

Совместное использование и доступ к файлам

Переходим к последнему параметру, совместному использования файлов и папок. Эта особенность позволит создавать в компании библиотеку документов, шаблонов и т.д. Открывать и ограничивать доступ к документам неугодных вам сетевиков. В общем, полностью организовать документооборот в сети. Для того, что бы разрешить сетевой доступ к файлам и папкам нужно в My Computer выбрать диск или папку, к которому нужно открыть доступ, и правой кнопкой войти в свойства диска или папки, где выберите закладку Sharing и ставите галочку.

Разное
Установка способа доступа к расшаренным ресурсам компьютера из сети.
Раздел: HKLM\System\CurrentControlSet\Control\Lsa
Параметр: restrictanonymous
Тип: DWORD
Если значение равно 1 - запрещает анонимным юзерам просматривать удаленно учетные записи и расшаренные ресурсы. 2 - отказывает любой неявный доступ к системе (в сетевом окружении компьютер не будет виден, однако, доступ к нему можно будет получить, обратившись к нему по его IP).

Если Вы работаете в сети, то можете "зашарить" какие-либо ресурсы, поставив символ "$" в конце имени "шары". Такая "шара" не видна при просмотре, и подключиться к ней сможет только человек, который точно знает её имя.

------

Управление общедоступными (shared) каталогами на удалённой машине в Windows NT 4.0.
Есть несколько очень простых способов делать это (пример — создание shared folder):
1. Запустите Server Manager. Щёлкните мышью на имени нужного компьютера. Computer –> Shared Directories –> New Share...
2. Можно использовать утилиту RMTSHARE из Resource Kit.
3. Ещё один способ — через File Manager (Winfile.exe — наследство предыдущих версий Windows NT). Сначала подключаемся к тому дисководу на удалённой машине, где лежит нужная папка (например, net use x: \\<remote computer name>\C$). Затем запускаем File Manager –> Х: –> Disk –> Share As.

Александр Зорич http://www.orc.ru/~zalex

------

Если необходимо обеспечить автоматический вход в домен MS Windows NT или LAN Manager при старте операционной системы MS Windows 9x без участия пользователя, то можно воспользоваться любым из приведённых ниже способов:
С помощью кэширования пароля.
Данный способ позволяет избежать появления диалогового окна ввода имени пользователя, пароля и имени домена и установить автоматический вход в сеть при условии, что на рабочей станции используются единые пользовательские настройки и параметры Рабочего стола.

– Войдите в Панель управления, откройте значок "Сеть".
– На вкладке "Конфигурация" выберите способ входа в сеть "Обычный вход в Windows".
– В ответ на запрос Windows перезагрузить компьютер нажмите кнопку "Нет".
– Откройте значок Панели управления "Пароли".
– На вкладке "Смена паролей" нажмите кнопку "Сменить пароль Windows".
– В диалоговом окне "Изменение пароля Windows" введите действующий сетевой пароль в поле "Старый пароль", поля "Новый пароль" и "Подтверждение пароля" оставьте пустыми.

– Перейдите на вкладку "Конфигурация", проверьте, что установлен параметр "Все пользователи работают с едиными глобальными настройками и параметрами рабочего стола".
– Перезапустите Windows.
– При появлении диалогового окна "Ввод сетевого пароля" во время загрузки Windows введите пользовательский пароль для входа в сеть в поле "Пароль", установите флажок "Сохранить пароль в списке паролей" и нажмите кнопку "OK".
При следующих загрузках операционной системы диалоговое окно "Ввод сетевого пароля" появляться не будет, регистрация пользователя в сети будет происходить автоматически.

-----

Вы можете улучшить сетевую производительность, проверив список сервисов своей рабочей станции Windows NT и удалив необязательные сервисы, расходующие важные системные ресурсы. Деинсталлируйте сервисы в апплете Services в Control Panel. Выберите сервис, который вы хотите удалить, затем укажите на Startup и выберите опцию Disable в диалоговом окне Startup Type.
-----
Потенциально необязательные сервисы Windows NT Workstation:
Computer Browser — Позволяет системе использоваться в качестве основного браузера и участвовать в выборах браузеров. Отключайте, если вы не хотите, чтобы машина рассматривалась в качестве потенциального основного браузера в сетевом сегменте.
Server — Реализует серверный компонент SMB (или иначе CIFS) в системе NT. Отключайте, если вы не хотите совместно использовать ресурсы печати и файлы на машине и нет необходимости поддерживать удалённый доступ к Registry.

Alerter — Посылает административные предупреждения получателям, указанным в диалоговом окне Alerts апплета Server на Control Panel. Если вам не нужна эта машина для пересылки административных уведомлений, то этот сервис можно отключить.
Messenger — Посылает и получает сообщения, которые появляются на консоли получателя. Если вам не нужна эта машина для рассылки или получения сообщений, появляющихся на консоли, то отключите этот сервис.
Remote Access Autodial Manager — Уведомляет систему об использовании DUN удаленных сетях. Если вы не заинтересованы в установке коммутируемых соединений и хотите, чтобы пользователи вручную инициировали соединения DUN, то отключите этот сервис.
-----
Выполнение в Windows NT операций на всех имеющихся в сети машинах.
Сначала получаем файл List.txt со списком всех имеющихся на данный момент в сети машин с помощью команды:
net view > list.txt
Затем, чтобы выполнить, например, копирование файла quaropts.dat на каждую машину в сети, дайте команду:
FOR /F " tokens=1 " %i in (list.txt) do copy quaropts.dat "%i\C$\program files\navnt"

Если команду надо давать из bat-файла, то требуется вместо % вводить %%.
-----

Удалённое выключение нескольких компьютеров одновременно.
Если у Вас в конторе множество машин и Вам надоело каждый раз после рабочего дня ходить и выключать их, используйте утилиту shutdown.exe из Windows NT Resource Kit и bat-файл (компьютеры PDC и BDC выключаются через 2 секунды, локальные — через 5):

========
shutdown \\pdc /t:2 /y /c
shutdown \\bdc /t:2 /y /c
shutdown /l /t:5 /y /c
========
Создайте на рабочем столе ярлык для этого командного файла и выключайте все компьютеры нажатием на этот ярлык.
-----

Для соединения двух компьютеров в локальную сеть на витой паре не обязательно использовать хаб. Можно сделать "нуль-хабный" ("cros s-over") кабель, который отличается от обычного только разводкой проводов в разъёмах:
1 3 бело-зелёный провод
2 6 зелёный
3 1 бело-оранжевый
4 4 синий
5 5 бело-синий
6 2 оранжевый
7 7 бело-коричневый
8 8 коричневый
Ограничение на длину кабеля сохраняется равным 100 метрам.

В заключении, я советую вам заглянуть на сайт www.homenetworks.ru, полностью посвященный домашним локальным сетям. Здесь вы почерпнете немало полезной информации, узнаете, чего не надо делать при прокладке сети, а на что следует обратить внимание. Там же найдете массу ссылок на другие ресурсы аналогичной тематики.


Система восстановления

Что представляет собой система восстановления Windows XP

В самом общем плане: System Restore производит "слепок" с системного реестра и создает резервные копии других необходимых для нормального функционирования операционной системы файлов, что дает возможность в случае необходимости произвести возврат системы к прошлому состоянию. Параметры системы восстановления задаются на вкладке System Restore апплета System Properties, до которого можно добраться так: Start/Control Panel/System. Хочу обратить внимание на то, что по умолчанию System Restore включена не только для загрузочного, но и для всех остальных дисков, при этом отключить System Restore штатными средствами ОС можно у всех дисков, кроме загрузочного.
Кроме этого, с целью дополнительной защиты системы от кривых рук некоторых разработчиков программного обеспечения, в Windows XP имеется система защиты файлов

Система восстановления файлов

В действительности имеющийся в Windows XP модуль Windows File Protection и вправду восстанавливает файлы, но не все, а только те из исполняемых и системных файлов (*.exe, *.dll, *.ocx и некоторые другие), которые оказались без всякой на то необходимости замененными (например, в процессе инсталляции какой-либо программы), предотвращая тем самым возможные нарушения в работе операционной системы. Дело в том, что для защиты наиболее важных файлов Microsoft ввела их цифровую подпись, и в том случае, если обнаруживается, что происходит замена системного файла другим, не имеющим такой цифровой пописи, следует немедленное оповещение пользователя, а подмененный файл заменяется "правильным", до поры до времени находящемся в специально для этого созданном хранилище. Если же "правильного" файла по какой-то причине на жестком диске не оказывается, то следует предложение вставить в CD-привод компакт-диск, с которого устанавливалась Windows XP...


Система

Система не загружается...

Для того, чтобы упростить восстановление системы после возможного отказа , нужно будет заранее предпринять некоторые шаги.

Первый способ состоит в резервном копировании всех основных системных файлов: в Properties системного жёсткого диска открываем вкладку Tools и нажимаем на кнопку Backup now... (это же можно проделать через Start -> Programs -> Accessories -> System Tools -> Backup). В открывшемся окне выбираем вкладку Backup и отмечаем галочкой System state, после чего нажимаем кнопку "Start Backup".
Способ этот хорош всем, кроме одного - созданный "резервирующий" файл (*.bkf) будет иметь размер примерно 200 MB, да и восстановить (вернее, исправить возникшие в ее работе ошибки) можно только при работающей системе, так этот способ всего лишь позволяет, восстанавливая системные файлы, не потерять все свои настройки, а значит, кроме прочего, и не переустанавливать заново инсталлирование программы.

Для уменьшения размера создаваемого при резервировании файла до 15-30 MB можно сохранить только содержимое папки \ system32\ config (полный список файлов реестра можно узнать, если заглянуть реестр: HKEY_LOCAL_MACHINE\ System\ CotnrolSet\ Control\ HiveList\ ), причем для этой цели совсем не обязательно проводить все те манипуляции, о которых рассказывалось выше - можно просто скопировать требующиеся для восстановления файлы в другое место, а при возникновении проблем с реестром загрузиться с любой загрузочной дискеты (хотя бы для DOS) и перезаписать сбойный реестр его резервной копией.

Всё это, конечно, прекрасно, но Windows XP может быть установлена не только на FAT, но и NTFS-раздел, и в этом случае обычная дискета не поможет - NTFS-раздел из DOS не виден. Естественно, и в этом случае выход есть, но для решения этой проблемы нужно будет воспользоваться утилитами сторонних разработчиков - например, воспользоваться программой NTFSDOS Pro, позволяющей производить чтение/запись файлов, размещенных на NTFS-разделе, из-под DOS. Кстати, на сайте разработчика NTFSDOS Pro есть подобная утилита и для работы с NTFS-разделами из-под Windows 9*.

А если NFSDOS (или какой-нибудь другой подобной утилиты) нет? - Сама Microsoft предумотрела лишь один способ - загрузку с загрузочного компакт-диска Windows XP: в процессе загрузки системы будет предложено два варианта - установить систему заново или восстановить ее с помощью Recovery Сonsole. В случае, если выбрать Recovery Сonsole, поступит предложение ввести пароль Администратора, после чего - если введенный пароль окажется правильным - загрузится интерфейс командной строки. Список всех допустимых команд выводится командой "help", а наиболее важные для них следующие:
перезапись реестра - copy
вывод на экран списка системных служб и драйверов - listsvc
оключение определенной службы - disable (включение - "enable"),
восстановление загрузочных файлов - fixboot
восстановление Master Boot Record - fixmbr

Кстати, загрузить Recovery Соnsole совсем необязательно с CD - ее можно установить на жёсткий диск, м тогда при загрузке можно будет выбирать, загружать ли систему полностью или загружаться в Recovery Console.

Для установки Recovery Console нужно из командной строки в директории i386 дистрибутива Windows XP набрать ->winnt32.exe /cmdcons

Учитывая, что набор команд в Recovery Соnsole является очень ограниченным, имеет смысл поставить жесткий диск с неработающей системой на другой компьютер, работающий под управлением Windows XP или 2000, и попытаться спокойно разобраться в причинах краха системы - если и не разберетесь, то уж все данные с NTFS-разделов сможете перенести без проблем...


Службы

Про управление службами написаны целые книги, и в рамках данной статьи мы не можем раскрыть все нюансы и тонкости. Если вы не знаете, для чего нужна конкретная служба, лучше ее не трогайте.
Службы – важный элемент операционной системы, они обеспечивают функциональность аппаратного и программного обеспечения, заданий и т.д. Конечно, лучше даже и не пытаться отключить ключевые процессы ядра операционной системы и связанные с ними службы, которые управляют распределением процессов, обработкой прерываний, операциями с файлами, с виртуальной памятью и т.д. Но в системе устанавливается большое число не критичных служб, которые работают по умолчанию и находятся на более высоком уровне абстракции по отношению к службам операционной системы. Эти службы вы можете отключить или изменить для увеличения времени реакции или производительности системы без серьезных побочных эффектов.
Вы можете запустить оснастку Службы (Services) через Панель управления/Администрирование/Службы (Control Panel/Administrative Tools/Services), или просто запустить Services.MSC.
После запуска оснастки вы увидите таблицу служб, которые доступны для модификации в вашей конфигурации Windows XP. В каждой строчке содержится описание службы (более подробный вариант можно получить в Справке), ее состояние (работает или нет), тип запуска (авто, вручную или отключено) и имя пользователя, под которым будет запущена служба.
Если тип запуска установлен "авто", то служба будет автоматически запускаться при старте Windows. Службы с типом запуска "вручную" можно соответственно запустить вручную, или они могут быть запущены другими зависимыми службами (зависимыми называются службы, которые не могут работать без данной). Если служба отключена, она не будет запускаться.
Для получения максимальной производительности вы можете остановить некоторые службы и/или поставить их в тип запуска "вручную". Не устанавливайте тип запуска в "отключено", если вы не абсолютно уверены, что служба не понадобится вам, другим службами или "железу".
К примеру, если вы отключили "Восстановление системы" (System Restore), вы можете остановить соответствующую службу и поставить ее тип запуска "вручную". Если вы не записываете CD-R, то аналогичную вещь вы можете осуществить и со службой COM записи компакт-дисков IMAPI (IMAPI CD-Burning COM). Служба "Серийный номер" переносного медиа-устройства (Portable Media Serial Number) практически бесполезна, так что спокойно установите ее в тип запуска "вручную" (или отключите вообще, если у вас нет портативного плеера). Если вы не печатаете, то остановите службу "Диспетчер очереди печати" (Print Spooler). Большинство пользователей могут установить службу "Справка и поддержка" (Help and Support) в тип "вручную" (опытные пользователи могут ее вообще отключить). Если вы не используете темы, отключите соответствующую службу.
С остальными службами следует экспериментировать очень осторожно. Вам могут никогда не понадобиться службы типа Telnet, "Службы регистрации ошибок" (Error Reporting), "Планировщика задач" (Task Scheduler) эта служба используется при операциях автоматической настройки, так что ее лучше не отключать, (он отличается от планировщика процессов ядра системы и работает в подсистеме пользователя), "Службы индексирования" (Indexing Service), "Совместимости быстрого переключения пользователей" (Fast User Switching), "Сервера папки обмена" (ClipBook), "Координатора распределенных транзакций" (Distributed Transaction Coordinator), "Брандмауэра Интернета/Общего доступа к Интернету" (Internet Connection Firewall/Sharing) (ICF/ICS) и другие. Но если вы не уверены насчет какой-либо службы, оставьте ее в покое.
Вы можете узнать больше информации о каждой службе, включая список зависимых служб, в свойствах службы.


Советы

Удаление списка часто используемых программ

Если вы хотите удалить список часто используемых программ кнопки Пуск , раздел

KEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explоrer

создать параметр NoStartMenuMFUprogramsList :dword =1

Свойства Дата и время

В процессе инсталляции предлагается выбрать региональные установки (а позже это можно сделать через «Панель управления — Язык и стандарты»), выберите для русского языка кнопку «Настройка», перейдите к вкладке «Дата» и в строке «Полный формат» исправьте шаблон на dddd d MMMM yyyy ‘г.’. Кроме даты, у вас будет отображаться и день недели.

Диспетчер устройств

Иногда с помощью Диспетчера устройств [Пуск- Выполнить-devmgmt.msc] решаются и некоторые малопонятные глюки. Например, если у вас будут проблемы c выключением компьютера или с пропадающим приводом флоппи-дисков, то иногда помогает такой трюк: выберите в Device Manager команду "View"> "Show hidden devices" - список имеющихся устройств несколько расширится, в том числе в нем появится и группа устройств "Non-Plug-and-Play Drivers". Делать там особенно нечего, но если в этом списке вы обнаружите устройство TPkd, то попробуйте удалить его, а также переместить файл TPkd.vxd из папки Winnt\System32 в другое место, где система его не сможет отыскать. После такой манипуляции проблемы с Windows XP у многих пользователей пропадают.

Если в Диспетчере устройств установить флажок "Вид" > "Показать скрытые устройства", то список этих самых устройств в его окне заметно возрастет, и вы увидите то, что Windows от вас так тщательно скрывала.

Горячие клавиши

Нажатие клавиши <Print Screen> помещает изображение Вашего экрана в буфер. Оно затем может быть вставлено в любую программу, работающую с графикой ≈ WinWord, PainBrush, PhotoShop и т.п. Нажатие сочетания клавиш <Alt>+<Print Screen> помещает в буфер изображение активного окна.

     Все знают, что
в Windows нажатие клавиши с логотипом Windows (<Win>) открывает главное меню. Но
не многие знают, что:

<Win>+<E> вызывает Проводник с открытием папки "Мой компьютер";
<Win>+<F> вызывает окно "Поиск файлов";
<Win>+<M> сворачивает все окна;
<Win>+<Shift>+<M> их снова развертывает;
<Win>+<R> вызывает окно "Выполнить";
<Win>+<Break> вызывает окно "Свойства: Система";
<Win>+<Tab> особым образом переключает задачи

Если в Проводнике (а также большинстве подобных программ) на "дереве" нажать клавишу <Стрелка═вправо> ≈ развернётся свёрнутая ветвь подкаталогов текущего каталога. При этом перемещения на подкаталоги не происходит, для этого нужно нажать <Стрелка═вниз>, либо снова <Стрелка═вправо>. <Стрелка═влево> сворачивает развёрнутую ветвь. А если подкаталогов нет, то отправляет на уровень вверх. Очень удобно, когда каталогов много, и мышью до предыдущего уровня без прокрутки не достать.

Работу на "дереве" Проводника можно ещё ускорить, используя клавиатуру. При нажатии символьной клавиши выполняется быстрый переход к папке, название которой начинается с этого символа. Если таких папок несколько, то происходит последовательный переход от одной к другой. Правило действует в обоих (ENG/РУС) регистрах.

Если во время перетаскивания файла в мусорную корзину (или выбора пункта меню "удалить") Вы будете держать нажатой клавишу <Shift>, то файл будет удалён, а не помещён в корзину.

Нужно иногда скопировать всю информацию с одной дискеты на другую. А дисковод-то обычно один... Чтобы не записывать файлы на винчестер, которые затем надо с него удалять, можно использовать такую возможность как "Копирование дискеты" (вызывается, например, нажатием правой кнопки мыши на иконку дисковода в Проводнике).

Если Вам требуется открыть файл с помощью программы, отличной от той, которая сопоставлена данному типу файлов, то щёлкните по нему правой кнопкой мыши, удерживая нажатой клавишу <Shift>. В появившемся контекстном меню Вы увидите пункт "Открыть с помощью..." ("Open with...").

Double-click по активной панели окна (синяя полоска сверху) меняет его режим с полноэкранного на окно и наоборот.

Если дважды щёлкнуть по файлу, удерживая нажатой клавишу <Shift>, то программа запустится минимизированной.

Чтобы быстро получить доступ к свойствам объекта, нажмите клавишу <Alt> и сделайте двойной щелчок кнопки мыши на значке объекта.

Проводник как два отдельных процесса

Проводник выступает и в качестве оболочки Windows, и в качестве файл-менеджера, в одном процессе. Хотя это повышает удобство, на использовании памяти это сказывается плохо. Можно изменить значение запуска Проводника, на два отдельных процесса вместо одного. Нужно изменить значение в разделе HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\ параметр SeparateProcess: dword=("0" - один процесс, "1" - два процесса)

Меню "Пуск √ Документы" содержит ярлыки недавно использовавшихся файлов или документов. Если в системе работает несколько пользователей с одной и той же конфигурацией, и, при этом, нежелательно предоставлять пользователям быстрый доступ к ярлыкам недавно использовавшихся файлов или документов, с которыми работали другие пользователи, то в Windows 98 можно включить автоматическую очистку содержимого меню "Документы" при завершении работы Windows:

1. Запустите редактор реестра (regedit.exe).
 2. Откройте следующий раздел системного реестра:
HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \Policies \Explorer
3. В данном разделе создайте двоичный параметр "ClearRecentDocsOnExit" и присвойте ему значение "01000000".
4. Закройте редактор реестра и перезагрузите компьютер. Примечание: Ярлыки меню "Документы" хранятся на жёстком диске в папке %WinDir%\Recent, где %WinDir% ≈ папка, в которую установлена Windows.

Чтобы скрыть все дополнительные папки в меню "Пуск", которые вы сами добавляли в каталог "C:\WINDOWS\Главное меню", надо в разделе реестра:
 HKEY_CURRENT_USER \Software \Microsoft \Windows \CurrentVersion \Policies \Explorer
создать dword-параметр "NoStartMenuSubFolders" и присвоить ему значение 1.

Windows позволяет ограничить доступ к программам, кроме разрешенных в специальном списке.

Раздел HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\Explorer создать ключ RestrictRun : dword= 0х00000001. Затем тут же надо создать подраздел с аналогичным именем RestrictRun и в нем перечислить список РАЗРЕШЕННЫХ к запуску программ для текущего пользователя. Записи в этом подразделе пронумеровываются, начиная с 1, и содержат строки с путями (необязательно) и именами приложений. Файлы должны быть с расширением. Например, Word.exe, Excel.exe ...

Не забудьте указать файл Regedit.exe, иначе Вы сами не сможете больше запустить редактор реестра! Для сброса ограничения на запуск программ надо установить значение ключа RestrictRun в 0

Пароль после ждущего режима (Windows XP)

Можно настроить систему таким образом, чтобы при включении компьютера, после Ждущего режима появлялось диалоговое окно с приглашением ввести пароль. Для этого в разделе
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System\Power создаем параметр PromptPasswordOnResume :dword=1.

Отложенное расширение переменных среды

Отложенное расширение переменных среды по умолчанию не включено. Для включения используйте в разделе HKEY_CURRENT_USER\Software\Microsoft\Command Processor параметр DelayedExpansion : dword= 1 (Аналогичная запись в ветви HKEY_LOCAL_MACHINE)

Бывают ситуации, когда надо запустить на компьютере пользователя программу в скрытом виде (чтобы не было кнопки программы на панели задач и иконки в трее, а также чтобы не было видно окна программы), однако программистами в программе не предусмотрен такой режим запуска. Примеров можно привести массу, например, запуск какого-то монитора работы пользователя или клавиатурного шпиона... В этом случае можно воспользоваться средствами WSH для скрытого запуска таких программ. Вот пример JS-скрипта, запускающего в таком режиме обычный виндовый блокнот:

var WSHShell = WScript.CreateObject("WScript.Shell");
WSHShell.Run("notepad",0);

Второй параметр во второй строке, а именно - 0, указывает, что надо запустить файл в невидимом режиме. Создайте файл с расширением *.js и пропишите его в автозагрузку. Теперь работа вашей программы практически незаметна. Окно у нее невидимо, кнопки на панели задач нет, в диспетчере задач на вкладке "Приложения" она тоже не светится. Только в списке процессов возможно найти notepad.exe и снять его. Но если изменить имя файла, например, nvidia32.exe или volsnd32.exe, то далеко не каждый пользователь найдет эту подделку. Да и потом, часто ли вы лазите в диспетчер задач с целью поиска "непонятных" процессов?

П ользовательский интерфейс настройки приложения "System Restore"

С помощью правки реестра в Windows XP можно отключить пользовательский интерфейс настройки приложения "System Restore", чтобы предотвратить изменение настройки этого приложения пользователем, а также отключение и включение этого свойства для системных и несистемных дисков. Для этого надо в разделе реестра HKEY_LOCAL_MACHINE \SOFTWARE \Policies \Microsoft \Windows NT создать подраздел "SystemRestore", а в нём dword-параметр "DisableConfig" со значением 1.

Систему шифрования EFS (Encrypted File System) можно выключать/включать на Windows 2000 и Windows XP Pro. Для этого достаточно в разделе реестра: HKEY_LOCAL_MACHINE \Software \Microsoft \Windows NT \CurrentVersion \EFS key создать или отредактировать уже существующий dword-параметр "EfsConfiguration". Присвоив этому параметру значение 1, вы выключите EFS, а присвоив 0, включите обратно. Для того чтобы изменения вошли в силу, необходимо перезагрузить компьютер. Очевидно, что, отключив EFS, вы потеряете возможность не только шифровать файлы, но и расшифровывать ранее зашифрованные. Как очевидно и то, что включение/отключение EFS влияет сразу на всех пользователей. Но на ключи пользователей (как открытые, так и личные) это действие не окажет абсолютно никакого влияния, поэтому после того как EFS будет включена вновь, никаких проблем с доступом к своим файлам пользователи не испытают.

Мой компьютер: Управление(Windows NT/2000/XP)

Чтобы удалить пункт Управление из контекстного меню значка Мой компьютер, создайте параметр типа DWORD NoManageMyComputerVerb со значением 1 в разделе
HKEY_CURRENT_USER\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer.

Примечание: Данный пункт запускает утилиту compmgmt.msc. Удаление пункта не удаляет саму программу

Прислал Александр

По умолчанию служба QoS (Quality of Service) в Windows XP резервирует для своих нужд 20% от пропускной способности канала (любого, хоть модем на 14400, хоть гигабитный Ethernet). Причём, даже если удалить службу QoS Packet Scheduler в свойствах соединения, этот канал не освобождается. Освободить канал, или просто настроить QoS, можно так. Запускаем апплет Group Policy (gpedit.msc). В Group Policy находим "Localcomputer policy" и нажимаем на "Administrative templates". Выбираем пункт "Network" – "QoS Packet Sheduler". Включаем "Limit reservable bandwidth". Теперь cнижаем "Bandwidth limit" с 20% до 0. При желании здесь же можно настроить и другие параметры QoS. Для активации произведённых изменений остаётся только перезагрузиться. ( Изменение "Bandwidth limit" с 20% до 0 ничего не дает.Григорий. )

Автор не известен.

. Убрать значки с "Рабочего стола" и создать ОЧЕНЬ быструю панель можно нажав на "трэе" (там, где часы) правую кнопку мыши. В меню выбрать "Панели инструментов" - поставить галочку "Рабочий стол" (если там такового нет - нажать "создать" и там выбрать "Рабочий стол"). При этом слева от трэя появится оная перемещаемая панелька со стрелкой, разворачивающей всё содержимое "Стола". После этого зайти в свойства экрана, вкладка "Эффекты" и там установить галку "Прятать содержимое стола, если...".
Всё! Вся фишка в том, что:
1. не захламляются ваши обои и
2. (самое главное!) через эту менюшку можно практически мгновенно добраться до ЛЮБОЙ точки вашего компа НЕ ЗАПУСКАЯ ПРИ ЭТОМ ВСЯКИХ "ПРОВОДНИКОВ", "КОММАНДЕРОВ" и т.д., (заодно и ресурсы экономятся!) Попробуйте, не пожалеете!
З.Ы. Для 98 Выньды. Для остальных - не знаю, есть ли там такое... ;) Действует и в XP Григорий

Прислал: Олег

Для работы с Интернетом давно пользую Proxomiton. Это фильтр для входящего html кода. Настраивается всё, есть внутренний язык. Богатые возможности. От обрезания самораскрывающихся окон и ява-скриптов, до изменения самих приходящих страничек.
вот ссылки
Для Proxomitron Naoko 4.0
http://proxomitron.hoha.ru/files/help/rus_help_n4.zip
http://www.proxomitron.nm.ru/files/help/rus_help_n4.zip
Для Proxomitron Naoko 3
http://proxomitron.hoha.ru/files/help/rus_html_help_n3.zip
http://proxomitron.hoha.ru/files/help/rus_win_help_n3.zip
http://proxomitron.nm.ru/files/help/rus_html_help_n3.zip
http://proxomitron.nm.ru/files/help/rus_win_help_n3.zip
И еще, если нужны другие файлы (русификаторы и т.д.) - просто зайдите на сайт, на страницу загрузки:
http://proxomitron.hoha.ru/download.htm
http://proxomitron.nm.ru/download.htm
Там все ссылки должны работать.
Есть и конференция, в которой на ваши вопросы ответят, за что модератору большое спасибо!
РАБОТА С КОНФЕРЕНЦИЕЙ:
Сайт: http://groups.yahoo.com/group/prox-ru/

Прислал: SerG

"Передвигаясь" по Вебу, очень удобно пользоваться правой кнопкой мыши. С её помощью Вы сможете открыть "содержимое" ссылки в новом окне или сохранить его на диск или скопировать ссылку в буфер.
В Internet Explorer, если удерживать клавишу <Shift> во время щелчка по ссылке, то она откроется в новом окне.
Если Вы работаете в 4-м Эксплорере или Навигаторе, и сайт, на который Вы хотите попасть, начинается на "WWW" и кончается на "COM", то достаточно напечатать только середину. Например, напечатав "listsoft", Вы попадёте на www.listsoft.com.
У меня это работало только в IE4. В IE5/6 эти подстановки не выполняются, хотя соответствующие параметры реестра IE по-прежнему создаёт. Заодно отмечу, что если после набора адреса нажать <Ctrl>+<Enter>, то в его начало всегда будет добавляться "www.", а в конец ".com". Это работает во всех версиях IE4/5/6.

Печать русских символов с некоторых Web-серверов в Internet Explorer может быть искажена. Для решения проблемы надо в IE в меню "Вид" (View) выбрать команду "Свойства обозревателя" (Internet Options), перейти на закладку "Общие" (General), нажать кнопку "Спец. возможности" (Accessibility) и установить флаг "Игнорировать шрифты, указанные на Web-страницах" (Ignore font styles specified on Web pages).

Для ускорения работы с запароленными сайтами (например, почта на mail.yahoo.com) попробуйте ввести в строке браузера IE информацию таким образом: username:password@sitename.com. Тогда загрузится страничка с уже заполненными полями логина и пароля. Это немного ускоряет серфинг, но работает не на всех сайтах.

Самый быстрый и удобный способ поиска в Интернете для браузера IE4. Щёлкните в поле адреса, наберите вопросительный знак, пробел и фразу для поиска. При нажатии <Enter> IE4 посылает запрос службе Yahoo (сервер поиска по умолчанию в AutoSearch).

Адрес поискового сервера, используемый по умолчанию, когда Вы нажимаете кнопку Go или открываете панель поиска в Internet Explorer, хранится в разделе реестра: HKEY_CURRENT_USER \Software \Microsoft \Internet Explorer \Main в строковом параметре "Search Page". Вы можете изменить значение этого параметра на нужный вам адрес, например: http://www.altavista.digital.com

Terminator II (http://winchanger.narod.ru/)

Если вдруг заголовок окна оказался за пределами вашего монитора, вы не можете перетащить окно в другое место. Но вы можете воспользоваться горячими клавишами. Нажмите ALT+SPACE а затем нажмите П (в русской версии) или M (в английской). Теперь вы может с помощью клавиш со стрелками перемещать окно в любое место.

В Windows XP появился новый способ упорядочивания значков (если используется вид "Значки"): Вид -> Упорядочить значки -> по группам. После этого значки будут упорядочены по группам в алфавитном порядке.

В Windows XP можно переименовать сразу несколько файлов. Для этого выделяем файлы, щелкаем по любому из них правой кнопкой и переименовываем.
Все выделенные файлы получат имя указанного файла с индивидуальным номером в скобках


Структура

Структура .reg-файла.

Знание реестра Windows XP будет неполным без умения написать reg-файл.

REG-файл — это файл, имеющий определенную структуру и содержащий информацию, которая импортируется в реестр.

Для чего нужно это знать и уметь? Например, если была заблокирована работа с редактором реестра, а это можно сделать с помощью изменения ключей реестра, то наиболее легким способом исправить установки в реестре будет создание и импортирование reg-файла.

Первая строка reg-файла для Windows XP обязательно должна быть такой:
Windows Registry Editor Version 5.00

однако REGEDIT от Windows XP понимает и такое:
REGEDIT4

сохраняя тем самым совместимость снизу вверх. Обратите внимание на регистр букв. Кроме этого, в первой строке ничего быть не должно. После текста обязательно должна быть пустая строка.

Затем указывается раздел реестра, в котором надо прописать или изменить какие-то параметры. Название раздела должно быть заключено в квадратные скобки. Затем ниже прописываются параметры и значения по одному параметру в строке. Когда вы закончили описание параметров и их значений, то оставьте пустую строку и либо закончите файл, либо, если нужно, начинайте описание для следующего раздела.

Вот пример reg-файла:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\ SYSTEM\ Setup]
"SetupType"=dword:0
"SystemSetupInProgress"=dword:0
"CmdLine"=""
"SystemPrefix"=hex:cc,1b,00,00,00,40,3d,68
"SystemPartition"="\ \ Device\ \ HarddiskVo-lume1"
"OsLoaderPath"="\ \ "uniqueid"="C:\
\ WINDOWS\ \ LPM"
[HKEY_LOCAL_MACHINE\ SYSTEM\ Setup\ AllowStart]
{...описание
параметров...}
Последнюю строку в файле сделайте пустой.

Как видим, строковые параметры заключаются в кавычки. Перед числами ставятся указатели на их тип. Например, dword — указывает на тип этого параметра, буквы должны быть обязательно маленькие. После двоеточия следует значение из восьми цифр в шестнадцатеричном формате. Однако большинство параметров dword имеют значение либо 0, либо 1. Пробелы в строке не допускаются.

В реестре существуют параметры "По умолчанию" (Default). Чтобы присвоить им какое-то значение через REG-файл, надо добавить такую строку:
@="какое-либо значение"
Regedit имеет некоторое множество опций командной строки, чтобы автоматизировать его использование в пакетных файлах. Ниже указаны некоторые из вариантов.

regedit.exe [options] [filename]
filename — импортируемый в реестр.reg файл
/s — подавлять запрос на подтверждение при импорте файла
/e — экспорт раздела реестра в файл.

Пример:
regedit /e file.reg HKEY_CURRENT_USER\ Software\ Microsoft
Довольно убого, не так ли? Но не все так плохо. Наберите в командной строке:
REG /?
и изучайте "Программу редактирования системного реестра из командной строки, версия 3.0". Я думаю, она вам понравится.

Удаление разделов и ключей реестра при помощи .reg-файла

Вы можете удалять разделы реестра и значения в разделах, не используя REGEDIT. Для удаления раздела используйте тот же самый формат reg-файла, только перед наименованием раздела поставьте знак "минус" ("-"). Например:
REGEDIT5
[-HKEY_LOCAL_MACHINE\ SYSTEM\ Test]
Этот же формат используйте для удаления отдельных параметров в выбранных разделах, поставив знак "минус" ("-") после знака "равно" ("="):
REGEDIT5
[HKEY_LOCAL_MACHINE\ SYSTEM\ Test]
"TestValue" =-
Помните, что прежде, чем проводить какие-либо манипуляции с реестром вручную, рекомендуется сделать резервную копию.


Тестируем HDD

Инструмент
Как и для любой работы, так и для нашей нужен инструмент. В нашем случае это программа. Ёе можно скачать по адресу mhdd.net, её название mhdd, есть инструкция на русском языке и вес около сотни килобайт. Работает программа не только под MS-Dos, но и под Win 9x.

Возможности: тестировать винчестер на наличие ошибок - сканирование поверхности вызывается клавишей F4, лечить его (вызывается через F4, ERASE WAITs, и предназначена для удаления софт-бэдов), увеличивать скорость работы винчестера. Вот что можно узнать с помощью этой программы: название винта, версия микропрограммы, размер, количество головок и секторов, серийный номер ,изменять параметры накопителя , все можно в любое время и без перезагрузки, а также завершать работу программы без различных последствий. и многое другое. Я назвал лишь основные функции, а полное описание можно найти на сайте, а сейчас перейдём к самому главному.

Функции: показывает состояние винчестера (в верхней части экрана):

DREQ - ждёт поступление команд;
WRFT - ошибка возникшая при записи;
BUSY - винт не реагирует на команды;
ABRT - команда не принята;
TONF - не найден 0-й трек;
AMNF - нельзя обратится к заданному сектору.

Команды
~ Что бы изменить скорость/уровень шума надо ввести aam далее:
*M - минимальный шум/производительность;
*L - средний шум/производительность;
*P - максимальный шум/производительность;
*D- выключает AAM; самая большая производительность/шум из всех опций.
~ SMART-тесты запускаются командой smart test.
~ Также возможна установка пароля на винт, если вы забудете пароль, то потеряете винчестер как устройство! Если пароль не установлен, есть надпись Security: high OFF, а установлен, то Security: high ON.

Для установки пароля:
1) Выбрать винчестер, на который нужно установить пароль (Shift + F3);
2) Нажать F2;
3) Набрать pwd;
4) Набрать пароль (не более 32 символов) Внимание: запомнить пароль!
5) Нажать Enter
6) Всё! Пароль установлен.

Для снятия пароля:
1) Выбрать винчестер, с который нужно снять пароль (Shift + F3);
2) Нажать F2;
3) Набрать unlock;
4) Ввести пароль;
5) Набрать dispwd;
4) Ввести пароль;
5) Нажать F2;
6) Если всё набрано правильно, то надпись PWD исчезнет.

Данную программу можно посоветовать, как универсальную для ухода за винчестером.


Утилиты командной строки

Windows XP предлагает ряд новых интересных утилит командной строки. Все утилиты выполняются [Пуск- Выполнить]. Рассмотрим некоторые из них. Для получения справки об интересующей вас команде запустите ее с параметром /?. Для сохранения информации в текстовый файл после команды добавьте > text.txt

Утилита Systeminfo предоставляет детальную информацию о конфигурации компьютера и его операционной системе: имя ПК, тип установленной ОС, ее версию, количество процессоров, их тактовую частоту и многое другое. Кроме всего прочего, с помощью этой утилиты вы сможете отследить, сколько времени операционная система работает без перезагрузки.

С помощью утилиты Shutdown выключается или перезагружается локальный или удаленный компьютер. Ее параметры позволяют задать время, через которое произойдет действие, пользователь получит сообщение, а также объяснение причины завершения работы.

В Windows XP появилась возможность завершать задачи из командной строки. Это можно сделать с помощью утилиты taskkill . Итак, для того чтобы завершить какую-то задачу, нужно сначала узнать ее номер, воспользовавшись утилитой tasklist. Обе упомянутые утилиты позволяют создавать фильтры для обрабатываемых задач. Например, команда tasklist /fi "status eq not responding" выведет на экран список всех зависших задач, а команда taskkill /f /fi "username eq Guest" завершит все задания, запущенные пользователем Guest.

Утилита bootcfg поможет в конфигурировании файла настроек boot.ini.

Утилита schtask позволяет создавать расписание для запуска задач периодически или в заданное время.


Утилиты очистки реестра

Здесь мы рассмотрим утилиты очистки реестра NGBCleanRR Утилита для поиска и удаления неправильных ссылок в реестре и в ярлыках Windows® 95/98/NT/2000/ME/2001. NBG Clean Registry является одной из самых мощных программ, ориентированных исключительно на очистку реестра. Она состоит из трех основных частей - сканера реестра, анализатора корректности ссылок и блока принятия решения, позволяет включать и отключать режим создания резервных копий, звуковые оповещения, а также выборочную проверку отдельных секций реестра, уменьшая, таким образом, суммарное время поиска. Кроме этого, весьма полезным является отображение в главном окне индикаторов загрузки оперативной памяти компьютера. И второй представитель чистильщиков jv16PowerTools, прекрасный менеджер для работы с реестром, zip-архивами, файлами. Среди всех программ, призванных облегчить процесс поддержания Реестра Windows в надлежащим состоянии, самой популярной, без сомнения, является программа jv16 Power Tools финского программиста Jouni Vuorio. Эта программа, являющаяся логическим продолжением и развитием другой, не менее популярной утилиты этого же автора, RegCleaner, способна удовлетворить большинство запросов всех категорий компьютерщиков - как зеленых новичков, так и прожженных профессионалов. Кроме того, из jv16 можно корректировать меню Windows "Найти" и "Открыть с помощью", деинсталлировать любую установленную ранее программу. Наконец, если пользователю вдруг понадобится сделать в реестре что-то, что выходит за пределы возможностей jv16, он может одним щелчком мыши вызвать стандартный редактор Реестра RegEdit. Почему эти утилиты, а не другие? Потому что эти утилиты более корректно и основательно чистят реестр. Мы перебрали практически все утилиты, и оставили у себя только эти утилиты. И ещё один нюанс, только одна из них должна стоять в системе, и ей делать чистку реестра. Почему? Когда будут две утилиты чистить, то какая из них, что и откуда удалит, знать не будете не вы, ни утилиты. Поэтому откат реестра будет не полным. После очистки системы двумя утилитами в течении недели, система начала зависать. Мы чистили сначала jv16pt , она почистила хорошо, мы перезагрузили систему и проверили, все нормально. Запустили утилиту NGBCleanRR , она нашла еще 59 ошибок. Получается что NGBCleanRR чистит глубже и основательней. Но с ней надо быть осторожней, ей не знакома Win XP. Перезагрузили систему и проверили работу, всё нормально. И так в течении недели. Результат плохой, система стала подвисать, некоторые проги начали зависать сразу при пуске. Проверили реестр, много бесхозных ключей, нужные исчезли. Удалили jv16pt , и запустили NGBCleanRR на восстановление реестра. После перезагрузки проверили ещё раз, результат 365 ошибок. Удалили их без лечения. NGBCleanRR имеет возможность лечить ошибки которые нашел. После перезагрузки проверили систему, она работала отлично. Исходя из выше рассказанного, jv16pt чистит реестр не до полной очистки, работает скажем так, мягко. NGBCleanRR чистит реестр основательно и поэтому его не рекомендуем новичкам. Для начинающих будет в самый раз jv16pt , или если уверены NGBCleanRR. Каждый волен выбирать то, что он сочтет нужным для себя. Важно , чтобы после чистки реестра система работала устойчиво. Будьте внимательны при работе с реестром.

RegScrubXP ftp://isurgut.ru/Utilits/Register/RegScrubXP_3.2.1.exe

Знакомьтесь - новый сканер реестра Windows XP - RegScrubXP (581 кб), который ищет ненужные ключи уже деинсталлированных приложений и удаляет их. Утилита оснащена опцией отката, так что вы всегда сможете вернуться к исходному положению записей в реестре, а также имеет специальный лист исключений, куда пользователь может вносить определенные ключи.
RegScrubXP ведет также сортировку по расширениям файлов, производителям, автозапускаемым приложениям, истории посещений страниц в интернете, оснащена подробной справочной системой и основными XP-твикерами.

Перед использованием программы, как водится, неплохо сделать резервную копию реестра, для чего необходимо проследовать в папку, куда была инсталлирована RegScrubXP, найти там hklm.cmd и hkcu.cmd, два раза кликнуть мышкой на первом и втором объекте, а созданные после этого файлы hklm.reg и hkcu.reg сохранить в безопасное место. Если когда-либо вам понадобится полностью восстановить реестр, вернуть его к изначальному положению, просто запустите эти файлы, реестр будет восстановлен и предстанет перед вами в первозданном виде, таким, каким он был до использования RegScrubXP.

Интерфейс сканера очень простой, после его запуска не составляет труда найти кнопку RegScrubXP Finds Problems и осознать ее предназначение. Прогулявшись по всему реестру, программа выводит список потенциальных проблемных ключей, далее у вас есть выбор - просмотреть список и отметить только некоторые ключи для исправления / удаления или, доверившись программе, удалить все, что она смогла найти. Нажав на кнопку Restore, вы увидите бэкап тех исправлений, которые вы только что внесли. Чтобы восстановить реестр, выделите файл бэкапа и нажмите кнопку Restore Selected Backups.

Реестр восстановлен. Но, в принципе, проблем возникнуть не должно. Обратите внимание также на кнопку User Determines Problems. Список, который вы увидите, нажав на нее, - не проблемные ключи, которые обнаружила RegScrubXP, а области реестра, где именно вы можете найти эти самые проблемные ключи. Простой пример: вы только что деинсталлировали какую-нибудь программу и, ориентируясь по ее названию, можете скомандовать RegScrubXP удалить ее следы в реестре.

Осталось рассказать про твикеры, которыми комплектована программка. Здесь есть и синхронизация системного времени через интернет, и отмена создания коротких имен в NTFS, и ускорение отображения меню, и ускорение выключения компьютера, и укрощение автозапуска CD-ROM, и изменение системного шрифта, и отображение версии XP на десктопе, и прочие глупости. В общем, попробуйте - вам понравится.


Файловые системы
 NT-системы

Обзор файловых систем, которые стандартно поддерживаются этими ОС (а нестандартно, с помощью сторонних драйверов, можно обеспечить работу с любой файловой системой). Следует учесть, что NTFS (New Technology File System) существует в виде нескольких версий, совпадающих с номером NT (5.1 для XP, например; наличие Service Pack'ов эту закономерность может нарушить), соответственно нововведения ФС (Файловой Системы) не будут поддерживаться старой версией NT, поэтому лучше использовать с ОС родную версию ФС. Вот список файловых систем, поддержка которых стандартно включена в Windows 2000/XP:
• NTFS — исключительно для NT-систем.
• FAT12 — поддержка дискет.
• FAT16 — для совместимости с MS-DOS.
• FAT32 — ФС, используемая в Windows 95 и 98.
• CDFS — файловая система компакт-дисков.
• UDF — универсальный формат дисков.

Также поддерживается распределенная файловая система (Distributed File System — DFS) и файловая система с шифрованием (Encrypted File System — EFS). Строго говоря, это не настоящие ФС. DFS представляет собой расширение сетевого сервиса и позволяет объединять в единый логически том сетевые ресурсы, а EFS — надстройка над NTFS, обеспечивающая функции шифрования. Ну, а теперь остановимся подробнее на каждой файловой системе.

CDFS
CDFS (Compact Disk File System), используемая в Windows 2000 (вроде, и в XP) выполнена по стандарту ISO 9660, согласно которому к именам файлов предъявляются следующие требования:
• Имя не превышает 32 символа.
• Все буквы строчные.
• Глубина вложения каталогов — не более 8 уровней.
Опытные пользователи заметят, что эти ограничения в большинстве случаев обходятся без проблем. В XP встроены средства для записи дисков с этой ФС.

UDF
UDF (Universal Disk Format) — файловая система, соответствующая стандарту ISO 13346, предназначенная для доступа в режиме чтения к DVD-ROM- и CD-ROM-дискам. В будущем планируется обеспечить доступ и на запись.

FAT12
ФС FAT (File Allocation Table) получила свое название из-за способа организации данных — таблицы размещения файлов. Она ориентирована на небольшие диски и простые структуры каталога. FAT12 является 12-битной верcией FAT, соответственно она может адресовывать 212 кластеров (минимальных логически адресуемых единиц данных на диске). Это ограничение и небольшое количество вхождений в корневой каталог определяет использование этой ФС. Сейчас она применяется на дискетах, раньше ее использовали на винчестерах, но эта ФС была быстро вытеснена улучшенной версией — FAT16. Диск с использованием любой FAT имеет следующую структуру (см. рис.1).
Корневой каталог имеет фиксированный размер. Каталоги — специальные файлы с элементами для каждого файла, содержащегося в этом каталоге. Эти элементы включают:
• Имя файла (8+3 символа).
• Байт атрибута (8 бит).
• Время модификации (16 бит).
• Дату модификации (16 бит).
• Первый размещаемый блок (12 бит для FAT12).
• Размер файла (32 бита).

Специальная надстройка над FAT, называемая VFAT (Virtual FAT), обеспечивает поддержку длинных имен файлов. Это следует учесть, так как некоторые старые DOS-утилиты могут запороть диск с длинными именами файлов, считая поврежденной структуру FAT. Все версии FAT не обладают функциями защиты данных и автоматического восстановления, посему я рекомендую их применять только для обеспечения совместимости.

FAT16
Улучшенная версия FAT. Максимальный размер тома равен 4095 Мб, размер кластера определяется размером тома и находится в диапазоне от 512 байт до 64 Кб. Число кластеров не превышает 216.

FAT32
Модифицированная версия FAT. Размер тома увеличен до 127 Гб, число кластеров — до 232. Позволяет использовать при одинаковых размерах томов кластеры меньшего размера, чем FAT16, что увеличивает эффективность организации данных. Впервые поддержка этой ФС появилась в Windows 95 OSR2. Все версии NT до 4.0 включительно ее не поддерживают (для поддержки в NT 4.0 нужен соответствующий Service Pack).

NTFS
Ну вот и дошли до самого интересного. Данная ФС является основной для NT. Без нее Windows NT уже и не NT (с этим трудно поспорить ввиду отсутствия в других ФС поддержки управления избирательным доступом и аудита). Эта файловая система обеспечивает эффективность, надежность и совместимость, невозможные в других поддерживаемых файловых системах, способна адресовывать до 264 кластеров (в текущей реализации — до 232) и работать с кластерами оптимальных размеров. NTFS — журналируемая, основанная на транзакциях ФС, обладающая функциями самовосстановления. Здесь необходимы небольшие пояснения.

Все операции с метаданными в NTFS разбиваются на неделимые блоки — транзакции. Каждая транзакция может быть выполнена успешно либо, в случае сбоя, откачана назад. Незавершенные транзакции не допускаются. Все транзакции регистрируются в файле журнала. Такой механизм обеспечивает абсолютную целостность структуры ФС, но допускает потерю пользовательских данных (архиредкое явление), так как журналировать все данные было бы неэффективно. В случае сбоя системы, например, в результате потери питания, при загрузке запускается программа AUTOCHK, проверяющая флаг "Грязный" тома. Если он установлен, запускается утилита CHKDSK, выполняющая 3 прохода: анализа, повторов и откатов. Таким образом обеспечивается выполнение либо откат всех незавершенных транзакций. Это очень упрощенная схема, но она позволяет понять преимущества журналируемой ФС над другими.

Структура NTFS довольно проста, хотя и сложнее, чем в FAT. Каждый распределенный на томе сектор принадлежит некоторому файлу, даже метаданные — информация, описывающая саму ФС. NTFS основана на атрибутах и обрабатывает все файлы как объекты с набором атрибутов, определенных как системой, так и пользователем. Каждый файл на томе с NTFS представлен записью в главной файловой таблице (MFT — Master File Table), аналоге FAT. Записи в MFT сортируются по алфавиту, что позволяет использовать двоичный поиск, существенно ускоряющий работу ФС. Для еще большей оптимизации диспетчером кэша используется алгоритм отложенной (lazy — ленивый) записи, когда данные не пишутся сразу на диск, а хранятся в памяти до тех пор, пока нагрузка на процессор не уменьшиться, а затем сбрасываются на диск фоновым процессом. Однако подобная практика чревата нехорошими последствиями в случае отказа питания. Журналирование не спасет пользовательских данных, хотя и обеспечит целостность структуры ФС. Вот почему любой уважающий себя администратор не ставит сервер без ИБП (Источник Бесперебойного Питания). В итоге, согласно авторитетным тестам, по быстродействию FAT выигрывает только на небольших томах с небольшим количеством файлов, в остальных случаях пальма лидерства остается за NTFS. Если вы хотите еще больше ускорить работу NTFS, воспользуйтесь следующим советом: отключите автоматическое обновление времени последнего доступа к файлу. Для этого в реестр по адресу HKLM\SYSTEM\CurrentControlSet\Control\FileSystem добавьте параметр NtfsDisableLastAccessUpdate типа REG_DWORD и установите его в 1. Существуют и другие способы оптимизации работы ФС, однако о них как-нибудь в другой раз. Ну, а сейчас я перечислю те функции, которые поддерживает наша героиня.

• Разреженные файлы. Это файлы, очень большие логически, но занимающие на диске только необходимый объем. Эта технология используется самой NT и СУБД (Системами Управления Базами Данных).

• Журнал изменений. Служит для регистрации всех изменений файлов на томе. Используется службой каталогов Active Directory и службой индексирования. Находится в папке System Volume Informa-tion в корне диска.

• Поддержка коротких имен. Это необходимо для совместимости с MS-DOS-программами. Каждый раз при создании файла NTFS делает дополнительную запись в MFT, содержащую короткий эквивалент имени. Эту опцию можно отключить, воспользовавшись ключом реестра Ntfs Disable8 dot3NameCreation в папке HKLM\SYSTEM\Current Control Set\Control\FileSystem, установив его в 1.

• Компрессия файлов и каталогов. NTFS обеспечивает динамическое, прозрачное для приложений сжатие файлов и каталогов на манер MS-DOS-утилит DriveSpace и Stack. Атрибут Сжатый можно установить как для всего тома, так и для отдельных файлов и каталогов. Сжатие возможно на разделах с кластером, не превышающим 4 Кб. Степень сжатия варьируется в зависимости от типа данных и максимальна для текстовых документов и файлов, созданных с помощью MS Office. Советую попробовать поэкспериментировать с утилитой COMPACT.

• Многопоточные файлы. Один и тот же файл может содержать несколько именованных потоков, содержащих разную информацию, причем размер файла высчитывается согласно содержимого главного, безымянного потока. Ради шутки можно создать файл, занимающий все место на диске, но обладающий нулевой длиной с точки зрения ПО. Писать в потоки можно с помощью перенаправления ввода-вывода: Echo Бла-бла-бла! > File.txt:First. Аналогично читаем: More < File.txt:First. Внимание! Данная функция поддерживается только в NTFS, и при копировании на тома с другой ФС информация в именованных потоках пропадет.

• Жесткие связи. Для одного и того же файла можно создать несколько имен внутри тома. При этом мы не увеличиваем количество файлов, а лишь делаем своеобразный ярлык. Файл остается на диске до тех пор, пока не удалят последнюю жесткую связь на него. Эта и 2 последующие технологии давно используются в UNIX-системах.

• Точки переопределения. Любой файл или каталог может быть точкой переопределения. Это способ представления имен системой ввода/вывода. Простейший пример: Диск D: монтируется в каталог C:\Disks\ D\. В итоге, зайдя в этот каталог, мы попадем на диск D:, хотя путь не изменится.

• Переходы NTFS. Позволяют спроецировать каталог-адресат в другой подкаталог. Т.е., зайдя в такой каталог, мы попадем в совсем другое место ФС. Чем-то напоминает предыдущий пункт, не правда ли? Доступны только на NTFS 5.0 и 5.1.

• Динамическое отслеживание ярлыков. Отслеживает перемещение файлов, на которые указывают ярлыки, соответственно изменяя ссылку на эти файлы в ярлыках. Работает только на локальных дисках с NTFS 5.0 и 5.1.

• Управление избирательным доступом. С помощью таблиц управления доступом (Access Control List — ACL) можно гибко разграничивать доступ к файлам и папкам. Можно работать как с отдельными пользователями, так и с группами, одновременно используя наследование прав доступа.

• Аудит доступа. Данная функция обеспечивает запись в журнал аудита все действия пользователя или группы аудита, предпринятые к указанному файловому объекту.

• Квотирование дискового пространства. Чтобы пользователи не захламляли диски своими файлами, для каждого из них можно создать квоту на используемое пространство диска. В итоге пользователь не сможет бездумно тащить на компьютер все, что под руку попадет: квота не резиновая, ее не превысишь. Данная функция появилась в Windows 2000.

В дополнение ко всему вышесказанному: существующий том с FAT можно преобразовать в NTFS без потери данных с помощью команды CONVERT, однако эффективность такого решения не очень высокая из-за особенностей процесса преобразования. Вот, собственно, и все, что должен знать пользователь о файловых системах. Если нужна более подробная информация — ищите соответствующую литературу. Я же широко использовал в данной статье материалы книги Федора Зубанова "Microsoft Windows 2000. Планирование, развертывание, управление".

P.S.: Надеюсь, убедил использовать NTFS везде, где это возможно. При грамотной настройке и обслуживании NT + NTFS показывают чудеса производительности и устойчивости. Ну, а с кривыми руками и M16 не более чем дубина.

Источник: http://www.nestor.minsk.by/kg/


ntfs

Что такое NTFS

При установке Windows XP вам будет предложено отформатировать существующий раздел, на который устанавливается ОС, в файловую систему NTFS. Так что же это такое?

Файловая система NTFS обеспечивает такое сочетание производительности, надежности и эффективности, которое невозможно получить с помощью FAT. Основными целями разработки NTFS являлись обеспечение скоростного выполнения стандартных операций над файлами, таких как чтение, запись, поиск, и предоставления дополнительных возможностей, включая восстановление поврежденной файловой системы на чрезвычайно больших дисках.

Файловая система NTFS является "своей" файловой системой для Windows NT, а как известно WinXP, является своеобразным продолжением этой линейки ОС. Но если вы собираетесь использовать на одном компьютере несколько операционных систем таких, как Windows 9x и Windows XP, то загрузочный том нельзя форматировать в NTFS, так как линейки Windows 95(98) "понимают" только FAT, и дисков, отформатированных в NTFS для этих ОС просто не существует. Файлы находящиеся на дисках NTFS можно увидеть только используя программы сторонних производителей. Если же во время установки вы не отформатировали раздел в NTFS, то это можно сделать и после неё. В командной строке WindowsXP необходимо набрать "Convert (имя диска)/FS:NTFS" без кавычек.

Ниже приводится сравнительная таблица файловых систем FAT и NTFS

Ограничения | NTFS | FAT и FAT 32
Размеры тома | Минимальный размер тома составляет приблизительно 10 Мб. | FAT поддерживает различные размеры томов - от объема дискет и до 4 Гб.
 | На практике рекомендуется создавать тома, размеры которых не превышают 2 Тб. | FAT 32 поддерживает тома объемом от 2 гб. до 2 Тб. Работая под управлением Windows XP для Fat 32 можно отформатировать тома, размер которых не превышает 32 Гб.
 | С помощью NTFS нельзя форматировать дискеты. | Не поддерживаются диски размеры которых меньше 512 Мб.
Размеры файлов | Теоритически размер файла может составлять 16 экзабайт. | FAT поддерживает файлы размером не более 2 Гб. FAT 32 подерживает файлы размером не более 4 Гб.

NTFS обладает характеристиками защищенности, поддерживая контроль доступа к данным и привилегии владельца, играющие исключительно важную роль в обеспечении целостности важных данных. Папки и файлы NTFS могут иметь назначенные им права доступа вне зависимости от того, являютя ли они разделяемыми или нет.
NTFS - единственная файловая система в Windows, которая позволяет назначать права доступа к различным файлам. Устанавливая пользователям определенные разрешения для файлов и каталогов, пользователь может защищать конфиденциальную информацию от несанкционированного доступа. Разрешения пользователя на доступ к объектам файловой системы работают по принципу дополнения. Это значит, что действующие разрешения, то есть те разрешения, которые пользователь реально имеет в отношении конкретного каталога или файла, образуются из всех прямых или косвенных разрешений, назначенных пользователю для данного объекта с помощью логической функции "Или". Например, если пользователь имеет право назначить разрешение для каталога на чтение, а косвенно через членство в группах ему дано право на запись, то в результате пользователь сможет читать информацию в файлах каталога и записывать в них данные.
Для назначения пользователю или группе разрешения на доступ к определенному файлу необходимо: 1. Указать файл мышью и нажать правую кнопку. Выбрать пункт Properties (Свойства) контекстного меню. В появившемся окне свойств файла перейти на вкладку Security (Безопасность). По умолчанию данной вкладки там нет, чтобы она появилась необходимо в свойствах папки убрать галочку Simple File Sharing (использовать простой общий доступ к файлам).
2. В группе Name (Имя) показан список пользователей и групп, которым уже предоставлены разрешения для этого файла. Для того, чтобы добавить или удалить пользователей или новые группы, нажать кнопку Add/Remove (Добавить/Удалить) Появится окно диалога Select Users, Groups (Выбрать пользователей, группы).В поле Enter the object names to select (Введите имена выбираемых объектов) написать имя пользователя, кнопка Check Names (Проверить имена) позволяет проверить правильность написания имени.
3. В группе Permissions (Разрешения)

устанавливаются разрешения. Присутствуют указатели Deny (запретить) и Allow (Разрешить). Устанавливаются флажки для следующих параметров: Full Control (полный контроль) - пользователь получает неограниченный доступ к файлу, Modify (Изменение) - пользователь может изменять файл, Read & execute (Чтение и выполнение), Read (Чтение) - пользователь может только читать файл, Write (Запись) - пользователь может записывать в файл.

Для более тонкой настройки разрешений необходимо нажать кнопку Advanced. Появляется диалоговое окно Advanced Security Settings for (Дополнительные параметры безопасности). Здесь можно дополнительно указать дополнительные разрешения, настроить политику аудита, изменить (просмотреть) информацию о владельце файла и добавить / удалить пользователей, могущих получить доступ к файлу.
Следующее, очень полезное свойство файловой системы NTFS - это возможность введения квот. Это свойство, как правило необходимо системным администраторам, больших компаний, где работают большое количество пользователей, у которых нет привычки следить за актуальностью информации, и которые хранят ненужные файлы, тем самым занимая дисковое пространство. Так как администратор не может проследить за всем этим, он может ввести квоту на использование диска определенному пользователю. После установки квот пользователь может хранить на томе ограниченный объем данных, в то время как на этом диске может оставаться свободное пространство. Если пользователь превысит выданную ему квоту, в журнал событий будет внесена соответствующая запись. Чтобы включить квоты на диске нужно прежде всего, чтобы он был в формате NTFS, затем в свойствах папки Tools-Folder Options-View убрать флажок Simple File Sharing. Это нужно для того, чтобы в свойствах диска появилась вкладка Quota. В ней необходимо установить флажок на Enable quota managment (Активизировать управление квотами). Это будет установлена мягкое квотирование, которое выдаст предупреждение, что пользователь, если так случится, превысил квоту, но право на запись у него будет. Чтобы в случае превышения квоты пользователю было отказано в доступе к этому тому, необходимо установить флажок на Deny disk space to users exceeding quota limit (Запретить запись на диск пользователям, превысившим размер дискового пространства). На этой же вкладке можно установить размер выделяемой квоты (Limit disk space to) и порог, превышение которого вызывает запись предупреждения в журнале событий (Set Warning level to) - Установить порог выдачи сообщения. Эти параметры устанавливаются по умолчанию для всех пользователей. В окне же Quota Entries можно изменить параметры квоты, задаваемой для конкретного пользователя. Для этого следует выделить конфигурируемую учетную запись, с помощью контекстного меню выбрать свойства и сконфигурировать квоту.
И ещё одно нововведение NTFS 5 - точки монтирования. Пользователь может определить различные, не связанные с собой папки и даже диски в системе как один диск или папка. Это имеет большую важность для определения в одном месте разнородной информации, находящейся в системе. Файлы и папки таким образом созданные имеют уникальный идентификационный номер, что гарантирует их правильное нахождение в системе, даже если папка или файл был перенесен.


Что такое реестр

Что такое реестр Windows XP.

Для начала определимся с терминологией. Эта важная часть нужна нам для того, чтобы лучше понимать друг друга.

Реестр - это прежде всего основа операционной системы, огромная база данных настроек, хранящихся в папках %SystemRoot%\System32\Config и папке пользовательских профилей (Ntuser.dat). Без реестра Winddows XP была бы просто набором программ, неспособных выполнить даже простейшие функции ОС. Все - даже мельчайшие детали конфигурационных данных ХР - упаковано в реестре.Разобраться в реестре - задание не из легких, но это необходимо, если Вы желаете узнать ОС полностью, в большинстве случаев мало кто даже подозревает о существовании реестра.

Итак, реестр или системный реестр - это база данных для хранения сведений о конфигурации компьютера и настроек операционной системы. Реестр содержит данные, к которым Windows XP постоянно обращается во время загрузки, работы и её завершения, а именно:

  • профили всех пользователей, то есть их настройки;

  • конфигурация оборудования, установленного в операционной системе. Я не пишу "установленного в компьютере", поскольку "железо" может быть, как говорится, "на борту", но не быть установленным в ОС, например, из-за устаревших драйверов.

  • данные об установленных программах и типах документов, создаваемых каждой программой;

  • свойства папок и значков программ;

  • данные об используемых портах.

Реестр имеет иерархическую древовидную структуру, состоящую из разделов, подразделов и ключей (параметров).

Для работы с реестром используется простая и понятная утилита Regedit

Запретить запуск Regedit

В разделе HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\System добавить ключ DisableRegistryTools :dword= 0х00000001. Запуск редактора реестра будет запрещен, однако останется возможность вносит изменения с помощью программного обеспечения сторонних разработчиков и с помощью REG-файла

Разделы и подразделы - это, грубо говоря, папки в левом окне regedit'а. Ключ реестра или параметр - это некая переменная, которой присвоено определённое значение, проще говоря - это то, что мы видим в правом окне regedit'а.

Куст (основной раздел, стандартный раздел, в английской документации - улей , от англ. "hive") - это раздел реестра, отображаемый как файл на жестком диске. Куст является набором разделов, подчиненных разделов и параметров и имеет корни на верхнем уровне иерархии реестра. По умолчанию большинство файлов кустов (Default, SAM, Security и System) сохраняются в папке %SystemRoot%\System32\Config. Папка %SystemRoot%\Profiles содержит профили (настройки) для каждого пользователя компьютера. Поскольку куст представляет собой файл, его можно перемещать из одной системы в другую. Для редактирования этого файла необходимо использовать редактор реестра.

Важное замечание : Windows XP в отличие от своих предшественниц не имеет ограничения по размеру реестра.

Реестр Windows XP состоит из следующих основных разделов :

Раздел реестра | Краткое описание
HKEY_CLASSES_ROOT | Это ссылка на раздел HKEY_LOCAL_MACHINE\Software\Classes. Хранящиеся здесь сведения обеспечивают запуск необходимой программы при открытии файла с помощью проводника. Этот раздел содержит связи между приложениями и типами файлов, а также информацию об OLE.
HKEY_CURRENT_USER | Это ссылка на определённый подраздел HKEY_USERS. Настройки соответствуют текущему, активному пользователю, выполнившему вход в систему.
HKEY_LOCAL_MACHINE | Раздел содержит настройки, относящиеся к вашему компьютеру и действительны для всех пользователей. Раздел содержит информацию об аппаратной конфигурации и установленном программном обеспечении.
HKEY_USERS | Этот раздел содержит настройки для всех пользователей компьютера.
HKEY_CURRENT_CONFIG | Это ссылка на HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\Hardware Profiles\Current. Раздел содержит сведения о настройках оборудования, используемом локальным компьютером при запуске системы, т.е. содержит информацию о текущей конфигурации.

Вышеуказанные основные стандартные разделы вы не сможете удалить или переименовать. Некоторые разделы реестра являются энергозависимыми (volatile) и не хранятся в каком-либо файле. Операционная система создает и управляет этими разделами полностью в памяти, поэтому они являются временными по своей природе. Система создает энергозависимые разделы каждый раз при начальной загрузке. Например, HKEY_LOCAL_MACHINE \HARDWARE - раздел реестра, который хранит информацию по физическим устройствам и назначенным им ресурсам. Назначение ресурса и аппаратное обнаружение происходят каждый раз при загрузке системы, поэтому логично, что эти данные не записываются на диск.

Сердце системного реестра - это раздел HKEY_LOCAL_MACHINE \SYSTEM.

Наибольший интерес для нас представляют ветви HKEY_CURRENT_USER и HKEY_LOCAL_MACHINE , именно там хранятся настройки, изменения которых способно облагородить нашу операционную систему.

Часто для обозначения основных разделов реестра пользуются сокращениями:

Раздел реестра | Аббревиатура
HKEY_CLASSES_ROOT | HKCR
HKEY_CURRENT_USER | HKCU
HKEY_LOCAL_MACHINE | HKLM
HKEY_USERS | HKU
HKEY_CURRENT_CONFIG | HKCC

Раздел HKEY_USERS содержит все активные загруженные параметры пользователя. Он имеет не менее трёх ключей:

  • подраздел DEFAULT, где хранится используемая конфигурация, когда ни один из пользователей ещё не вошёл в компьютер. То есть мы ещё видим приглашение на вход в систему.
  • дополнительный подраздел, который имеет имя в соответствии с security ID текущего пользователя (описание SID см. ниже). Этот подключ реестра содержит конфигурацию текущего пользователя. Если пользователь вошёл удалённо, данные для конфигурации пользователя сохраняются в системном реестре местного компьютера. Данные из HKEY_USERS\%SID% также появляются в HKEY_CURRENT_USER.
  • дополнительный подраздел, который имеет имя в соответствии с SID текущего пользователя с суффиксом Classes. Этот раздел содержит классы текущего пользователя. Данные в HKEY_USERS\%SID%_Classes также содержатся в HKEY_CLASSES_ROOT.

В Windows XP конфигурация пользователя по умолчанию (default user profile) не хранится в системном реестре. Она находится на системном диске в файле \Documents and Settings\Default User\Ntuser.dat.

Отметим, и это важно, что куст HKEY_CURRENT_USER является ссылкой, линком на определённый подраздел куста HKEY_USERS. Это значит, что все изменения в разделах, подразделах и ключах куста HKEY_CURRENT_USER автоматически тут же отображаются в определённом подразделе HKEY_USERS соответствующем активному пользователю. То есть пользователю, выполнившему процедуру входа.

В каком же именно разделе HKEY_USERS проводятся изменения? Для этого вы должны узнать свой SID. Тогда искомый раздел будет именоваться, например, так : HKEY_USERS\S-1-5-21-117609710-1606980848-839522115-500. Где цифровая часть, вместе с буквой "S", и есть SID.

Идентификатор безопасности (SID, security ID) - структура данных переменной длины, которая идентифицирует пользователя, группу или компьютер. Каждая учётная запись в сети имеет уникальный SID. Внутренние процессы в Windows обращаются к SID для получения учётной записи пользователя или имени группы.

Откройте редактор реестра HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. Выберите SID и посмотрите ProfileImagePath. В конце строки найдете имя пользователя.

Увидеть все SID, относящиеся к пользователям компьютера, вы можете раскрыв раздел HKEY_USERS. Но, в большинстве случаев, знать SID не обязательно.

Отметим также, что HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet это тоже ссылка, линк на один из пронумерованных подразделов с именами HKEY_LOCAL_MACHINE\SYSTEM\ControlSet00n, где n - номер. Подразделы ControlSet00n представляют собой наборы настроек для операционнной системы Windows XP. Большинство систем имеет два пронумерованных управляющих набора, оригинал и резервную копию, которая использовалась при последнем успешном старте системы. Операционная система Windows XP может обслуживать несколько таких наборов. Windows XP обслуживает резервные копии так, чтобы вы могли отменить изменения конфигурации, которые в противном случае могли бы препятствовать загрузке операционной системы. Windows XP хранит последний набор настроек, который был использован успешно, и настройки по умолчанию. Эти значения сохранены в подключе Select. Имена параметров ключа Select соответственно: Current - текущие настройки и Default - настройки по умолчанию. Также обратите внимание на параметр LastKnownGood расположенный там же. При загрузке Windows XP вы можете выбрать пункт меню "Загрузка последней удачной конфигурации", а действительный номер набора загружаемых настроек будет определён именно этим параметром реестра.

Все значения ключей реестра относятся к определённому типу. Следующая таблица содержит типы данных, используемых в реестре Windows XP:

Тип данных | Краткое описание
REG_BINARY | Двоичные данные. Большинство сведений об аппаратных компонентах хранится в виде двоичных данных и выводится в редакторе реестра в шестнадцатеричном формате.
REG_DWORD | Целые числа размером в 4 байта. Многие параметры служб и драйверов устройств имеют этот тип и отображаются в двоичном, шестнадцатеричном или десятичном форматах.
REG_EXPAND_SZ | Строка данных переменной длины.
REG_MULTI_SZ | Многострочный текст. Этот тип, как правило, имеют списки и другие записи в формате, удобном для чтения. Записи разделяются пробелами, запятыми или другими символами.
REG_SZ | Текстовая строка фиксированной длины.
REG_FULL_ RESOURCE_DESCRIPTOR | Последовательность вложенных массивов, разработанная для хранения списка ресурсов железа или драйверов.

Хранение реестра.

Элементы реестра хранятся в виде атомарной структуры. Реестр разделяется на составные части, называемые ульями (hives), или кустами. Ульи хранятся на диске в виде файлов. Некоторые ульи, такие, как HKLM\HARDWARE, не сохраняются в файлах, а создаются при каждой загрузке, то есть являются изменяемыми (vola-tile). При запуске системы реестр собирается из ульев в единую древовидную структуру с корневыми разделами. Перечислим ульи реестра и их местоположение на диске (для NT старше версии 4.0).

Улей | Расположение
HKLM\SYSTEM | %SystemRoot%\system32\config\system
HKLM\SAM | %SystemRoot%\system32\config\SAM
HKLM\SECURITY | %SystemRoot%\system32\config\SECURITY
HKLM\SOFTWARE | %SystemRoot%\system32\config\software
HKLM\HARDWARE | Изменяемый улей
HKLM\SYSTEM\Clone | Изменяемый улей
HKU\<SID_пользователя> | %USERPROFILE%\ntuser.dat
HKU\<SID_пользователя>_Classes | %USERPROFILE%\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat
HKU\.DEFAULT | %SystemRoot%\system32\config\default

Кроме этих файлов, есть ряд вспомогательных, со следующими расширениями:
• LOG — журнал транзакций, в котором регистрируются все изменения реестра.
• SAV — копии ульев в том виде, в котором они были после завершения текстовой фазы установки.

Реестр является настоящей базой данных, поэтому в нем используется технология восстановления, похожая как в NTFS. Уже упомянутые LOG-файлы содержат журнал транзакций, который хранит все изменения. Благодаря этому реализуется атомарность реестра — то есть в данный момент времени в реестре могут быть либо старые значения, либо новые, даже после сбоя. Как видим, в отличие от NTFS, здесь обеспечивается сохранность не только структуры реестра, но и данных. К тому же, реестр поддерживает такие параметры NTFS, как управление избирательным доступом и аудит событий — система безопасности пронизывает всю NT .

ОС Windows XP и приложения помещают информацпию в реестр ОС, что хорошо и плохо одновременно. Хорошо - потому что реестр представляет собой общую память для эффективного хранения информации. Плохо - потому что размеры реестра увеличиваются по мере того, как приложения и система сохраняют в системе все новую информацию. По мере этого процесса в реестре появляется огромное количество мусора, который необходимо и нелегко удалить.


Можно ли в окне

В окне "Welcome" изменить шрифты на сглаженные (cleartype)

Открываем реестр, ключ HKEY_USERS \ .DEFAULT \ Control Panel \ Desktop, находим в нем параметр FontSmoothingType и изменяем его значение на 2. При следующей перезагрузке системы ждем появления экрана "Welkome", после чего наслаждаемся полученным эффектом..

"Оформление" изменить шрифт которым отображаются меню программ.

Если ничего не помогает, и шрифт в окне программы никак не реагирует на изменения, то есть программа не использует системные настройки для своего интерфейса, или иероглифы отображаются в каком-то другом элементе, не в меню, то придется поковыряться в реестре. В ряде случаев помогает известный трюк с подменой нескольких параметров в реестре, относящихся к настройкам ОС в целом.

Попробуйте в разделе реестра HKEY_LOCAL_MACHINE\
System\CurrentControlSet\Control\Nls\Codepage
изменить несколько параметров:
"1250"="cp_1251.nls"
"1251"="cp_1251.nls"
"1252"="cp_1251.nls"

Пропадают системные шрифты

Проверяем наличие системных файлов с помощью командыsfc.exe /scannow
Windows проверит их (шрифты - тоже системные файлы) и при необходимости переустановит недостающие или поврежденные. Если не помогло - запускаем установочный диск Windows XP и выбираем пункт Upgrade to Windows XP (делать это надо из Windows XP).

Вместо русских букв видны какие-то закорючки

Если такое происходит в Фотошопе, то проблема решается так: находим в реестре ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \Nls \CodePage и изменяем значение параметра 1252 на c_1251.nls (было c_1252.nls, станет c_1251.nls). Кстати, такая манипуляция помогает иногда и для некоторых других программ.
Если же кракозябры все равно не исчезли, следует проверить правильность установки Languadge Options: запускаем апплет Regional and Languadge Options (он в Контрольной панели) и открываем закладку Regional Options. В разделе Standart and formats имеет смысл выставить "russian", в разделе Location, отвечающем в том числе за системные шрифты - обязательно указать "Russia". Для полного счастья необходимо проверить вкладку Advanced: Language for non-Unicode programs должен быть выставлен в "Russian". Или для решения проблемы следует воспользоваться вот этим ( ps601patch110.zip) патчем. Для его использования необходимо пропатчить Photoshop до версии 6.01. Еще одним решением, является использование Photoshop 7 версии, в нём нет проблем с национальными раскладками.

DOS: русские буквы видны, а раскладка не переключается

Открываем реестр, находим ключ HKEY_LOCAL_MACHINE \SYSTEM \CurrentControlSet \Control \KeyboardLayout \DosKeybCodes и изменяем значение 00000409 на "ru". После этого открываем файл autoexec.nt (он находится в папке %SystemRoot%\system32) и добавляем строку->
lh %SystemRoot%\system32\kb16.com ru
Перегружаем компьютер и убеждаемся, что теперь в DOS-прилложениях переключение на русскую раскладку происходит по нажатию Ctrl+Right Shift, на английскую - Ctrl+Left Shift.


ядро системы

Как поменять ядро системы?
Ядро меняется в Device Manager -> Computer, как и любой другой драйвер.

Это ИСКЛЮЧИТЕЛЬНО важно, НЕ СТАВЬТЕ ядро, которое не держится железом. Если не уверены, то лучше ничего не трогать, потому что последствия установки неправильного ядра непредсказуемы. Скорее всего машина просто перестанет загружаться, во всех режимах. Предотвратить подобное можно подредактировав boot.ini. Нужно всего лишь продублировать рабочий пункт меню выбора ОС, например,

multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /fastdetect

и приписать после /fastdetect следующие опции: /kernel=ntoskchk.exe /hal=halchk.dll,

а также в директории WINDOWS\System32 сделать копии вашего ядра и HAL-а. Назвать их, конечно же, надо ntoskrnl.exe -> ntoskchk.exe и hal.dll -> halchk.dll.

Кроме этого, необходимо учитывать одну тонкость. Видимо из за того, что при установке неправильного ядра XP просто виснет, теперь весь список доступных ядер не выводиться в окне смены драйвера. Таким образом, возможна ситуация, когда точно знаете, что ядро поддерживается системой, но система не даёт его установить. В этом случае, придётся делать это вручную. Для начала найдите в windows\inf файл под названием hal.inf. После этого, изучите его, чтобы выяснить, какие файлы и куда переписываются при смене ядра. Обычно перезаписывается только hal.dll, названия какого hal какому ядру соответствуют, можно узнать из списка:

Standard PC - hal.dll
Advanced Configuration and Power Interface (ACPI) PC -halacpi.dll
ACPI Uniprocessor PC - halaacpi.dll ACPI Multiprocessor PC -halmacpi.dll
Compaq SystemPro Multiprocessor or 100% Compatible - halsp.dll
MPS Uniprocessor PC -halapic.dll
MPS Multiprocessor PC -halmps

После этого "выдрать" соответствующий файл из Windows\Driver Cache\i386\driver.cab, скопировать его с Windows\system32, и сослаться на него в boot.ini. После загрузки (если повезёт :-)), можно переставить его по нормальному, в списке это ядро появится.